No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Multicast

AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R007

This document describes the principles and configurations of IP multicast, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Inter-AS MVPN Option A

Example for Configuring Inter-AS MVPN Option A

Multicast services are deployed in an inter-AS MPLS VPN Option A scenario to transmit MVPN data on the public network or across ASs.

Networking Requirements

A carrier needs to provide multicast services for downstream Internet Service Providers (ISPs). Multicast Virtual Private Network (MVPN) is used to ensure network security and reliability. Inter-AS MVPN Option A is suitable when either of the following conditions is met:

  • Multicast services need to be deployed on a network where inter-AS VPN Option A has been deployed.

  • There are a small number of VPNs that access each PE and there are a small number of VPN routes on each PE on a network where no inter-AS VPN mode is configured.

Inter-AS MVPN Option A supports Any-Source Multicast (ASM) and Source-Specific Multicast (SSM). ASM is used as example to show how to configure inter-AS MVPN Option A.

On the network shown in Figure 7-24, Source1 is required to provide multicast services for PC1. Therefore, multicast networks between ASs 65001 and 65002 must interwork to forward MVPN services.

Figure 7-24  Networking for configuring inter-AS MVPN Option A

Figure 7-24 lists the configurations of the interfaces shown in Table 7-5.

Table 7-5  The router interface configurations

Device

Interface IP Address

Remarks

PE1

GE1: 10.1.1.2/24

Belongs to a VPN instance named VPN1.

GE2: 172.16.1.2/24

Belongs to the public network instance.

Loopback 1: 1.1.1.9/32

Belongs to the public network instance and establishes an IBGP peer relationship with the Loopback 1 interface of ASBR1 and an EBGP peer relationship with GE1 of CE1.

PE2

GE1: 192.168.1.2/24

Belongs to the public network instance.

GE2: 10.2.1.2/24

Belongs to a VPN instance named VPN1.

Loopback 1: 4.4.4.9/32

Belongs to the public network instance and establishes an IBGP peer relationship with the Loopback 1 interface of ASBR 2 and an EBGP peer relationship with GE1 of CE2.

ASBR1

GE1: 172.16.1.1/24

Belongs to the public network instance.

GE2: 192.168.2.1/24

Belongs to a VPN instance named VPN1.

Loopback 1: 2.2.2.9/32

Belongs to the public network instance and establishes an IBGP peer relationship with the Loopback 1 interface of PE1 and an EBGP peer relationship with the Loopback 1 interface of ASBR2.

Loopback 2: 5.5.5.9/32

Belongs to the public network instance and serves as a Candidate-BSR (C-BSR) and Candidate-RP (C-RP) in the PIM domain to which AS 100 corresponds.

ASBR2

GE1: 192.168.2.2/24

Belongs to a VPN instance named VPN1.

GE2: 192.168.1.1/24

Belongs to the public network instance.

Loopback 1: 3.3.3.9/32

Belongs to the public network instance and establishes an IBGP peer relationship with the Loopback 1 interface of PE2 and an EBGP peer relationship with the Loopback 1 interface of ASBR1.

Loopback 2: 6.6.6.9/32

Belongs to the public network instance and serves as a C-BSR and C-RP in the PIM domain to which AS 101 corresponds.

CE1

GE1: 10.1.1.1/24

Establishes an EBGP peer relationship with the GE1 interface of PE1.

GE2: 10.111.5.1/24

-

Loopback 1: 8.8.8.8/32

-

CE2

GE1: 10.2.1.1/24

Establishes an EBGP peer relationship with the GE2 interface of PE2.

GE2: 10.111.8.1/24

-

Loopback 1: 9.9.9.9/32

-

Source1

10.111.5.2/24

Is a multicast source of VPN1.

PC2

10.111.8.2/24

Is a multicast receiver of VPN1.

NOTE:

GE1 represents GigabitEthernet 1/0/0 and GE2 represents GigabitEthernet 2/0/0.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure inter-AS BGP/MPLS IP VPN Option A to ensure that the inter-AS VPN works properly and unicast routes are reachable.

  2. Configure basic PIM-SM functions to ensure that multicast runs properly in each AS.

  3. Configure the same share-group address, and MTI for the same VPN instance on PE1,PE2,ASBR1 and ASBR2 and implement automatic MTI configuration.

Data Preparation

To complete the configuration, you need the following data:

  • RD of VPN1 in AS 100 (100:1) and AS 101 (101:1)

  • VPN-target (1:1) of VPN1

  • Share-group address (239.1.1.1) of VPN1

Procedure

  1. Configure inter-AS BGP/MPLS IP VPN Option A to ensure that the inter-AS VPN works properly and unicast routes are reachable.

    Inter-AS VPN Option A has been deployed on the network in this example. For configuration details, see the section "Example for Configuring Inter-AS VPN Option B" in the BGP/MPLS IP VPN Configuration in the Huawei AR Series Access Routers Configuration Guide - VPN.

  2. Configure basic PIM-SM functions to ensure that multicast runs properly in each AS.

    # Enable public network IP multicast routing and VPN IP multicast routing on PE1, and enable PIM-SM on the public network interface GE 2/0/0, VPN interface GE 1/0/0, and Loopback 1 of PE1.

    [PE1] multicast routing-enable
    [PE1] ip vpn-instance VPN1
    [PE1-vpn-instance-VPN1] multicast routing-enable
    [PE1-vpn-instance-VPN1] quit
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] pim sm
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] pim sm
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] interface loopback 1
    [PE1-LoopBack1] pim sm
    [PE1-LoopBack1] quit

    # Enable public network IP multicast routing and VPN IP multicast routing on PE2, and enable PIM-SM on the public network interface GE 1/0/0, VPN interface GE 2/0/0, and Loopback 1 of PE2.

    [PE2] multicast routing-enable
    [PE2] ip vpn-instance VPN1
    [PE2-vpn-instance-VPN1] multicast routing-enable
    [PE2-vpn-instance-VPN1] quit
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] pim sm
    [PE2-GigabitEthernet1/0/0] quit
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] pim sm
    [PE2-GigabitEthernet2/0/0] quit
    [PE2] interface loopback 1
    [PE2-LoopBack1] pim sm
    [PE2-LoopBack1] quit

    # Enable public network IP multicast routing and VPN IP multicast routing on ASBR 1, enable PIM-SM on the public network interface GE 1/0/0, GE 2/0/0, Loopback 1, and Loopback 2 of ASBR 1, and configure C-BSRs and C-RPs.

    [ASBR1] multicast routing-enable
    [ASBR1] ip vpn-instance VPN1
    [ASBR1-vpn-instance-VPN1] multicast routing-enable
    [ASBR1-vpn-instance-VPN1] quit
    [ASBR1] interface gigabitethernet 1/0/0
    [ASBR1-GigabitEthernet1/0/0] pim sm
    [ASBR1-GigabitEthernet1/0/0] quit
    [ASBR1] interface gigabitethernet 2/0/0
    [ASBR1-GigabitEthernet2/0/0] ip binding vpn-instance VPN1
    [ASBR1-GigabitEthernet2/0/0] pim sm
    [ASBR1-GigabitEthernet2/0/0] quit
    [ASBR1] interface loopback 1
    [ASBR1-LoopBack1] pim sm
    [ASBR1-LoopBack1] quit
    [ASBR1] interface loopback 2
    [ASBR1-LoopBack2] pim sm
    [ASBR1-LoopBack2] quit
    [ASBR1] pim
    [ASBR1-pim] c-bsr loopback 2
    [ASBR1-pim] c-rp loopback 2
    [ASBR1-pim] quit

    # Enable public network IP multicast routing and VPN IP multicast routing on ASBR 2, enable PIM-SM on the public network interface GE 1/0/0, GE 2/0/0, Loopback 1, and Loopback 2 of ASBR 2, and configure C-BSRs and C-RPs.

    [ASBR2] multicast routing-enable
    [ASBR2] ip vpn-instance VPN1
    [ASBR2-vpn-instance-VPN1] multicast routing-enable
    [ASBR2-vpn-instance-VPN1] quit
    [ASBR2] interface gigabitethernet 1/0/0
    [ASBR2-GigabitEthernet1/0/0] ip binding vpn-instance VPN1
    [ASBR2-GigabitEthernet1/0/0] pim sm
    [ASBR2-GigabitEthernet1/0/0] quit
    [ASBR2] interface gigabitethernet 2/0/0
    [ASBR2-GigabitEthernet2/0/0] pim sm
    [ASBR2-GigabitEthernet2/0/0] quit
    [ASBR2] interface loopback 1
    [ASBR2-LoopBack1] pim sm
    [ASBR2-LoopBack1] quit
    [ASBR2] interface loopback 2
    [ASBR2-LoopBack2] pim sm
    [ASBR2-LoopBack2] quit
    [ASBR2] pim
    [ASBR2-pim] c-bsr loopback 2
    [ASBR2-pim] c-rp loopback 2
    [ASBR2-pim] quit

    # Enable IP multicast routing on CE1, PIM-SM on the VPN interface GE 1/0/0 and Loopback 1, and PIM-SM and IGMP on the VPN interface GE 2/0/0, and configure C-BSRs and C-RPs.

    [CE1] multicast routing-enable
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] pim sm
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface loopback 1
    [CE1-LoopBack1] pim sm
    [CE1-LoopBack1] quit
    [CE1] interface gigabitethernet 2/0/0
    [CE1-GigabitEthernet2/0/0] pim sm
    [CE1-GigabitEthernet2/0/0] igmp enable
    [CE1-GigabitEthernet2/0/0] quit
    [CE1] pim
    [CE1-pim] c-bsr loopback 1
    [CE1-pim] c-rp loopback 1
    [CE1-pim] quit

    # Enable IP multicast routing on CE2, PIM-SM on the VPN interface GE 1/0/0 and Loopback 1, and PIM-SM and IGMP on the VPN interface GE 2/0/0.

    [CE2] multicast routing-enable
    [CE2] interface gigabitethernet 1/0/0
    [CE2-GigabitEthernet1/0/0] pim sm
    [CE2-GigabitEthernet1/0/0] quit
    [CE2] interface loopback 1
    [CE2-LoopBack1] pim sm
    [CE2-LoopBack1] quit
    [CE2] interface gigabitethernet 2/0/0
    [CE2-GigabitEthernet2/0/0] pim sm
    [CE2-GigabitEthernet2/0/0] igmp enable
    [CE2-GigabitEthernet2/0/0] quit

  3. Configure the same share-group address, and Multicast Tunnel Interface (MTI) for the same VPN instance on PE1, PE2, ASBR 1, and ASBR 2 and implement automatic MTI configuration.

    # On PE1, enter the VPN instance IPv4 address family view, configure a share-group, specify an MTI to be bound to the VPN instance and implement automatic MTI configuration.

    [PE1] ip vpn-instance VPN1
    [PE1-vpn-instance-VPN1] ipv4-family
    [PE1-vpn-instance-VPN1-af-ipv4] multicast-domain share-group 239.1.1.1 binding mtunnel 0
    [PE1-vpn-instance-VPN1-af-ipv4] multicast-domain source-interface loopback 1
    [PE1-vpn-instance-VPN1-af-ipv4] quit
    [PE1-vpn-instance-VPN1] quit

    # On PE2, enter the VPN instance IPv4 address family view, configure a share-group, specify an MTI to be bound to the VPN instance and implement automatic MTI configuration.

    [PE2] ip vpn-instance VPN1
    [PE2-vpn-instance-VPN1] ipv4-family
    [PE2-vpn-instance-VPN1-af-ipv4] multicast-domain share-group 239.1.1.1 binding mtunnel 0
    [PE2-vpn-instance-VPN1-af-ipv4] multicast-domain source-interface loopback 1
    [PE2-vpn-instance-VPN1-af-ipv4] quit
    [PE2-vpn-instance-VPN1] quit

    # On ASBR 1, enter the VPN instance IPv4 address family view, configure a share-group, specify an MTI to be bound to the VPN instance and implement automatic MTI configuration.

    [ASBR1] ip vpn-instance VPN1
    [ASBR1-vpn-instance-VPN1] ipv4-family
    [ASBR1-vpn-instance-VPN1-af-ipv4] multicast-domain share-group 239.1.1.1 binding mtunnel 0
    [ASBR1-vpn-instance-VPN1-af-ipv4] multicast-domain source-interface loopback 1
    [ASBR1-vpn-instance-VPN1-af-ipv4] quit
    [ASBR1-vpn-instance-VPN1] quit

    # On ASBR 2, enter the VPN instance IPv4 address family view, configure a share-group, specify an MTI to be bound to the VPN instance and implement automatic MTI configuration.

    [ASBR2] ip vpn-instance VPN1
    [ASBR2-vpn-instance-VPN1] ipv4-family
    [ASBR2-vpn-instance-VPN1-af-ipv4] multicast-domain share-group 239.1.1.1 binding mtunnel 0
    [ASBR2-vpn-instance-VPN1-af-ipv4] multicast-domain source-interface loopback 1
    [ASBR2-vpn-instance-VPN1-af-ipv4] quit
    [ASBR2-vpn-instance-VPN1] quit

  4. Verify the configuration.

    # Run the igmp static-group command on CE2 to configure static join.

    [CE2] interface loopback 1
    [CE2-LoopBack1] igmp static-group 226.0.0.7 source 8.8.8.8

    # Run the display pim routing-table command on CE1 to view the PIM routing table. The command output is as follows:

    [CE1] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 2 (S, G) entries
    
     (8.8.8.8, 226.0.0.7)
         RP: 8.8.8.8 (local)
         Protocol: pim-sm, Flag: SPT LOC
         UpTime: 00:03:18
         Upstream interface: LoopBack1
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: pim-sm, UpTime: 00:03:18, Expires: 00:03:11

    The preceding command output shows that Source1 can receive Join messages from PC1, indicating that inter-AS MVPN has been configured successfully.

Configuration Files

  • Configuration file of PE1

    #
    sysname PE1
    #
    multicast routing-enable
    #
    ip vpn-instance VPN1
     ipv4-family
      route-distinguisher 100:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack1
      multicast-domain share-group 239.1.1.1 binding mtunnel 0
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    mpls ldp
    # 
    interface GigabitEthernet1/0/0
     undo shutdown
     ip binding vpn-instance VPN1
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 172.16.1.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    # 
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance VPN1
    #
    bgp 100
     peer 2.2.2.9 as-number 100
     peer 2.2.2.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.9 enable
     # 
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.9 enable
     #
     ipv4-family vpn-instance VPN1
      peer 10.1.1.1 as-number 65001
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.16.1.0 0.0.0.255
    # 
    return
  • Configuration file of PE2

    #
    sysname PE2
    #
    multicast routing-enable
    #
    ip vpn-instance VPN1
     ipv4-family
      route-distinguisher 101:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack1
      multicast-domain share-group 239.1.1.1 binding mtunnel 0
    #
    mpls lsr-id 4.4.4.9
    mpls
    #
    mpls ldp
    # 
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    # 
    interface GigabitEthernet2/0/0
     undo shutdown
     ip binding vpn-instance VPN1
     ip address 10.2.1.2 255.255.255.0
     pim sm
    # 
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    interface MTunnel0
     ip binding vpn-instance VPN1
    #
    bgp 101
     peer 3.3.3.9 as-number 101
     peer 3.3.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.9 enable
     #
     ipv4-family vpn-instance VPN1
      peer 10.2.1.1 as-number 65002
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    return 
    
  • Configuration file of ASBR1

    #
    sysname ASBR1
    #
    multicast routing-enable
    #
    ip vpn-instance VPN1
     ipv4-family
      route-distinguisher 100:2
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack1
      multicast-domain share-group 239.1.1.1 binding mtunnel 0
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 172.16.1.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip binding vpn-instance VPN1
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    interface LoopBack2
     ip address 5.5.5.9 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance VPN1
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
     #
     ipv4-family vpn-instance VPN1
      import-route direct
      peer 192.168.2.2 as-number 101
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 5.5.5.9 0.0.0.0
    #
    pim
     c-bsr LoopBack2
     c-rp LoopBack2
    #
    return
    
  • Configuration file of ASBR2

    #
    sysname ASBR2
    #
    multicast routing-enable
    #
    ip vpn-instance VPN1
     ipv4-family
      route-distinguisher 200:2
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack1
      multicast-domain share-group 239.1.1.1 binding mtunnel 0
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip binding vpn-instance VPN1
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    interface LoopBack2
     ip address 6.6.6.9 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance VPN1
    #
    bgp 101
     peer 4.4.4.9 as-number 101
     peer 4.4.4.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 4.4.4.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 4.4.4.9 enable
     #
     ipv4-family vpn-instance VPN1
      import-route direct
      peer 192.168.2.1 as-number 100
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 6.6.6.9 0.0.0.0
    #
    pim
     c-bsr LoopBack2
     c-rp LoopBack2
    #
    return
  • Configuration file of CE1

    #
    sysname CE1
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.111.5.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface LoopBack1
     ip address 8.8.8.8 255.255.255.255
     pim sm
    # 
    bgp 65001
     peer 10.1.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      network 8.8.8.8 255.255.255.255
      import-route direct
      peer 10.1.1.2 enable
    #
    pim
     c-bsr LoopBack1
     c-rp LoopBack1
    #
    return 
    
  • Configuration file of CE2

    #
    sysname CE2
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.111.8.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface LoopBack1
     ip address 9.9.9.9 255.255.255.255
     pim sm
    #
    bgp 65002
     peer 10.2.1.2 as-number 101
     #
     ipv4-family unicast
      undo synchronization
      network 9.9.9.9 255.255.255.255
      import-route direct
      peer 10.2.1.2 enable
    #
    return
Translation
Download
Updated: 2019-06-12

Document ID: EDOC1000097181

Views: 20704

Downloads: 401

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next