No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Multicast

AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R007

This document describes the principles and configurations of IP multicast, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Receiver VPN Instance on the Source PE in the Remote-Cross Scenario of Multicast VPN Extranet

Example for Configuring the Receiver VPN Instance on the Source PE in the Remote-Cross Scenario of Multicast VPN Extranet

In the remote-cross scenario, you can implement multicast VPN extranet in an AS by configuring the receiver VPN instance on the source PE. In this manner, the user hosts in one VPN can receive multicast data from the multicast source in another VPN and thus inter-VPN multicast service transmission is implemented.

Networking Requirements

In current multicast VPN applications, only VPN sites in the same VPN can transmit multicast traffic between each other. Inter-VPN multicast traffic transmission, however, is not supported.

In actual situations, it is common that two enterprises in different VPNs need to communicate or a service provider needs to provide multicast services for multiple customers but the service provider and the customers are in different VPNs. Therefore, inter-VPN multicast service transmission is required so that multicast data from a user in one VPN can reach users in other VPNs.

On a single-AS MPLS/BGP VPN shown in Figure 7-29, Receiver in VPN RED wants to receive multicast data from Source in VPN BLUE. Because the receiver PE is a non-Huawei device, configuring the source VPN instance on the receiver VPN is not allowed. To solve this problem, you can configure VPN RED on the source PE (PE1) to implement inter-VPN multicast data transmission. In this manner, Receiver in VPN RED can receive multicast data from Source in VPN BLUE.

NOTE:

In such a scenario, Source and Receiver are in different VPNs. The source VPN and receiver VPN can be only PIM-SM/Source-Specific Multicast (SSM) networks.

Figure 7-29  Networking for configuring the receiver VPN instance on the source PE in the remote-cross scenario of multicast VPN extranet

Device Interface IP Address
CE1 GE 1/0/0 10.110.1.1/24
GE 2/0/0 10.110.2.1/24
Loopback1 11.11.11.11/32
PE1 GE 1/0/0 10.110.2.2/24
POS 2/0/0 192.168.1.1/24
Loopback1 1.1.1.1/32
P POS 1/0/0 192.168.1.2/24
POS 2/0/0 192.168.2.1/24
Loopback1 2.2.2.2/32
PE2 POS 1/0/0 192.168.2.2/24
GE 2/0/0 10.110.3.1/24
Loopback1 3.3.3.3/32
CE2 GE 1/0/0 10.110.3.2/24
GE 2/0/0 10.110.4.1/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic MPLS functions and MPLS LDP and set up LDP LSPs on the public network.

  2. Configure a unicast routing protocol on the public network and enable the multicast function, ensuring normal multicast routing on the public network.

  3. Configure a VPN instance enabled with the IPv4 address family on each PE; set the share-group address and address pool range of the switch-group for each VPN instance; create MTunnel interfaces; bind the interface connecting a PE to a CE to a VPN instance.

  4. Configure a unicast routing protocol on the public network and enable the multicast function in each VPN instance, ensuring normal multicast routing in the VPN instance.

  5. Establish a Multiprotocol Internal Border Gateway Protocol (MP-IBGP) peer relationship between PEs and configure a unicast routing protocol between a PE and a CE to ensure that the PE and the CE are routable.

  6. Configure the VPN instance (VPN RED) enabled with the IPv4 address family on PE1 and bind the VPN instance to an MTunnel interface.

  7. Configure Rendezvous Points (RPs) to serve the public network and the multicast groups running the multicast VPN extranet service separately so that Receiver in VPN RED can receive multicast data from Source in VPN BLUE.

Data Preparation

To complete the configuration, you need the following data:

  • Route Distinguisher (RD) and Router-Target (RT) of VPN BLUE: 100:1

  • RD and RT of VPN RED: 200:1

  • Share-group address of VPN BLUE: 239.0.0.0

  • Address pool range of the switch-group in VPN BLUE: 225.1.1.0 255.255.255.240

  • Share-group address of VPN RED: 238.0.0.0

  • Address pool range of the switch-group in VPN RED: 226.1.1.0 255.255.255.240

Procedure

  1. Configure basic MPLS functions and MPLS LDP and set up LDP LSPs on the public network.

    Configure router IDs and MPLS LSR IDs for PEs and P and enable MPLS and MPLS LDP in both the system view and the interface view.

    # Configure PE1.

    <Huawei> system-view
    [Huawei] sysname PE1
    [PE1] router id 1.1.1.1
    [PE1] mpls lsr-id 1.1.1.1
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface pos 2/0/0
    [PE1-POS2/0/0] mpls
    [PE1-POS2/0/0] mpls ldp
    [PE1-POS2/0/0] quit

    # Configure P.

    <Huawei> system-view
    [Huawei] sysname P
    [P] router id 2.2.2.2
    [P] mpls lsr-id 2.2.2.2
    [P] mpls
    [P-mpls] quit
    [P] mpls ldp
    [P-mpls-ldp] quit
    [P] interface pos 1/0/0
    [P-POS1/0/0] mpls
    [P-POS1/0/0] mpls ldp
    [P-POS1/0/0] quit
    [P] interface pos 2/0/0
    [P-POS2/0/0] mpls
    [P-POS2/0/0] mpls ldp
    [P-POS2/0/0] quit

    # Configure PE2.

    <Huawei> system-view
    [Huawei] sysname PE2
    [PE2] router id 3.3.3.3
    [PE2] mpls lsr-id 3.3.3.3
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface pos 1/0/0
    [PE2-POS1/0/0] mpls
    [PE2-POS1/0/0] mpls ldp
    [PE2-POS1/0/0] quit

  2. Configure a unicast routing protocol on the public network and enable the multicast function, ensuring normal multicast routing on the public network.

    # Configure OSPF on the public network to ensure that devices on the public network are routable. Enable the global multicast function and enable the PIM function in the interface view, ensuring normal running of the public network.

    # Configure PE1.

    [PE1] multicast routing-enable
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.1 32
    [PE1-LoopBack1] pim sm
    [PE1-LoopBack1] quit
    [PE1] interface pos 2/0/0
    [PE1-Pos2/0/0] ip address 192.168.1.1 24
    [PE1-Pos2/0/0] pim sm
    [PE1-Pos2/0/0] quit
    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # Configure P.

    [P] multicast routing-enable
    [P] interface loopback 1
    [P-LoopBack1] ip address 2.2.2.2 32
    [P-LoopBack1] pim sm
    [P-LoopBack1] quit
    [P] interface pos 1/0/0
    [P-Pos1/0/0] ip address 192.168.1.2 24
    [P-Pos1/0/0] pim sm
    [P-Pos1/0/0] quit
    [P] interface pos 2/0/0
    [P-Pos2/0/0] ip address 192.168.2.1 24
    [P-Pos2/0/0] pim sm
    [P-Pos2/0/0] quit
    [P] ospf
    [P-ospf-1] area 0
    [P-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [P-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] quit
    [P-ospf-1] quit

    # Configure PE2.

    [PE2] multicast routing-enable
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 3.3.3.3 32
    [PE2-LoopBack1] pim sm
    [PE2-LoopBack1] quit
    [PE2] interface pos 1/0/0
    [PE2-Pos1/0/0] ip address 192.168.2.2 24
    [PE2-Pos1/0/0] pim sm
    [PE2-Pos1/0/0] quit
    [PE2] ospf
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

  3. Configure a VPN instance enabled with the IPv4 address family on each PE; set the share-group address and address pool range of the switch-group for each VPN instance; create MTunnel interfaces; bind the interface connecting a PE to a CE to a VPN instance.

    # On PE1, create VPN BLUE enabled with the IPv4 address family. Enable the global multicast function in VPN BLUE and set the share-group address and address pool range of the switch-group for VPN BLUE. Bind the share-group address to MTunnel 0 and bind GE 1/0/0 connecting PE1 to CE1 to VPN BLUE.

    [PE1] ip vpn-instance BLUE
    [PE1-vpn-instance-BLUE] ipv4-family
    [PE1-vpn-instance-BLUE-af-ipv4] route-distinguisher 100:1
    [PE1-vpn-instance-BLUE-af-ipv4] vpn-target 100:1 both
    [PE1-vpn-instance-BLUE-af-ipv4] multicast routing-enable
    [PE1-vpn-instance-BLUE-af-ipv4] multicast-domain share-group 239.0.0.0 binding mtunnel 0
    [PE1-vpn-instance-BLUE-af-ipv4] multicast-domain switch-group-pool 225.1.1.0 28
    [PE1-vpn-instance-BLUE-af-ipv4] quit
    [PE1-vpn-instance-BLUE] quit
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] ip binding vpn-instance BLUE
    [PE1-GigabitEthernet1/0/0] ip address 10.110.2.2 24
    [PE1-GigabitEthernet1/0/0] pim sm
    [PE1-GigabitEthernet1/0/0] quit

    # On PE2, create VPN RED enabled with the IPv4 address family. Enable the global multicast function in VPN RED and set the share-group address and address pool range of the switch-group for VPN RED. Bind the share-group address to MTunnel 1 and bind GE 2/0/0 connecting PE2 to CE2 to VPN RED. Import the routes from VPN BLUE into VPN RED.

    [PE2] ip vpn-instance RED
    [PE2] ip vpn-instance RED
    [PE2-vpn-instance-RED] ipv4-family
    [PE2-vpn-instance-RED-af-ipv4] route-distinguisher 200:1
    [PE2-vpn-instance-RED-af-ipv4] vpn-target 200:1 both
    [PE2-vpn-instance-RED-af-ipv4] vpn-target 100:1 import-extcommunity 
    [PE2-vpn-instance-RED-af-ipv4] multicast routing-enable
    [PE2-vpn-instance-RED-af-ipv4] multicast-domain share-group 238.0.0.0 binding mtunnel 1
    [PE2-vpn-instance-RED-af-ipv4] multicast-domain switch-group-pool 226.1.1.0 28
    [PE2-vpn-instance-RED-af-ipv4] quit
    [PE2-vpn-instance-RED] quit
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] ip binding vpn-instance RED
    [PE2-GigabitEthernet2/0/0] ip address 10.110.3.1 24
    [PE2-GigabitEthernet2/0/0] quit

  4. Configure a unicast routing protocol on the public network and enable the multicast function in VPN BLUE and VPN RED separately, ensuring normal multicast routing in the VPN instances.

    # Configure OSPF in VPN BLUE to ensure that devices in VPN BLUE are routable. Enable the global multicast function and enable the PIM function in the interface view, ensuring normal running of the multicast network in the VPN instances.

    # Configure CE1.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] multicast routing-enable
    [CE1] interface loopback 1
    [CE1-LoopBack1] ip address 11.11.11.11 32
    [CE1-LoopBack1] pim sm
    [CE1-LoopBack1] quit
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] ip address 10.110.1.1 24
    [CE1-GigabitEthernet1/0/0] pim sm
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface gigabitethernet 2/0/0
    [CE1-GigabitEthernet2/0/0] ip address 10.110.2.1 24
    [CE1-GigabitEthernet2/0/0] pim sm
    [CE1-GigabitEthernet2/0/0] quit
    [CE1] ospf 2
    [CE1-ospf-2] area 0
    [CE1-ospf-2-area-0.0.0.0] network 11.11.11.11 0.0.0.0
    [CE1-ospf-2-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [CE1-ospf-2-area-0.0.0.0] network 10.110.2.0 0.0.0.255
    [CE1-ospf-2-area-0.0.0.0] quit
    [CE1-ospf-2] quit

    # Configure CE2.

    <Huawei> system-view
    [Huawei] sysname CE2
    [CE2] interface gigabitethernet 1/0/0
    [CE2-GigabitEthernet1/0/0] ip address 10.110.3.2 24
    [CE2-GigabitEthernet1/0/0] pim sm
    [CE2-GigabitEthernet1/0/0] quit
    [CE2] interface gigabitethernet 2/0/0
    [CE2-GigabitEthernet2/0/0] ip address 10.110.4.1 24
    [CE2-GigabitEthernet2/0/0] pim sm
    [CE2-GigabitEthernet2/0/0] quit
    [CE2] ospf 2
    [CE2-ospf-2] area 0
    [CE2-ospf-2-area-0.0.0.0] network 10.110.3.0 0.0.0.255
    [CE2-ospf-2-area-0.0.0.0] network 10.110.4.0 0.0.0.255
    [CE2-ospf-2-area-0.0.0.0] quit
    [CE2-ospf-2] quit

  5. Configure VPN RED enabled with the IPv4 address family on PE1 and bind VPN RED to MTunnel 1.

    # Configure VPN RED enabled with the IPv4 address family on PE1, set the share-group address and address pool range of the switch-group for VPN RED, and bind the share-group address to MTunnel 1. Import the routes from VPN BLUE into VPN RED.

    [PE1] ip vpn-instance RED
    [PE1-vpn-instance-RED] ipv4-family
    [PE1-vpn-instance-RED-af-ipv4] route-distinguisher 200:1
    [PE1-vpn-instance-RED-af-ipv4] vpn-target 200:1 both
    [PE1-vpn-instance-RED-af-ipv4] vpn-target 100:1 import-extcommunity 
    [PE1-vpn-instance-RED-af-ipv4] multicast routing-enable
    [PE1-vpn-instance-RED-af-ipv4] multicast-domain share-group 238.0.0.0 binding mtunnel 1
    [PE1-vpn-instance-RED-af-ipv4] multicast-domain switch-group-pool 226.1.1.0 28
    [PE1-vpn-instance-RED-af-ipv4] quit
    [PE1-vpn-instance-RED] quit

  6. Establish an MP-IBGP peer relationship between PEs; configure a unicast routing protocol between a PE and a CE to ensure that the PE and the CE are routable.

    # Establish an MP-IBGP peer relationship between PE1 and PE2 and configure OSPF between CE1 and PE1 and between CE2 and PE2 to ensure that PEs and CEs are routable.

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] peer 3.3.3.3 as-number 100
    [PE1-bgp] peer 3.3.3.3 connect-interface LoopBack 1
    [PE1-bgp] ipv4-family vpn-instance BLUE
    [PE1-bgp-BLUE] import-route ospf 2
    [PE1-bgp-BLUE] import-route direct
    [PE1-bgp-BLUE] quit
    [PE1-bgp] ipv4-family vpn-instance RED
    [PE1-bgp-RED] import-route ospf 2
    [PE1-bgp-RED] import-route direct
    [PE1-bgp-RED] quit
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 3.3.3.3 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit
    [PE1] ospf 2 vpn-instance BLUE
    [PE1-ospf-2] import-route bgp
    [PE1-ospf-2] area 0
    [PE1-ospf-2-area-0.0.0.0] network 10.110.2.0 0.0.0.255
    [PE1-ospf-2-area-0.0.0.0] quit
    [PE1-ospf-2] quit

    # Configure PE2.

    [PE2] bgp 100
    [PE2-bgp] peer 1.1.1.1 as-number 100
    [PE2-bgp] peer 1.1.1.1 connect-interface LoopBack 1
    [PE2-bgp] ipv4-family vpn-instance RED
    [PE2-bgp-RED] import-route ospf 2
    [PE2-bgp-RED] import-route direct
    [PE2-bgp-RED] quit
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 1.1.1.1 enable
    [PE2-bgp-af-vpnv4] quit
    [PE2-bgp] quit
    [PE2] ospf 2 vpn-instance RED
    [PE2-ospf-3] import-route bgp
    [PE2-ospf-2] area 0
    [PE2-ospf-2-area-0.0.0.0] network 10.110.3.0 0.0.0.255
    [PE2-ospf-2-area-0.0.0.0] quit
    [PE2-ospf-2] quit

  7. Configure IP addresses for MTunnel interfaces.

    # On each PE, configure the address of the MTunnel interface as the address of loopback 1. The system automatically associates the MTunnel interfaces with VPN BLUE and VPN RED.

    # Configure PE1.

    [PE1] interface mtunnel 0
    [PE1-MTunnel0] ip address 1.1.1.1 32
    [PE1-MTunnel0] quit
    [PE1] interface mtunnel 1
    [PE1-MTunnel1] ip address 1.1.1.1 32
    [PE1-MTunnel1] quit

    # Configure PE2.

    [PE2] interface mtunnel 1
    [PE2-MTunnel1] ip address 3.3.3.3 32
    [PE2-MTunnel1] quit

  8. Configure an RP to serve the public network.

    # Configure loopback 1 on P as a Candidate-BSR (C-BSR) and a Candidate-RP (C-RP) on the public network.

    [P] pim
    [P-pim] c-bsr Loopback 1 
    [P-pim] c-rp Loopback 1
    [P-pim] quit

  9. Configure an RP to serve the multicast groups running the multicast VPN extranet service.

    # In the PIM view of CE1 and CE2, view of VPN BLUE on PE1, and view of VPN RED on PE1 and PE2, configure loopback 1 of CE1 as a static RP to serve the multicast groups running the multicast VPN extranet service.

    NOTE:

    Source VPN instances and receiver VPN instances support only static RPs. In addition, static RPs must be deployed only in source VPN instances.

    # Configure CE1.

    [CE1] pim
    [CE1-pim] static-rp 11.11.11.11
    [CE1-pim] quit

    # Configure PE1.

    [PE1] pim vpn-instance BLUE
    [PE1-pim-BLUE] static-rp 11.11.11.11
    [PE1-pim-BLUE] quit
    [PE1] pim vpn-instance RED
    [PE1-pim-RED] static-rp 11.11.11.11
    [PE1-pim-RED] quit

    # Configure PE2.

    [PE2] pim vpn-instance RED
    [PE2-pim-RED] static-rp 11.11.11.11
    [PE2-pim-RED] quit

    # Configure CE2.

    [CE2] pim
    [CE2-pim] static-rp 11.11.11.11
    [CE2-pim] quit

  10. Verify the configuration.

    By checking the configuration result, you can view that Receiver in VPN RED can receive multicast data from Source in VPN BLUE.

    # Run the display pim routing-table command on PE1 to check information about the PIM routing table. The following command output shows that the upstream of the Reverse Path Forwarding (RPF) route selected by the PIM entry corresponding to group 228.0.0.1 is VPN BLUE.

    <PE1> display pim vpn-instance RED routing-table extranet source-vpn-instance BLUE
     VPN-Instance: RED
     Total 2 (*, G) entries; 1 (S, G) entry
    
     Total matched 1 (*, G) entry; 1 (S, G) entry
    
     (*, 228.0.0.1)
         RP: 11.11.11.11
         Protocol: pim-sm, Flag: WC
         UpTime: 00:01:28
         Upstream interface: MCAST_Extranet(BLUE)
             Upstream neighbor: 10.110.2.1
             RPF prime neighbor: 10.110.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: MTunnel1
                 Protocol: pim-sm, UpTime: 00:01:28, Expires: 00:03:01
    
     (10.110.1.2, 228.0.0.1)
         RP: 11.11.11.11
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:01:28
         Upstream interface: MCAST_Extranet(BLUE)
             Upstream neighbor: 10.110.2.1
             RPF prime neighbor: 10.110.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: MTunnel1
                 Protocol: pim-sm, UpTime: 00:01:28, Expires: 00:03:07
    

    # Run the display multicast routing-table command on PE1 to check information about the multicast routing table. The following command output shows that the upstream of the RPF route selected by the multicast routing entry corresponding to group 228.0.0.1 is VPN BLUE.

    <PE1> display multicast vpn-instance RED routing-table extranet source-vpn-instance BLUE
    Multicast routing table of VPN-Instance: RED
     Total 1 entry ,1 matched
    
     00001. (10.110.1.2, 228.0.0.1)
           Uptime: 00:00:39
           Upstream Interface: MCAST_Extranet(BLUE)
           List of 1 downstream interface
               1:  MTunnel1
    

    # Run the display multicast rpf-info command on PE1 to check the RPF routing information of source 10.110.1.2. The following command output shows that the upstream of the RPF route selected by the multicast routing entry corresponding to group 228.0.0.1 is VPN BLUE.

    <PE1> display multicast vpn-instance RED rpf-info 10.110.1.2 228.0.0.1
     VPN-Instance: RED
     RPF information about source 10.110.1.2 and group 228.0.0.1 
         RPF interface: MCAST_Extranet
         RPF Source VPN-Instance: BLUE
         Referenced route/mask: 10.110.1.0/24
         Referenced route type: unicast
         Route selection rule: preference-preferred
         Load splitting rule: disabled
    

    # After the preceding configurations, Receiver can receive multicast data from Source. Run the display pim routing-table command on CE2 to check information about the PIM routing table. The following command output shows that multicast data has reached CE2 and forwarded to Receiver.

    <CE2> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 228.0.0.1)
         RP: 11.11.11.11
         Protocol: pim-sm, Flag: WC
         UpTime: 00:01:31
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.110.3.1
             RPF prime neighbor: 10.110.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Serial0/0/1
                 Protocol: igmp, UpTime: 00:01:31, Expires: -
    
     (10.110.1.2, 228.0.0.1)
         RP: 11.11.11.11
         Protocol: pim-sm, Flag: SPT ACT     
         UpTime: 00:00:08
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.110.3.1
             RPF prime neighbor: 10.110.3.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Serial0/0/1
                 Protocol: pim-sm, UpTime: 00:00:08, Expires: -
    

Configuration Files

  • Configuration file of PE1

    #
     sysname PE1
    #
     router id 1.1.1.1
    #
     multicast routing-enable
    #
     mpls lsr-id 1.1.1.1
     mpls 
    #
    mpls ldp
    #
    ip vpn-instance BLUE
     ipv4-family
      route-distinguisher 100:1
      vpn-target 100:1 export-extcommunity
      vpn-target 100:1 import-extcommunity
      multicast routing-enable
      multicast-domain share-group 239.0.0.0 binding mtunnel 0
      multicast-domain switch-group-pool 225.1.1.0 255.255.255.240
    ip vpn-instance RED
     ipv4-family
      route-distinguisher 200:1
      vpn-target 200:1 export-extcommunity
      vpn-target 200:1 100:1 import-extcommunity
      multicast routing-enable
      multicast-domain share-group 238.0.0.0 binding mtunnel 1
      multicast-domain switch-group-pool 226.1.1.0 255.255.255.240
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip binding vpn-instance BLUE
     ip address 10.110.2.2 255.255.255.0
     pim sm
    #
    interface POS2/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.1.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance BLUE
     ip address 1.1.1.1 255.255.255.255
    #
    interface MTunnel1
     ip binding vpn-instance RED
     ip address 1.1.1.1 255.255.255.255
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.3 enable
     #
     ipv4-family vpn-instance BLUE
      import-route direct
      import-route ospf 2
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 1.1.1.1 0.0.0.0
    #
    ospf 2 vpn-instance BLUE
     import-route bgp
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
    #
    pim
    #
    pim vpn-instance BLUE
     static-rp 11.11.11.11
    #
    pim vpn-instance RED
     static-rp 11.11.11.11
    #
    return 
  • Configuration file of P

    #
     sysname P
    #
     router id 2.2.2.2
    #
     multicast routing-enable
    #
     mpls lsr-id 2.2.2.2
     mpls 
    #
    mpls ldp
    #
    interface POS1/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.1.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface POS2/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.2.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 2.2.2.2 0.0.0.0
    #
    pim
     c-bsr LoopBack1
     c-rp LoopBack1
    #
    return
  • Configuration file of PE2

    #
     sysname PE2
    #
     router id 3.3.3.3
    #
     multicast routing-enable
    #
     mpls lsr-id 3.3.3.3
     mpls 
    #
    mpls ldp
    #
    ip vpn-instance RED
     ipv4-family
      route-distinguisher 200:1
      vpn-target 200:1 export-extcommunity
      vpn-target 200:1 100:1 import-extcommunity
      multicast routing-enable
      multicast-domain share-group 238.0.0.0 binding mtunnel 1
      multicast-domain switch-group-pool 226.1.1.0 255.255.255.240
    #
    interface POS1/0/0
     link-protocol ppp
     undo shutdown
     ip address 192.168.2.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip binding vpn-instance RED
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    interface MTunnel1
     ip binding vpn-instance RED
     ip address 3.3.3.3 255.255.255.255
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
     #
     ipv4-family vpn-instance RED
      import-route direct
      import-route ospf 2
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 3.3.3.3 0.0.0.0
    #
    ospf 2 vpn-instance RED
     import-route bgp
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
    #
    pim
    #
    pim vpn-instance RED
     static-rp 11.11.11.11
    #
    return
    
  • Configuration file of CE1

    #
     sysname CE1
    #
     multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.110.2.1 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 11.11.11.11 255.255.255.255
     pim sm
    #
    ospf 2
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 10.110.2.0 0.0.0.255
      network 11.11.11.11 0.0.0.0
    #
    pim
     static-rp 11.11.11.11
    #
    return 
  • Configuration file of CE2

    #
     sysname CE2
    #
     multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.110.3.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.110.4.1 255.255.255.0
     pim sm
     igmp enable
     #
    ospf 2
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 10.110.4.0 0.0.0.255
    #
    pim
     static-rp 11.11.11.11
    #
    return 
    
Translation
Download
Updated: 2019-06-12

Document ID: EDOC1000097181

Views: 21564

Downloads: 403

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next