No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR500, AR510, and AR530 V200R007 CLI-based Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring transparent bridge, MAC table, link aggregation, VLANs, STP/RSTP/MSTP, and so on.The document provides the configuration procedures and configuration examples to illustrate the service configuration methods and application scenario.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Link Aggregation in Manual Load Balancing Mode

Example for Configuring Link Aggregation in Manual Load Balancing Mode

Networking Requirements

As shown in Figure 2-12, RouterA and RouterB connect to devices in VLAN 10 and VLAN 20 through Ethernet links, and heavy traffic is transmitted between RouterA and RouterB.

RouterA and RouterB can provide higher link bandwidth to implement inter-VLAN communication. Reliability of data transmission needs to be ensured.

Figure 2-12  Configuring link aggregation in manual load balancing mode

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk and add member interfaces to the Eth-Trunk to increase link bandwidth.

  2. Create VLANs and add interfaces to the VLANs.

  3. Configure a load balancing mode to ensure that traffic is load balanced among Eth-Trunk member interfaces.

Procedure

  1. Create an Eth-Trunk on RouterA and add member interfaces to the Eth-Trunk. The configuration of RouterB is similar to the configuration of RouterA, and is not mentioned here.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface Eth-Trunk1
    [RouterA-Eth-Trunk1] trunkport ethernet 1/0/1 to 1/0/3
    [RouterA-Eth-Trunk1] quit

  2. Create VLANs and add interfaces to the VLANs. The configuration of RouterB is similar to the configuration of RouterA, and is not mentioned here.

    # Create VLAN 10 and VLAN 20, and add interfaces to VLAN 10 and VLAN 20.

    [RouterA] vlan batch 10 20
    [RouterA] interface ethernet 1/0/4
    [RouterA-Ethernet1/0/4] port link-type trunk
    [RouterA-Ethernet1/0/4] port trunk allow-pass vlan 10
    [RouterA-Ethernet1/0/4] quit
    [RouterA] interface ethernet 1/0/5
    [RouterA-Ethernet1/0/5] port link-type trunk
    [RouterA-Ethernet1/0/5] port trunk allow-pass vlan 20
    [RouterA-Ethernet1/0/5] quit
    

    # Configure Eth-Trunk 1 to allow packets from VLAN 10 and VLAN 20 to pass through.

    [RouterA] interface Eth-Trunk1
    [RouterA-Eth-Trunk1] port link-type trunk
    [RouterA-Eth-Trunk1] port trunk allow-pass vlan 10 20
    

  3. Configure a load balancing mode for Eth-Trunk 1. The configuration of RouterB is similar to the configuration of RouterA, and is not mentioned here.

    [RouterA] load-balance src-dst-mac

  4. Verify the configuration.

    # Run the display eth-trunk 1 command in any view to check whether the Eth-Trunk is created and whether member interfaces are added.

    [RouterA] display eth-trunk 1
    Eth-Trunk1's state information is: 
    WorkingMode: NORMAL          Hash arithmetic: According to SIP-XOR-DIP             
    Least Active-linknumber: 1     Max Bandwidth-affected-linknumber: 8
    Operate status: up             Number Of Up Ports In Trunk: 3 
    --------------------------------------------------------------------------------
    PortName                           Status       Weight
    Ethernet1/0/1                       Up           1
    Ethernet1/0/2                       Up           1
    Ethernet1/0/3                       Up           1
    

    # The preceding command output shows that Eth-Trunk 1 has three member interfaces: Ethernet1/0/1, Ethernet1/0/2, and Ethernet1/0/3. The member interfaces are all in Up state.

Configuration Files

  • Configuration file of RouterA

    #
     sysname RouterA
    #                                                                               
    vlan batch 10 20
    # 
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac 
    # 
    interface Ethernet1/0/1 
     eth-trunk 1
    # 
    interface Ethernet1/0/2
     eth-trunk 1
    # 
    interface Ethernet1/0/3
     eth-trunk 1
    #
    interface Ethernet1/0/4
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface Ethernet1/0/5
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of RouterB

    #
     sysname RouterB
    #                                                                               
    vlan batch 10 20
    # 
    interface Eth-Trunk1
     port link-type trunk 
     port trunk allow-pass vlan 10 20
     load-balance src-dst-mac 
    # 
    interface Ethernet1/0/1
     eth-trunk 1
    # 
    interface Ethernet1/0/2
     eth-trunk 1
    # 
    interface Ethernet1/0/3
     eth-trunk 1
    #
    interface Ethernet1/0/4
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    interface Ethernet1/0/5
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    return
Translation
Download
Updated: 2019-05-25

Document ID: EDOC1000097279

Views: 20041

Downloads: 64

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next