No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR500, AR510, and AR530 V200R007 CLI-based Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring transparent bridge, MAC table, link aggregation, VLANs, STP/RSTP/MSTP, and so on.The document provides the configuration procedures and configuration examples to illustrate the service configuration methods and application scenario.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic QinQ

Example for Configuring Basic QinQ

Networking Requirements

As shown in Figure 8-7, enterprise A has two branches that connect to the carrier network through PE1 and PE2 respectively. Enterprise A has different services, so different VLANs are assigned.

The requirements are as follows:
  • VLANs are assigned independently in enterprise A, and are independent of carrier VLANs or VLANs of other enterprises.
  • Traffic between two branches of enterprise A is transparently transmitted through the public network, devices transmitting the same service in different branches of enterprise A are allowed to communicate, and devices transmitting different services are isolated.
Figure 8-7  Networking diagram for configuring basic QinQ

Configuration Roadmap

The configuration roadmap is as follows:

You can configure the basic QinQ function on a CE connected to a PE and implement communication between two branches of enterprise A through VLAN 20 provided by the carrier.

  1. Create a bridge group and add a sub-interface to the bridge group.

  2. Configure VLANs allowed by the sub-interface.

  3. Configure basic QinQ on the CE interface connected to the PE so that the CE can add the S-VLAN tag to user packets.

  4. Add interfaces of the PE and P to VLAN 20 so that packets from VLAN 20 are allowed to pass through.

Procedure

  1. Create a bridge group and add a sub-interface to the bridge group.

    # Create a bridge group and add a sub-interface to the bridge group on CE1. The configuration of CE2 is similar to that of CE1.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] bridge 1
    [CE1-bridge1] quit
    [CE1] interface gigabitethernet 0/0/0.1
    [CE1-GigabitEthernet0/0/0.1] bridge 1
    [CE1-GigabitEthernet0/0/0.1] bridge vlan-transmit enable
    [CE1-GigabitEthernet0/0/0.1] quit
    [CE1] interface gigabitethernet 0/0/1
    [CE1-GigabitEthernet0/0/1] bridge 1
    [CE1-GigabitEthernet0/0/1] bridge vlan-transmit enable
    [CE1-GigabitEthernet0/0/0] quit
    

  2. Configure VLANs allowed by the sub-interface.

    # Configure VLANs allowed by the sub-interface on CE1. The configuration of CE2 is similar to that of CE1.

    [CE1-GigabitEthernet0/0/0.1] vlan allow-pass vid 10 to 50
    

  3. Configure an interface on CE connected to a PE to add a VLAN tag to user packets.

    # Configure an interface on CE1 connected to a PE to add a VLAN tag to user packets. The configuration of CE2 is similar to that of CE1.

    [CE1-GigabitEthernet0/0/0.1] vlan dot1q-tunnel 20
    [CE1-GigabitEthernet0/0/0.1] quit
    

  4. Add interfaces on PEs to VLAN 20 in trunk mode. The configurations of PE2 and P are similar to the configuration of PE1.

    # Add GE0/0/0 and GE0/0/1 on PE1 to VLAN 20 in trunk mode.

    <Huawei> system-view
    [Huawei] sysname PE1
    [PE1] vlan batch 20
    [PE1] interface gigabitethernet 0/0/0
    [PE1-GigabitEthernet0/0/0] port link-type trunk
    [PE1-GigabitEthernet0/0/0] port trunk allow-pass vlan 20
    [PE1-GigabitEthernet0/0/0] quit
    [PE1] interface gigabitethernet 0/0/1
    [PE1-GigabitEthernet0/0/1] port link-type trunk
    [PE1-GigabitEthernet0/0/1] port trunk allow-pass vlan 20
    [PE1-GigabitEthernet0/0/1] quit
    

  5. Verify the configuration.

    # On a PC in a VLAN of a branch in enterprise A, ping a PC in the same VLAN of the other branch in enterprise A. The ping operation succeeds, indicating that devices transmitting the same service can communicate with each other.

Configuration Files

  • CE1 configuration file
    #
     sysname CE1
    #
    bridge 1
    #
    interface GigabitEthernet0/0/0.1
     bridge 1
     bridge vlan-transmit enable
     vlan allow-pass vid 10 to 50 
     vlan dot1q-tunnel 20
    #
    interface GigabitEthernet0/0/1
     bridge 1    
     bridge vlan-transmit enable
    #
    return
  • CE2 configuration file
    #
     sysname CE2
    #
    bridge 1
    #
    interface GigabitEthernet0/0/0.1
     bridge 1
     bridge vlan-transmit enable
     vlan allow-pass vid 10 to 50 
     vlan dot1q-tunnel 20
    #
    interface GigabitEthernet0/0/1
     bridge 1    
     bridge vlan-transmit enable
    #
    return
  • PE1 configuration file
    #
     sysname PE1
    #
    vlan batch 20
    #
    interface GigabitEthernet0/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • PE2 configuration file
    #
     sysname PE2
    #
    vlan batch 20
    #
    interface GigabitEthernet0/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • P configuration file
    #
     sysname P
    #
    vlan batch 20
    #
    interface GigabitEthernet0/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
Translation
Download
Updated: 2019-05-25

Document ID: EDOC1000097279

Views: 11535

Downloads: 62

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next