No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR500, AR510, and AR530 V200R007 CLI-based Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring transparent bridge, MAC table, link aggregation, VLANs, STP/RSTP/MSTP, and so on.The document provides the configuration procedures and configuration examples to illustrate the service configuration methods and application scenario.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN Aggregation

Example for Configuring VLAN Aggregation

Networking Requirements

As shown in Figure 4-7, a company has many departments on the same network segment. To improve service security, the company adds different departments to different VLANs. VLAN 2 and VLAN 3 belong to different departments. Each department wants to access the Internet, and PCs in different departments need to communicate to meet service requirements.

Figure 4-7  Networking of VLAN aggregation

Configuration Roadmap

Configure VLAN aggregation on RouterB to add VLANs of different departments to a super-VLAN so that PCs in different departments can access the Internet using the super-VLAN. Deploy proxy ARP in the super-VLAN so that PCs in different departments can communicate. The configuration roadmap is as follows:

  1. Configure VLANs and interfaces on RouterA and RouterB, add PCs of different departments to different VLANs, and configure interfaces to transparently transmit packets from VLANs to RouterB.
  2. Configure a super-VLAN, a VLANIF interface, and a static route on RouterB so that PCs in different departments can access the Internet.
  3. Configure proxy ARP in the super-VLAN on RouterB so that PCs in different departments can communicate at Layer 3.

Procedure

  1. Configure VLANs and interfaces on RouterA and RouterB, add PCs of different departments to different VLANs, and configure interfaces to transparently transmit packets from VLANs to RouterB.

    1. Configure RouterA.

      # Configure Eth2/0/1 as an access interface. The configurations of Eth2/0/2, Eth2/0/3, and Eth2/0/4 are similar to the configuration of Eth2/0/1, and are not mentioned here.

      <Huawei> system-view
      [Huawei] sysname RouterA
      [RouterA] interface ethernet 2/0/1
      [RouterA-Ethernet2/0/1] port link-type access
      [RouterA-Ethernet2/0/1] quit

      # Create VLAN 2 and add Eth2/0/1 and Eth2/0/2 to VLAN 2.

      [RouterA] vlan 2
      [RouterA-vlan2] port ethernet 2/0/1 2/0/2
      [RouterA-vlan2] quit
      

      # Create VLAN 3 and add Eth2/0/3 and Eth2/0/4 to VLAN 3.

      [RouterA] vlan 3
      [RouterA-vlan3] port ethernet 2/0/3 2/0/4
      [RouterA-vlan3] quit
      

      # Configure the interface of RouterA connected to RouterB to transparently transmit packets from VLAN 2 and VLAN 3 to RouterB.

      [RouterA] interface ethernet 2/0/5
      [RouterA-Ethernet2/0/5] port link-type trunk
      [RouterA-Ethernet2/0/5] port trunk allow-pass vlan 2 3
      [RouterA-Ethernet2/0/5] quit
    2. Configure RouterB.

      # Create VLAN 2, VLAN 3, VLAN 4, and VLAN 10 and configure the interface of RouterB connected to RouterA to transparently transmit packets from VLAN 2 and VLAN 3 to RouterB.

      <Huawei> system-view
      [Huawei] sysname RouterB
      [RouterB] vlan batch 2 3 4 10
      [RouterB] interface ethernet 2/0/5
      [RouterB-Ethernet2/0/5] port link-type trunk
      [RouterB-Ethernet2/0/5] port trunk allow-pass vlan 2 3
      [RouterB-Ethernet2/0/5] quit

  2. Configure a super-VLAN and a VLANIF interface corresponding to the super-VLAN.

    # Configure super-VLAN 4 on RouterB and add VLAN 2 and VLAN 3 to super-VLAN 4 as sub-VLANs.

    [RouterB] vlan 4
    [RouterB-vlan4] aggregate-vlan
    [RouterB-vlan4] access-vlan 2 to 3
    [RouterB-vlan4] quit
    

    # Create and configure VLANIF 4 so that PCs in different departments can access the Internet using super-VLAN 4.

    [RouterB] interface vlanif 4
    [RouterB-Vlanif4] ip address 10.1.1.1 255.255.255.0
    [RouterB-Vlanif4] quit
    

  3. Configure a static route.

    # Configure the uplink interface Eth2/0/1 on RouterB to transparently transmit packets from the VLAN that RouterB and router belong to.

    [RouterB] interface ethernet 2/0/1
    [RouterB-Ethernet2/0/1] port link-type trunk
    [RouterB-Ethernet2/0/1] port trunk allow-pass vlan 10
    [RouterB-Ethernet2/0/1] quit

    # Create and configure VLANIF 10 and specify the IP address of VLANIF 10 as the IP address for connecting RouterB and the router (egress gateway).

    [RouterB] interface vlanif 10
    [RouterB-Vlanif10] ip address 10.10.1.1 255.255.255.0
    [RouterB-Vlanif10] quit
    

    # Configure a static route to the router on RouterB so that PCs can access the Internet.

    [RouterB] ip route-static 0.0.0.0 0.0.0.0 10.10.1.2

  4. Assign IP addresses to PCs.

    Configure an IP address for each PC and make the PCs reside on the same network segment as VLAN 4.

    After the configuration is complete, PCs in each department can access the Internet, and PCs in VLAN 2 and VLAN 3 cannot ping each other.

  5. Configure proxy ARP.

    # Configure proxy ARP in super-VLAN 4 on RouterB so that PCs in different departments can communicate at Layer 3.

    [RouterB] interface vlanif 4 
    [RouterB-Vlanif4] arp-proxy inter-sub-vlan-proxy enable
    [RouterB-Vlanif4] quit

  6. Verify the configuration.

    # After the configuration is complete, PCs in VLAN 2 and VLAN 3 can ping each other and access the Internet.

Configuration Files

  • RouterA configuration file

    #
    sysname RouterA
    #
    vlan batch 2 to 3
    #
    interface Ethernet2/0/1
     port link-type access
     port default vlan 2
    #
    interface Ethernet2/0/2
     port link-type access
     port default vlan 2
    #
    interface Ethernet2/0/3
     port link-type access
     port default vlan 3
    #
    interface Ethernet2/0/4
     port link-type access
     port default vlan 3
    #
    interface Ethernet2/0/5
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • RouterB configuration file

    #
    sysname RouterB
    #
    vlan batch 2 to 4 10
    #
    vlan 4
     aggregate-vlan
     access-vlan 2 to 3
    #
    interface Vlanif4
     ip address 10.1.1.1 255.255.255.0
     arp-proxy inter-sub-vlan-proxy enable
    #
    interface Vlanif10
     ip address 10.10.1.1 255.255.255.0
    #
    interface Ethernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface Ethernet2/0/5
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    ip route-static 0.0.0.0 0.0.0.0 10.10.1.2
    #
    return
Translation
Download
Updated: 2019-05-25

Document ID: EDOC1000097279

Views: 20312

Downloads: 64

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next