No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR500, AR510, and AR530 V200R007 CLI-based Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring transparent bridge, MAC table, link aggregation, VLANs, STP/RSTP/MSTP, and so on.The document provides the configuration procedures and configuration examples to illustrate the service configuration methods and application scenario.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Local Bridging with IP Routing

Example for Configuring Local Bridging with IP Routing

Configuring local bridging and IP routing allows LANs on different network segments to communicate with each other.

Networking Requirements

Departments of Enterprise A need to communicate with each other and with local Enterprise B.

Departments of Enterprise A belong to the LANs on the same network segment and can be bridged, but Enterprise B belongs to a LAN on a different network segment. As a result, link-layer bridging cannot be used to communicate between Enterprise A and Enterprise B.

In this scenario, local bridging integrated with IP routing offers a viable solution.

As shown in Figure 15-19, bridge groups are configured on local bridging, and interfaces are added to different bridge groups. After Bridge-if interfaces are created and assigned IP addresses, and the IP routing function is enabled, the two hosts of Enterprise A can communicate with the hosts of Enterprises B.

Figure 15-19  Networking diagram of local bridging integrated with IP routing

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create a bridge group on RouterA.

  2. Add Eth2/0/1 and Eth2/0/2 on Router A to the created bridge group to allow the two hosts of Enterprise A to communicate with each other.

  3. Create a Bridge-if interface and enable IP routing for the bridge group on RouterA to allow Enterprise A to communicate with Enterprise B.

Procedure

  1. Configure the IP routing function.

    # Create bridge group 1 and enable local bridging and IP routing for the bridge group.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] bridge 1
    [RouterA-bridge1] routing ip
    [RouterA-bridge1] quit

    # Add Eth2/0/1 and Eth2/0/2 to VLAN 11.

    [RouterA] vlan 11
    [RouterA-vlan11] quit
    [RouterA] interface ethernet 2/0/1
    [RouterA-Ethernet2/0/1] port link-type access
    [RouterA-Ethernet2/0/1] port default vlan 11
    [RouterA-Ethernet2/0/1] quit
    [RouterA] interface ethernet 2/0/2
    [RouterA-Ethernet2/0/2] port link-type access
    [RouterA-Ethernet2/0/2] port default vlan 11
    [RouterA-Ethernet2/0/2] quit

    #Add VLANIF 11 to bridge group 1.

    [RouterA] interface vlanif 11
    [RouterA-Vlanif11] bridge 1
    [RouterA-Vlanif11] quit

    # Configure an IP address for Ethernet3/0/0 on RouterA.

    [RouterA] interface ethernet 3/0/0
    [RouterA-Ethernet3/0/0] undo portswitch
    [RouterA-Ethernet3/0/0] ip address 10.1.3.1 255.255.255.0
    [RouterA-Ethernet3/0/0] quit

    # Create Bridge-if interface 1 and configure an IP address for it.

    [RouterA] interface bridge-if 1
    [RouterA-Bridge-if1] ip address 10.1.1.3 255.255.255.0
    [RouterA-Bridge-if1] quit

  2. Verify the configuration.

    # After the preceding configurations are complete, User 1 and User 3 can ping each other.

Configuration Files

Configuration file of RouterA

#
 sysname RouterA
#
vlan batch 11
#
bridge 1
 routing ip
#
interface Vlanif11
 bridge 1
#
interface Ethernet2/0/1
 port link-type access
 port default vlan 11
#
interface Ethernet2/0/2
 port link-type access
 port default vlan 11
#
interface Ethernet3/0/0
undo portswitch
 ip address 10.1.3.1 255.255.255.0
#
interface Bridge-if1
 ip address 10.1.1.3 255.255.255.0
#
return     
Translation
Download
Updated: 2019-05-25

Document ID: EDOC1000097279

Views: 11455

Downloads: 62

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next