No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR500, AR510, and AR530 V200R007 CLI-based Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring transparent bridge, MAC table, link aggregation, VLANs, STP/RSTP/MSTP, and so on.The document provides the configuration procedures and configuration examples to illustrate the service configuration methods and application scenario.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN Assignment

Example for Configuring VLAN Assignment

Networking Requirements

As shown in Figure 3-19, multiple user terminals are connected to devices in an enterprise. Users who use the same service access the enterprise network using different devices.

To ensure the communication security and avoid broadcast storms, the enterprise wants to allow users who use the same service to communicate with each other and isolate users who use different services.

Configure interface-based VLAN assignments on the device and add interfaces connected to terminals of users who use the same service to the same VLAN. Users in different VLANs communicate at Layer 2, and users in the same VLAN can communicate directly.

Figure 3-19  Networking of interface-based VLAN assignment

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs and add interfaces connecting to user terminals to VLANs to isolate Layer 2 traffic between users who use different services.
  2. Configure the type of link between RouterA and RouterB and VLANs to allow users who use the same service to communicate.

Procedure

  1. Create VLAN 2 and VLAN 3 on RouterA, and add interfaces connected to user terminals to different VLANs. The configuration of RouterB is similar to that of RouterA, and is not mentioned here.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] vlan batch 2 3
    [RouterA] interface ethernet 2/0/1
    [RouterA-Ethernet2/0/1] port link-type access
    [RouterA-Ethernet2/0/1] port default vlan 2
    [RouterA-Ethernet2/0/1] quit
    [RouterA] interface ethernet 2/0/2
    [RouterA-Ethernet2/0/2] port link-type access
    [RouterA-Ethernet2/0/2] port default vlan 3
    [RouterA-Ethernet2/0/2] quit
    

  2. Configure the type of the interface connected to RouterB on RouterA and VLANs. The configuration of RouterB is similar to that of RouterA, and is not mentioned here.

    [RouterA] interface ethernet 2/0/3
    [RouterA-Ethernet2/0/3] port link-type trunk
    [RouterA-Ethernet2/0/3] port trunk allow-pass vlan 2 3

  3. Verify the configuration.

    # Add User1 and User2 to the same IP address segment, for example, 192.168.100.0/24; add User3 and User4 to the same IP address segment, for example, 192.168.200.0/24.

    # Only User1's and User2's terminals can ping each other, and only User3's and User4's terminals can ping each other.

Configuration Files

  • Configuration file of RouterA
    #
    sysname RouterA
    #
    vlan batch 2 to 3
    #
    interface Ethernet2/0/1
     port link-type access
     port default vlan 2
    #
    interface Ethernet2/0/2
     port link-type access
     port default vlan 3
    #
    interface Ethernet2/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • Configuration file of RouterB
    #
    sysname RouterB
    #
    vlan batch 2 to 3
    #
    interface Ethernet2/0/1
     port link-type access
     port default vlan 2
    #
    interface Ethernet2/0/2
     port link-type access
     port default vlan 3  
    #
    interface Ethernet2/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
Translation
Download
Updated: 2019-05-25

Document ID: EDOC1000097279

Views: 16982

Downloads: 63

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next