No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Security

AR500, AR510, and AR530 V200R007

This document describes the configurations of Security, including AAA, DAA,NAC, BRAS Access, ACL, Firewall, Deep Security Defense, Local Attack Defense;Attack Defense, Traffic Suppression, ARP Security, Port Security, DHCP Snooping, IPSG, URPF, PKI, SSL, HTTPS, Keychain, separating the management plane from the service plane, security risks.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Built-in Portal Authentication to Control Internal User Access

Example for Configuring Built-in Portal Authentication to Control Internal User Access

Networking Requirements

As shown in Figure 3-15, many users on a company access network through Eth2/0/0 of the Router (used as an access device). After the network operates for a period of time, attacks are detected. The administrator must control network access rights of user terminals to ensure network security. The Router allows user terminals to access Internet resources only after they are authenticated.

Figure 3-15  Networking diagram for configuring built-in Portal authentication

Configuration Roadmap

To control the network access permission of users, the administrator can configure Portal authentication on the Router after the server with the IP address 192.168.2.30 is configured as the RADIUS server. Due to limited device resources, the administrator uses the built-in Portal server and configures the IP address 192.168.1.30 of a loopback interface of the Router as the IP address for the built-in Portal server.

The configuration roadmap is as follows (configured on the Router):

  1. Create and configure a RADIUS server template, an AAA scheme, and an ISP domain; bind the RADIUS server template and the AAA scheme to the ISP domain. The Router can then exchange information with the RADIUS server.

  2. Configure built-in Portal authentication so that terminals can connect to the network using Portal authentication.
NOTE:

Before configuring this example, ensure that devices can communicate with each other in the network.

AR500&AR510 series does not support Portal authentication on Ethernet interfaces.

Procedure

  1. Create VLANs and configure the VLAN allowed by the interface to ensure network communication.

    # Create VLAN 10 and VLAN 20.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 10 20
    

    # On the Router, set Eth2/0/0 connecting to users as a access interface, and add Eth2/0/0 to VLAN 10.

    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type access
    [Router-Ethernet2/0/0] port default vlan 10 
    [Router-Ethernet2/0/0] quit
    NOTE:

    Configure the interface type and VLANs according to the actual situation. In this example, users are added to VLAN 10.

    # On the Router, set Eth2/0/1 connecting to the RADIUS server as an access interface, and add Eth2/0/1 to VLAN 20.

    [Router] interface ethernet 2/0/1
    [Router-Ethernet2/0/1] port link-type access
    [Router-Ethernet2/0/1] port default vlan 20
    [Router-Ethernet2/0/1] quit

  2. Configure IP addresses for VLANIF 10 and VLANIF 20.

    [Huawei] interface vlanif 10
    [Huawei-Vlanif10] ip address 192.168.3.1 24
    [Huawei-Vlanif10] quit

    [Huawei] interface vlanif 20
    [Huawei-Vlanif20] ip address 192.168.2.1 24
    [Huawei-Vlanif20] quit

  3. Create and configure a RADIUS server template, an AAA scheme, and an authentication domain.

    # Create and configure RADIUS server template rd1.

    [Router] radius-server template rd1
    [Router-radius-rd1] radius-server authentication 192.168.2.30 1812
    [Router-radius-rd1] radius-server shared-key cipher Huawei@2012
    [Router-radius-rd1] quit

    # Create AAA scheme abc and set the authentication mode to RADIUS.

    [Router] aaa
    [Router-aaa] authentication-scheme abc
    [Router-aaa-authen-abc] authentication-mode radius
    [Router-aaa-authen-abc] quit

    # Create authentication domain isp1, and bind AAA scheme abc and RADIUS server template rd1 to authentication domain isp1.

    [Router-aaa] domain isp1
    [Router-aaa-domain-isp1] authentication-scheme abc
    [Router-aaa-domain-isp1] radius-server rd1
    [Router-aaa-domain-isp1] quit
    [Router-aaa] quit

    # Configure the default domain isp1 in the system view.When a user enters the user name in the format of user@isp1, the user is authenticated in the authentication domain isp1. If the user name does not carry the domain name or carries a nonexistent domain name, the user is authenticated in the default domain.

    [Router] domain isp1

    # Test whether a user can be authenticated using RADIUS authentication. A user name test@huawei.com and password Huawei2012 have been configured on the RADIUS server.

    [Router] test-aaa test@huawei.com Huawei2012 radius-template rd1
    Info: Account test succeed.

  4. Configure Portal authentication.

    # Create a loopback interface and assign an IP address to the loopback interface.

    [Router] interface loopback 6
    [Router-LoopBack6] ip address 192.168.1.30 32
    [Router-LoopBack6] quit

    # Configure the IP address for the built-in Portal server.

    [Router] portal local-server ip 192.168.1.30

    # Enable Portal authentication.

    [Huawei] portal local-server https ssl-policy huawei
    [Huawei] interface vlanif 10
    [Huawei-Vlanif10] portal local-server enable
    [Huawei-Vlanif10] quit
    NOTE:

    When the portal local-server https ssl-policy huawei command is executed, ensure that SSL policy huawei has been configured (for details, see Configuring a Server SSL Policy).

  5. Verify the configuration.

    1. Run the display portal local-server commands to check the built-in Portal authentication configuration.
    2. After starting the browser and entering any network address, the user is redirected to the Portal authentication page. The user then enters the user name and password for authentication.
    3. If the user name and password are correct, an authentication success message is displayed on the Portal authentication page. The user can access the network.
    4. After the user goes online, you can run the display access-user command on the device to check the online Portal authentication user information.

Configuration Files

Configuration file of the Router

#
sysname Router 
#                                                                               
vlan batch 10 20 
#                                                                               
domain isp1
#                                                                               
portal local-server ip 192.168.1.30                                                  
portal local-server https ssl-policy huawei   
#
radius-server template rd1
 radius-server shared-key cipher %^%#BS'$!w:u7H.lu:/&W9A5=pUt%^%#
 radius-server authentication 192.168.2.30 1812 weight 80
#
aaa
 authentication-scheme abc
  authentication-mode radius
 domain isp1
  authentication-scheme abc
  radius-server rd1
#
interface Vlanif10
 ip address 192.168.3.1 255.255.255.0
 portal local-server enable
interface Vlanif20
 ip address 192.168.2.1 255.255.255.0
#
interface Ethernet2/0/0
 port link-type access
 port default vlan 10  
#                                                                              
interface Ethernet2/0/1            
 port link-type access                                                          
 port default vlan 20
#                                                                               
interface LoopBack6                                                             
 ip address 192.168.1.30 255.255.255.255 
# 
return
Translation
Download
Updated: 2019-05-25

Document ID: EDOC1000097287

Views: 14811

Downloads: 40

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next