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OceanStor 9000 V300R005C00 File System Feature Guide 11

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All Hadoop Nodes and Clients Fail to Access the Data Analysis Directory of OceanStor 9000

All Hadoop Nodes and Clients Fail to Access the Data Analysis Directory of OceanStor 9000

None of Hadoop nodes or clients can access the data analysis directory of OceanStor 9000.

Symptom

None of Hadoop nodes or clients can access the data analysis directory of OceanStor 9000. On one FusionInsight Hadoop client or Cloudera Hadoop node, hadoop fs -mkdir /mytest fails to be executed.

Possible Causes

  • Possible cause 1: OceanStor 9000 cannot communicate with the Hadoop cluster.
  • Possible cause 2: OceanStor 9000 fails.

Procedure

  • Possible cause 1: OceanStor 9000 cannot communicate with the Hadoop cluster.
    1. Log in to any Hadoop node as user root.
    2. Run ping xx.xx.xx.xx to check whether OceanStor 9000 can communicate with the Hadoop cluster. xx.xx.xx.xx is the static IP address of the front-end service network of any storage node.

    3. Contact the network administrator to rectify the network fault. The network fault may be caused by a switch fault or route fault.
    4. Check whether the fault is rectified.

  • Possible cause 2: OceanStor 9000 fails.
    1. Log in to DeviceManager.
    2. View the alarm and clear it according to the recommended actions.
    3. Check whether the fault is rectified.

      • If yes, no further action is required.

      • If no, contact technical support engineers.

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Updated: 2019-03-30

Document ID: EDOC1000101823

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