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OceanStor 9000 V300R005C00 File System Feature Guide 11

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Some Hadoop Nodes or Clients Fail to Access the Data Analysis Directory of OceanStor 9000

Some Hadoop Nodes or Clients Fail to Access the Data Analysis Directory of OceanStor 9000

One or more Hadoop nodes or clients cannot access the data analysis directory of OceanStor 9000.

Symptom

The /mnt/nfsdata0 directory on one or more Hadoop nodes or clients is empty. At least one Hadoop node or client has no such abnormality.

Possible Causes

  • Possible cause 1. The abnormal Hadoop node or client cannot communicate with OceanStor 9000.
  • Possible 2: The Hadoop node or node service is abnormal.

Procedure

  • Possible cause 1. The abnormal Hadoop node or client cannot communicate with OceanStor 9000.
    1. Log in to the abnormal Hadoop node or client as user root.
    2. Run ping FS_DOMAIN_NAME to check whether the network is normal. FS_DOMAIN_NAME is the dynamic domain name configured during file system initialization. To view the parameter value, log in to DeviceManager and choose Settings > Cluster Settings > InfoEqualizer > Network Settings.

    3. Contact the network administrator to rectify the network fault. The network faulty may be caused by an IP address or mask configuration fault, route fault, network adapter fault, or cabling fault.
    4. Check whether the fault is rectified.

  • Possible 2: The Hadoop node or node service is abnormal.
    1. Log in to FusionInsight Hadoop Manager or Cloudera Manager.
    2. As instructed by the Hadoop product documentation, locate and eliminate the Hadoop node abnormality or node service abnormality.
    3. Check whether the fault is rectified.

      • If yes, no further action is required.

      • If no, contact technical support engineers.

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Updated: 2019-03-30

Document ID: EDOC1000101823

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