No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN Product Interoperation Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring User Authorization Based on User Groups (Web)

Example for Configuring User Authorization Based on User Groups (Web)

Introduction to User Authorization Based on User Groups

In user authorization, the device controls network access rights based on the user role during each phase of user authentication.

A user group consists of users (terminals) with the same attributes such as the role and rights. For example, you can divide users on a campus network into the R&D group, finance group, marketing group, and guest group based on the enterprise department structure, and grant different security policies to different departments.

When the AC is interconnected with the Cisco ISE, three authentication methods, that is Password Authentication Protocol (PAP), Challenge Handshake Authentication Protocol (CHAP), and Extensible Authentication Protocol (EAP), can be used in 802.1X authentication. The configurations for the three authentication methods are similar. The following uses EAP as an example.

For details about how to configure user authorization based on user groups on the AC, see Configure a user group.

For details about how to configure user authorization based on user groups on the Cisco ISE server, see Configure the Cisco ISE.

Applicable Products and Versions

Table 2-22  Applicable products and versions

Product

Version

Huawei AC

V200R007C10 and later versions

Cisco ISE

2.0.0.306

Service Requirements

Different user groups are created to assign network access rights to different users when they access the WLAN through 802.1X authentication. Furthermore, users' services are not affected during roaming in the coverage area.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: The AC and SwitchB function as DHCP servers to assign IP addresses to APs and STAs, respectively.
  • Service data forwarding mode: direct forwarding
  • WLAN authentication mode: WPA-WPA2+802.1X+AES
Figure 2-8  Networking for configuring user authorization based on user groups

Data Plan

Table 2-23  Data planning on the AC

Configuration Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

AC's source interface

VLANIF 100: 10.23.100.1/24

DHCP server

The AC functions as a DHCP server to assign IP addresses to APs, and SwitchB functions as a DHCP server to assign IP addresses to STAs.

IP address pool for APs

10.23.100.2-10.23.100.254/24

IP address pool for the STAs

10.23.101.2-10.23.101.254/24

RADIUS authentication parameters

  • RADIUS server template name: wlan-net
  • IP address: 10.23.103.1
  • Authentication port number: 1812
  • Shared key: huawei@123
  • Authentication scheme: wlan-net

802.1X access profile

  • Name: wlan-net
  • Authentication mode: EAP

Authentication profile

  • Name: wlan-net
  • Bound profile and authentication scheme: 802.1X access profile wlan-net, RADIUS server template wlan-net, and RADIUS authentication scheme wlan-net

AP group

  • Name: ap-group1
  • Bound profile: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: China

SSID profile

  • Name: wlan-net
  • SSID name: wlan-net

Security profile

  • Name: wlan-net
  • Security policy: WPA-WPA2+802.1X+AES

VAP profile

  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Bound profiles: SSID profile wlan-net, security profile wlan-net, and authentication profile wlan-net

User group

  • Name: group1
  • Bound ACL number: 3001
  • User group right: Only members in the user group can access network resources on 10.23.200.0/24.
Table 2-24  Data planning on the Cisco ISE

Configuration Item

Data

Department

R&D

Account

Account: huawei

Password: huawei123

Device profile

Huawei

Device name

AC6605

Device's IP address

10.23.102.2/32

RADIUS shared key

huawei@123

Authentication protocol

  • MS-CHAPv2
  • PEAP
  • CHAP (only for the test-aaa test)

User group

group1

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Select Config Wizard to configure AC system parameters.
  3. Select Config Wizard to configure the APs to go online on the AC.
  4. Select Config Wizard to configure WLAN services on the AC. When configuring the security policy, select 802.1x and RADIUS authentication, and set the RADIUS server parameters.
  5. Configure a user group.
  6. Configure the Cisco ISE server.

Configuration Notes

  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • The AC and server must have the same RADIUS shared key.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on SwitchA (access switch) to VLAN 100 and VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 on SwitchB (aggregation switch) to VLAN 100 and VLAN 101, GE0/0/2 to VLAN 100 and VLAN 102, GE0/0/3 to VLAN 103, and GE0/0/4 to VLAN104. Create VLANIF 102, VLANIF 103, and VLANIF 104, and configure a default route with the next hop of the address of Router.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 to 104
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk pvid vlan 103
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 103
    [SwitchB-GigabitEthernet0/0/3] quit
    [SwitchB] interface gigabitethernet 0/0/4
    [SwitchB-GigabitEthernet0/0/4] port link-type trunk
    [SwitchB-GigabitEthernet0/0/4] port trunk pvid vlan 104
    [SwitchB-GigabitEthernet0/0/4] port trunk allow-pass vlan 104
    [SwitchB-GigabitEthernet0/0/4] quit
    [SwitchB] interface vlanif 102
    [SwitchB-Vlanif102] ip address 10.23.102.1 24
    [SwitchB-Vlanif102] quit
    [SwitchB] interface vlanif 103
    [SwitchB-Vlanif103] ip address 10.23.103.2 24
    [SwitchB-Vlanif103] quit
    [SwitchB] interface vlanif 104
    [SwitchB-Vlanif104] ip address 10.23.104.1 24
    [SwitchB-Vlanif104] quit
    [SwitchB] ip route-static 0.0.0.0 0.0.0.0 10.23.104.2
    
    # Configure the IP address of GE0/0/1 on Router and a static route to the network segment for STAs.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] ip address 10.23.104.2 24
    [Router-GigabitEthernet0/0/1] quit
    [Router] ip route-static 10.23.101.0 24 10.23.104.1
    

  2. Configure a DHCP server to assign IP addresses to STAs.

    # On SwitchB, configure the VLANIF 101 to assign IP addresses to STAs.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] quit

  3. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure ports.

      # Select GigabitEthernet0/0/1. Expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN) and VLAN 102.
      NOTE:

      If the AC and AP are directly connected, set the default VLAN of the interface connected to the AP to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configure network interconnection.

      # Under Interface Configuration, click Create. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24, DHCP status to ON, and DHCP type to Interface address pool.

      NOTE:
      Configure the DNS server address as required.


      # Click OK.

      # Set the IP address of VLANIF 102 to 10.23.102.2/24 in the same way.

      # Under Static Route Table, click Create. The Create Static Route Table page is displayed.

      # Set Destination IP to 10.23.103.0, Subnet Mask to 24(255.255.255.0), and Next hop address to 10.23.102.1.

      # Click OK.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure WLAN services
    1. # Click Create. The Basic Information page is displayed.
    2. # Set the SSID name, forwarding mode, and service VLAN ID.

    3. # Click Next. The Security Authentication page is displayed.
    4. # Set Security settings to 802.1x authentication, and configure parameters of the external RADIUS server.

    5. # Click Next. The Access Control page is displayed.
    6. # Set Binding the AP group to ap-group1.
    7. # Click Finish.
  6. Set the AP channel and power.
    1. Disable automatic channel and power calibration functions of AP radios, and manually configure the AP channel and power.

      NOTE:

      Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.

      # Choose Configuration > AP Config > AP Config > AP Info. The AP List page is displayed.

      # Click the ID of the AP whose channel and power need to be configured. The AP customized settings page is displayed.

      # Click next to Radio Management. The profiles under Radio Management are displayed.

      # Click Radio 0. On the radio 0 configuration page that is displayed, disable the automatic channel and power calibration functions, and set the channel to 20-MHz channel 6 and transmit power to 127 dBm.



      # The configuration of Radio 1 is similar to that of Radio0. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 149 and transmit power to 127 dBm.

      # Click Apply. In the dialog box that is displayed, click OK.

  7. Configure a user group.
    1. Configure an ACL.

      # Choose Configuration > Security > ACL > Advanced ACL Settings. The Advanced ACL Settings page is displayed.

      # Click Create on the ACLv4 tab. On the Create Advanced ACL page that is displayed, configure an ACL.



      # Click OK. The Advanced ACL Settings page is displayed.

      # Click Add Rule next to ACL 3001. On the Add Rule page that is displayed, add an ACL rule.



      # Click OK. On the Advanced ACL Settings page that is displayed, use the same method to add another ACL rule.



      # Click OK.

    2. Configure a user group.

      # Choose Configuration > Security > User Group > User Group. The User Group page is displayed.

      # Click Create. On the Create User Group page that is displayed, set User group name and bind an ACL.



      # Click OK.

  8. Configure the Cisco ISE.
    1. # Log in to the Cisco ISE server.

      # Enter the access address of the Cisco ISE server in the address box, which is in the format of https://Cisco ISE IP. Cisco ISE IP is the IP address of the Cisco ISE server.

      # On the displayed page, enter the user name and password to log in to the Cisco ISE server.

    2. Create a department and an account.

      # Choose Administration > Identity Management > Groups > User Identity Groups. In the pane on the right side, click Add and create a department named R&D. Then, click Submit.



      # Choose Administration > Identity Management > Identities > Users. In the pane on the right side, click Add to create the account with the user name of huawei and password of huawei123. Add the account to department R&D. Then, click Submit.



    3. Add the AC so that the Cisco ISE can interwork with the AC.

      # Choose Administration > Network Resources > Network Device Profiles. In the pane on the left side, click Add and create a device profile named Huawei. Then, click Submit.



      # Choose Administration > Network Resources > Network Devices. In the pane on the right side, click Add. Set the device name to AC6605, IP address to 10.23.102.2/32, and RADIUS shared key to huawei@123. Then, click Submit.



    4. Configure the authentication protocol.

      # Choose Policy > Policy Elements > Results > Authentication > Allowed Protocols. Select Default Network Access and click Edit.



      # Select Allow CHAP, Allow MS-CHAPv2, and Allow PEAP. For other parameters, use the default settings. Click Save.
      NOTE:

      By default, the Cisco ISE disables the CHAP authentication protocol. You need to select the CHAP authentication protocol on the server so that the CHAP protocol can be used to carry out the test-aaa test on the AC.



    5. Configure an authorized user group.

      # Choose Policy > Policy Elements > Results > Authorization > Authorization Profiles. In the pane on the right side, click Add. Configure Name, Access Type, and Advanced Attributes Settings. Then, click Submit.



      # Choose Policy > Authorization. Click next to Edit and choose Insert New Rule Above from the menu to add a new authorization policy.



      # In the new authorization policy, configure Rule Name, Conditions, and Permissions. Click Done and then Save.



  9. On the AC, check that users can pass RADIUS authentication.

    # Choose Diagnosis > Diagnosis Tool > AAA Test. The AAA Test page is displayed.

    # Configure the RADIUS server template, authentication mode, user name, and password.



    # Click Start.

  10. Verify the configuration.

    • The WLAN with the SSID wlan-net is available for STAs after the configuration is complete.
    • The STAs obtain IP addresses when they successfully associate with the WLAN.
    • A user can use the 802.1X authentication client on an STA for authentication. After entering the correct user name and password, the user is successfully authenticated and can access resources on the network segment 10.23.200.0/24. You need to configure the 802.1X authentication client based on the configured authentication mode PEAP.
      • Configuration on the Windows XP operating system:

        1. On the Association tab page of the Wireless network properties dialog box, add SSID wlan-net, set the authentication mode to WPA2, and encryption algorithm to AES.
        2. On the Authentication tab page, set EAP type to PEAP and click Properties. In the Protected EAP Properties dialog box, deselect Validate server certificate and click Configure. In the displayed dialog box, deselect Automatically use my Windows logon name and password and click OK.
      • Configuration on the Windows 7 operating system:

        1. Access the Manage wireless networks page, click Add, and select Manually create a network profile. Add SSID wlan-net. Set the authentication mode to WPA2-Enterprise, and encryption algorithm to AES. Click Next.
        2. Click Change connection settings. On the Wireless Network Properties page that is displayed, select the Security tab page and click Settings. In the Protected EAP Properties dialog box, deselect Validate server certificate and click Configure. In the displayed dialog box, deselect Automatically use my Windows logon name and password and click OK.
        3. Click OK. On the Wireless Network Properties page, click Advanced settings. On the Advanced settings page that is displayed, select Specify authentication mode, set the identity authentication mode to User authentication, and click OK.

Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000113779

Views: 51484

Downloads: 1693

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next