No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN Product Interoperation Configuration Guide

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MAC Address Authentication (Web)

Example for Configuring MAC Address Authentication (Web)

Introduction to MAC Address Authentication

MAC address authentication is a method used for Network Admission Control (NAC). It controls user access rights based on access ports and user MAC addresses to protect security for enterprise networks.

MAC address authentication does not need client software, but user terminals' MAC addresses must be registered on the authentication server. Network configuration and management are complex. In contrast, 802.1X authentication needs client software, allowing low networking flexibility. However, 802.1X authentication is more secure. Portal authentication also does not need client software, allowing flexible deployment. However, it does not provide high security.

MAC address authentication is applicable to dumb terminals such as printers and fax machine.

For details about how to configure MAC address authentication on the AC, see Configure WLAN services.

For details about how to configure MAC address authentication on the Cisco ISE server, see Configure the Cisco ISE.

Applicable Products and Versions

Table 2-10  Applicable products and versions

Product

Version

Huawei AC

V200R007C10 and later versions

Cisco ISE

2.0.0.306

Service Requirements

MAC address authentication is used to authenticate dumb terminals such as wireless network printers and wireless phones that cannot have an authentication client installed.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: The AC functions as the DHCP server to assign IP addresses to APs, and SwitchB functions as the DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: direct forwarding
  • Authentication mode: open system authentication
Figure 2-4  Networking diagram for configuring MAC address authentication

Data Planning

Table 2-11  Data planning on the AC

Configuration Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

AC's source interface

VLANIF 100: 10.23.100.1/24

DHCP server

The AC functions as the DHCP server to assign IP addresses to APs, and SwitchB functions as the DHCP server to assign IP addresses to STAs.

IP address pool for APs

10.23.100.2-10.23.100.254/24

IP address pool for the STAs

10.23.101.2-10.23.101.254/24

RADIUS authentication parameters

  • RADIUS server template name: wlan-net
  • IP address: 10.23.103.1
  • Authentication port number: 1812
  • Shared key: huawei@123
  • Authentication scheme: wlan-net

MAC access profile

Name: wlan-net

Authentication profile

  • Name: wlan-net
  • Bound profile and authentication scheme: MAC access profile wlan-net, RADIUS server template wlan-net, and authentication scheme wlan-net

AP group

  • Name: ap-group1
  • Bound profile: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: CN

SSID profile

  • Name: wlan-net
  • SSID name: wlan-net

Security profile

  • Name: wlan-net
  • Security policy: open system authentication

VAP profile

  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Bound profiles: SSID profile wlan-net, security profile wlan-net, and authentication profile wlan-net
Table 2-12  Data planning on the Cisco ISE

Configuration Item

Data

Terminals

MAC addresses (use the actual MAC addresses of devices)

Account

Account: huawei

Password: huawei123

Device profile

Huawei

Device name

AC6605

Device's IP address

10.23.102.2/32

RADIUS shared key

huawei@123

Authentication protocol

  • MS-CHAPv2
  • PEAP
  • CHAP (only for the test-aaa test)

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Select Config Wizard to configure AC system parameters.
  3. Select Config Wizard to configure the APs to go online on the AC.
  4. Select Config Wizard to configure WLAN services on the AC. When configuring the security policy, select MAC address and RADIUS authentication, and set the RADIUS server parameters.
  5. Configure the Cisco ISE server.

Configuration Notes

  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • The AC and server must have the same RADIUS shared key.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on SwitchA (access switch) to VLAN 100 and VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 on SwitchB (aggregation switch) to VLAN 100 and VLAN 101, GE0/0/2 to VLAN 100 and VLAN 102, GE0/0/3 to VLAN 103, and GE0/0/4 to VLAN104. Create VLANIF 102, VLANIF 103, and VLANIF 104, and configure a default route with the next hop of the address of Router.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 to 104
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk pvid vlan 103
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 103
    [SwitchB-GigabitEthernet0/0/3] quit
    [SwitchB] interface gigabitethernet 0/0/4
    [SwitchB-GigabitEthernet0/0/4] port link-type trunk
    [SwitchB-GigabitEthernet0/0/4] port trunk pvid vlan 104
    [SwitchB-GigabitEthernet0/0/4] port trunk allow-pass vlan 104
    [SwitchB-GigabitEthernet0/0/4] quit
    [SwitchB] interface vlanif 102
    [SwitchB-Vlanif102] ip address 10.23.102.1 24
    [SwitchB-Vlanif102] quit
    [SwitchB] interface vlanif 103
    [SwitchB-Vlanif103] ip address 10.23.103.2 24
    [SwitchB-Vlanif103] quit
    [SwitchB] interface vlanif 104
    [SwitchB-Vlanif104] ip address 10.23.104.1 24
    [SwitchB-Vlanif104] quit
    [SwitchB] ip route-static 0.0.0.0 0.0.0.0 10.23.104.2
    
    # Configure the IP address of GE0/0/1 on Router and a static route to the network segment for STAs.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] ip address 10.23.104.2 24
    [Router-GigabitEthernet0/0/1] quit
    [Router] ip route-static 10.23.101.0 24 10.23.104.1
    

  2. Configure a DHCP server to assign IP addresses to STAs.

    # On SwitchB, configure the VLANIF 101 to assign IP addresses to STAs.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] quit

  3. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure ports.

      # Select GigabitEthernet0/0/1. Expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN) and VLAN 102.
      NOTE:

      If the AC and AP are directly connected, set the default VLAN of the interface connected to the AP to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configure network interconnection.

      # Under Interface Configuration, click Create. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24, DHCP status to ON, and DHCP type to Interface address pool.

      NOTE:
      Configure the DNS server address as required.


      # Click OK.

      # Set the IP address of VLANIF 102 to 10.23.102.2/24 in the same way.

      # Under Static Route Table, click Create. The Create Static Route Table page is displayed.

      # Set Destination IP to 10.23.103.0, Subnet Mask to 24(255.255.255.0), and Next hop address to 10.23.102.1.

      # Click OK.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure WLAN services.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN ID.



    # Click Next. The Security Authentication page is displayed.

    # Set Security settings to Open (applicable to personal networks).

    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    # Click Finish.

  6. Set the AP channel and power.
    1. Disable automatic channel and power calibration functions of AP radios, and manually configure the AP channel and power.

      NOTE:

      Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.

      # Choose Configuration > AP Config > AP Config > AP Info. The AP List page is displayed.

      # Click the ID of the AP whose channel and power need to be configured. The AP customized settings page is displayed.

      # Click next to Radio Management. The profiles under Radio Management are displayed.

      # Click Radio 0. On the radio 0 configuration page that is displayed, disable the automatic channel and power calibration functions, and set the channel to 20-MHz channel 6 and transmit power to 127 dBm.



      # The configuration of Radio 1 is similar to that of Radio0. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 149 and transmit power to 127 dBm.

      # Click Apply. In the dialog box that is displayed, click OK.

  7. Configure the Cisco ISE.
    1. # Log in to the Cisco ISE server.

      # Enter the access address of the Cisco ISE server in the address box, which is in the format of https://Cisco ISE IP. Cisco ISE IP is the IP address of the Cisco ISE server.

      # On the displayed page, enter the user name and password to log in to the Cisco ISE server.

    2. Add STAs.

      # Choose Administration > Identity Management > Identities > EndPoints. In the pane on the right side, click Add. On the page that is displayed, set MAC Address and click Save.



    3. Add the AC so that the Cisco ISE can interwork with the AC.

      # Choose Administration > Network Resources > Network Device Profiles. In the pane on the left side, click Add and create a device profile named Huawei. Then, click Submit.



      # Choose Administration > Network Resources > Network Devices. In the pane on the right side, click Add. Set the device name to AC6605, IP address to 10.23.102.2/32, and RADIUS shared key to huawei@123. Then, click Submit.



    4. Configure the authentication protocol.

      # Choose Policy > Policy Elements > Results > Authentication > Allowed Protocols. Select Default Network Access and click Edit.



      # Select Allow CHAP, Allow MS-CHAPv2, and Allow PEAP. For other parameters, use the default settings. Click Save.
      NOTE:

      By default, the Cisco ISE disables the CHAP authentication protocol. You need to select the CHAP authentication protocol on the server so that the CHAP protocol can be used to carry out the test-aaa test on the AC.



  8. On the AC, check that users can pass RADIUS authentication.

    # Choose Diagnosis > Diagnosis Tool > AAA Test. The AAA Test page is displayed.

    # Configure the RADIUS server template, authentication mode, user name, and password.



    # Click Start.

  9. Verify the configuration.

    • After dumb terminals associate with the WLAN, authentication is performed automatically. After the terminals pass authentication, they can access the network.
    • After dumb terminals associate with the WLAN, choose Monitoring > User on the AC to view information about the dumb terminals.

Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000113779

Views: 50795

Downloads: 1687

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next