No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN Product Interoperation Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring User Authorization Based on ACL Numbers or Dynamic VLANs (Web)

Example for Configuring User Authorization Based on ACL Numbers or Dynamic VLANs (Web)

Introduction to User Authorization

In user authorization, the device controls network access rights based on the user role during each phase of user authentication. After an 802.1x user is successfully authenticated on a RADIUS server, the server sends authorization information to the access device of the user. When the Aruba ClearPass functions as a RADIUS server, it can deliver multiple authorization parameters. The following example uses ACL numbers and dynamic VLANs to control user authorization.
  • Authorization based on ACL numbers

    If ACL number delivery is configured on the RADIUS server, authorization information sent to the access device includes the ACL number. The access device matches ACL rules based on the delivered ACL number to control user rights.

    The RADIUS attribute used for ACL number delivery is (011) Filter-Id.

    The ACL numbers supported by the AC range from 3000 to 3031.

  • Authorization based on dynamic VLANs

    If dynamic VLAN delivery is configured on the RADIUS server, authorization information sent to the access device includes the VLAN attribute. After the access device receives the authorization information, it changes the VLAN of the user to the delivered VLAN. The delivered VLAN does not change or affect the interface configuration. The priority of the delivered VLAN, however, is higher than that of the user configured VLAN. That is, the delivered VLAN takes effect after the authentication succeeds and the user-configured VLAN takes effect after the user goes offline.

    The following RADIUS attributes are used for dynamic VLAN delivery:
    • (064) Tunnel-Type (It must be set to VLAN or 13.)
    • (065) Tunnel-Medium-Type (It must be set to 802 or 6.)
    • (081) Tunnel-Private-Group-ID (It can be a VLAN ID or VLAN name.)
    To ensure that the RADIUS server delivers VLAN information correctly, all the three RADIUS attributes must be used. In addition, the Tunnel-Type and Tunnel-Medium-Type attributes must be set to the specified values.

When the AC is interconnected with the Aruba ClearPass, three authentication methods, that is, Password Authentication Protocol (PAP), Challenge Handshake Authentication Protocol (CHAP), and Extensible Authentication Protocol (EAP), can be used in 802.1x authentication. The configurations for the three authentication methods are similar. The following uses EAP as an example.

For details about how to configure user authorization based on ACL numbers on the AC, see user authorization configuration on the AC.

For details about how to configure user authorization based on ACL numbers on the Aruba ClearPass server, see Aruba ClearPass configuration.

Applicable Products and Versions

Table 3-16  Applicable products and versions

Product

Version

Huawei AC

V200R007C10 and later versions

Aruba ClearPass Policy Manager

6.5.0.71095

Service Requirements

Network access rights are controlled based on user roles when users access the WLAN through 802.1x authentication.

A large number of employees use wireless terminals to access an enterprise network. To ensure network security, the administrator needs to control network access rights of terminals. After successful authentication, terminals can access the service server (with IP address 10.23.105.1) and devices in the laboratory (with VLAN ID 20 and IP address segment 10.23.20.2-10.23.20.100).

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to allocate IP addresses to APs.
    • SwitchB functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: direct forwarding
  • WLAN authentication mode: WPA-WPA2+802.1x+AES
Figure 3-6  Networking for configuring user authorization based on ACL numbers or dynamic VLANs

Data Planning

Table 3-17  Data planning on the AC

Configuration Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

AC's source interface

VLANIF 100: 10.23.100.1/24

DHCP server

  • The AC functions as a DHCP server to allocate IP addresses to APs.
  • SwitchB functions as a DHCP server to assign IP addresses to STAs.

IP address pool for APs

10.23.100.2-10.23.100.254/24

IP address pool for the STAs

10.23.101.2-10.23.101.254/24

10.23.20.101-10.23.20.254/24

RADIUS authentication parameters

  • RADIUS server template name: wlan-net
  • IP address: 10.23.103.1
  • Authentication port number: 1812
  • Shared key: huawei@123
  • Authentication scheme: wlan-net
Resources accessible to users after authentication
  • Access rights to the laboratory are granted using a dynamic VLAN. The VLAN ID is 20.
  • Access rights to the service server are granted using an ACL number. The ACL number is 3002.

802.1x access profile

  • Name: wlan-net
  • Authentication mode: EAP

Authentication profile

  • Name: wlan-net
  • Bound profile and authentication scheme: 802.1x access profile wlan-net, RADIUS server template wlan-net, and authentication scheme wlan-net

AP group

  • Name: ap-group1
  • Bound profile: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: CN
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+802.1x+AES
VAP profile
  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Bound profiles: SSID profile wlan-net, security profile wlan-net, and authentication profile wlan-net
Table 3-18  Data planning on the Aruba ClearPass

Configuration Item

Data

Account

  • Account: huawei
  • Password: huawei123

Device name

AC6605

Device's IP address

10.23.102.2/32

RADIUS shared key

huawei@123

Service

  • Name: Radius
  • Type: 802.1x Wireless - Identity Only
  • Authentication method:
    • MS-CHAPv2
    • PEAP
  • Authentication source: Local User Respository[Local SQL DB]
  • Name: TEST-AAA
  • Type: 802.1x Wireless - Identity Only
  • Authentication method: PAP (only for the test-aaa test)
  • Authentication source: Local User Respository[Local SQL DB]

Authorization ACL

3002

Dynamic VLAN

VLAN 20

Configuration Roadmap

  1. Configure network interworking.
  2. Configure basic WLAN services.
  3. Configure the parameters for interconnecting the AC and RADIUS server and network access rights after successful authentication.
  4. Configure the Aruba ClearPass server.
    • Add users.
    • Add the AC.
    • Configure configuration files.
    • Configure policies.
    • Configure services.

Configuration Notes

  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • The AC and server must have the same RADIUS shared key.

  • If a terminal obtains an IP address using DHCP, you need to manually trigger the DHCP process to request an IP address after VLAN-based authorization is successful or the authorization VLAN changes.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/3 on SwitchA (access switch) to VLAN20, VLAN 100 and VLAN 101 and GE0/0/2 to VLAN 20.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 20 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 20 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type trunk
    [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 20 100 101
    [SwitchA-GigabitEthernet0/0/3] quit
    
    # Add GE0/0/1 on SwitchB (aggregation switch) to VLAN20, VLAN 100 and VLAN 101, GE0/0/2 to VLAN 100 and VLAN 102, GE0/0/3 to VLAN 103, GE0/0/4 to VLAN104, and GE0/0/5 to VLAN 105.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 20 100 to 105
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 20 100 101
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk pvid vlan 103
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 103
    [SwitchB-GigabitEthernet0/0/3] quit
    [SwitchB] interface gigabitethernet 0/0/4
    [SwitchB-GigabitEthernet0/0/4] port link-type trunk
    [SwitchB-GigabitEthernet0/0/4] port trunk pvid vlan 104
    [SwitchB-GigabitEthernet0/0/4] port trunk allow-pass vlan 104
    [SwitchB-GigabitEthernet0/0/4] quit
    [SwitchB] interface gigabitethernet 0/0/5
    [SwitchB-GigabitEthernet0/0/5] port link-type trunk
    [SwitchB-GigabitEthernet0/0/5] port trunk pvid vlan 105
    [SwitchB-GigabitEthernet0/0/5] port trunk allow-pass vlan 105
    [SwitchB-GigabitEthernet0/0/5] quit
    
    # Create VLANIF interfaces VLANIF 102, VLANIF 103, VLANIF 104 and VLANIF 105 on SwitchB and configure configure a default route with the next hop of the address of Router.
    [SwitchB] interface vlanif 102
    [SwitchB-Vlanif102] ip address 10.23.102.1 24
    [SwitchB-Vlanif102] quit
    [SwitchB] interface vlanif 103
    [SwitchB-Vlanif103] ip address 10.23.103.2 24
    [SwitchB-Vlanif103] quit
    [SwitchB] interface vlanif 104
    [SwitchB-Vlanif104] ip address 10.23.104.1 24
    [SwitchB-Vlanif104] quit
    [SwitchB] interface vlanif 105
    [SwitchB-Vlanif105] ip address 10.23.105.2 24
    [SwitchB-Vlanif105] quit
    [SwitchB] ip route-static 0.0.0.0 0.0.0.0 10.23.104.2
    
    # Configure the IP address of GE0/0/1 on Router and a static route to the network segment for STAs.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] ip address 10.23.104.2 24
    [Router-GigabitEthernet0/0/1] quit
    [Router] ip route-static 10.23.101.0 24 10.23.104.1
    

  2. Configure SwitchB to function as a DHCP server to assign IP addresses to STAs.

    # On SwitchB, configure the VLANIF 101 to assign IP addresses to STAs.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] quit
    # On SwitchB, configure the VLANIF 20 to assign IP addresses to authorized STAs. The IP address segment 10.23.20.2-10.23.20.100 cannot be assigned to STAs.
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] ip address 10.23.20.1 24
    [SwitchB-Vlanif20] dhcp select interface
    [SwitchB-Vlanif20] dhcp server excluded-ip-address 10.23.20.2 10.23.20.100
    [SwitchB-Vlanif20] quit

  3. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure ports.

      # Select GigabitEthernet0/0/1. Expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN) and VLAN 102.
      NOTE:

      If the AC and AP are directly connected, set the default VLAN of the interface connected to the AP to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configure network interconnection.

      # Under Interface Configuration, click Create. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24, DHCP status to ON, and DHCP type to Interface address pool.

      NOTE:
      Configure the DNS server address as required.


      # Click OK.

      # Set the IP address of VLANIF 102 to 10.23.102.2/24 in the same way.

      # Under Static Route Table, click Create. The Create Static Route Table page is displayed.

      # Set Destination IP to 10.23.103.0, Subnet Mask to 24(255.255.255.0), and Next hop address to 10.23.102.1.

      # Click OK.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure WLAN services
    1. # Click Create. The Basic Information page is displayed.
    2. # Set the SSID name, forwarding mode, and service VLAN ID.

    3. # Click Next. The Security Authentication page is displayed.
    4. # Set Security settings to 802.1x authentication, and configure parameters of the external RADIUS server.

    5. # Click Next. The Access Control page is displayed.
    6. # Set Binding the AP group to ap-group1.
    7. # Click Finish.
  6. Set the AP channel and power.
    1. Disable automatic channel and power calibration functions of AP radios, and manually configure the AP channel and power.

      NOTE:

      Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.

      # Choose Configuration > AP Config > AP Config > AP Info. The AP List page is displayed.

      # Click the ID of the AP whose channel and power need to be configured. The AP customized settings page is displayed.

      # Click next to Radio Management. The profiles under Radio Management are displayed.

      # Click Radio 0. On the radio 0 configuration page that is displayed, disable the automatic channel and power calibration functions, and set the channel to 20-MHz channel 6 and transmit power to 127 dBm.



      # The configuration of Radio 1 is similar to that of Radio0. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 149 and transmit power to 127 dBm.

      # Click Apply. In the dialog box that is displayed, click OK.

  7. Create VLAN 20 for authorization on the AC.

    # Choose Configuration > AC Config > VLAN > VLAN. The VLAN page is displayed.

    # Click Create. On the Create VLAN page that is displayed, configure a VLAN.

  8. Configure the authorization parameter ACL 3002 for users who pass authentication.

    # Choose Configuration > Security > ACL > Advanced ACL Settings > ACLv4. The Advanced ACL Settings page is displayed.

    # Click Create. On the Create Advanced ACL page that is displayed, configure an ACL.

    # Click OK. The Advanced ACL Settings page is displayed.

    # Click Add Rule next to ACL 3002. On the Add Rule page that is displayed, add an ACL rule.

    # Click OK. On the Advanced ACL Settings page that is displayed, add another ACL rule.

    # Click OK.

  9. Configure the Aruba ClearPass server.
    1. Log in to the Aruba ClearPass server.

      # Enter the access address of the Aruba ClearPass server in the address box, which is in the format of https://Aruba ClearPass IP. Aruba ClearPass IP is the IP address of the Aruba ClearPass server.

      # Choose ClearPass Policy Manager.

      # On the displayed page, enter the user name and password to log in to the Aruba ClearPass server.

    2. Create a local account.

      # Choose Configuration > Identity > Local Users. In the pane on the right side, click Add to create the account with the user name of huawei and password of huawei123. Select Enable User and choose Role. Then, click Add.



    3. Add the AC so that the Aruba ClearPass can interwork with the AC.

      # Choose Configuration > Network > Devices. In the pane on the right side, click Add. Configure Name, IP or Subnet Address, RADIUS Shared Secret, and Vendor Name. Then, click Add.



    4. Configure the service Radius.

      # Choose Configuration > Services. In the pane on the right side, click Add.

      # On the Service tab, set Type to 802.1X Wireless – Identity Only and Name to Radius, and select Authorization.On the Service Rule tab, click Click to add. On the page that is displayed, set Type to Radius:IETF, Name to NAS-Identifier, Operator to EQUALS, and Value to huaweiac

      NOTE:

      The NAS-Identifier value must be the same on the AC and ClearPass server. If this attribute is not configured on the AC, set the value of NAS-Identifier on the ClearPass server to the AC name.



      # On the Authentication tab, add [EAP PEAP] and [EAP MSCHAPv2] to Authentication Methods and [Local User Repository][Local SQL DB] to Authentication Sources.



      # On the Authorization tab, add [Local User Repository][Local SQL DB] to Authentication Source.



      # On other tabs, use default settings. Click Save.

    5. Configure the service TEST-AAA.

      NOTE:

      The service TEST-AAA must be added to the server so that the test-aaa test can be carried out on the AC.

      Aruba ClearPass Policy Manager 6.5.0 cannot save CHAP passwords locally. Therefore, only the PAP protocol can be used to carry out the test-aaa test on the AC to test whether users can pass RADIUS authentication.

      The NAS-Identifier value must be the same on the AC and ClearPass server. If this attribute is not configured on the AC, set the value of NAS-Identifier on the ClearPass server to the AC name.

      # Choose Configuration > Services. In the pane on the right side, click Add.

      # On the Service tab, set Type to 802.1X Wireless – Identity Only and Name to TEST-AAA and change NAS-Port-Type in the Service Rule pane to Ethernet(15).On the Service Rule tab, click Click to add. On the page that is displayed, set Type to Radius:IETF, Name to NAS-Identifier, Operator to EQUALS, and Value to huaweiac



      # On the Authentication tab, add PAP to Authentication Methods and [Local User Respository][Local SQL DB] to Authentication Sources. Then, click Save.



      # On other tabs, use default settings.

    6. Configure the ACL and dynamic VLAN for authorization.

      # Choose Configuration > Enforcement > Profiles. In the pane on the right side, click Add.

      # On the Profile tab, set Template to RADIUS Based Enforcement, and enter ACLVLAN in the Name field.

      # On the Attributes tab, configure attributes and values. Then, click Save.

      # For parameters on other tabs, use the default settings.

      # Choose Configuration > Enforcement > Policies. In the pane on the right side, click Add.

      # On the Enforcement tab, enter ACLVLAN in the Name field, set Enforcement Type to RADIUS and Default Profile to Allow Access Profile.

      # On the Rules tab, click Add Rule. On the Rules Editor tab, set Type to Authentication, Name to Username, Operator to EQUALS, Value to huawei, and Profile Names to [RADIUS]ACLVLAN. This configuration is used to deliver the authorization ACL and dynamic VLAN to user huawei. Then, click Save.

      # On the Rules tab, click Add Rule. On the Rules Editor tab, set Type to Authentication, Name to Username, Operator to NOT_EQUALS, Value to huawei, and Profile Names to [RADIUS][Allow Access Profile]. This configuration is used to allow users to pass authentication without authorization operations. Then, click Save.

      # Click Save to complete the configuration.

    7. Bind authorization policies.

      # Choose Configuration > Services. In the pane on the right side, click service name Radius to open the Edit tab. Select the Enforcement tab, set Enforcement Policy to ACLVLAN, and then click Save.

  10. On the AC, check that users can pass RADIUS authentication.

    # Choose Diagnosis > Diagnosis Tool > AAA Test. The AAA Test page is displayed.

    # Configure the RADIUS server template, authentication mode, user name, and password.



    # Click Start.

  11. Verify the configuration.

    • An employee can access the service server, and laboratory after passing authentication.
    • After the authentication succeeds, choose Monitoring > User on the AC. Information about online employees is displayed.

Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000113779

Views: 55998

Downloads: 1759

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next