No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN Product Interoperation Configuration Guide

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring External Portal Authentication

Example for Configuring External Portal Authentication

External Portal Authentication Overview

Portal authentication is a method used for Network Admission Control (NAC) and is also called web authentication. To access the Internet, the user must pass authentication on the Portal. Portal authentication supports Portal 2.0, Hypertext Transfer Protocol (HTTP), and Hypertext Transfer Protocol Secure (HTTPS). When a Huawei AC is interconnected with a Aruba ClearPass, Portal authentication is implemented based on HTTP or HTTPS.

When the AC is interconnected with the Aruba ClearPass server, HTTPS and HTTP can be used in Portal authentication. The configurations for the two authentication methods are similar. The following uses HTTPS as an example.

For the configuration for external Portal authentication on the AC, see 4.

For the configuration on the Aruba ClearPass server, see 5.

Applicable Products and Versions

Table 3-25  Applicable products and versions

Product

Version

Product

V200R007C20

Aruba Clearpass

6.5.0.31375

Service Requirements

To improve WLAN security, an enterprise performs external Portal authentication using HTTP or HTTPS to access-control users.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: The AC functions as the DHCP server to assign IP addresses to APs, and SwitchB functions as the DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: direct forwarding
  • Authentication mode: external Portal authentication
  • Security policy: open system authentication
Figure 3-9  Networking diagram for configuring external Portal authentication

Data Planning

Table 3-26  Data planning on the AC

Configuration Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

DHCP server

The AC functions as the DHCP server to assign IP addresses to APs, and SwitchB functions as the DHCP server to assign IP addresses to STAs.

IP address pool for APs

10.23.100.2 to 10.23.100.254/24

IP address pool for the STAs

10.23.101.2 to 10.23.101.254/24

IP address of the AC's source interface

VLANIF 100: 10.23.100.1/24

AP group

  • Name: ap-group1
  • Bound profiles: VAP profile wlan-net and regulatory domain profile default

AP group

  • Name: default
  • Country code: China

SSID profile

  • Name: wlan-net
  • SSID name: wlan-net

Security profile

  • Name: wlan-net
  • Security policy: open system authentication

Portal authentication parameters

Portal authentication scheme name: wlan-net

Portal server template name: wlan-net
  • IP address: 10.23.103.1
  • Portal authentication protocol: HTTP
  • URL address: https://10.23.103.1/guest/huawei.php

Portal access profile

  • Name: wlan-net
  • Bound profile: Portal server template wlan-net

Authentication profile

  • Name: wlan-net
  • Bound profiles and authentication scheme: portal access profile wlan-net, free-rule template default, and RADIUS authentication scheme wlan-net

VAP profile

  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Bound profiles: SSID profile wlan-net, security profile wlan-net, and authentication profile wlan-net
Table 3-27  Data planning on the Aruba ClearPass

Configuration Item

Data

Department

Huawei

Account

Account: test@huawei.com

Password: 470541 (manually set or randomly generated by the Aruba ClearPass server)

Device name

AC6605

Device's IP address

10.23.102.2/32

RADIUS shared key

huawei@123

Authentication protocol

  • PAP
  • CHAP

Configuration Roadmap

  1. Configure network interworking.
  2. Configure the AC and SwitchB to assign IP addresses to APs and STAs, respectively.
  3. Configure APs to go online.
  4. Configure WLAN service parameters.
  5. Configure Portal authentication on the AC.
  6. Configure the Aruba ClearPass server.

Configuration Notes

  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • The AC and server must have the same RADIUS shared key.

Procedure

  1. Configure network interworking.

    # Add GE0/0/1 and GE0/0/2 on SwitchA (access switch) to VLAN 100 and VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 on SwitchB (aggregation switch) to VLAN 100 and VLAN 101, GE0/0/2 to VLAN 100 and VLAN 102, GE0/0/3 to VLAN 103, and GE0/0/4 to VLAN104. Create VLANIF 102, VLANIF 103, and VLANIF 104, and configure a default route with the next hop of the address of Router.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 to 104
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk pvid vlan 103
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 103
    [SwitchB-GigabitEthernet0/0/3] quit
    [SwitchB] interface gigabitethernet 0/0/4
    [SwitchB-GigabitEthernet0/0/4] port link-type trunk
    [SwitchB-GigabitEthernet0/0/4] port trunk pvid vlan 104
    [SwitchB-GigabitEthernet0/0/4] port trunk allow-pass vlan 104
    [SwitchB-GigabitEthernet0/0/4] quit
    [SwitchB] interface vlanif 102
    [SwitchB-Vlanif102] ip address 10.23.102.1 24
    [SwitchB-Vlanif102] quit
    [SwitchB] interface vlanif 103
    [SwitchB-Vlanif103] ip address 10.23.103.2 24
    [SwitchB-Vlanif103] quit
    [SwitchB] interface vlanif 104
    [SwitchB-Vlanif104] ip address 10.23.104.1 24
    [SwitchB-Vlanif104] quit
    [SwitchB] ip route-static 0.0.0.0 0.0.0.0 10.23.104.2
    
    # Add GE0/0/1 on the AC to VLAN 100 and VLAN 102. Create VLANIF 102 and configure the static route to the RADIUS server.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101 102
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 102
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 102
    [AC-Vlanif102] ip address 10.23.102.2 24
    [AC-Vlanif102] quit
    [AC] ip route-static 10.23.103.0 24 10.23.102.1
    
    # Configure the IP address of GE0/0/1 on Router and a static route to the network segment for STAs.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] ip address 10.23.104.2 24
    [Router-GigabitEthernet0/0/1] quit
    [Router] ip route-static 10.23.101.0 24 10.23.104.1
    

  2. Configure the AC and SwitchB to function as DHCP servers to assign IP addresses to APs and STAs respectively.

    # On the AC, configure the VLANIF 100 to assign IP addresses to APs.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    # On SwitchB, configure the VLANIF 101 to assign IP addresses to STAs.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] quit
    # Configure a static route to 10.0.0.1.
    [SwitchB] ip route-static 10.0.0.1 32 10.23.102.2
    

  3. Configure APs to go online.

    # Create an AP group to which the APs with the same configuration can be added.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and bind the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the APs offline to the AC and add the APs to the AP group ap-group1. Configure names for the APs based on the AP locations, so that you can know where the APs are located. For example, if the AP with MAC address 60de-4476-e360 is deployed in area 1, name the AP area_1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 and radio 1. Radio 0 and radio 1 operate on the 2.4 GHz and 5 GHz bands respectively.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field displays nor, the AP has gone online.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime   ExtraInfo
    -------------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S      -
    -------------------------------------------------------------------------------------------------
    Total: 1
    

  4. Configure external Portal authentication on the AC.
    1. Configure RADIUS authentication parameters.

      # Configure a RADIUS server template.

      [AC] radius-server template wlan-net
      [AC-radius-wlan-net] radius-server authentication 10.23.103.1 1812 source ip-address 10.23.102.2
      [AC-radius-wlan-net] radius-server shared-key cipher huawei@123
      [AC-radius-wlan-net] quit
      

      # Create an AAA scheme and set the authentication method to RADIUS.

      [AC] aaa
      [AC-aaa] authentication-scheme wlan-net
      [AC-aaa-authen-wlan-net] authentication-mode radius
      [AC-aaa-authen-wlan-net] quit
      [AC-aaa] quit
      
      # Configure the NAS-Identifier attribute.
      NOTE:

      The NAS-Identifier value must be the same on the AC and ClearPass server. If this attribute is not configured on the AC, set the value of NAS-Identifier on the ClearPass server to the AC name.

      [AC] radius-server template wlan-net
      [AC-radius-wlan-net] radius-attribute set NAS-Identifier huaweiac
      [AC-radius-wlan-net] quit
      

    2. Configure the PKI certificate.

      # Load the certificate and private key file.

      NOTE:
      The CA certificate rootca.pem, local certificate, and private key file localcert.p12 have been obtained and uploaded to the storage of the device. If you have applied for multiple CA certificates, perform the same operation to load them.
      [AC] pki realm abc
      [AC-pki-realm-abc] quit 
      [AC] pki import-certificate ca realm abc pem filename rootca.pem
      [AC] pki import-certificate local realm abc pkcs12 filename localcert.p12
      [AC] pki import rsa-key-pair key1 pkcs12 localcert.p12 password Huawei@123
      

      # Configure the SSL policy sslserver and load the digital certificate.

      [AC] ssl policy sslserver type server
      [AC-ssl-policy-sslserver] pki-realm abc
      [AC-ssl-policy-sslserver] version tls1.0 tls1.1 tls1.2
      [AC-ssl-policy-sslserver] ciphersuite rsa_aes_128_sha256 rsa_aes_256_sha256
      [AC-ssl-policy-sslserver] quit
      [AC] http secure-server ssl-policy sslserver
      [AC] http secure-server enable
      

      # Check the SSL policy configuration and ensure that the CA certificate and local certificate are in loaded state.

      [AC] display ssl policy sslserver
      ------------------------------------------------------------------------------
        Policy name                            :   sslserver                             
        Policy ID                              :   2                                
        Policy type                            :   Server                            
        Cipher suite                           :   rsa_aes_128_sha256 rsa_aes_256_sha256 
        PKI realm                              :   abc
        Version                                :   tls1.0 tls1.1 tls1.2  
        Cache number                           :   32                                
        Time out(second)                       :   3600                              
        Server certificate load status         :   loaded                            
        CA certificate chain load status       :   loaded                            
        SSL renegotiation status               :   enable
        Bind number                            :   1                                 
        SSL connection number                  :   0                                 
        ------------------------------------------------------------------------------
      

    3. Configure a Portal server profile.

      NOTE:

      Ensure that the Portal server IP address and URL are configured correctly and are the same as those on the Portal server.

      The Clearpass Portal URL is in format of https://10.23.103.1/guest/huawei.php?_browser=1 and can be obtained through 5.b.

      [AC] portal https-redirect enable
      [AC] portal web-authen-server https ssl-policy sslserver port 8443          //Parse the HTTPS authentication request from users and send authentication information to the server.
      [AC] interface loopback 0
      [AC-LoopBack0] ip address 10.0.0.1 32
      [AC-LoopBack0] quit
      [AC] free-rule-template name default
      [AC-free-rule-default] free-rule 0 destination ip 10.0.0.1 mask 255.255.255.255
      [AC-free-rule-default] quit
      [AC] web-auth-server wlan-net
      [AC-web-auth-server-wlan-net] server-ip 10.23.103.1
      [AC-web-auth-server-wlan-net] url https://10.23.103.1/guest/huawei.php
      [AC-web-auth-server-wlan-net] source-ip 10.23.102.2
      [AC-web-auth-server-wlan-net] protocol http
      [AC-web-auth-server-wlan-net] quit
      

    4. Configure the Portal access profile wlan-net and configure Layer 3 Portal authentication.

      [AC] portal-access-profile name wlan-net
      [AC-portal-access-profile-wlan-net] web-auth-server wlan-net layer3
      [AC-portal-access-profile-wlan-net] quit
      

    5. Create the authentication profile wlan-net.

      [AC] authentication-profile name wlan-net
      [AC-authentication-profile-wlan-net] portal-access-profile wlan-net
      [AC-authentication-profile-wlan-net] authentication-scheme wlan-net
      [AC-authentication-profile-wlan-net] free-rule-template default
      [AC-authentication-profile-wlan-net] radius-server wlan-net
      [AC-authentication-profile-wlan-net] quit

    6. Configure WLAN service parameters.

      # Create the security profile wlan-net and retain the default security policy (open system authentication).

      [AC] wlan
      [AC-wlan-view] security-profile name wlan-net
      [AC-wlan-sec-prof-wlan-net] quit
      

      # Create the SSID profile wlan-net and set the SSID name to wlan-net.

      [AC-wlan-view] ssid-profile name wlan-net
      [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
      [AC-wlan-ssid-prof-wlan-net] quit
      

      # Create the VAP profile wlan-net, configure the direct data forwarding mode and service VLANs, and bind the security profile, authentication profile, and SSID profile to the VAP profile.

      [AC-wlan-view] vap-profile name wlan-net
      [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
      [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
      [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
      [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
      [AC-wlan-vap-prof-wlan-net] authentication-profile wlan-net
      [AC-wlan-vap-prof-wlan-net] quit
      

      # Bind the VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.

      [AC-wlan-view] ap-group name ap-group1
      [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
      [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
      [AC-wlan-ap-group-ap-group1] quit
      [AC-wlan-view] quit
      

  5. Configure the Aruba Clearpass.
    1. Log in to the Aruba ClearPass server.

      # Enter the access address of the Aruba ClearPass server in the address box, which is in the format of https://Aruba ClearPass IP. Aruba ClearPass IP is the IP address of the Aruba ClearPass server.

      # Click ClearPass Guest.

      # On the displayed page, enter the user name and password to log in to the Aruba ClearPass server.

    2. Configure the authentication page.

      # Choose Configuration > Pages > Web Logins. Click Create a new web login page in the right pane.

      # Set parameters as follows:
      • Name: huawei
      • Page Name: huawei
      • Vendor Settings: Custom Settings
      • Submit URL: https://10.0.0.1:8443/login, the same as the authentication address configured on the AC
      • Username Field: username
      • Password Field: password
      Retain the default settings for other parameters.


      # Click Save Changes.

      # Click Test mapping huawei. Record the URL of the displayed page, for example, https://10.23.103.1/guest/huawei.php?_browser=1.



    3. Add guest accounts.

      # Choose Guest > Create Account. Set Guest's Name to test@huawei.com, Company Name to huawei, and Email Address to test@huawei.com. Record the generated password and select Terms of Use.



      # Click Create.

    4. Add the AC so that the Aruba ClearPass server can interwork with the AC.

      # On the ClearPass home page, click ClearPass Policy Manager. On the page that is displayed, enter the user name and password.

      # Choose Configuration > Network > Devices. Click Add in the page. In the Add Device dialog box that is displayed, set parameters as follows:
      • Name: AC6605
      • IP or Subnet Address: 10.23.102.2
      • RADIUS Shared Secret and Verify: huawei@123
      • Vendor Name: Huawei
      Click Add.


    5. Add the guest access service.

      # Choose Configuration > Start Here. Click Guest Access - Web Login in the right pane.

      # On the General tab page, set Name Prefix to huawei.



      # On the Service Rule tab page, set Page name to huawei.



      # Click Add Service.

    6. Configure the RADIUS service.

      # Choose Configuration > Services. Click Add in the right pane.

      # On the Service tab, set Type to 802.1X Wireless – Identity Only and Name to Radius.On the Service Rule tab, click Click to add. On the page that is displayed, set Type to Radius:IETF, Name to NAS-Identifier, Operator to EQUALS, and Value to huaweiac.

      NOTE:

      The NAS-Identifier value must be the same on the AC and ClearPass server. If this attribute is not configured on the AC, set the value of NAS-Identifier on the ClearPass server to the AC name.



      # On the Authentication tab page, add authentication methods [CHAP] and [PAP], and authentication sources [Guest User Repository][Local SQL DB] and [Local User Repository][Local SQL DB].



      # On other tabs, use default settings. Click Save.

  6. On the AC, check whether users can pass RADIUS authentication.

    [AC] test-aaa test@huawei.com 470541 radius-template wlan-net
    Info: Account test succeed.
    

  7. Verify the configuration.

    • The WLAN with SSID wlan-net is available for STAs connected to the AP.
    • The wireless STA obtains an IP address after it associates with the WLAN.
    • When a user opens the browser on the STA, the user is redirected to the Portal authentication page. After the user enters the correct user name and password and is successfully authenticated, the user can access the Internet.
    • After authentication succeeds, run the display access-user access-type command on the AC. The command output shows online users.

      [AC] display access-user access-type portal 
      ------------------------------------------------------------------------------
      UserID Username                IP address       MAC            Status          
      ------------------------------------------------------------------------------
      460    huawei                  10.23.101.254    8000-6e74-e78a Success 
      ------------------------------------------------------------------------------
      Total: 1, printed: 1
      

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 to 101
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 to 104
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
    #
    interface Vlanif103
     ip address 10.23.103.2 255.255.255.0
    #
    interface Vlanif104
     ip address 10.23.104.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 103
     port trunk allow-pass vlan 103
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk pvid vlan 104
     port trunk allow-pass vlan 104
    #
    ip route-static 0.0.0.0 0.0.0.0 10.23.104.2
    ip route-static 10.0.0.1 255.255.255.255 10.23.102.2
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    interface GigabitEthernet0/0/1
     ip address 10.23.104.2 255.255.255.0
    #
    ip route-static 10.23.101.0 255.255.255.0 10.23.104.1
    #
    return
    
  • #
     sysname AC
    #
     http secure-server ssl-policy sslserver
     http server enable 
    #
    portal https-redirect enable
    #
    vlan batch 100 102
    #
    authentication-profile name wlan-net
     portal-access-profile wlan-net
     free-rule-template default
     authentication-scheme wlan-net
     radius-server wlan-net
    #
    portal web-authen-server https ssl-policy sslserver
    #
    dhcp enable
    #
    radius-server template wlan-net
     radius-server shared-key cipher %^%#Oc6_BMCw#9gZ2@SMVtk!PAC6>Ou*eLW/"qLp+f#$%^%#
     radius-server authentication 10.23.103.1 1812 source ip-address 10.23.102.2 weight 80
     radius-attribute set NAS-Identifier huaweiac
    #
    pki realm abc                                                                   
     pki import-certificate ca realm abc pem filename rootca.pem
     pki import-certificate local realm abc pkcs12 filename localcert.p12
     pki import rsa-key-pair key1 pkcs12 localcert.p12 password Huawei@123
    #                                                                               
    ssl policy sslserver type server                                                
     pki-realm abc                                                                  
     version tls1.0 tls1.1 tls1.2                                                   
     ciphersuite rsa_aes_128_sha256 rsa_aes_256_sha256                              
    #                                                     free-rule-template name default
     free-rule 0 destination ip 10.0.0.1 mask 255.255.255.255
    #
    web-auth-server wlan-net
     server-ip 10.23.103.1
     url https://10.23.103.1/guest/huawei.php
     source-ip 10.23.102.2
     protocol http
    #
    portal-access-profile name wlan-net
     web-auth-server wlan-net layer3
    #
    aaa
     authentication-scheme wlan-net
      authentication-mode radius
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.2 255.255.255.0
    
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    interface LoopBack0
     ip address 10.0.0.1 255.255.255.255  
    #
    ip route-static 10.23.103.0 255.255.255.0 10.23.102.1
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
      authentication-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 ap-mac 60de-4476-e360
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000113779

Views: 51044

Downloads: 1689

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next