No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Interoperation and Replacement Guide

This document provides typical configuration examples for interoperation between Huawei switches and mainstream IP phones, firewalls, routers, Microsoft NLB servers, multi-NIC servers, Cisco switches, and SolarWinds.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Interoperation Between a Stack and an Microsoft NLB Cluster (Using Physical Link Loopback)

Interoperation Between a Stack and an Microsoft NLB Cluster (Using Physical Link Loopback)

Overview

NLB is developed by Microsoft for a cluster set up by multiple Windows servers. When a switch is connected to an NLB cluster, the switch needs to send packets destined for the cluster IP address to every NLB server in the cluster. An NLB server can work in unicast, multicast, or IGMP multicast mode.

Currently, a switch can be connected to the NLB server working in only unicast or multicast mode. If the switch supports multi-interface ARP, this function is recommended to implement the connection between the switch and NLB cluster. When the switch or version does not support multi-interface ARP and there are insufficient device resources, you can use physical link loopback to connect the switch to the NLB cluster.

Networking Requirements

As shown in Figure 3-4, Switch_1 and Switch_2 form a stack and are directly connected to two NLB servers respectively through GE0/0/1 and GE1/0/1. The NLB cluster works in multicast mode, the cluster IP address is 10.128.246.252/24, and the cluster MAC address is 03bf-0a80-f6fc. There are reachable routes between the Switch and Client.

The customer requires that the stack be able to send the Client's packets destined for the NLB cluster IP address to all NLB servers.

Figure 3-4  Connecting a stack to an NLB cluster in multicast mode

Data plan

Before the configuration, you need the following data.

Item Data Description
IP address VLANIF200: 10.128.246.250/24 -

Configuration Roadmap

  1. Add GE0/0/1 and GE1/0/1 that are directly connected to NLB servers to VLAN 100.
  2. Add GE0/0/4 and GE1/0/4 to Eth-Trunk 4, and GE0/0/5 and GE1/0/5 to Eth-Trunk 5.
  3. Disable STP, RSTP, VBST, or MSTP on Eth-Trunk 4 and Eth-Trunk 5, and add Eth-Trunk 4 and Eth-Trunk 5 to VLAN 100 and VLAN 200 respectively in access mode.
  4. Configure an IP address for VLANIF 200 that functions as the NLB cluster's gateway.
  5. Configure a static ARP entry. In the static ARP entry, the IP address is the cluster IP address, the MAC address is the cluster multicast MAC address, and the outbound interface is the interface where the VLAN to which the NLB cluster's gateway belongs is configured.
  6. Connect GE0/0/4 and GE0/0/5 as well as GE1/0/4 and GE1/0/5.

Configuration Notes

  • When the NLB cluster works in unicast mode, static ARP entries do not need to be configured on the switch; when the cluster works in multicast mode, static ARP entries need to be configured on the switch.

  • A VRRP virtual gateway cannot be configured on a switch in a stack for clients.

Procedure

  1. Add interfaces directly connected to NLB servers to VLAN 100.

    # Add GE0/0/1 to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname Stack
    [Stack] vlan batch 100 200
    [Stack] interface gigabitethernet 0/0/1
    [Stack-GigabitEthernet0/0/1] port link-type access 
    [Stack-GigabitEthernet0/0/1] port default vlan 100
    [Stack-GigabitEthernet0/0/1] quit
    

    # Add GE1/0/1 to VLAN 100.

    [Stack] interface gigabitethernet 1/0/1
    [Stack-GigabitEthernet1/0/1] port link-type access 
    [Stack-GigabitEthernet1/0/1] port default vlan 100
    [Stack-GigabitEthernet1/0/1] quit
    

  2. Add interfaces to Eth-Trunks.

    # Add GE0/0/4 and GE1/0/4 to Eth-Trunk 4.

    [Stack] interface eth-trunk 4
    [Stack-Eth-Trunk4] quit
    [Stack] interface gigabitethernet 0/0/4
    [Stack-GigabitEthernet0/0/4] eth-trunk 4
    [Stack-GigabitEthernet0/0/4] quit
    [Stack] interface gigabitethernet 1/0/4
    [Stack-GigabitEthernet1/0/4] eth-trunk 4
    [Stack-GigabitEthernet1/0/4] quit

    # Add GE0/0/5 and GE1/0/5 to Eth-Trunk 5.

    [Stack] interface eth-trunk 5
    [Stack-Eth-Trunk5] quit
    [Stack] interface gigabitethernet 0/0/5
    [Stack-GigabitEthernet0/0/5] eth-trunk 5
    [Stack-GigabitEthernet0/0/5] quit
    [Stack] interface gigabitethernet 1/0/5
    [Stack-GigabitEthernet1/0/5] eth-trunk 5
    [Stack-GigabitEthernet1/0/5] quit

  3. Configure Eth-Trunk 4 and Eth-Trunk 5.

    # Disable STP, RSTP, VBST, or MSTP on Eth-Trunk 4 and Eth-Trunk 5.

    [Stack] interface eth-trunk 4
    [Stack-Eth-Trunk4] undo stp enable  //Disable STP, RSTP, VBST, or MSTP
    [Stack-Eth-Trunk4] quit
    [Stack] interface eth-trunk 5
    [Stack-Eth-Trunk5] undo stp enable  //Disable STP, RSTP, VBST, or MSTP
    [Stack-Eth-Trunk5] quit
    

    # Add Eth-Trunk 4 and Eth-Trunk 5 to VLAN 100 and VLAN 200 respectively in access mode.

    [Stack] interface eth-trunk 4
    [Stack-Eth-Trunk4] port link-type access
    [Stack-Eth-Trunk4] port default vlan 100
    [Stack-Eth-Trunk4] quit
    [Stack] interface eth-trunk 5
    [Stack-Eth-Trunk5] port link-type access
    [Stack-Eth-Trunk5] port default vlan 200
    [Stack-Eth-Trunk5] quit

  4. Configure an IP address for the NLB cluster's gateway.

    [Stack] interface vlanif 200
    [Stack-Vlanif200] ip address 10.128.246.250 24
    [Stack-Vlanif200] quit
    

  5. Configure a static ARP entry. In the static ARP entry, the IP address is the cluster IP address 10.128.246.252, the MAC address is the cluster multicast MAC address 03bf-0a80-f6fc, and the outbound interface is Eth-Trunk 5 in VLAN 200.

    [Stack] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface eth-trunk 5   //Configure a static ARP entry

  6. Connect GE0/0/4 and GE0/0/5 on Switch_1, and GE1/0/4 and GE1/0/5 on Switch_2.

    After the previous configurations, connect physical links.

  7. Verify the configuration.

    Verify that Server_1 and Server_2 can receive packets destined for the NLB cluster IP address.

Configuration Files

Stack configuration file

#
sysname Stack
#
vlan batch 100 200
#                                                                               
interface Vlanif200                                                             
 ip address 10.128.246.250 255.255.255.0                                        
#
interface Eth-Trunk4                                                            
 port link-type access                                                          
 port default vlan 100                                                          
 stp disable                                                                    
#                                                                                
interface Eth-Trunk5                                                            
 port link-type access                                                          
 port default vlan 200                                                          
 stp disable                                                                    
#                                                                                
interface GigabitEthernet0/0/1                                                 
 port link-type access                                                          
 port default vlan 100                                               
# 
interface GigabitEthernet0/0/4
 eth-trunk 4
# 
interface GigabitEthernet0/0/5
 eth-trunk 5
# 
interface GigabitEthernet1/0/1                                                 
 port link-type access                                                          
 port default vlan 100                                                
#                                                                               
interface GigabitEthernet1/0/4                                                 
 eth-trunk 4                                                                    
#                                                                               
interface GigabitEthernet1/0/5                                                 
 eth-trunk 5                                                                    
#
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface Eth-Trunk5 
#
return

Applicable Product Models and Versions

Product

Product Model

Software Version

S2700

S2710SI

V100R006C05

S2700EI

V100R006C05

S2720EI

V200R006C10, V200R009C00, V200R010C00, V200R011C10, V200R012C00, V200R013C00

S2750EI

V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S3700

S3700SI

V100R006C05

S3700EI

V100R006C05

S5700

S5700LI

V200R001C00, V200R002C00, V200R003(C00&C02&C10), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5700S-LI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5700SI

V200R001C00, V200R002C00, V200R003C00, V200R005C00

S5700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02&C03)

S5700HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00SPC500&C01&C02)

S5710-C-LI

V200R001C00

S5710-X-LI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00

S5710EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5710HI

V200R005C03

S5720LI and S5720S-LI

V200R010C00, V200R011C00, V200R011C10, V200R012(C00&C20), V200R013C00

S5720SI and S5720S-SI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5720I-SI

V200R012C00, V200R013C00

S5720EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5720HI

V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S5730HI

V200R012C00, V200R013C00

S5730SI

V200R011C10, V200R012C00, V200R013C00

S5730S-EI

V200R011C10, V200R012C00, V200R013C00

S6700

S6700EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6720LI and S6720S-LI

V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720SI and S6720S-SI

V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720EI

V200R008C00, V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720S-EI

V200R009C00, V200R010C00, V200R011C00, V200R011C10, V200R012C00, V200R013C00

S6720HI

V200R012C00, V200R013C00

Translation
Download
Updated: 2019-05-15

Document ID: EDOC1000114005

Views: 178810

Downloads: 8162

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next