No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Interoperation and Replacement Guide

This document provides typical configuration examples for interoperation between Huawei switches and mainstream IP phones, firewalls, routers, Microsoft NLB servers, multi-NIC servers, Cisco switches, and SolarWinds.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
OSPF and EIGRP Interoperation and Replacement Case 2: OSPF Replaces EIGRP

OSPF and EIGRP Interoperation and Replacement Case 2: OSPF Replaces EIGRP

Overview

OSPF can be configured to replace EIGRP on Cisco switches so that all devices on the network run OSPF. This solution enables Huawei switches and Cisco switches to communicate with each other through OSPF.

Configuration Notes

  • This case applies to OSPF-supporting Huawei switches.
  • This case provides only the basic configuration for the replacement of EIGRP with OSPF.
  • During interworking and replacement of Cisco switches and Huawei switches, the encapsulation mode must be IEEE 802.1Q.
  • If route summarization has been used on the EIGRP network before protocol replacement, during OSPF configuration, summary routes need to be advertised first, and then specific routes of the connected network segments can be advertised. This avoids the situation where OSPF specific routes take effect but EIGRP summary routes do not.
  • EIGRP route summarization and filtering are implemented based on interfaces and can be performed on each router. OSPF route summarization and filtering are implemented based on areas and can be configured on only ABRs or autonomous system boundary routers (ASBRs). Therefore, if route summarization and filtering have been deployed on a large number of devices on the existing EIGRP network, you need to adjust the EIGRP route summarization and filtering configuration before configuring OSPF and make the new configuration similar to the configuration of an OSPF network. That is, route summarization and filtering are configured on only ABRs or ASBRs so that OSPF routes can override EIGRP routes and OSPF can replace EIGRP.
  • If you adjust the EIGRP route preference on a large-scale network, you are advised to adjust the preference on edge devices first and then on core devices. Loops may occur on the network because within a short period of time, EIGRP routes take effect on some devices while OSPF routes take effect on other devices. Therefore, the EIGRP route preference needs to be adjusted quickly. You are advised to use the configuration script to perform batch adjustment through the NMS.
  • If the network scale is large and multiple branch networks exist, replace EIGRP on the branch networks with OSPF gradually, and then replace EIGRP the backbone network with OSPF. In this scenario, EIGRP and OSPF coexist. To ensure that routes on the entire network are reachable during the replacement, you need to configure EIGRP and OSPF to import routes from each other on the border devices of the EIGRP and OSPF networks.

Networking Requirements

In Figure 5-35, a Cisco switch is running EIGRP on the network. Based on service requirements, a Huawei switch needs to be added to the network, and all network devices need to run OSPF only to enable the Huawei and Cisco switches to interoperate with each other through OSPF.

In this example, HuaweiA running OSPF needs to replace CiscoA running EIGRP.

Figure 5-35  Replacing EIGRP with OSPF

Configuration Roadmap

  1. Configure basic EIGRP functions on the Cisco switch.
  2. Configure basic OSPF functions on the Huawei switch.
  3. Back up the EIGRP topology table and routing table of the Cisco switch to a local PC.
  4. Adjust the EIGRP route preference to be higher than the OSPF route preference.
  5. Configure OSPF on the Cisco switch and check OSPF routes to ensure that OSPF routes are consistent with EIGRP routes.
  6. Adjust the EIGRP route preference to be lower than the OSPF route preference.
  7. Delete the EIGRP configuration from the Cisco switch after services on the live network has been running stably for a certain period of time to enable all network devices to run OSPF only.
  8. Verify the configuration.

Procedure

  1. Configure basic EIGRP functions on the Cisco switch.

    # Create VLAN 10, and add GE1/0/1 to VLAN 10.

    CISCO> enable
    CISCO# config terminal
    CISCO(config)# vlan 10
    CISCO(config-vlan)# exit
    CISCO(config)# interface gigabitEthernet 1/0/1
    CISCO(config-if)# switchport trunk encapsulation dot1q
    CISCO(config-if)# switchport mode trunk
    CISCO(config-if)# switchport trunk allowed vlan 10
    CISCO(config-if)# exit
    

    # Configure the IP address 192.168.1.2/24 for VLANIF 10.

    CISCO(config)# interface vlan 10
    CISCO(config-if)# ip address 192.168.1.2 255.255.255.0
    CISCO(config-if)# no shutdown
    CISCO(config-if)# exit
    

    # Configure the IP address 192.168.3.1/32 for Loopback1.

    CISCO(config)# interface loopback 1
    CISCO(config-if)# ip address 192.168.3.1 255.255.255.255
    CISCO(config-if)# exit
    

    # Configure the IP address 192.168.4.1/32 for Loopback2.

    CISCO(config)# interface loopback 2
    CISCO(config-if)# ip address 192.168.4.1 255.255.255.255
    CISCO(config-if)# exit
    

    # Configure basic EIGRP functions.

    CISCO(config)# router eigrp 1
    CISCO(config-router)# eigrp router-id 2.2.2.2
    CISCO(config-router)# network 192.168.1.0 0.0.0.255
    CISCO(config-router)# network 192.168.3.1 0.0.0.0
    CISCO(config-router)# network 192.168.4.1 0.0.0.0
    CISCO(config-router)# end
    

  2. Configure basic OSPF functions on the Huawei switch.

    # Create VLAN 10, and add GE0/0/1 to VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] vlan 10
    [HUAWEI-vlan10] quit
    [HUAWEI] interface GigabitEthernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] port link-type trunk
    [HUAWEI-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [HUAWEI-GigabitEthernet0/0/1] quit
    

    # Configure the IP address 192.168.1.1/24 to VLANIF 10.

    [HUAWEI] interface vlanif 10
    [HUAWEI-Vlanif10] ip address 192.168.1.1 24
    [HUAWEI-Vlanif10] quit
    

    # Configure the IP address 192.168.2.1/32 for Loopback1.

    [HUAWEI] interface Loopback 1
    [HUAWEI-LoopBack1] ip address 192.168.2.1 32
    [HUAWEI-LoopBack1] quit
    

    # Configure basic OSPF functions.

    [HUAWEI] ospf 1 router-id 1.1.1.1
    [HUAWEI-ospf-1] area 0
    [HUAWEI-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [HUAWEI-ospf-1-area-0.0.0.0] network 192.168.2.1 0.0.0.0
    [HUAWEI-ospf-1-area-0.0.0.0] return

  3. Back up the EIGRP topology table and routing table of the Cisco switch to a local PC.

    # View the EIGRP topology table of the Cisco switch.

    CISCO# show ip eigrp topology
    IP-EIGRP Topology Table for AS(1)/ID(2.2.2.2)                                   
                                                                                    
    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,               
           r - reply Status, s - sia Status                                         
                                                                                    
    P 192.168.4.0/24, 1 successors, FD is 128256                                   
            via Summary (128256/0), Null0                                           
    P 192.168.4.1/32, 1 successors, FD is 128256                                   
            via Connected, Loopback2                                                
    P 192.168.1.0/24, 1 successors, FD is 2816                                     
            via Connected, Vlan10                                                   
    P 192.168.3.0/24, 1 successors, FD is 128256                                   
            via Summary (128256/0), Null0                                           
    P 192.168.3.1/32, 1 successors, FD is 128256                                   
            via Connected, Loopback1                                   

    # View the routing table of the Cisco switch.

    CISCO# show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP                  
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area           
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2           
           E1 - OSPF external type 1, E2 - OSPF external type 2                     
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2    
           ia - IS-IS inter area, * - candidate default, U - per-user static route  
           o - ODR, P - periodic downloaded static route                            
                                                                                    
    Gateway of last resort is not set                                               
                                                                                    
         192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks                  
    D       192.168.3.0/24 is a summary, 00:04:09, Null0                           
    C       192.168.3.1/32 is directly connected, Loopback1                        
    C    192.168.1.0/24 is directly connected, Vlan10                              
         192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks                  
    D       192.168.4.0/24 is a summary, 00:01:02, Null0                           
    C       192.168.4.1/32 is directly connected, Loopback2                        
    C    192.89.5.0/24 is directly connected, Vlan4094                              
    S    192.0.0.0/8 [1/0] via 192.89.5.1                                           

  4. Adjust the EIGRP route preference to be higher than the OSPF route preference.

    The following table lists the route preferences on Cisco switches, a smaller priority value indicates a higher priority.

    Route Type Route Preference
    Direct route 0
    Static route 1
    EIGRP internal route 90
    OSPF route 110
    IS-IS route 115
    RIP route 120
    EIGRP external route 170

    # Set the preference value of EIGRP external routes to 100 to make the preference of EIGRP internal and external routes be higher than that of OSPF routes (with the preference value 110).

    CISCO# config terminal
    CISCO(config)# router eigrp 1
    CISCO(config-router)# distance eigrp 90 100
    CISCO(config-router)# exit

  5. Configure OSPF on the Cisco switch and check OSPF routes to ensure that OSPF routes are consistent with EIGRP routes.

    # Configure basic OSPF functions.

    CISCO(config)# router ospf 1
    CISCO(config-router)# router-id 2.2.2.2
    CISCO(config-router)# network 192.168.1.0 0.0.0.255 area 0
    CISCO(config-router)# network 192.168.3.1 0.0.0.0 area 0
    CISCO(config-router)# network 192.168.4.1 0.0.0.0 area 0
    CISCO(config-router)# end
    

    # View the routing table to check whether OSPF routes have overridden EIGRP routes.

    CISCO# show ip protocols
    *** IP Routing is NSF aware ***                                                 
                                                                                    
    Routing Protocol is "eigrp 1"                                                   
      Outgoing update filter list for all interfaces is not set                     
      Incoming update filter list for all interfaces is not set                     
      Default networks flagged in outgoing updates                                  
      Default networks accepted from incoming updates                               
      EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0                              
      EIGRP maximum hopcount 100                                                    
      EIGRP maximum metric variance 1                                               
      Redistributing: eigrp 1                                                       
      EIGRP NSF-aware route hold timer is 240s                                      
      EIGRP NSF disabled                                                            
         NSF signal timer is 20s                                                    
         NSF converge timer is 120s                                                 
      Automatic network summarization is in effect                                  
      Automatic address summarization:                                              
        192.168.4.0/24 for Loopback1, Vlan10                                       
          Summarizing with metric 128256                                            
        192.168.3.0/24 for Loopback2, Vlan10                                       
          Summarizing with metric 128256                                            
        192.168.1.0/24 for Loopback1, Loopback2                                    
      Maximum path: 4                                                               
      Routing for Networks:                                                         
        192.168.1.0  //EIGRP route of the Cisco switch
        192.168.3.1/32  //EIGRP route of the Cisco switch
        192.168.4.1/32  //EIGRP route of the Cisco switch
      Routing Information Sources:                                                  
        Gateway         Distance      Last Update                                   
      Distance: internal 90 external 100                                           
                                                                                    
    Routing Protocol is "ospf 1"                                                    
      Outgoing update filter list for all interfaces is not set                     
      Incoming update filter list for all interfaces is not set                     
      Router ID 2.2.2.2                                                             
      It is an area border router                                                   
      Number of areas in this router is 2. 2 normal 0 stub 0 nssa                   
      Maximum path: 4                                                               
      Routing for Networks:                                                         
        192.168.1.0 0.0.0.255 area 0  //OSPF route of the Cisco switch
        192.168.3.1 0.0.0.0   area 0  //OSPF route of the Cisco switch
        192.168.4.1 0.0.0.0   area 0  //OSPF route of the Cisco switch
      Routing Information Sources:                                                  
        Gateway         Distance      Last Update                                   
        1.1.1.1              110      00:20:54                                      
      Distance: (default is 110)                                                    

  6. Adjust the EIGRP route preference to be lower than the OSPF route preference.

    # Set the preference values of EIGRP internal and external routes to 130 and 170 respectively to make the preferences of EIGRP routes be lower than that of OSPF routes (with the preference value 110).

    CISCO# config terminal
    CISCO(config)# router eigrp 1
    CISCO(config-router)# distance eigrp 130 170
    CISCO(config-router)# exit

  7. Delete the EIGRP configuration from the Cisco switch after services on the live network has been running stably for a certain period of time to enable all network devices to run OSPF only.

    CISCO(config)# no router eigrp 1
    CISCO(config)# exit
    

  8. Verify the configuration.

    # View the OSPF routing table of the Huawei switch.

    <HUAWEI> display ospf 1 routing                     
             OSPF Process 1 with Router ID 1.1.1.1                                  
                      Routing Tables                                                
                                                                                    
     Routing for Network                                                            
     Destination        Cost  Type       NextHop         AdvRouter       Area       
     192.168.1.0/24    1     Transit    192.168.1.1    1.1.1.1         0.0.0.0    
     192.168.2.1/32    0     Stub       192.168.2.1    1.1.1.1         0.0.0.0    
     192.168.3.1/32    2     Inter-area 192.168.1.2    2.2.2.2         0.0.0.0  //OSPF route of the Cisco switch learned through OSPF of the Huawei switch
     192.168.4.1/32    2     Inter-area 192.168.1.2    2.2.2.2         0.0.0.0  //OSPF route of the Cisco switch learned through OSPF of the Huawei switch
                                                                                   
     Total Nets: 4                                                                  
     Intra Area: 2  Inter Area: 2  ASE: 0  NSSA: 0                                  

    # View the OSPF routing table of the Cisco switch.

    CISCO# show ip route ospf                                                      
         192.168.2.0/32 is subnetted, 1 subnets                                    
    O IA    192.168.2.1 [110/1] via 192.168.1.1, 00:06:41, Vlan10  //OSPF route of the Huawei switch learned through OSPF of the Cisco switch
    

    # View the EIGRP topology table of the Cisco switch.

    CISCO# show ip eigrp topology                                                    
                                      //The EIGRP configuration of the Cisco switch has been deleted, so the topology table is empty.

    # View the IP routing table of the Huawei switch.

    <HUAWEI> display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 10       Routes : 10                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          192.0.0.0/8   Static  60   0          RD   192.89.5.1      Vlanif4094     
         192.89.5.0/24  Direct  0    0           D   192.89.5.57     Vlanif4094     
        192.89.5.57/32  Direct  0    0           D   127.0.0.1       Vlanif4094     
       192.168.1.0/24   Direct  0    0           D   192.168.1.1     Vlanif10       
       192.168.1.1/32   Direct  0    0           D   127.0.0.1       Vlanif10       
       192.168.2.1/32   Direct  0    0           D   127.0.0.1       LoopBack1      
       192.168.3.1/32   OSPF    10   2           D   192.168.1.2     Vlanif10  //OSPF route of the Cisco switch learned through OSPF of the Huawei switch
       192.168.4.1/32   OSPF    10   2           D   192.168.1.2     Vlanif10  //OSPF route of the Cisco switch learned through OSPF of the Huawei switch

    # View the routing table of the Cisco switch.

    CISCO# show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP                  
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area           
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2           
           E1 - OSPF external type 1, E2 - OSPF external type 2                     
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2    
           ia - IS-IS inter area, * - candidate default, U - per-user static route  
           o - ODR, P - periodic downloaded static route                            
                                                                                    
    Gateway of last resort is not set                                               
                                                                                    
         192.168.3.0/32 is subnetted, 1 subnets                                    
    C       192.168.3.1 is directly connected, Loopback1                           
    C    192.168.1.0/24 is directly connected, Vlan10                              
         192.168.4.0/32 is subnetted, 1 subnets                                    
    C       192.168.4.1 is directly connected, Loopback2                           
    C    192.89.5.0/24 is directly connected, Vlan4094                              
         192.168.2.0/32 is subnetted, 1 subnets                                    
    O IA    192.168.2.1 [110/1] via 192.168.1.1, 00:00:12, Vlan10  //OSPF route of the Huawei switch learned through OSPF of the Cisco switch
    S    192.0.0.0/8 [1/0] via 192.89.5.1                                           

    # Check whether the Huawei switch can communicate with the Cisco switch through OSPF.

    <HUAWEI> ping 192.168.3.1
      PING 192.168.3.1: 56  data bytes, press CTRL_C to break                      
        Reply from 192.168.3.1: bytes=56 Sequence=1 ttl=255 time=1 ms              
        Reply from 192.168.3.1: bytes=56 Sequence=2 ttl=255 time=1 ms              
        Reply from 192.168.3.1: bytes=56 Sequence=3 ttl=255 time=1 ms              
        Reply from 192.168.3.1: bytes=56 Sequence=4 ttl=255 time=1 ms              
        Reply from 192.168.3.1: bytes=56 Sequence=5 ttl=255 time=1 ms              
                                                                                    
      --- 192.168.3.1 ping statistics ---                                          
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 1/1/1 ms                                           

Translation
Download
Updated: 2019-05-15

Document ID: EDOC1000114005

Views: 177254

Downloads: 8152

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next