No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Interoperation and Replacement Guide

This document provides typical configuration examples for interoperation between Huawei switches and mainstream IP phones, firewalls, routers, Microsoft NLB servers, multi-NIC servers, Cisco switches, and SolarWinds.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Interoperation and Replacement Solution 2: C-H-C Model Networking

Interoperation and Replacement Solution 2: C-H-C Model Networking

Overview

In the C-H-C model, a Cisco switch directly connects to a Huawei S series switch that has a downstream Cisco switch connected.

When VTP is enabled on a Cisco switch to synchronize VLAN information, a Huawei S series switch with a downstream Cisco switch connected cannot process VTP packets. Therefore, the Huawei S series switch needs to transparently transmit VTP packets.

Configuration Notes

  • This example applies to Huawei switches of all versions.
  • When a Huawei S series switch sets up a Layer 2 tunnel to transparently transmit VTP packets, the destination multicast address must map to the unused multicast address to prevent address conflicts.
  • The VTP tunnel must be set up on an interface of the Huawei S series switch in VLAN 1 where VTP packets are transmitted.
  • If switchport dynamic auto or switchport dynamic desirable is configured on the Cisco switch interface before the Cisco switch interface is directly connects to the Huawei S series switch, change it to switchport mode trunk to prevent DTP negotiation failure.

Networking Requirements

In Figure 5-10, a Huawei S series switch is directly connected to the Cisco VTP server and client. The Huawei S series switch needs to transparently transmit VTP packets to the Cisco VTP client, and user hosts need to communicate in VLAN 10.

Figure 5-10  Hybrid networking of the C-H-C model

Configuration Roadmap

  1. Check the configuration of Cisco switches.
  2. Configure Layer 2 transparent transmission on the Huawei S series switch to transparently transmit VTP packets.
  3. Create a VLAN manually on the Huawei S series switch and add interfaces to the VLAN.

Procedure

  1. Check the Cisco VTP server configuration. The display depends on the device configuration.

    # Run the show running-config command to check the interface configuration.

    !
    hostname VTP_Sever
    !
    interface GigabitEthernet5/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet5/3
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !

    If the interface configuration is incorrect, perform the following operations to configure the interface.

    VTP_Sever# configure terminal
    VTP_Sever(config)# interface gigabitethernet 5/1
    VTP_Sever(config-if)# switchport trunk encapsulation dot1q  //Configure an encapsulation mode; otherwise, the link type of an interface cannot be set to trunk.
    VTP_Sever(config-if)# switchport mode trunk  //Configure the interface connected to the switch as a trunk interface. The interface joins all VLANs by default.
    VTP_Sever(config-if)# exit
    VTP_Sever(config)# interface gigabitethernet 5/3
    VTP_Sever(config-if)# switchport trunk encapsulation dot1q
    VTP_Sever(config-if)# switchport mode trunk
    VTP_Sever(config-if)# exit
    

    # Run the show vlan brief command to check whether VLAN 10 has been created. If VLAN 10 is created, perform the following operation to create VLAN 10.

    VTP_Sever(config)# vlan 10

    # Run the show vtp status command to check whether the VTP working mode is server and whether the domain name is the same as that on the client. Run the show vtp password command to check whether the password is the same as that on the client.

    If the VTP configuration is incorrect, perform the following operations to configure the VTP server.

    VTP_Sever(config)# vtp domain Cisco  //Configure the VTP domain name.
    VTP_Sever(config)# vtp mode server  //Set the VTP mode to server.
    VTP_Sever(config)# vtp password Cisco  //Configure the VTP password.
    

  2. Check the Cisco VTP client configuration. The configurations of two VTP clients are the same. The following information is used for reference only.

    # Run the show running-config command to check the interface configuration.

    !
    hostname VTP_Client
    !
    interface GigabitEthernet0/1
     switchport access vlan 10
     switchport trunk encapsulation dot1q
     switchport mode access
    !
    interface GigabitEthernet0/2
     switchport access vlan 10
     switchport trunk encapsulation dot1q
     switchport mode access
    !
    interface GigabitEthernet0/48
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !

    If the interface configuration is incorrect, perform the following operations to configure the interface.

    VTP_Client# configure terminal
    VTP_Client(config)# interface gigabitethernet 0/1
    VTP_Client(config-if)# switchport mode access  //Configure the interface connected to terminals as an access interface.
    VTP_Client(config-if)# switchport access vlan 10  //Add the interface to VLAN 10.
    VTP_Client(config-if)# exit
    VTP_Client(config)# interface gigabitethernet 0/2
    VTP_Client(config-if)# switchport mode access
    VTP_Client(config-if)# switchport access vlan 10
    VTP_Client(config-if)# exit
    VTP_Client(config)# interface gigabitethernet 0/48
    VTP_Client(config-if)# switchport trunk encapsulation dot1q  //Configure an encapsulation mode; otherwise, the link type of an interface cannot be set to trunk.
    VTP_Client(config-if)# switchport mode trunk  //Configure the interface connected to the switch as a trunk interface. The interface joins all VLANs by default.
    VTP_Client(config-if)# exit
    

    # Run the show vtp status command to check whether the VTP working mode is client and whether the domain name is the same as that on the server. Run the show vtp password command to check whether the password is the same as that on the server.

    If the VTP configuration is incorrect, perform the following operations to configure the VTP client.

    VTP_Client(config)# vtp domain Cisco  //Configure the VTP domain name.
    VTP_Client(config)# vtp mode client  //Set the VTP mode to client.
    VTP_Client(config)# vtp password Cisco  //Configure the VTP password.
    

  3. Configure the Huawei S series switch.

    # Configure Layer 2 transparent transmission on the Huawei S series switch.

    <HUAWEI> system-view
    [HUAWEI] l2protocol-tunnel vtp group-mac 0100-5e00-0011  //Map the VTP destination MAC address to a specified multicast address.
    [HUAWEI] interface GigabitEthernet0/0/48
    [HUAWEI-GigabitEthernet0/0/48] l2protocol-tunnel vtp vlan 1  //Set up a Layer 2 tunnel to transmit VTP packets in VLAN 1.
    [HUAWEI-GigabitEthernet0/0/48] quit
    [HUAWEI] interface GigabitEthernet0/0/46
    [HUAWEI-GigabitEthernet0/0/46] l2protocol-tunnel vtp vlan 1  //Set up a Layer 2 tunnel to transmit VTP packets in VLAN 1.
    [HUAWEI-GigabitEthernet0/0/46] quit
    
    # Add interfaces on the Huawei S series
    [HUAWEI] vlan 10  //Manually create VLAN 10.
    [HUAWEI-vlan10] quit
    [HUAWEI] interface GigabitEthernet0/0/48
    [HUAWEI-GigabitEthernet0/0/48] port link-type trunk  //Configure the interface connected to the switch as a trunk interface.
    [HUAWEI-GigabitEthernet0/0/48] port trunk allow-pass vlan 2 to 4094  //Add the interface to VLANs  2 to 4094.
    [HUAWEI-GigabitEthernet0/0/48] quit
    [HUAWEI] interface GigabitEthernet0/0/46
    [HUAWEI-GigabitEthernet0/0/46] port link-type trunk  //Configure the interface connected to the switch as a trunk interface. 
    [HUAWEI-GigabitEthernet0/0/46] port trunk allow-pass vlan 2 to 4094  //Add the interface to VLANs  2 to 4094.
    [HUAWEI-GigabitEthernet0/0/46] quit
    

  4. Verify the configuration.

    • Run the display l2protocol-tunnel group-mac vtp command to check the Layer 2 transparent transmission configuration on the Huawei S series switch.
    • Run the display vlan 10 command to check whether interfaces on the Huawei S series switch have been added to VLAN 10.

Translation
Download
Updated: 2019-05-15

Document ID: EDOC1000114005

Views: 178238

Downloads: 8154

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next