No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Interoperation and Replacement Guide

This document provides typical configuration examples for interoperation between Huawei switches and mainstream IP phones, firewalls, routers, Microsoft NLB servers, multi-NIC servers, Cisco switches, and SolarWinds.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
OSPF and EIGRP Interoperation and Replacement Case 1: OSPF Interoperates with EIGRP

OSPF and EIGRP Interoperation and Replacement Case 1: OSPF Interoperates with EIGRP

Overview

OSPF can be used on Cisco EIGRP-enabled switches to exchange routing information with Huawei OSPF-enabled switches. This solution enables Huawei OSPF-enabled switches to interoperate with Cisco EIGRP-enabled switches.

Configuration Notes

  • This case applies to OSPF-supporting Huawei switches.
  • This case provides only the basic configuration for interoperation between OSPF and EIGRP.
  • During interworking and replacement of Cisco switches and Huawei switches, the encapsulation mode must be IEEE 802.1Q.
  • The subnets parameter needs to be configured when EIGRP routes need to be imported into OSPF. Otherwise, only major network routes but no subnet routes can be imported into OSPF.
  • The metric-related parameters need to be configured when OSPF routes need to be imported into EIGRP. Otherwise, the metric value of the imported OSPF routes is infinite, and these routes cannot be transmitted to other EIGRP devices.

Networking Requirements

In Figure 5-34, a Cisco switch is running EIGRP on the network. Based on service requirements, a Huawei switch needs to be added to the network to enable the Huawei OSPF-enabled switch to interoperate with the Cisco EIGRP-enabled switch. Both OSPF and EIGRP need to run on the network.

In this example, HuaweiA running OSPF needs to interoperate with CiscoA running EIGRP.

Figure 5-34  Interoperation between OSPF and EIGRP

Configuration Roadmap

  1. Configure basic EIGRP functions on the Cisco switch.
  2. Configure basic OSPF functions on the Huawei switch.
  3. Configure basic OSPF functions on the Cisco switch for interoperation with the Huawei switch through OSPF.
  4. Configure OSPF and EIGRP to import routes from each other on the Cisco switch so that the Huawei OSPF-enabled switch can interoperate with the Cisco EIGRP-enabled switch.
  5. Verify the configuration.

Procedure

  1. Configure basic EIGRP functions on the Cisco switch.

    # Create VLAN 10, and add GE1/0/1 to VLAN 10.

    CISCO(config)# vlan 10
    CISCO(config-vlan)# exit
    CISCO(config)# interface gigabitEthernet 1/0/1
    CISCO(config-if)# switchport trunk encapsulation dot1q
    CISCO(config-if)# switchport mode trunk
    CISCO(config-if)# switchport trunk allowed vlan 10
    CISCO(config-if)# exit
    

    # Configure the IP address 192.168.1.2/24 for VLANIF 10.

    CISCO(config)# interface vlan 10
    CISCO(config-if)# ip address 192.168.1.2 255.255.255.0
    CISCO(config-if)# no shutdown
    CISCO(config-if)# exit
    

    # Configure the IP address 192.168.3.1/32 for Loopback1.

    CISCO> enable
    CISCO# config terminal
    CISCO(config)# interface loopback 1
    CISCO(config-if)# ip address 192.168.3.1 255.255.255.255
    CISCO(config-if)# exit
    

    # Configure basic EIGRP functions.

    CISCO(config)# router eigrp 1
    CISCO(config-router)# eigrp router-id 2.2.2.2
    CISCO(config-router)# network 192.168.3.1 0.0.0.0
    CISCO(config-router)# exit

  2. Configure basic OSPF functions on the Huawei switch.

    # Create VLAN 10, and add GE0/0/1 to VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] vlan 10
    [HUAWEI-vlan10] quit
    [HUAWEI] interface GigabitEthernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] port link-type trunk
    [HUAWEI-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [HUAWEI-GigabitEthernet0/0/1] quit
    

    # Configure the IP address 192.168.1.1/24 to VLANIF 10.

    [HUAWEI] interface vlanif 10
    [HUAWEI-Vlanif10] ip address 192.168.1.1 24
    [HUAWEI-Vlanif10] quit
    

    # Configure the IP address 192.168.2.1/32 for Loopback1.

    [HUAWEI] interface Loopback 1
    [HUAWEI-LoopBack1] ip address 192.168.2.1 32
    [HUAWEI-LoopBack1] quit
    

    # Configure basic OSPF functions.

    [HUAWEI] ospf 1 router-id 1.1.1.1
    [HUAWEI-ospf-1] area 0
    [HUAWEI-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [HUAWEI-ospf-1-area-0.0.0.0] network 192.168.2.1 0.0.0.0
    [HUAWEI-ospf-1-area-0.0.0.0] return

  3. Configure basic OSPF functions on the Cisco switch for interoperation with the Huawei switch through OSPF.

    # Configure basic OSPF functions.

    CISCO(config)# router ospf 1
    CISCO(config-router)# router-id 2.2.2.2
    CISCO(config-router)# network 192.168.1.0 0.0.0.255 area 0
    CISCO(config-router)# exit

  4. Configure OSPF and EIGRP to import routes from each other on the Cisco switch so that the Huawei OSPF-enabled switch can interoperate with the Cisco EIGRP-enabled switch.

    # Configure OSPF to import EIGRP routes.

    CISCO(config)# router ospf 1
    CISCO(config-router)# redistribute eigrp 1 subnets
    CISCO(config-router)# exit
    

    # Configure EIGRP to import OSPF routes.

    CISCO(config)# router eigrp 1
    CISCO(config-router)# redistribute ospf 1 metric 1 1 1 1 1
    CISCO(config-router)# end
    

  5. Verify the configuration.

    # View the OSPF routing table of the Huawei switch.

    <HUAWEI> display ospf 1 routing
     Destination        Cost  Type       NextHop         AdvRouter       Area       
     192.168.1.0/24     1     Transit    192.168.1.1     1.1.1.1         0.0.0.0    
     192.168.2.1/32     0     Stub       192.168.2.1     1.1.1.1         0.0.0.0    
                                                                                    
     Routing for ASEs                                                               
     Destination        Cost      Type       Tag         NextHop         AdvRouter  
     192.168.3.1/32     20        Type2      0           192.168.1.2     2.2.2.2  //EIGRP route of the Cisco switch imported through OSPF of the Cisco switch
                                                                                    
     Total Nets: 3                                                                  
     Intra Area: 2  Inter Area: 0  ASE: 1  NSSA: 0                     

    # View the OSPF routing table of the Cisco switch.

    CISCO# show ip route ospf
         192.168.2.0/32 is subnetted, 1 subnets                                    
    O IA    192.168.2.1 [110/1] via 192.168.1.1, 00:09:07, Vlan10  //OSPF route of the Huawei switch learned through OSPF of the Cisco switch

    # View the EIGRP topology table of the Cisco switch.

    CISCO# show ip eigrp topology                                                    
    IP-EIGRP Topology Table for AS(1)/ID(2.2.2.2)                                   
                                                                                    
    Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,               
           r - reply Status, s - sia Status                                         
                                                                                    
    P 192.168.1.0/24, 1 successors, FD is 2560000256  //Imported OSPF route of the Cisco switch
            via Redistributed (2560000256/0)                                        
    P 192.168.3.1/32, 1 successors, FD is 128256                                   
            via Connected, Loopback1                                                
    P 192.168.2.1/32, 1 successors, FD is 2560000256  //OSPF route of the Huawei switch imported through OSPF of the Cisco switch
            via Redistributed (2560000256/0)                                        

    # View the IP routing table of the Huawei switch.

    <HUAWEI> display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 9       Routes : 9                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          192.0.0.0/8   Static  60   0          RD   192.89.5.1      Vlanif4094     
         192.89.5.0/24  Direct  0    0           D   192.89.5.57     Vlanif4094     
        192.89.5.57/32  Direct  0    0           D   127.0.0.1       Vlanif4094    
        192.168.1.0/24  Direct  0    0           D   192.168.1.1     Vlanif10       
        192.168.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10       
        192.168.2.1/32  Direct  0    0           D   127.0.0.1       LoopBack1      
        192.168.3.1/32  O_ASE   150  20          D   192.168.1.2     Vlanif10  //EIGRP route of the Cisco switch imported through OSPF of the Cisco switch
    

    # View the routing table of the Cisco switch.

    CISCO# show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP                  
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area           
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2           
           E1 - OSPF external type 1, E2 - OSPF external type 2                     
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2    
           ia - IS-IS inter area, * - candidate default, U - per-user static route  
           o - ODR, P - periodic downloaded static route                            
                                                                                    
    Gateway of last resort is not set                                               
                                                                                    
         192.168.3.0/32 is subnetted, 1 subnets                                    
    C       192.168.3.1 is directly connected, Loopback1                           
    C    192.168.1.0/24 is directly connected, Vlan10                              
    C    192.89.5.0/24 is directly connected, Vlan4094                              
         192.168.2.0/32 is subnetted, 1 subnets                                    
    O       192.168.2.1 [110/1] via 192.168.1.1, 00:06:59, Vlan10  //OSPF route of the Huawei switch learned through OSPF of the Cisco switch
    
    S    192.0.0.0/8 [1/0] via 192.89.5.1                                         

    # Check whether the Huawei OSPF-enabled switch can communicate with the Cisco EIGRP-enabled switch.

    <HUAWEI> ping 192.168.3.1
      PING 192.168.3.1: 56  data bytes, press CTRL_C to break                      
        Reply from 192.168.3.1: bytes=56 Sequence=1 ttl=255 time=1 ms              
        Reply from 192.168.3.1: bytes=56 Sequence=2 ttl=255 time=1 ms              
        Reply from 192.168.3.1: bytes=56 Sequence=3 ttl=255 time=1 ms              
        Reply from 192.168.3.1: bytes=56 Sequence=4 ttl=255 time=1 ms              
        Reply from 192.168.3.1: bytes=56 Sequence=5 ttl=255 time=1 ms              
                                                                                    
      --- 192.168.3.1 ping statistics ---                                          
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 1/1/1 ms                                           

Translation
Download
Updated: 2019-05-15

Document ID: EDOC1000114005

Views: 179401

Downloads: 8164

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next