No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S2700, S3700, S5700, S6700, S7700, and S9700 Series Switches Interoperation and Replacement Guide

This document provides typical configuration examples for interoperation between Huawei switches and mainstream IP phones, firewalls, routers, Microsoft NLB servers, multi-NIC servers, Cisco switches, and SolarWinds.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Interoperation Between Switches and IP Phones Through LLDP-MED

Interoperation Between Switches and IP Phones Through LLDP-MED

Overview

If an IP phone can obtain the voice VLAN through the network-policy TLV field of LLDP and the voice packet sent by the IP phone has a higher priority, you can configure the lldp tlv-enable med-tlv network-policy voice-vlan command on the switch to assign a voice VLAN to the IP phone, and configure the trusted packet priority on the interface to connect the IP phone to the network.

For applicable IP phones, see List of IP Phone Models That Can Be Connected to Switches.

Configuration Notes

Networking Requirements

In Figure 1-10, to save investment costs, the customer requires that IP phones connect to the network through VoIP. IP phones can obtain voice VLAN IDs from the network-policy TLV field of LLDP. The network plan should meet the following requirements:
  • Voice packets sent by IP phones can carry VLAN tags and have a high priority, and only the trusted packet priority needs to be configured on switches.
  • Voice packets are transmitted in VLAN 100.
  • IP addresses of IP phones are dynamically allocated by the DHCP server, and are on a different network segment from that of the DHCP server.
  • IP phones need to connect to switches through 802.1X authentication and MAC address authentication.
Figure 1-10  Networking diagram of connecting switches to IP phones through LLDP-MED

Configuration Roadmap

To implement interoperation between switches and IP phones through LLDP-MED, IP phones need to obtain the voice VLAN, apply for IP addresses, go online after authentication, and send packets. Figure 1-11 shows the process for interoperation between switches and IP phones through LLDP-MED.

The operations of obtaining the voice VLAN, applying for IP addresses, and enabling IP phones to go online after authentication can be performed simultaneously.

Figure 1-11  Process for interoperation between switches and IP phones through LLDP-MED

According to the preceding process, the configuration roadmap is as follows:
  • Enable LLDP to allocate a voice VLAN to IP phones.
  • Configure the trusted packet priority on the interface so that packets are forwarded based on their original priorities.
  • Configure the DHCP relay function and DHCP server to allocate IP addresses to IP phones.
  • Configure the authentication server and enable IP phones to go online after authentication.

Data Plan

Table 1-10  Data plan for IP phones

Item

Value

Voice VLAN

VLAN 100

MAC address

001b-d4c7-0001

0021-a08f-0002

Address segment

10.20.20.1/24

Authentication mode

802.1X authentication and MAC address authentication. 802.1X authentication is performed first. If the authentication fails, MAC address authentication is performed.

Table 1-11  Data plan for communication

Item

Value

VLAN and IP address used by SwitchA to communicate with SwitchB

VLAN 200; 10.10.20.1/24

VLAN and IP address used by SwitchB to communicate with SwitchA

VLAN 200; 10.10.20.2/24

IP address of SwitchA

192.168.100.200

802.1X access profile name

ipphone

MAC access profile name

ipphone

IP address of the RADIUS authentication and accounting server

192.168.100.182

Port number of the RADIUS authentication server

1812

Port number of the RADIUS accounting server

1813

RADIUS shared key

Huawei2012

Procedure

  1. Enable LLDP on SwitchA and configure the network-policy TLV field on interfaces.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] lldp enable  //After LLDP is enabled globally, LLDP is enabled on all interfaces by default.
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60  //Configure the switch to use the network-policy TLV field to allocate a voice VLAN ID and priority to IP phones.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60
    [SwitchA-GigabitEthernet1/0/2] quit
    

  2. Add an interface on SwitchA to a VLAN.

    # Create voice VLAN 100

    [SwitchA] vlan batch 100
    
    # Add interfaces to voice VLAN 100.
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid   //In V200R005C00 and later versions, the default link type of an interface is not hybrid, and needs to be manually configured.
    [SwitchA-GigabitEthernet1/0/1] port hybrid tagged vlan 100  //Add the interface to voice VLAN 100 in tagged mode.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/2] port hybrid tagged vlan 100
    [SwitchA-GigabitEthernet1/0/2] quit
    

  3. Configure the interface to trust the packet priority.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] trust 8021p inner  //The trust 8021p (inner) command varies by device model.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] trust 8021p inner
    [SwitchA-GigabitEthernet1/0/2] quit
    

  4. Configure the DHCP relay function and DHCP server.
    1. Configure the DHCP relay function on SwitchA.

      # Configure the DHCP relay function on an interface.

      [SwitchA] dhcp enable  //Enable DHCP globally. By default, DHCP is disabled.
      [SwitchA] interface Vlanif 100
      [SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0  //Assign an IP address to VLANIF 100.
      [SwitchA-Vlanif100] dhcp select relay  //Enable the DHCP relay function on VLANIF 100.
      [SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2  //Configure the DHCP server address on the DHCP relay agent.
      [SwitchA-Vlanif100] quit
      

      # Create VLANIF 200.

      [SwitchA] vlan batch 200
      [SwitchA] interface Vlanif 200
      [SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0  //Configure an IP address for VLANIF 200 for communication with SwitchB.
      [SwitchA-Vlanif200] quit
      

      # Add the uplink interface to VLAN 200.

      [SwitchA] interface gigabitethernet 1/0/3
      [SwitchA-GigabitEthernet1/0/3] port link-type access
      [SwitchA-GigabitEthernet1/0/3] port default vlan 200
      [SwitchA-GigabitEthernet1/0/3] quit
      

      # Configure a default static route.

      [SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2  //The next hop address of the route corresponds to the IP address of VLANIF 200 on SwitchB.
      

    2. Configure SwitchB as the DHCP server to allocate IP addresses to IP phones.

      # Configure an address pool.

      <HUAWEI> system-view
      [HUAWEI] sysname SwitchB
      [SwitchB] ip pool ip-phone  //Create an address pool to allocate IP addresses to IP phones.
      [SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1  //Configure the gateway address on the DHCP server.
      [SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0  //Configure allocatable IP addresses in the IP address pool.
      [SwitchB-ip-pool-ip-phone] quit
      

      # Configure the DHCP server function.

      [SwitchB] dhcp enable  //Enable DHCP globally. By default, DHCP is disabled.
      [SwitchB] vlan batch 200
      [SwitchB] interface Vlanif 200  //Create VLANIF 200.
      [SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0  //Assign an IP address to VLANIF 200.
      [SwitchB-Vlanif200] dhcp select global  //Configure SwitchB to allocate IP addresses from the global IP address pool to the IP phone.
      [SwitchB-Vlanif200] quit
      

      # Add the downlink interface to VLAN 200.

      [SwitchB] interface gigabitethernet 1/0/3
      [SwitchB-GigabitEthernet1/0/3] port link-type access
      [SwitchB-GigabitEthernet1/0/3] port default vlan 200
      [SwitchB-GigabitEthernet1/0/3] quit

      # Configure a return route.

      [SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1

  5. Configure an AAA domain and configure 802.1X authentication and MAC address authentication for IP phones.
    1. Configure an AAA domain.

      # Create and configure a RADIUS server template.

      [SwitchA] radius-server template ipphone  //Create a RADIUS server template named ipphone.
      [SwitchA-radius-ipphone] radius-server authentication 192.168.100.182 1812  //Configure the IP address and port number of the RADIUS authentication server.
      [SwitchA-radius-ipphone] radius-server accounting 192.168.100.182 1813  //Configure the IP address and port number of the RADIUS accounting server.
      [SwitchA-radius-ipphone] radius-server shared-key cipher Huawei2012  //Configure the shared key of the RADIUS server.
      [SwitchA-radius-ipphone] quit
      

      # Configure an authentication scheme.

      [SwitchA] aaa
      [SwitchA-aaa] authentication-scheme radius  //Set the authentication mode to RADIUS.
      [SwitchA-aaa-authen-radius] authentication-mode radius  //Set the authentication mode to RADIUS.
      [SwitchA-aaa-authen-radius] quit
      

      # Create an AAA domain and bind the RADIUS server template and authentication scheme to the AAA domain.

      [SwitchA-aaa] domain default  //Configure a domain named default.
      [SwitchA-aaa-domain-default] authentication-scheme radius  //Bind the authentication scheme radius to the domain.
      [SwitchA-aaa-domain-default] radius-server ipphone  //Bind the RADIUS server template ipphone to the domain.
      [SwitchA-aaa-domain-default] quit
      [SwitchA-aaa] quit
      

    2. Configure 802.1X authentication and MAC address authentication for IP phones.

      • V200R007C00 and earlier versions, and V200R008C00

        # Set the NAC mode to traditional.

        [SwitchA] undo authentication unified-mode  //By default, the switch uses the unified mode. When the traditional and unified modes are switched, the administrator must save the configuration and restart the switch to make the configuration take effect.

        # Enable 802.1X authentication and MAC address authentication on interfaces.

        [SwitchA] interface gigabitethernet 1/0/1
        [SwitchA-GigabitEthernet1/0/1] dot1x mac-bypass  //Enable MAC address bypass authentication. MAC address authentication is used when 802.1X authentication fails.
        [SwitchA-GigabitEthernet1/0/1] quit
        [SwitchA] interface gigabitethernet 1/0/2
        [SwitchA-GigabitEthernet1/0/2] dot1x mac-bypass
        [SwitchA-GigabitEthernet1/0/2] quit
        
      • V200R009C00 and later versions

        # Set the NAC mode to unified.

        [SwitchA] authentication unified-mode  //By default, the switch uses the unified mode. When the traditional and unified modes are switched, the administrator must save the configuration and restart the switch to make the configuration take effect.

        # Configure access profiles.

        [SwitchA] dot1x-access-profile name ipphone  //Create an 802.1X access profile named ipphone.
        [SwitchA-dot1x-access-profile-ipphone] quit
        [SwitchA] mac-access-profile name ipphone  //Create a MAC access profile named ipphone.
        [SwitchA-mac-access-profile-ipphone] quit

        # Configure an authentication profile.

        [SwitchA] authentication-profile name ipphone  //Configure an authentication profile.
        [SwitchA-authen-profile-ipphone] dot1x-access-profile ipphone  //Bind the 802.1X access profile ipphone to the authentication profile.
        [SwitchA-authen-profile-ipphone] mac-access-profile ipphone  //Bind the MAC access profile ipphone to the authentication profile.
        [SwitchA-authen-profile-ipphone] authentication dot1x-mac-bypass  //Enable MAC address bypass authentication.
        [SwitchA-authen-profile-ipphone] quit

        # Apply the authentication profile to interfaces.

        [SwitchA] interface gigabitethernet 1/0/1
        [SwitchA-GigabitEthernet1/0/1] authentication-profile ipphone  //Bind the authentication profile.
        [SwitchA-GigabitEthernet1/0/1] quit
        [SwitchA] interface gigabitethernet 1/0/2
        [SwitchA-GigabitEthernet1/0/2] authentication-profile ipphone
        [SwitchA-GigabitEthernet1/0/2] quit
        

    3. Configure the Agile Controller. The display of the Agile Controller varies by version. V100R003C60 is used as an example.

      1. Log in to the Agile Controller.
      2. Add a common account.
        1. Choose Resource > User > User Management.
        2. Click Add in the operation area on the right, and create an 802.1X account. Click Common account and enter the user name and password. The configured user name and password must be the same as those configured on the IP phone, and the account is configured to be the same as the user name.

        3. Click OK to complete the configuration. Be aware that the account belongs to the user group named ROOT.
      3. Add SwitchA to the Agile Controller.
        1. Choose Resource > Device > Device Management.

        2. Click Add in the operation area on the right. On the Add Device page that is displayed, set Name to SwitchA and IP address to 192.168.100.200 (IP address used by SwitchA to communicate with the Agile Controller). Select Enable RADIUS, and set Authentication/Accounting key and Authorization key to Huawei2012 (shared key configured on SwitchA). The real-time accounting interval is not configured and accounting is performed based on the time.

        3. Click OK to complete the configuration.
      4. Add MAC address information of an IP phone to the Agile Controller. If 802.1X authentication fails, MAC address authentication is performed.
        1. Choose Resource > Terminal > Terminal List.
        2. Click Add in the operation area on the right. On the Add Device Group page that is displayed, add an IP phone group ipphone.

        3. Click OK to complete the configuration.
        4. Click the device group in the navigation tree and select the created IP phone group ipphone.
        5. Click Add in the device list, add an IP phone, and enter the MAC address of the IP phone.

        6. Click OK to complete the configuration.
        7. Click Add and add the MAC address of another IP phone.
        8. Click OK to complete the configuration.
      5. Add an authentication rule.
        1. Choose Policy > Permission Control > Authentication & Authorization > Authentication Rule
        2. Click Add in the operation area on the right and add an authentication rule for the IP phone using 802.1X authentication. Set Name to ipphone_8021x, click Access, set User group to ROOT, and select allowed authentication protocols under Authentication Rule.



        3. Click OK to complete the configuration.
        4. Click Add again and add an authentication rule for the IP phone using MAC address authentication. Set Name to ipphone_mac, Service type to MAC bypass authentication, and Terminal group to ipphone.

        5. Click OK to complete the configuration.
      6. Add an authorization result.
        1. Choose Policy > Permission Control > Authentication & Authorization > Authorization Result.
        2. Click Add in the operation area on the right and add an authorization result after 802.1X authentication. Set Name to 8021X_voice vlan 100, Service type to Access, and VLAN under Authorization Parameter to 100.

        3. Click Add under customized authorization parameter to add authorization information. Set Vendor/Standard attribute to Huawei, Attribute ID/name to HW-Voice-Vlan(33), and Attribute type to Integer. If Attribute value is set to 1, VLAN 100 is a voice VLAN.

        4. Click OK to complete the configuration, and the Add Authorization Result page is displayed.
        5. Add authorization information on the page.

        6. Click OK to complete the configuration.
        7. Click Add again and add an authorization result after MAC address authentication. Set Name to mac_voice vlan 100, Service type to MAC bypass authentication, and VLAN under Authorization Parameter to 100.

        8. Click Add under customized authorization parameter to add authorization information. Set Vendor/Standard attribute to Huawei, Attribute ID/name to HW-Voice-Vlan(33), and Attribute type to Integer. If Attribute value is set to 1, VLAN 100 is a voice VLAN.

        9. Click OK to complete the configuration, and the Add Authorization Result page is displayed.
        10. Add authorization information on the page.

        11. Click OK to complete the configuration.
      7. Add an authorization rule.

        After the check in the authentication phase is passed, the authorization phase starts. During this phase, the Agile Controller assigns rights to users based on authorization rules.

        1. Choose Policy > Permission Control > Authentication & Authorization > Authorization Rule.
        2. Click Add in the operation area on the right and add an authorization rule for the IP phone using 802.1X authentication. Set Name to ipphone_8021X, click Access, set User group to ROOT, and set Authorization result to 8021X_voice vlan 100.



        3. Click OK to complete the configuration.
        4. Click Add again and add an authorization rule for the IP phone using MAC address authentication. Set Name to ipphone_mac, click MAC bypass authentication, set Terminal Group to ipphone, and set Authorization result to mac_voice vlan 100.

        5. Click OK to complete the configuration.

  6. Verify the configuration.

    • You can see that the IP phone can correctly obtain the voice VLAN ID and IP address through the menu of the IP phone.
    • The display access-user command output on SwitchA displays connection information about IP phones.
      [SwitchA] display access-user
       ------------------------------------------------------------------------------ 
       UserID Username     IP address       MAC            Status          
       ------------------------------------------------------------------------------ 
       564   001bd4c71fa9  10.20.20.198     001b-d4c7-1fa9 Success        
       565   0021a08f2fa8  10.20.20.199     0021-a08f-2fa8 Success         
       ------------------------------------------------------------------------------ 
       Total: 2, printed: 2  

Configuration Files

  • SwitchA configuration file (V200R007C00 and V200R008C00)
    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    undo authentication unified-mode
    #
    lldp enable
    #
    dhcp enable
    #
    radius-server template ipphone
     radius-server shared-key cipher %^%#e33GK([auIJQ+54M/i7>u5!/M8*A%0]~a@FQ,41K%^%#
     radius-server authentication 192.168.100.182 1812 weight 80
     radius-server accounting 192.168.100.182 1813 weight 80
    #
    aaa
     authentication-scheme radius
      authentication-mode radius
     service-scheme ipphone  
     domain default
      authentication-scheme radius
      radius-server ipphone
    #
    interface Vlanif100
     ip address 10.20.20.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.10.20.2
    #
    interface Vlanif200
     ip address 10.10.20.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1       
     port link-type hybrid
     port hybrid tagged vlan 100                                                                                                        
     trust 8021p inner                                                                                                                  
     lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60
     dot1x mac-bypass
    #
    interface GigabitEthernet1/0/2       
     port link-type hybrid
     port hybrid tagged vlan 100
     trust 8021p inner                                                                                                                  
     lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60
     dot1x mac-bypass
    #
    interface GigabitEthernet1/0/3       
     port link-type access
     port default vlan 200
    #
    ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
    #
    return
    
  • SwitchA configuration file (V200R009C00 and later versions)
    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    authentication-profile name ipphone                                                                                                 
     dot1x-access-profile ipphone                                                                                                       
     mac-access-profile ipphone                                                                                                         
     authentication dot1x-mac-bypass  
    #
    lldp enable
    #
    dhcp enable
    #
    radius-server template ipphone
     radius-server shared-key cipher %^%#e33GK([auIJQ+54M/i7>u5!/M8*A%0]~a@FQ,41K%^%#
     radius-server authentication 192.168.100.182 1812 weight 80
     radius-server accounting 192.168.100.182 1813 weight 80
    #
    aaa
     authentication-scheme radius
      authentication-mode radius
     service-scheme ipphone
     domain default
      authentication-scheme radius
      service-scheme ipphone 
      radius-server ipphone
    #
    interface Vlanif100
     ip address 10.20.20.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.10.20.2
    #
    interface Vlanif200
     ip address 10.10.20.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1       
     port link-type hybrid
     port hybrid tagged vlan 100
     authentication-profile ipphone
     trust 8021p inner                                                                                                                  
     lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60
    #
    interface GigabitEthernet1/0/2       
     port link-type hybrid
     port hybrid tagged vlan 100
     authentication-profile ipphone
     trust 8021p inner                                                                                                                  
     lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60
    #
    interface GigabitEthernet1/0/3       
     port link-type access
     port default vlan 200
    #
    ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
    #                                                                                                                                   
    dot1x-access-profile name dot1x_access_profile                                                                                      
    dot1x-access-profile name ipphone                                                                                                   
    #                                                                                                                                   
    mac-access-profile name mac_access_profile                                                                                          
    mac-access-profile name ipphone  
    #
    return
    
  • SwitchB configuration file
    #
    sysname SwitchB
    #
    vlan batch 200
    #
    dhcp enable
    #
    ip pool ip-phone
     gateway-list 10.20.20.1 
     network 10.20.20.0 mask 255.255.255.0 
    #
    interface Vlanif200
     ip address 10.10.20.2 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet1/0/3
     port link-type access
     port default vlan 200
    #
    ip route-static 10.20.20.0 255.255.255.0 10.10.20.1
    #
    return
    
Translation
Download
Updated: 2019-05-15

Document ID: EDOC1000114005

Views: 177936

Downloads: 8153

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next