No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Examples for NE and ME60 Routers in Typical Enterprise Scenarios 2.0

This document provides NE series routers typical configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a V.24 Interface to Transparently Transmit Services

Example for Configuring a V.24 Interface to Transparently Transmit Services

CES services, such as a power station's product dispatching and information management data, between a remote terminal unit (RTU) and a control center can be transparently transmitted over TDM links on Metro Ethernet (ME) network.

Applicable Products and Versions

This configuration example applies to NE05E&08E series products running V300R003C10 or later.

Networking Requirements

In Figure 1-2, when uplink data services of a remote terminal unit (RTU), such as a smart meter, aggregate on a serial interface of PE1, PE1 encapsulates the data services into PSN packets on the serial interface and transmits them over the PSN. After the packets arrive at PE2, PE2 decapsulates the PSN packets, reconstitutes the original data services, and sends them to the control center. The control center device is old and has only RX, TX, and GND pins, which do not output control signals.

Figure 1-2  Configuring TDMoPSN
NOTE:

In this example, interface 1, interface 2, interface 3, interface 4, interface 5, and interface 6 refer to Serial 0/4/0, GE 0/2/4, GE 0/1/0, GE 0/2/1, GE0/2/0, and Serial 0/4/0, respectively.



Device

Interface

IP Address

PE1

GE0/2/4

Loopback0

10.1.1.1/24

192.168.2.2/32

P

GE0/1/0

GE0/2/1

Loopback0

10.1.1.2/24

10.2.1.1/24

192.168.4.4/32

PE2

GE0/2/0

Loopback0

10.2.1.2/24

192.168.3.3/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable an IGP on the backbone network for devices on the backbone network to communicate.

  2. Configure basic MPLS functions on the backbone network and MPLS L2VPN on the PEs. Then, establish a remote MPLS LDP peer relationship between PEs at the two ends of the PW to be created.

  3. Configure V.24 interfaces' attributes.

  4. Configure the interface used by PE2 to connect to the control center to ensure that the interface is Up even when the interface detects an abnormal signal.

  5. Set the link layer protocol of the serial interface to TDM on each PE.

  6. Configure a PW.

  7. Create MPLS L2VCs on PEs.

Data Preparation

To complete the configuration, you need the following data.

  • L2VC IDs (must be the same) at both ends of the PW
  • MPLS LSR IDs of the PEs and P
  • IP addresses of the remote peers of PEs
  • V.24 interface attributes

Procedure

  1. Enable an IGP on the backbone network for devices on the backbone network to communicate. For detailed configurations, see the configuration files in this example.
  2. Configure basic MPLS functions on the backbone network and MPLS L2VPN on the PEs. Then, establish a remote MPLS LDP peer relationship between PEs at the two ends of the PW to be created. For detailed configurations, see the configuration files in this example.

    NOTE:

    The remote MPLS LDP peer relationship needs to be established only when a dynamic PW is established.

  3. Configure V.24 interfaces' attributes with a rate of 9600 bit/s and in asynchronous mode.

    1. Configure PE1.

      # Configure interface attributes for PE1's serial 0/4/0.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE1
      [*HUAWEI] commit
      [~PE1] interface serial 0/4/0
      [~PE1-Serial0/4/0] portmode v-24
      [*PE1-Serial0/4/0] physical-mode async
      [*PE1-Serial0/4/0] baudrate 4
      [*PE1-Serial0/4/0] workmode dce
      [*PE1-Serial0/4/0] clocksource slave
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configure PE2.

      # Configure interface attributes for PE2's serial 0/4/0.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE2
      [*HUAWEI] commit
      [~PE2] interface serial 0/4/0
      [~PE2-Serial0/4/0] portmode v-24
      [*PE1-Serial0/4/0] physical-mode async
      [*PE2-Serial0/4/0] baudrate 4
      [*PE2-Serial0/4/0] workmode dce
      [*PE2-Serial0/4/0] clocksource slave
      [*PE2-Serial0/4/0] quit
      [*PE2] commit
      

  4. Disassociate control signal detection from the status of PE2's serial interface connected to the control center to ensure that the interface remains Up in case of abnormal signals.

    [~PE2] interface serial 0/4/0
    [~PE2-Serial0/4/0] nodetect dtr
    [*PE2-Serial0/4/0] quit
    [*PE2] commit
    

  5. Set the link layer protocol of the serial interface to TDM on each PE.

    1. Configure PE1.

      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] link-protocol tdm
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configure PE2.

      [~PE2] interface serial0/4/0
      [~PE2-Serial0/4/0] link-protocol tdm
      [*PE2-Serial0/4/0] quit
      [*PE2] commit
      

  6. Configure a PW.

    1. Configure PE1.

      [~PE1] pw-template 1to3
      [*PE1-pw-template-1to3] peer-address 192.168.3.3
      [*PE1-pw-template-1to3] jitter-buffer depth 6
      [*PE1-pw-template-1to3] tdm-encapsulation-number 24
      [*PE1-pw-template-1to3] quit
      [*PE1] commit
      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] mpls l2vc pw-template 1to3 100 control-word 
      [*PE1-Serial0/4/0] undo shutdown
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configure PE2.

      [~PE2] pw-template 3to1
      [*PE2-pw-template-3to1] peer-address 192.168.2.2
      [*PE2-pw-template-3to1] jitter-buffer depth 6
      [*PE2-pw-template-3to1] tdm-encapsulation-number 24
      [*PE2-pw-template-3to1] quit
      [*PE2] commit
      [~PE2] interface serial0/4/0
      [~PE2-Serial0/4/0] mpls l2vc pw-template 3to1 100 control-word 
      [*PE2-Serial0/4/0] undo shutdown
      [*PE2-Serial0/4/0] quit
      [*PE2] commit
      

  7. Verify the configuration.

    Run the display mpls l2vc command on PEs to check the PW's status. The following example uses the command output on PE1. The command output shows that the PW is Up.

    # PE1's command output

    <PE1> display mpls l2vc interface serial0/4/0
     *client interface       : Serial0/4/0 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

Configuration Files

  • PE1 configuration file

    #
     sysname PE1
    #
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 6
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    interface serial0/4/0
     link-protocol tdm
     portmode v-24
     physical-mode async
     baudrate 4
     clocksource slave
     mpls l2vc pw-template 1to3 100 control-word control-word
     undo shutdown
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.2.2 255.255.255.255
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • PE2 configuration file

    #
     sysname PE2
    #
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 6
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    interface serial0/4/0
     link-protocol tdm
     portmode v-24
     physical-mode async
     baudrate 4
     clocksource slave
     nodetect dtr
     mpls l2vc pw-template 3to1 100 control-word
     undo shutdown
    #
    interface GigabitEthernet0/2/0 
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • P configuration file

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/1
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    
Updated: 2019-05-16

Document ID: EDOC1000120969

Views: 26294

Downloads: 879

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next