No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Examples for NE and ME60 Routers in Typical Enterprise Scenarios 2.0

This document provides NE series routers typical configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring GRE Tunnels in an Urban Rail DCS

Example for Configuring GRE Tunnels in an Urban Rail DCS

This section provides an example of how to configure GRE tunnels in an urban rail Data Communication System (DCS). This process performs security control on trains by implementing communication between the server and LTE core network and terminal access units (TAUs) on trains.

Applicable Products and Versions

This configuration applies to NE40E series products running V600R008C10SPC300 or later.

Networking Requirements

The urban rail DCS in this example runs on an LTE vehicle-ground wireless communication network and ground wired backbone network. The LTE network carries a variety of services, such as communications-based train control (CBTC), a passenger information system (PIS), closed-circuit television (CCTV), and a Train Control and Monitoring System (TCMS). As shown in Figure 1-3, four TAUs are deployed on trains:
  • TAU-CBTC-A and TAU-CBTC-B are terminals of CBTC services and work in master/backup mode.
  • TAU-PIS/CCTV/TMCS1 and TAU-PIS/CCTV/TMCS2 are used to carry CCTV, PIS, and TCMS services. They also work in master/backup mode.
The CBTC, CCTV, PIS, and TCMS servers and the LTE core network communicate with the TAUs deployed on trains through Device A (a Huawei device). To encapsulate communication packets, you can deploy GRE tunnels to the TAUs on Device A. The GRE tunnel functions are as follows:
  • GRE (CBTC) Primary and GRE (CBTC) Backup: primary and backup GRE tunnels that are used to carry CBTC services.

  • GRE (PIS) Primary and GRE (PIS) Backup: primary and backup GRE tunnels that are used to carry PIS services. Because PIS services are multicast services, multicast configurations must be performed on the GRE tunnels.

  • GRE (CCTV/TCMS) Primary and GRE (CCTV/TCMS) Backup: primary and backup GRE tunnels that are used to carry CCTV and TCMS services.

Figure 1-3  Configuring GRE tunnels in the urban rail DCS

Table 1-1  Data preparation

Device Name

Parameter

Data

Device A

IP address of Loopback 1 1.1.1.1/32
IP address of Tunnel 1/0/0 10.1.1.1/24
IP address of Loopback 2 2.2.2.2/32
IP address of Tunnel 1/0/1 10.2.2.2/24
IP address of Loopback 3 3.3.3.3/32
IP address of Tunnel 1/0/2 10.3.3.3/24
IP address of Loopback 4 4.4.4.4/32
IP address of Tunnel 1/0/3 10.4.4.4/24
IP address of Loopback 5 5.5.5.5/32
IP address of Tunnel 1/0/4 10.5.5.5/24
IP address of Loopback 6 6.6.6.6/32
IP address of Tunnel 1/0/5 10.6.6.6/24
Interface address (suppose Interface 1 is GE 0/1/0) 10.8.10.1/24
TAU-CBTC-A Communication IP address 10.18.10.20/24
IP address of an attached terminal 10.18.1.1/32
TAU-CBTC-B Communication IP address 10.18.20.20/24
IP address of an attached terminal 10.18.2.2/32
TAU-PIS/CCTV/TCMS-1 Communication IP address 10.18.11.20/24
Multicast IP address 224.1.1.1
IP address of an attached terminal 10.20.1.1/32
TAU-PIS/CCTV/TCMS-2 Communication IP address 10.18.21.20/24
Multicast IP address 224.1.1.1
IP address of an attached terminal 10.20.2.2/32

Configuration Roadmap

  1. On Device A, configure the primary and backup GRE tunnels to carry CBTC services. Then, configure static routes to import traffic destined for the terminals connected to TAU-CBTC-A and TAU-CBTC-B to the GRE tunnels.

  2. On Device A, configure the primary and backup GRE tunnels to carry PIS services and deploy multicast services on the GRE tunnel interfaces.

  3. On Device A, configure the primary and backup GRE tunnels to carry CCTV and TCMS services. Then, configure static routes to import traffic destined for the terminals connected to TAU-PIS/CCTV/TCMS1 and TAU-PIS/CCTV/TCMS2 to the GRE tunnels.

NOTE:

Before configuring a GRE tunnel, ensure that routes between the source interface and destination interface of the tunnel are reachable.

Procedure

  1. On Device A, configure the primary and backup GRE tunnels to carry CBTC services. Then, configure static routes to import traffic destined for the terminals connected to TAU-CBTC-A and TAU-CBTC-B to the GRE tunnels.

    # Configure Device A.

    #
    sysname Device A
    #
    interface GigabitEthernet 0/1/0
     undo shutdown
     ip address 10.8.10.1 255.255.255.0
    #
    //Configure an IP address for the loopback interface and bind GRE to the loopback interface.
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     target-board 1
     binding tunnel gre
    #
    interface LoopBack2
     ip address 2.2.2.2 255.255.255.255
     target-board 1
     binding tunnel gre
    #
    //Configure the primary GRE tunnel to carry the CBTC service.
    interface Tunnel1/0/0
     description to_TAU-CBTC-A
     ip address 10.1.1.1 255.255.255.0
     tunnel-protocol gre
     source LoopBack1
     destination 10.18.10.20
    #
    //Configure the backup GRE tunnel to carry the CBTC service.
    interface Tunnel1/0/1
     description to_TAU-CBTC-B
     ip address 10.2.2.2 255.255.255.0
     tunnel-protocol gre
     source LoopBack2
     destination 10.18.20.20
    #
    //Configure static routes to import traffic destined for the terminals connected to TAU-CBTC-A and TAU-CBTC-B to the GRE tunnels.
    ip route-static 10.18.1.1 255.255.255.255 Tunnel1/0/0 description TO_TAU_CBTC-A
    ip route-static 10.18.2.2 255.255.255.255 Tunnel1/0/1 description TO_TAU_CBTC-B
    #
    return
    

  2. On Device A, configure the primary and backup GRE tunnels to carry PIS services and deploy multicast services on the GRE tunnel interfaces.

    # Configure Device A.

    #
    interface LoopBack3
     ip address 3.3.3.3 255.255.255.255
     target-board 1
     binding tunnel gre
    #
    interface LoopBack4
     ip address 4.4.4.4 255.255.255.255
     target-board 1
     binding tunnel gre
    #
    //Configure the primary GRE tunnel to carry the PIS service and enable PIM-SM on the tunnel interface.
    interface Tunnel1/0/2
     description to_TAU-PIS-A
     ip address 10.3.3.3 255.255.255.0
     tunnel-protocol gre
     source LoopBack3
     destination 10.18.11.20
     pim sm
     igmp version 3
     igmp static-group 224.1.1.1
    #
    //Configure the backup GRE tunnel to carry the PIS service and enable PIM-SM on the tunnel interface.
    interface Tunnel1/0/3
     description to_TAU-PIS-B
     ip address 10.4.4.4 255.255.255.0
     tunnel-protocol gre
     source LoopBack4
     destination 10.18.21.20
     pim sm
     igmp version 3
     igmp static-group 224.1.1.1
    #
    return
    

  3. On Device A, configure the primary and backup GRE tunnels to carry CCTV and TCMS services. Then, configure static routes to import traffic destined for the terminals connected to TAU-PIS/CCTV/TCMS1 and TAU-PIS/CCTV/TCMS2 to the GRE tunnels.

    # Configure Device A.

    #
    interface LoopBack5
     ip address 5.5.5.5 255.255.255.255
     target-board 1
     binding tunnel gre
    #
    interface LoopBack6
     ip address 6.6.6.6 255.255.255.255
     target-board 1
     binding tunnel gre
    #
    //Configure the primary GRE tunnel to carry the CCTV and TCMS services.
    interface Tunnel1/0/4
     description to_CCTV/TCMS-1
     ip address 10.5.5.5 255.255.255.0
     tunnel-protocol gre
     source LoopBack5
     destination 10.18.11.20
    #
    //Configure the backup GRE tunnel to carry the CCTV and TCMS services.
    interface Tunnel1/0/5
     description to_TAU-CCTV/TCMS-2
     ip address 10.6.6.6 255.255.255.0
     tunnel-protocol gre
     source LoopBack6
     destination 10.18.21.20
    #
    //Configure static routes to import traffic destined for the terminals connected to TAU-PIS/CCTV/TCMS1 and TAU-PIS/CCTV/TCMS2 to the GRE tunnels.
    ip route-static 10.20.1.1 255.255.255.255 Tunnel1/0/4 description TO_TAU_CCTV/TCMS-1
    ip route-static 10.20.2.2 255.255.255.255 Tunnel1/0/5 description TO_TAU_CCTV/TCMS-2
    #
    return
    

  4. Verify the configuration.

    Run the display ip routing-table command on Device A. The command output shows the static routes from the tunnel interfaces to the user-side network segments at the peer end.

    Run the display pim routing-table command on Device A. The command output shows information about the PIM routing table.

Updated: 2019-05-16

Document ID: EDOC1000120969

Views: 26293

Downloads: 879

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next