No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Examples for NE and ME60 Routers in Typical Enterprise Scenarios 2.0

This document provides NE series routers typical configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring RS-232 Interfaces to Transparently Services in P2MP Mode

Example for Configuring RS-232 Interfaces to Transparently Services in P2MP Mode

To implement P2MP, a SCADA group can associate an RS-232 serial interface with multiple virtual-serial interfaces. The RS-232 serial interface connects to a local control center, and each virtual-serial interface connects to an RTU through a PW. In a SCADA group, the RS-232 serial interface's data can be broadcast to multiple virtual-serial interfaces, and the virtual-serial interfaces' data can be filtered and converged to the RS-232 serial interface.

Applicable Products and Versions

This configuration applies to NE05E&08E series products running V300R003C10 or later.

Networking Requirements

In Figure 1-1, a PW is established between each RTU and the control center to transparently transmit services. PEs do not parse service data. When the control center broadcasts its information to RTUs, only one RTU is allowed to reply the control center at one time over its PW. Other PWs stay idle.

Figure 1-1  Configuring TDMoPSN
NOTE:

In this example, interface 1, interface 2, interface 3, interface 4, interface 5, interface 6, interface 7, interface 8, and interface 9 refer to Serial 0/2/1, Serial 0/2/2, Serial 0/2/3, GE 0/1/4, GE 0/1/5, GE 0/1/6, GE 0/1/7, Serial 0/2/4, and Serial0/2/5, respectively.



Device

Interface

IP Address

PE1

GE0/1/4

Loopback0

10.1.1.1/24

192.168.1.1/32

P

GE0/1/5

GE0/1/6

Loopback0

10.1.1.2/24

10.2.1.1/24

192.168.4.4/32

PE2

GE0/1/7

Loopback0

10.2.1.2/24

192.168.2.2/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable an IGP on the backbone network for devices on the backbone network to communicate.

  2. Configure basic MPLS functions on the backbone network and MPLS L2VPN on the PEs. Then, establish a remote MPLS LDP peer relationship between PEs at the two ends of the PW to be created.

  3. Configure RS-232 interfaces' attributes.

  4. Configure TDM as the RS-232 serial interfaces' encapsulation protocol.

  5. Create a SCADA group on PE2 and add the RS-232 serial interfaces and virtual-serial interfaces to the group.

  6. Configure PWs.

  7. Create MPLS L2VCs on PEs.

Data Preparation

To complete the configuration, you need the following data.

  • L2VC IDs (must be the same) at both ends of each PW
  • MPLS LSR IDs of the PEs and P
  • IP addresses of the remote peers of PEs
  • RS-232 interface attributes

Procedure

  1. Enable an IGP on the backbone network for devices on the backbone network to communicate. For detailed configurations, see the configuration files in this example.
  2. Configure basic MPLS functions on the backbone network and MPLS L2VPN on the PEs. Then, establish a remote MPLS LDP peer relationship between PEs at the two ends of the PW to be created. For detailed configurations, see the configuration files in this example.

    NOTE:

    The remote MPLS LDP peer relationship needs to be established only when a dynamic PW is established.

  3. Configure RS-232 interfaces' attributes with a rate of 19200 bit/s.

    1. Configure PE1.

      # Configure interface attributes for PE1's serial 0/2/1, serial 0/2/2, and serial 0/2/3.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE1
      [*HUAWEI] commit
      [~PE1] interface serial 0/2/1
      [~PE1-Serial0/2/1] portmode rs-232
      [*PE1-Serial0/2/1] baudrate 5
      [*PE1-Serial0/2/1] databits 7
      [*PE1-Serial0/2/1] stopbits 2
      [*PE1-Serial0/2/1] parity odd
      [*PE1-Serial0/2/1] mux-protocol 2
      [*PE1-Serial0/2/1] x-50 set phasemode interval
      [*PE1-Serial0/2/1] quit
      [*PE1] commit
      [~PE1] interface serial 0/2/2
      [~PE1-Serial0/2/2] portmode rs-232
      [*PE1-Serial0/2/2] baudrate 5
      [*PE1-Serial0/2/2] databits 7
      [*PE1-Serial0/2/2] stopbits 2
      [*PE1-Serial0/2/2] parity odd
      [*PE1-Serial0/2/2] mux-protocol 2
      [*PE1-Serial0/2/2] x-50 set phasemode interval
      [*PE1-Serial0/2/2] quit
      [*PE1] commit
      [~PE1] interface serial 0/2/3
      [~PE1-Serial0/2/3] portmode rs-232
      [*PE1-Serial0/2/3] baudrate 5
      [*PE1-Serial0/2/3] databits 7
      [*PE1-Serial0/2/3] stopbits 2
      [*PE1-Serial0/2/3] parity odd
      [*PE1-Serial0/2/3] mux-protocol 2
      [*PE1-Serial0/2/3] x-50 set phasemode interval
      [*PE1-Serial0/2/3] quit
      [*PE1] commit
      
    2. Configure PE2.

      # Configure interface attributes for PE2's serial 0/2/4 and serial 0/2/5.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE2
      [*HUAWEI] commit
      [~PE2] interface serial 0/2/4
      [~PE2-Serial0/2/4] portmode rs-232
      [*PE2-Serial0/2/4] baudrate 5
      [*PE2-Serial0/2/4] databits 7
      [*PE2-Serial0/2/4] stopbits 2
      [*PE2-Serial0/2/4] parity odd
      [*PE2-Serial0/2/4] mux-protocol 2
      [*PE2-Serial0/2/4] x-50 set phasemode interval
      [*PE2-Serial0/2/4] quit
      [*PE2] commit
      [~PE2] interface serial 0/2/5
      [~PE2-Serial0/2/5] portmode rs-232
      [*PE2-Serial0/2/5] baudrate 7
      [*PE2-Serial0/2/5] databits 8
      [*PE2-Serial0/2/5] stopbits 1
      [*PE2-Serial0/2/5] parity odd
      [*PE2-Serial0/2/5] mux-protocol 0
      [*PE2-Serial0/2/5] x-50 set phasemode interval
      [*PE2-Serial0/2/5] quit
      [*PE2] commit
      

  4. Configure TDM as the RS-232 serial interfaces' encapsulation protocol.

    1. Configure PE1.

      # Configure TDM as the encapsulation protocol of PE1's serial 0/2/1, serial 0/2/2, and serial 0/2/3.

      [~PE1] interface serial0/2/1
      [~PE1-Serial0/2/1] link-protocol tdm
      [*PE1-Serial0/2/1] quit
      [*PE1] commit
      [~PE1] interface serial0/2/2
      [~PE1-Serial0/2/2] link-protocol tdm
      [*PE1-Serial0/2/2] quit
      [*PE1] commit
      [~PE1] interface serial0/2/3
      [~PE1-Serial0/2/3] link-protocol tdm
      [*PE1-Serial0/2/3] quit
      [*PE1] commit
      
    2. Configure PE2.

      # Create virtual-serial 0/2/1, virtual-serial 0/2/2, and virtual-serial 0/2/3 on PE2 and configure TDM as the encapsulation protocol of the three virtual serial interfaces.

      [~PE2] interface virtual-serial0/2/1
      [~PE2-Virtual-Serial0/2/1] link-protocol tdm
      [*PE2-Virtual-Serial0/2/1] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/2
      [~PE2-Virtual-Serial0/2/2] link-protocol tdm
      [*PE2-Virtual-Serial0/2/2] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/3
      [~PE2-Virtual-Serial0/2/3] link-protocol tdm
      [*PE2-Virtual-Serial0/2/3] quit
      [*PE2] commit
      

  5. Create a SCADA group on PE2 and add the RS-232 serial interfaces and virtual-serial interfaces to the group.

    [~PE2] scada-group 1
    [*PE2-scada-group-1] commit
    [~PE2-scada-group-1] quit
    [~PE2] interface serial0/2/4
    [~PE2-Serial0/2/4] scada-group 1 work
    [*PE2-Serial0/2/4] commit
    [~PE2-Serial0/2/4] quit
    [~PE2] interface serial0/2/5
    [~PE2-Serial0/2/5] scada-group 1 protect
    [*PE2-Serial0/2/5] commit
    [~PE2-Serial0/2/5] quit
    [~PE2] interface virtual-serial0/2/1
    [~PE2-Virtual-Serial0/2/1] bind scada-group 1
    [*PE2-Virtual-Serial0/2/1] commit
    [~PE2-Virtual-Serial0/2/1] quit
    [~PE2] interface virtual-serial0/2/2
    [~PE2-Virtual-Serial0/2/2] bind scada-group 1
    [*PE2-Virtual-Serial0/2/2] commit
    [~PE2-Virtual-Serial0/2/2] quit
    [~PE2] interface virtual-serial0/2/3
    [~PE2-Virtual-Serial0/2/3] bind scada-group 1
    [*PE2-Virtual-Serial0/2/3] commit
    [~PE2-Virtual-Serial0/2/3] quit
    

  6. Configure PWs.

    1. Configure PE1.

      [~PE1] pw-template pe1tope2
      [*PE1-pw-template-pe1tope2] peer-address 192.168.2.2
      [*PE1-pw-template-pe1tope2] jitter-buffer depth 6
      [*PE1-pw-template-pe1tope2] tdm-encapsulation-number 24
      [*PE1-pw-template-pe1tope2] commit
      [~PE1-pw-template-pe1tope2] quit
      [~PE1] interface serial0/2/1
      [~PE1-Serial0/2/1] mpls l2vc pw-template pe1tope2 101 control-word
      [*PE1-Serial0/2/1] undo shutdown
      [*PE1-Serial0/2/1] quit
      [*PE1] commit
      [~PE1] interface serial0/2/2
      [~PE1-Serial0/2/2] mpls l2vc pw-template pe1tope2 102 control-word
      [*PE1-Serial0/2/2] undo shutdown
      [*PE1-Serial0/2/2] quit
      [*PE1] commit
      [~PE1] interface serial0/2/3
      [~PE1-Serial0/2/3] mpls l2vc pw-template pe1tope2 103 control-word
      [*PE1-Serial0/2/3] undo shutdown
      [*PE1-Serial0/2/3] quit
      [*PE1] commit
      
    2. Configure PE2.

      [~PE2] pw-template pe2tope1
      [~PE2-pw-template-pe2tope1] peer-address 192.168.1.1
      [*PE2-pw-template-pe2tope1] jitter-buffer depth 6
      [*PE2-pw-template-pe2tope1] tdm-encapsulation-number 24
      [*PE2-pw-template-pe2tope1] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/1
      [~PE2-Virtual-Serial0/2/1] mpls l2vc pw-template pe2tope1 101 control-word
      [*PE2-Virtual-Serial0/2/1] undo shutdown
      [*PE2-Virtual-Serial0/2/1] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/2
      [~PE2-Virtual-Serial0/2/2] mpls l2vc pw-template pe2tope1 102 control-word
      [*PE2-Virtual-Serial0/2/2] undo shutdown
      [*PE2-Virtual-Serial0/2/2] quit
      [*PE2] commit
      [~PE2] interface virtual-serial0/2/3
      [~PE2-Virtual-Serial0/2/3] mpls l2vc pw-template pe2tope1 103 control-word
      [*PE2-Virtual-Serial0/2/3] undo shutdown
      [*PE2-Virtual-Serial0/2/3] quit
      [*PE2] commit
      

  7. Verify the configuration.

    Run the display mpls l2vc command on PEs to check PWs' status. The following example uses the command output on PE1. The command output shows that the PW established using virtual-serial 0/2/1 is Up.

    # PE2's command output

    <PE2> display mpls l2vc interface virtual-serial0/2/1
     *client interface       : Virtual-Serial0/2/1 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.1.1
      local group ID         : 0            remote group ID      : 0
      local VC label         : 17           remote VC label      : 17
      local TDM Encap Num    : 24           remote TDM Encap Num : 24
      jitter-buffer          : 6
      idle-code              : ff
      local rtp-header       : enable       remote rtp-header    : enable
      local bit-rate         : enable       remote bit-rate      : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      OAM Protocol           : --                                       
      OAM Status             : --                                       
      OAM Fault Type         : --                                       
      PW APS ID              : 0                                        
      PW APS Status          : --                                       
      TTL Value              : 1                                        
      link state             : up
      local VC MTU           : 1500         remote VC MTU        : 20000
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      PW template name       : pe2tope1                                       
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

Configuration Files

  • PE1 configuration file

    #
     sysname PE1
    #
     mpls lsr-id 192.168.1.1
     mpls
    #
     mpls l2vpn
    #
    pw-template pe1tope2
     peer-address 192.168.2.2
     jitter-buffer depth 6
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2 
    #
    interface serial0/2/1
     link-protocol tdm                                        
     undo shutdown
     mpls l2vc pw-template pe1tope2 101 control-word 
     portmode rs-232
     baudrate 5
     parity odd
     stopbits 2
     databits 7
     mux-protocol 2
     x-50 set phasemode interval
    #
    interface serial0/2/2
     link-protocol tdm                                        
     undo shutdown
     mpls l2vc pw-template pe1tope2 102 control-word 
     portmode rs-232
     baudrate 5
     parity odd
     stopbits 2
     databits 7
     mux-protocol 2
     x-50 set phasemode interval
    #
    interface serial0/2/3
     link-protocol tdm                                        
     undo shutdown
     mpls l2vc pw-template pe1tope2 103 control-word 
     portmode rs-232
     baudrate 5
     parity odd
     stopbits 2
     databits 7
     mux-protocol 2
     x-50 set phasemode interval
    #
    interface GigabitEthernet0/1/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.1.1 255.255.255.255
    #
    ospf 1
    area 0.0.0.0
      network 192.168.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • PE2 configuration file

    #
     sysname PE2
    #
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.1.1
     jitter-buffer depth 6
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.1.1
     remote-ip 192.168.1.1
    #
    interface serial0/2/4
     undo shutdown
     portmode rs-232
     baudrate 5
     parity odd
     stopbits 2
     databits 7
     mux-protocol 2
     x-50 set phasemode interval
     scada-group 1 work
    #
    interface serial0/2/5
     undo shutdown                                            
     portmode rs-232                                          
     baudrate 7                                               
     parity odd 
     undo shutdown
     scada-group 1 protect
    #
    interface GigabitEthernet0/1/7 
     undo shutdown
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    interface Virtual-Serial0/2/1
     link-protocol tdm
     mpls l2vc pw-template pe2tope1 101 control-word 
     bind scada-group 1
    #
    interface Virtual-Serial0/2/2
     link-protocol tdm
     mpls l2vc pw-template pe2tope1 103 control-word 
     bind scada-group 1
    #
    interface Virtual-Serial0/2/3
     link-protocol tdm
     mpls l2vc pw-template pe2tope1 103 control-word 
     bind scada-group 1
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
    
  • P configuration file

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/5
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/1/6
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
    
Updated: 2019-05-16

Document ID: EDOC1000120969

Views: 25927

Downloads: 872

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next