No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Examples for NE and ME60 Routers in Typical Enterprise Scenarios 2.0

This document provides NE series routers typical configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Low-Speed Service Features

Low-Speed Service Features

Example for Configuring CESoPSN

Through TDM transparent cell transport, services between the users and companies in the same city can be transparently transmitted over CES links in a Metro Ethernet (ME) network.

Applicable Products and Versions
  • NE05E series routers with the version of V200R005C00 or later, with NED2ML1A/NED2ML1B - 16 Channels E1 Interface Board support.

  • NE08E series routers with the version of V200R005C00 or later, with NED3ML1A/NED3ML1B - 16 Channels E1 Interface Board or NED2CQ1B - 4 Channels Channelized OC-3c/STM-1c POS Optical Interface Board support.

Networking Requirements

As shown in Figure 1-71, it is required that the User and PE1 should be connected through two E1 links. The Company and PE2 should be connected through the CPOS interface. On the channelized serial interface of E1 links, configure the encapsulation protocol as CES. Then, a PW is set up between PE1 and PE2 to transparently transmit TDM data.

Figure 1-71  Networking diagram of configuring TDMoPSN

Router

Interface

IP Address

PE1

GE 0/2/4

Loopback0

10.1.1.1/24

192.168.2.2/32

P

GE 1/0/0

GE 2/0/0

Loopback0

10.1.1.2/24

10.2.1.1/24

192.168.4.4/32

PE2

GE 2/0/0

Loopback0

10.2.1.2/24

192.168.3.3/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Run the IGP protocol on the backbone network so that devices can communicate with each other.

  2. Configure basic MPLS functions on the backbone network and MPLS L2VPN functions on the PEs. Establish a remote MPLS LDP peer relationship between the PEs at both end of a target PW.

  3. Configure parameters for TDM interfaces.

  4. Configure a PW.

  5. Establish MPLS L2VC connections on PEs.

Data Preparation

To complete the configuration, you need the following data:

  • L2VC IDs at both ends of the PW (must be the same)
  • MPLS LSR IDs of the PEs and P router
  • IP addresses of the remote peers of PEs
  • Coding mode and frame format of the E1/CE1 interface

Procedure

  1. Run the IGP protocol on the backbone network so that devices can communicate with each other. For detailed configurations, see the configuration file of this example.
  2. Configure basic MPLS functions on the backbone network, and configure MPLS L2VPN functions on PE devices. Then, establish the remote MPLS LDP peer relationship between PEs at both ends of the PW. For detailed configurations, see the configuration file of this example.

    The remote MPLS LDP peer relationship is required only for the dynamic PW.

  3. Configure parameters for the TDM interface.

    1. Configure PE1.

      # Configure the channelized mode and CRC4 frames for Controller E1 0/2/1 and Controller E1 0/2/2 on PE1.

      NOTE:
      The NEs support any of the following modes for binding timeslots to form a synchronous serial interface:
      • Timeslots 1 to 31 are bound to form a synchronous serial interface, and timeslot 0 is used to transmit signaling information (applicable when ATM, PPP, or TDM is specified as the link-layer protocol on an interface).

      • Timeslots 1 to 15 and timeslots 17 to 31 are bound to form a synchronous serial interface, and timeslots 0 and 16 are used to transmit signaling information (applicable when ATM, PPP, or TDM is specified as the link-layer protocol on an interface).

      • Bundling of any timeslots in timeslots 1–31, with timeslot 0 used to transmit signaling information. This type of bundling is applicable when TDM is specified as the link-layer protocol at an interface.
      [PE1] controller e1 0/2/1
      [PE1-E1 0/2/1] using ce1
      [PE1-E1 0/2/1] frame-format crc4
      [PE1-E1 0/2/1] channel-set 1 timeslot-list 1-31
      [PE1-E1 0/2/1] quit
      [PE1] controller e1 0/2/2
      [PE1-E1 0/2/2] using ce1
      [PE1-E1 0/2/2] frame-format crc4
      [PE1-E1 0/2/2] channel-set 1 timeslot-list 1-31
      [PE1-E1 0/2/2] quit
      
    2. Configure PE2.

      # Set parameters for the CPOS interface on PE2.

      [PE2] controller cpos 3/0/1
      [PE2-Cpos3/0/1] e1 1 channel-set 1 timeslot-list 1-31
      [PE2-Cpos3/0/1] e1 2 channel-set 2 timeslot-list 1-31

  4. Configure the encapsulation protocol on the serial interface as TDM.

    1. Configure PE1.

      [PE1] interface serial0/2/1:1
      [PE1-Serial0/2/1:1] link-protocol tdm
      [PE1-Serial0/2/1:1] quit
      [PE1] interface serial0/2/2:1
      [PE1-Serial0/2/2:1] link-protocol tdm
      [PE1-Serial0/2/2:1] quit
      
    2. Configure PE2.

      [PE2] interface serial3/0/1/1:1
      [PE2-Serial3/0/1/1:1] link-protocol tdm
      [PE2-Serial3/0/1/1:1] quit
      [PE2] interface serial3/0/1/2:2
      [PE2-Serial3/0/1/2:2] link-protocol tdm
      [PE2-Serial3/0/1/2:2] quit
      

  5. Configuring the PW.

    1. [PE1] pw-template 1to3
      [PE1-pw-template-1to3] peer-address 192.168.3.3
      [PE1-pw-template-1to3] jitter-buffer depth 8
      [PE1-pw-template-1to3] tdm-encapsulation-number 24
      [PE1-pw-template-1to3] quit
      [PE1] interface serial0/2/1:1
      [PE1-Serial0/2/1:1] mpls l2vc pw-template 1to3 100 control-word
      [PE1] interface serial0/2/2:1
      [PE1-Serial0/2/2:1] mpls l2vc pw-template 1to3 200 control-word
      
    2. Configure PE2.

      [PE2] pw-template 3to1
      [PE2-pw-template-3to1] peer-address 192.168.2.2
      [PE2-pw-template-3to1] jitter-buffer depth 8
      [PE2-pw-template-3to1] tdm-encapsulation-number 24
      [PE2-pw-template-3to1] quit
      [PE2] interface serial3/0/1/1:1
      [PE2-Serial3/0/1/1:1] mpls l2vc pw-template 3to1 100 control-word
      [PE2-Serial3/0/1/1:1] undo shutdown
      [PE2-Serial3/0/1/1:1] quit
      [PE2] interface serial3/0/1/2:2
      [PE2-Serial3/0/1/2:2] mpls l2vc pw-template 3to1 200 control-word
      [PE2-Serial3/0/1/2:2] undo shutdown
      [PE2-Serial3/0/1/2:2] quit
      

  6. Verify the configuration.

    Run the display mpls l2vc command on PEs. You can view that the status of the PW is Up.

    Take the display on PE1 as an example:

    <PE1> display mpls l2vc interface serial0/2/1:1
     *client interface       : Serial0/2/1:1 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

Configuration Files
  • Configuration file of PE1

    #
     sysname PE1
    #
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    controller e1 0/3/1
    using ce1
    frame-format crc4
    channel-set 1 timeslot-list 1-31
    undo shutdown
    #
    controller e1 0/2/2
    using ce1
    frame-format crc4
    channel-set 1 timeslot-list 1-31
    undo shutdown
    #
    interface serial0/2/1:1
    link-protocol tdm
    mpls l2vc pw-template 1to3 100 control-word
    undo shutdown
    #
    interface serial0/2/2:1
    link-protocol tdm
    mpls l2vc pw-template 1to3 200 control-word
    undo shutdown
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.2.2 255.255.255.255
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • Configuration file of PE2

    #
     sysname PE2
    #
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    controller cpos 3/0/1
    e1 1 channel-set 1 timeslot-list 1-31
    e1 2 channel-set 1 timeslot-list 1-31
    #
    interface serial3/0/1/1:1
    link-protocol tdm
    mpls l2vc pw-template 3to1 100 control-word
    undo shutdown
    #
    interface serial3/0/1/2:2
    link-protocol tdm
    mpls l2vc pw-template 3to1 200 control-word
    undo shutdown
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • Configuration file of P

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    

Example for Configuring Z Interface Extension

To implement Z interface extension, signals of an analog phone connected to a PBX are transparently transmitted over the PSN between PE1 and PE2 to another place using CESoPSN.

Applicable Products and Versions

This configuration applies to NE05E&08E series products running V300R003C10 or later.

Networking Requirements

Figure 1 shows that a hotel's users (phones) are connected to a PBX. To extend the call distance of POTS phones, an interface of the PBX is connected to PE1. Remote branch phones are connected to PE2. PE1 and PE2 are connected through E1 or PWE3.

Figure 1-72  Z interface extension networking diagram
NOTE:

In this example, interface 1, interface 2, interface 3, and interface 4 refer to GE 0/2/4, GE 0/1/0, GE 0/2/1, and GE 0/2/0, respectively.



Device

Interface

PE1

GE0/2/4

FXO

P

GE0/1/0

GE0/2/1

PE2

GE0/2/0

FXS

Configuration Roadmap

To configure a PW on the PSN network to transmit TDM services, the configuration roadmap is as follows:

  1. Configure PE1's FXSO interface type and interface physical attributes.

  2. Configure PE2's FXSO interface type and interface physical attributes, and disable the hotline phone function.

  3. Enable an IGP on the backbone network for devices to communicate with each other.

  4. Configure basic MPLS functions on the backbone network and MPLS L2VPNs on the PEs. Then, establish a remote MPLS LDP peer relationship between PEs at the two ends of the PW.

  5. Configure TDM interface parameters.

  6. Configure a PW.

  7. Create MPLS L2VCs on PEs.

Data Preparation

To complete the configuration, you need the following data:

No.

Data

1

PE1 and PE2 serial interface numbers

2

PE1 and PE2 serial interface types (FXS/FXO)

3

FXS and FXO interfaces' receive and transmit gains

4

PE1's FXO interface ringing current

5

L2VC IDs (must be the same) at both ends of the PW

6

MPLS LSR IDs of the PEs and P

7

Coding mode and frame format of the E1/CE1 interface

Procedure

  1. Configure PE1's FXSO interface type and interface physical attributes.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] interface serial 0/4/0
    [~PE1-Serial0/4/0] portmode fxo
    Warning: The operation will update the existing interface mode, 
              and delete the interface configurations.                    
    continue?[y/n]:y 
    [*PE1-Serial0/4/0] fxo ring minimum-duration 5
    [*PE1-Serial0/4/0] fxo ring  maximum-interval 15
    [*PE1-Serial0/4/0] undo shutdown
    [*PE1-Serial0/4/0] commit
    [~PE1-Serial0/4/0] display this
    #                       
    interface Serial0/4/0        
     undo shutdown                
     fxo ring minimum-duration 5  
     fxo ring maximum-interval 15 
    #                             
    return

  2. Configure PE2's FXSO interface type and interface physical attributes, and disable the hotline phone function.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE2
    [*HUAWEI] commit
    [~PE2] interface serial 0/4/1
    [~PE2-Serial0/4/1] portmode fxs
    Warning: The operation will update the existing interface mode, 
              and delete the interface configurations.                    
    continue?[y/n]:y 
    [*PE2-Serial0/4/1] undo shutdown
    [*PE2-Serial0/4/1] fxs gain send 5
    [*PE2-Serial0/4/1] fxs gain receive 0
    [*PE2-Serial0/4/1] fxs hotline disable
    [*PE2-Serial0/4/0] commit
    [~PE2-Serial0/4/1] display this
    #                                                                                                                                   
    interface Serial0/4/1                                                                                                               
     undo shutdown                                                                                                                      
     portmode fxs                                                                                                                       
     fxs gain send 5                                                                                                                    
     fxs gain receive 0                                                                                                                 
     fxs hotline disable                                                                                                                
    #                                                                                                                                   
    return 

  3. Run an IGP on the backbone network so that devices can communicate with each other. For detailed configurations, see configuration files.
  4. Configure basic MPLS functions on the backbone network and MPLS L2VPNs on the PEs. Then, establish the remote MPLS LDP peer relationship between the PEs at both ends of the PW. For configuration details, see "Configuration Files" in this section.

    The remote MPLS LDP peer relationship must be established only when a dynamic PW is established.

  5. Configure the encapsulation protocol of the serial interfaces as TDM.

    1. Configure PE1.

      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] link-protocol tdm
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configure PE2.

      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] link-protocol tdm
      [*PE2-serial0/4/1] quit
      [*PE2] commit
      

  6. Configure a PW.

    1. Configure PE1.

      [~PE1] pw-template 1to3
      [*PE1-pw-template-1to3] peer-address 192.168.3.3
      [*PE1-pw-template-1to3] jitter-buffer depth 8
      [*PE1-pw-template-1to3] tdm-encapsulation-number 24
      [*PE1-pw-template-1to3] quit
      [*PE1] commit
      [~PE1] interface serial0/4/0
      [~PE1-serial0/4/0] mpls l2vc pw-template 1to3 100 control-word 
      [*PE1-serial0/4/0] undo shutdown
      [*PE1-serial0/4/0] quit
      [*PE1] commit
      
    2. Configure PE2.

      [~PE2] pw-template 3to1
      [*PE2-pw-template-3to1] peer-address 192.168.2.2
      [*PE2-pw-template-3to1] jitter-buffer depth 8
      [*PE2-pw-template-3to1] tdm-encapsulation-number 24
      [*PE2-pw-template-3to1] quit
      [*PE2] commit
      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] mpls l2vc pw-template 3to1 100 control-word 
      [*PE2-serial0/4/1] undo shutdown
      [*PE2-serial0/4/1] quit
      [*PE2] commit
      

  7. Verify the configuration.

    Run the display this interface command on PEs to view FXO interface or FXS interface configuration and status.

    # PE1's command output

    [~PE1-Serial0/4/0] display this interface
    Serial0/4/0 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2015-03-20 16:59:13                                
    Description:Huawei, Serial0/4/0 Interface                                       
    Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 10:36:46                                        
    Physical layer is: FXO, loopback none                                           
        Pcm code: A-law  
        Impedance: 600 ohm, Hotline: ENABLE                                                             
        DC impedance: 50 ohm, AC impedance: 600 ohm                                 
        Ring: Minimum duration: 5 ms, Maximum interval: 15 ms, Frequence: 25 Hz,
     AC amplitude: 50 V, Offset: 70 mA                                              
        Receive gain: 0 dB, Send gain: 0 dB                                         
      Output error:                                                                 
        0 Underrun Count , 0 Overrun Count                                          
        0 LosPkts , 0 MisOrderPkts                                                  
        0 MalformedPkts , 0 ErrorPkts                                               
        0 TotleErrorCur, 0 TotleErrorOld                                            
        ES: 0 , SES: 0 , UAS: 0                                                     
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    # PE2's command output

    [~PE2-Serial0/4/1] display this interface
    Serial0/4/1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2015-03-20 16:59:13                                
    Description:Huawei, Serial0/4/1 Interface                                       
    Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 10:36:46                                        
    Physical layer is: FXS, loopback none                                           
        Pcm code: A-law                                                             
        DC impedance: 50 ohm, AC impedance: 600 ohm                                 
        Receive gain: 0 dB, Send gain: 5 dB                                         
      Output error:                                                                 
        0 Underrun Count , 0 Overrun Count                                          
        0 LosPkts , 0 MisOrderPkts                                                  
        0 MalformedPkts , 0 ErrorPkts                                               
        0 TotleErrorCur, 0 TotleErrorOld                                            
        ES: 0 , SES: 0 , UAS: 0                                                     
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    Run the displaympls l2vc command on PEs. The following example uses the command output on PE1. The command output shows that the status of the PW is Up.

    # PE1's command output

    <PE1> display mpls l2vc interface serial0/4/0
     *client interface       : serial0/4/0 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

Configuration Files
  • PE1 configuration file

    #
     sysname PE1
    #                       
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    interface serial0/4/0
    undo shutdown
    link-protocol tdm
    portmode fxo                
    fxo ring minimum-duration 5  
    fxo ring maximum-interval 15 
    mpls l2vc pw-template 1to3 100 control-word control-word
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • PE2 configuration file

    #
     sysname PE2
    #           
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    interface Serial0/4/1 
    undo shutdown 
    link-protocol tdm
    portmode fxs                                             
    fxs gain send 5                                          
    fxs gain receive 0                                       
    fxs hotline disable
    mpls l2vc pw-template 3to1 100 control-word
    undo shutdown
    #
    interface GigabitEthernet0/2/0 
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • P configuration file

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    

Example for Configuring the Hotline Phone Function

The hotline phone function allows the system to automatically ring the fixed callee after the caller picks up the phone. When the callee picks up the phone, a call connection is established.

Applicable Products and Versions

This configuration applies to NE05E&08E series products running V300R003C10 or later.

Networking Requirements

Figure 1 shows that a hotel phone is connected to PE1, and another phone is connected to PE2. PE1 and PE2 are connected through E1 or PWE3. In the hotline phone scenario, the hotline phone function must be enabled on both PE1's and PE2's FXS interfaces.

Figure 1-73  Hotline phone networking diagram
NOTE:

In this example, interface 1, interface 2, interface 3, and interface 4 refer to GE 0/2/4, GE 0/1/0, GE 0/2/1, and GE 0/2/0, respectively.



Device

Interface

PE1

GE0/2/4

FXS

P

GE0/1/0

GE0/2/1

PE2

GE0/2/0

FXS

Configuration Roadmap

To configure a PW on the PSN network to transmit TDM services, the configuration roadmap is as follows:

  1. Configure PE1's FXSO interface type and interface physical attributes, and enable the hotline phone function.

  2. Configure PE2's FXSO interface type and interface physical attributes, and enable the hotline phone function.

  3. Enable an IGP on the backbone network for devices to communicate with each other.

  4. Configure basic MPLS functions on the backbone network and MPLS L2VPNs on the PEs. Then, establish a remote MPLS LDP peer relationship between PEs at the two ends of the PW.

  5. Configure TDM interface parameters.

  6. Configure a PW.

  7. Create an MPLS L2VC on PE1.

  8. Create an MPLS L2VC on PE2.

Data Preparation

To complete the configuration, you need the following data:

No.

Data

1

PE1 and PE2 serial interface numbers

2

PE1 and PE2 serial interface types (FXS)

3

L2VC IDs (must be the same) at both ends of the PW

4

MPLS LSR IDs of the PEs and P

5

Coding mode and frame format of the E1/CE1 interface

Procedure

  1. Configure PE1's FXSO interface type and interface physical attributes, and enable the hotline phone function.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1] interface serial 0/4/0
    [*PE1-Serial0/4/0] portmode fxs
    Warning: The operation will update the existing interface mode, 
              and delete the interface configurations.                    
    continue?[y/n]:y 
    [*PE1-Serial0/4/0] undo shutdown
    [*PE1-Serial0/4/0] fxs hotline enable
    [*PE1-Serial0/4/0] commit
    [~PE1-Serial0/4/0] quit

  2. Configure PE2's FXSO interface type and interface physical attributes, and enable the hotline phone function.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE2
    [*HUAWEI] commit
    [~PE2] interface serial 0/4/1
    [~PE2-Serial0/4/1] portmode fxs
    Warning: The operation will update the existing interface mode, 
              and delete the interface configurations.                    
    continue?[y/n]:y 
    [*PE2-Serial0/4/1] undo shutdown
    [*PE2-Serial0/4/1] fxs hotline enable
    [*PE2-Serial0/4/1] commit
    [~PE2-Serial0/4/1] quit

  3. Run an IGP on the backbone network so that devices can communicate with each other. For configuration details, see "Configuration Files" in this section.
  4. Configure basic MPLS functions on the backbone network and MPLS L2VPNs on the PEs. Then, establish the remote MPLS LDP peer relationship between the PEs at both ends of the PW. For configuration details, see "Configuration Files" in this section.

    The remote MPLS LDP peer relationship must be established only when a dynamic PW is established.

  5. Configure the encapsulation protocol of the serial interfaces as TDM.

    1. Configure PE1.

      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] link-protocol tdm
      [*PE1-Serial0/4/0] quit
      [*PE1] commit
      
    2. Configure PE2.

      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] link-protocol tdm
      [*PE2-serial0/4/1] quit
      [*PE2] commit
      

  6. Configure a PW.

    1. Configure PE1.

      [~PE1] pw-template 1to3
      [*PE1-pw-template-1to3] peer-address 192.168.3.3
      [*PE1-pw-template-1to3] jitter-buffer depth 8
      [*PE1-pw-template-1to3] tdm-encapsulation-number 24
      [*PE1-pw-template-1to3] quit
      [*PE1] commit
      [~PE1] interface serial0/4/0
      [~PE1-serial0/4/0] mpls l2vc pw-template 1to3 100 control-word 
      [*PE2-serial0/4/0] undo shutdown
      [*PE2-serial0/4/0] quit
      [*PE2] commit
      
    2. Configure PE2.

      [~PE2] pw-template 3to1
      [*PE2-pw-template-3to1] peer-address 192.168.2.2
      [*PE2-pw-template-3to1] jitter-buffer depth 8
      [*PE2-pw-template-3to1] tdm-encapsulation-number 24
      [*PE2-pw-template-3to1] quit
      [*PE2] commit
      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] mpls l2vc pw-template 3to1 100 control-word 
      [*PE2-serial0/4/1] undo shutdown
      [*PE2-serial0/4/1] quit
      [*PE2] commit
      

  7. Verify the configuration.

    Run the display this interface command on PEs to view FXS interface configuration and status.

    # PE1's command output

    [~PE1-Serial0/4/0] display this interface
    Serial0/4/0 current state : UP                                                  
    Line protocol current state : UP                                                                                                    
    Last line protocol up time : 2015-06-17 13:24:20                                                                                    
    Description:HUAWEI, Serial0/4/0 Interface                                                                                           
    Route Port,The Maximum Transmit Unit(L3) is 1500 bytes, Hold timer is 10(sec)                                                       
    Internet protocol processing : disabled                                                                                             
    Last physical up time   : 2015-06-17 13:24:20                                                                                       
    Last physical down time : 2015-06-17 13:24:20                                                                                       
    Current system time: 2015-06-17 13:24:23                                                                                            
    Physical layer is: FXS, loopback none                                                                                               
        Pcmcode: A-law, Current:16 mA                                                                                                   
        Impedance: 600 ohm, Hotline: ENABLE                                                                                             
        Receive gain: -7 dB, Send gain: 0 dB                                                                                            
    TDM statistics:                                                                                                                     
      Output error:                                                                                                                     
        0 Underrun Count , 0 Overrun Count                                                                                              
        0 LosPkts , 0 MisOrderPkts                                                                                                      
        0 MalformedPkts , 0 ErrorPkts                                                                                                   
        0 TotleErrorCur, 0 TotleErrorOld                                                                                                
        ES: 0 , SES: 0 , UAS: 0                                                                                                         
        Input bandwidth utilization  :    0%                                                                                            
        Output bandwidth utilization :    0%

    # PE2's command output

    [~PE2-Serial0/4/1] display this interface
    Serial0/4/1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2015-03-20 16:59:13                                
    Description:Huawei, Serial0/4/1 Interface                                       
    Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 10:36:46                                        
    Physical layer is: FXS, loopback none                                           
        Pcm code: A-law                                                             
        DC impedance: 50 ohm, AC impedance: 600 ohm                                 
        Receive gain: 0 dB, Send gain: 5 dB                                         
      Output error:                                                                 
        0 Underrun Count , 0 Overrun Count                                          
        0 LosPkts , 0 MisOrderPkts                                                  
        0 MalformedPkts , 0 ErrorPkts                                               
        0 TotleErrorCur, 0 TotleErrorOld                                            
        ES: 0 , SES: 0 , UAS: 0                                                     
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    Run the display mpls l2vc command on PEs. The following example uses the command output on PE1. The command output shows that the status of the PW is Up.

    # PE1's command output

    <PE1> display mpls l2vc interface serial0/4/0
     *client interface       : serial0/4/0 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

Configuration Files
  • PE1 configuration file

    #
     sysname PE1
    #                       
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    interface serial0/4/0
    undo shutdown                
    link-protocol tdm
    portmode fxs
    fxs hotline enable
    mpls l2vc pw-template 1to3 100 control-word control-word
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • PE2 configuration file

    #
     sysname PE2
    #           
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    interface Serial0/4/1 
    undo shutdown 
    link-protocol tdm
    portmode fxs                                             
    fxs hotline enable
    mpls l2vc pw-template 3to1 100 control-word
    undo shutdown
    #
    interface GigabitEthernet0/2/0 
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • P configuration file

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/1
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    

Example for Configuring TDM Services Transparent Transmission Over E&M Interfaces

E&M interfaces are mainly used to transparently transmit incoming TDM service data to the remote end.

Applicable Products and Versions

This configuration applies to NE05E&08E series products running V300R003C10 or later.

Networking Requirements

Figure 1 shows that PE1's E&M interface is connected to a PBX. PE2's E&M interface is connected to another PBX. PE1 and PE2 are connected through E1 or PWE3 to implement transparent transmission over E&M interfaces.

Figure 1-74  TDM service transparent transmission over E&M interfaces
NOTE:

In this example, interface 1, interface 2, interface 3, and interface 4 refer to GE 0/2/4, GE 0/1/0, GE 0/2/1, and GE 0/2/0, respectively.



Device

Interface

PE1

GE0/2/4

E&M interface

P

GE0/1/0

GE0/2/1

PE2

GE0/2/0

E&M interface

Configuration Roadmap

To configure a PW on the PSN network to transmit TDM services, the configuration roadmap is as follows:

  1. Configure PE1's E&M interface physical attributes.

  2. Configure PE2's E&M interface physical attributes.

  3. Enable an IGP on the backbone network for devices to communicate with each other.

  4. Configure basic MPLS functions on the backbone network and MPLS L2VPNs on the PEs. Then, establish a remote MPLS LDP peer relationship between PEs at the two ends of the PW.

  5. Configure TDM interface parameters.

  6. Configure a PW.

  7. Create MPLS L2VCs on PEs.

Data Preparation

To complete the configuration, you need the following data:

No.

Data

1

PE1 and PE2's E&M signaling modes

2

Subscriber line modes of E&M interfaces

3

L2VC IDs (must be the same) at both ends of the PW

4

MPLS LSR IDs of the PEs and P

5

Coding mode and frame format of the E1/CE1 interface

Procedure

  1. Configure PE1's E&M interface physical attributes.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE1
    [*HUAWEI] commit
    [~PE1]em signal-mode bell-5 card 1
    [*PE1]em userline 4wire card 1
    [*PE1]commit

  2. Configure PE2's E&M interface physical attributes.

    <HUAWEI> system-view
    [~HUAWEI] sysname PE2
    [*HUAWEI] commit
    [~PE2]em signal-mode bell-5 card 1
    [*PE2]em userline 4wire card 1
    [*PE2]commit

  3. Run an IGP on the backbone network so that devices can communicate with each other. For configuration details, see "Configuration Files" in this section.
  4. Configure basic MPLS functions on the backbone network and MPLS L2VPNs on the PEs. Then, establish the remote MPLS LDP peer relationship between the PEs at both ends of the PW. For configuration details, see "Configuration Files" in this section.

    The remote MPLS LDP peer relationship must be established only when a dynamic PW is established.

  5. Configure the encapsulation protocol of the serial interfaces as TDM.

    1. Configure PE1.

      [~PE1] interface serial0/4/0
      [~PE1-Serial0/4/0] link-protocol tdm
      [*PE1-Serial0/4/0] quit
      [*PE1]commit
      
    2. Configure PE2.

      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] link-protocol tdm
      [*PE2-serial0/4/1] quit
      [*PE2]commit
      

  6. Configure a PW.

    1. Configure PE1.

      [~PE1] pw-template 1to3
      [*PE1-pw-template-1to3] peer-address 192.168.3.3
      [*PE1-pw-template-1to3] jitter-buffer depth 8
      [*PE1-pw-template-1to3] tdm-encapsulation-number 24
      [*PE1-pw-template-1to3] quit
      [*PE1]commit
      [~PE1] interface serial0/4/0
      [~PE1-serial0/4/0] mpls l2vc pw-template 1to3 100 control-word 
      [*PE1-serial0/4/0] undo shutdown
      [*PE1-serial0/4/0] quit
      [*PE1]commit
      
    2. Configure PE2.

      [~PE2] pw-template 3to1
      [*PE2-pw-template-3to1] peer-address 192.168.2.2
      [*PE2-pw-template-3to1] jitter-buffer depth 8
      [*PE2-pw-template-3to1] tdm-encapsulation-number 24
      [*PE2-pw-template-3to1] quit
      [*PE2]commit
      [~PE2] interface serial0/4/1
      [~PE2-serial0/4/1] mpls l2vc pw-template 3to1 100 control-word 
      [*PE2-serial0/4/1] undo shutdown
      [*PE2-serial0/4/1] quit
      [*PE2]commit
      

  7. Verify the configuration.

    Run the display this interface command on PEs to view Serial0/4/0 interface basic configuration and statistics.

    # PE1's command output

    [~PE1-Serial0/4/0] display this interface
    Serial0/4/0 current state : UP                                                  
    Line protocol current state : DOWN                                              
    Description:HUAWEI, Serial0/4/0 Interface                                       
    Route Port,The Maximum Transmit Unit is 2000, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 11:12:29                                        
    Physical layer is: E&M, loopback none                                          
        Pcm code: A-law, Signal mode: Bell-5                                        
        User line: 4 Wire, Passthrough: ENABLE                                      
        Receive gain: 0 dB, Send gain: 0 dB                                         
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    # PE2's command output

    [~PE2-Serial0/4/1] display this interface
    Serial0/4/1 current state : UP                                                  
    Line protocol current state : DOWN                                              
    Description:HUAWEI, Serial0/4/1 Interface                                       
    Route Port,The Maximum Transmit Unit is 2000, Hold timer is 10(sec)             
    Internet protocol processing : disabled                                         
    Last physical up time   : 2015-03-20 16:59:13                                   
    Last physical down time : 2015-03-20 16:57:39                                   
    Current system time: 2015-03-23 11:12:29                                        
    Physical layer is: E&M, loopback none                                          
        Pcm code: A-law, Signal mode: Bell-5                                        
        User line: 4 Wire, Passthrough: ENABLE                                      
        Receive gain: 0 dB, Send gain: 0 dB                                         
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

    Run the displaympls l2vc command on PEs. The following example uses the command output on PE1. The command output shows that the status of the PW is Up.

    # PE1's command output

    <PE1> display mpls l2vc interface serial0/4/0
     *client interface       : serial0/4/0 is up
      Administrator PW       : no
      session state          : up
      AC state               : up
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 100
      VC type                : CESoPSN basic mode
      destination            : 192.168.3.3
      local group ID         : 0            remote group ID      : 0
      local VC label         : 16           remote VC label      : 16
      TDM encapsulation number: 24
      jitter-buffer          : 8
      idle-code              : ff
      rtp-header             : enable
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0 
      remote AC OAM state    : up 
      remote PSN OAM state   : up 
      remote forwarding state: forwarding 
      remote status code     : 0x0
      ignore standby state   : no 
      Dynamic BFD for PW     : enable 
      Detect Multipier       : 3
      Min Transit Interval   : 1500
      Max Receive Interval   : 1500
      Dynamic BFD Session    : built
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 2000         remote VC MTU        : 1500
      local VCCV             : cw alert ttl lsp-ping bfd                     
      remote VCCV            : cw alert ttl lsp-ping bfd                     
      local control word     : enable       remote control word  : enable    
      tunnel policy name     : --                                           
      traffic behavior name  : --                                            
      PW template name       : 1to3                                           
      primary or secondary   : primary                                       
      load balance type      : flow                                          
      Access-port            : false                                         
      Switchover Flag        : false                                         
      VC tunnel/token info   : 1 tunnels/tokens                              
        NO.0  TNL type       : lsp   , TNL ID : 0x392                        
        Backup TNL type      : lsp   , TNL ID : 0x0                          
      create time            : 0 days, 18 hours, 36 minutes, 29 seconds      
      up time                : 0 days, 0 hours, 0 minutes, 32 seconds        
      last change time       : 0 days, 0 hours, 0 minutes, 32 seconds        
      VC last up time        : 2014/11/11 10:36:45                           
      VC total up time       : 0 days, 1 hours, 25 minutes, 31 seconds       
      CKey                   : 2                                             
      NKey                   : 1                                             
      PW redundancy mode     : frr                                           
      AdminPw interface      : --                                            
      AdminPw link state     : --                                            
      Diffserv Mode          : pipe                                          
      Service Class          : ef                                            
      Color                  : green                                         
      DomainId               : --                                            
      Domain Name            : --                                            
    

Configuration Files
  • PE1 configuration file

    #
     sysname PE1
    #                       
     mpls lsr-id 192.168.2.2
     mpls
    #
     mpls l2vpn
    #
    pw-template 1to3
     peer-address 192.168.3.3
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.3.3
     remote-ip 192.168.3.3 
    #
    interface serial0/4/0
     undo shutdown                
     link-protocol tdm
     mpls l2vc pw-template 1to3 100 control-word control-word
    #
    em signal-mode bell-5 card 1
    em userline 4wire card 1
    #
    interface GigabitEthernet0/2/4
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    ospf 1
    area 0.0.0.0
      network 192.168.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
    
  • PE2 configuration file

    #
     sysname PE2
    #           
     mpls lsr-id 192.168.3.3
     mpls
    #
     mpls l2vpn
    #
    pw-template 3to1
     peer-address 192.168.2.2
     jitter-buffer depth 8
     tdm-encapsulation-number 24
    #
    mpls ldp
    #
     mpls ldp remote-peer 192.168.2.2
     remote-ip 192.168.2.2
    #
    interface Serial0/4/1 
     undo shutdown 
     link-protocol tdm
     mpls l2vc pw-template 3to1 100 control-word
    #
    em signal-mode bell-5 card 1
    em userline 4wire card 1
    #
    interface GigabitEthernet0/2/0 
     undo shutdown
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • P configuration file

    #
     sysname P
    #
     mpls lsr-id 192.168.4.4
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet0/1/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/2/1
     undo shutdown
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack0
     ip address 192.168.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 192.168.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
    

Example for Configuring CPOS Interface Interconnection

This section provides an example on how to interconnect devices through CPOS interfaces and how to configure MP-group interfaces for link bundling.

Applicable Products and Versions

This configuration example applies to NE40E/ME60 series products running V800R010C00 or later.

Networking Requirements

On the network shown in Figure 1-75, Device A and Device B need to communicate with each other through CPOS interfaces, and MP-group interfaces need to be configured for link bundling.

Figure 1-75  Configuring CPOS interface interconnection
NOTE:

In this example, interface1 and interface2 represent CPOS 0/3/0 and CPOS 0/5/0, respectively.



Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a working mode for CPOS interfaces and channelize them into synchronous serial interfaces.

  2. Configure MP-group interfaces and add the synchronous serial interfaces to the MP-group interfaces.

Data Preparation

To complete the configuration, you need the following data:

  • Channel number and timeslot number of each E1 channel

  • IP addresses of MP-group interfaces

NOTE:

The interface to be added to an MP-group interface must have the same slot number and card number as the MP-group interface.

The timeslot channels of the serial interfaces on Device A must be the same as those on Device B.

Procedure

  1. Configure a working mode for CPOS interfaces and channelize them into synchronous serial interfaces.

    # Create synchronous serial interfaces on the CPOS interface of Device A.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*DeviceA] controller cpos 0/3/0
    [*DeviceA-Cpos0/3/0] e1 1 channel-set 1 timeslot-list 1-15
    [*DeviceA-Cpos0/3/0] e1 2 channel-set 1 timeslot-list 16-31
    [*DeviceA-Cpos0/3/0] undo shutdown
    [*DeviceA-Cpos0/3/0] commit
    [~DeviceA-Cpos0/3/0] quit

    # Create synchronous serial interfaces on the CPOS interface of Device B.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*DeviceB] controller cpos 0/5/0
    [*DeviceB-Cpos0/5/0] e1 1 channel-set 1 timeslot-list 1-15
    [*DeviceB-Cpos0/5/0] e1 2 channel-set 1 timeslot-list 16-31
    [*DeviceB-Cpos0/5/0] undo shutdown
    [*DeviceB-Cpos0/5/0] commit
    [~DeviceB-Cpos0/5/0] quit

  2. Configure MP-group interfaces and add the synchronous serial interfaces to the MP-group interfaces.

    # Create an MP-group interface on Device A.

    [~DeviceA] interface mp-group 0/3/0
    [*DeviceA-Mp-group0/3/0] ip address 10.1.1.1 255.255.255.0
    [*DeviceA-Mp-group0/3/0] undo shutdown
    [*DeviceA-Mp-group0/3/0] commit
    [~DeviceA-Mp-group0/3/0] quit

    # Add the synchronous serial interfaces to the MP-group interface on Device A.

    [~DeviceA] interface serial 0/3/0/1:1
    [~DeviceA-Serial0/3/0/1:1] link-protocol ppp
    [*DeviceA-Serial0/3/0/1:1] ppp mp mp-group 0/3/0
    [*DeviceA-Serial0/3/0/1:1] commit
    [~DeviceA-Serial0/3/0/1:1] quit
    [~DeviceA] interface serial 0/3/0/2:1
    [~DeviceA-Serial0/3/0/2:1] link-protocol ppp
    [*DeviceA-Serial0/3/0/2:1] ppp mp mp-group 0/3/0
    [*DeviceA-Serial0/3/0/2:1] commit
    [~DeviceA-Serial0/3/0/2:1] quit

    # Create an MP-group interface on Device B.

    [~DeviceB] interface mp-group 0/5/0
    [*DeviceB-Mp-group0/5/0] ip address 10.1.1.2 255.255.255.0
    [*DeviceB-Mp-group0/5/0] undo shutdown
    [*DeviceB-Mp-group0/5/0] commit
    [~DeviceB-Mp-group0/5/0] quit

    # Add the synchronous serial interfaces to the MP-group interface on Device B.

    [~DeviceB] interface serial 0/5/0/1:1
    [~DeviceB-Serial0/5/0/1:1] link-protocol ppp
    [*DeviceB-Serial0/5/0/1:1] ppp mp mp-group 0/5/0
    [*DeviceB-Serial0/5/0/1:1] commit
    [~DeviceB-Serial0/5/0/1:1] quit
    [~DeviceB] interface serial 0/5/0/2:1
    [~DeviceB-Serial0/5/0/2:1] link-protocol ppp
    [*DeviceB-Serial0/5/0/2:1] ppp mp mp-group 0/5/0
    [*DeviceB-Serial0/5/0/2:1] commit
    [~DeviceB-Serial0/5/0/2:1] quit

  3. Verify the configuration.

    # On Device A, ping the IP address of the MP-group interface on Device B. The command output shows that the ping is successful.

    [~DeviceA] ping 10.1.1.2
    PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=31 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 29/29/31 ms

Configuration Files
  • Device A configuration file

    #
    sysname DeviceA
    #
    controller Cpos0/3/0
     e1 1 channel-set 1 timeslot-list 1-15
     e1 2 channel-set 1 timeslot-list 16-31
     undo shutdown
    #
    interface Mp-group0/3/0
    #
    interface Serial0/3/0/1:1
     link-protocol ppp
     ppp mp Mp-group0/3/0
    #
    interface Serial0/3/0/2:1
     link-protocol ppp
     ppp mp Mp-group0/3/0
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    controller Cpos0/5/0
     e1 1 channel-set 1 timeslot-list 1-15
     e1 2 channel-set 1 timeslot-list 16-31
     undo shutdown
    #
    interface Mp-group0/5/0
    #
    interface Serial0/5/0/1:1
     link-protocol ppp
     ppp mp Mp-group0/5/0
    #
    interface Serial0/5/0/2:1
     link-protocol ppp
     ppp mp Mp-group0/5/0
    #
    return

Example for Configuring a PRBS Test

This section provides an example on how to configure a PRBS test to check device connectivity when two devices are connected to each other through E1 interfaces.

Applicable Products and Versions

This configuration example applies to NE40E/ME60 series products running V800R010C00 or later.

Networking Requirements

On the network shown in Figure 1-76, Device A and Device B connect to each other through E1 interfaces. A PRBS test needs to be performed to check the connectivity between the two devices.

Figure 1-76  Networking diagram for configuring a PRBS test
NOTE:

In this example, interface1 and interface2 represent E1 0/1/0 and E1 0/2/0, respectively.



Configuration Roadmap
The configuration roadmap is as follows:
  1. Create a synchronous serial interface on Device A and Device B.
  2. Configure remote loopback on the E1 interface of Device B.
  3. Perform a PRBS test on Device A.
  4. Check the PRBS test result on Device A.
  5. After the PRBS test is completed, cancel the remote loopback configuration on the E1 interface of Device B.
Data Preparation

To complete the configuration, you need the following data:

  • E1 interface number of Device A

  • E1 interface number of Device B

Procedure

  1. Create a synchronous serial interface on Device A and Device B.

    # Configure the E1 interface on Device A as a synchronous serial interface.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] controller e1 0/1/0
    [~DeviceA-E1 0/1/0] channel-set 1 timeslot-list 1-31
    [*DeviceA-E1 0/1/0] commit
    [~DeviceA-E1 0/1/0] quit
    

    # Configure the E1 interface on Device B as a synchronous serial interface.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] channel-set 1 timeslot-list 1-31
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

  2. Configure remote loopback on the E1 interface of Device B.

    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] loopback remote
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

  3. Perform a PRBS test on Device A.

    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] link-protocol tdm
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    [~DeviceA] test connectivity interface Serial0/1/0:1 uni-direction pattern prbs15 interval second 20 interval-repeat 5

  4. Check the PRBS test result on Device A.

    [~DeviceA] display connectivity-test interface serial 0/1/0:1
    Summary:
    Start time           Side  Pattern  Phy-port   Total time (Interval*Round)
    2018-08-10 16:12:46  UNI   PRBS15   E1 0/1/0   00:01:40 (20s*5)
    Total bits     Error bits     BER   LOS      Test progress
    198400000      0              0e-0  0s       100%(00:01:40)finished
    Details:
    Round  Total bits   Error bits   BER   LOS     ES      EFS     SES     UAS
    1      39680000     0            0e-0  0s      0s      20s     0s      0s
    2      39680000     0            0e-0  0s      0s      20s     0s      0s
    3      39680000     0            0e-0  0s      0s      20s     0s      0s
    4      39680000     0            0e-0  0s      0s      20s     0s      0s
    5      39680000     0            0e-0  0s      0s      20s     0s      0s
    Error Bits Insert Record (Latest 10):
    Start time           Type        BER   Duration  Insert in round
    

  5. After the PRBS test is completed, cancel the remote loopback configuration on the E1 interface of Device B.

    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] undo loopback
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

Configuration Files
  • Device A configuration file

    #
    sysname DeviceA
    #
    controller E1 0/1/0
     channel-set 1 timeslot-list 1-31
    #
    interface Serial0/1/0:1
     link-protocol tdm
    #
     test connectivity interface Serial0/1/0:1 uni-direction pattern prbs15 interval second 20 interval-repeat 5
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    controller E1 0/2/0
     channel-set 1 timeslot-list 1-31
    #
    controller E1 0/2/0
     loopback remote
    #
    controller E1 0/2/0
     undo loopback
    #
    return

Configuring CE1 Interface Interconnection

This section provides an example on how to interconnect devices through CE1 interfaces.

Applicable Products and Versions

This configuration example applies to NE40E/ME60 series products running V800R010C00 or later.

Networking Requirements

On the network shown in Figure 1-77, Device A and Device B need to communicate with each other through CE1 interfaces.

Figure 1-77  CE1 interface interconnection
NOTE:

In this example, interface1 and interface2 represent CE1 0/1/0 and CE1 0/2/0, respectively.



Configuration Roadmap
The configuration roadmap is as follows:
  1. Create synchronous serial interfaces.
  2. Configure IP addresses for the synchronous serial interfaces.
  3. Restart all the interfaces to make the configuration take effect.
Data Preparation

To complete the configuration, you need the following data:

  • CE1 interface number of Device A

  • CE1 interface number of Device B

  • IP address of the synchronous serial interface on Device A

  • IP address of the synchronous serial interface on Device B

NOTE:

The timeslot channels of the serial interfaces on Device A must be the same as those on Device B.

Procedure

  1. Create synchronous serial interfaces.

    # Configure the CE1 interface on Device A as a synchronous serial interface.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] controller e1 0/1/0
    [~DeviceA-E1 0/1/0] channel-set 1 timeslot-list 1-15
    [*DeviceA-E1 0/1/0] commit
    [~DeviceA-E1 0/1/0] quit
    

    # Configure the CE1 interface on Device B as a synchronous serial interface.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] channel-set 1 timeslot-list 1-15
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

  2. Configure IP addresses for the synchronous serial interfaces.

    # Configure an IP address for the synchronous serial interface on Device A.

    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] link-protocol ppp
    [*DeviceA-Serial0/1/0:1] ip address 10.1.1.1 255.255.255.0
    [*DeviceA-Serial0/1/0:1] shutdown
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    

    # Configure an IP address for the synchronous serial interface on Device B.

    [~DeviceB] interface serial 0/2/0:1
    [~DeviceB-Serial0/2/0:1] link-protocol ppp
    [*DeviceB-Serial0/2/0:1] ip address 10.1.1.2 255.255.255.0
    [*DeviceB-Serial0/2/0:1] shutdown
    [*DeviceB-Serial0/2/0:1] commit
    [~DeviceB-Serial0/2/0:1] quit
    

  3. Restart all the interfaces to make the configuration take effect.

    # Restart the synchronous serial interface on Device A.

    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] undo shutdown
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    

    # Restart the synchronous serial interface on Device B.

    [~DeviceB] interface serial 0/2/0:1
    [~DeviceB-Serial0/2/0:1] undo shutdown
    [*DeviceB-Serial0/2/0:1] commit
    [~DeviceB-Serial0/2/0:1] quit
    

  4. Verify the configuration.

    # On Device A, ping the IP address of the synchronous serial interface on Device B. The command output shows that the ping is successful.

    [~DeviceA] ping 10.1.1.2
    PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=31 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 29/29/31 ms

Configuration Files
  • Device A configuration file

    #
    sysname DeviceA
    #
    controller E1 0/1/0
     channel-set 1 timeslot-list 1-15
    #
    interface Serial0/1/0:1
     link-protocol ppp
     ip address 10.1.1.1 255.255.255.0
     undo shutdown
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    controller E1 0/2/0
     channel-set 1 timeslot-list 1-15
    #
    interface Serial0/2/0:1
     link-protocol ppp
     ip address 10.1.1.2 255.255.255.0
     undo shutdown
    #
    return

Example for Configuring E1 Interface Interconnection

This section provides an example on how to interconnect devices through E1 interfaces.

Applicable Products and Versions

This configuration example applies to NE40E/ME60 series products running V800R010C00 or later.

Networking Requirements

On the network shown in Figure 1-78, Device A and Device B need to communicate with each other through E1 interfaces.

Figure 1-78  E1 interface interconnection
NOTE:

In this example, interface1 and interface2 represent E1 0/1/0 and E1 0/2/0, respectively.



Configuration Roadmap
The configuration roadmap is as follows:
  1. Create synchronous serial interfaces.
  2. Configure IP addresses for the synchronous serial interfaces.
  3. Restart all the interfaces to make the configuration take effect.
Data Preparation

To complete the configuration, you need the following data:

  • E1 interface number of Device A

  • E1 interface number of Device B

  • IP address of the synchronous serial interface on Device A

  • IP address of the synchronous serial interface on Device B

Procedure

  1. Create a synchronous serial interface on Device A.

    # Configure the E1 interface on Device A as a synchronous serial interface.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] controller e1 0/1/0
    [~DeviceA-E1 0/1/0] using e1
    [*DeviceA-E1 0/1/0] commit
    [~DeviceA-E1 0/1/0] quit
    

    # Configure the E1 interface on Device B as a synchronous serial interface.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] using e1
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    

  2. Configure IP addresses for the synchronous serial interfaces.

    # Configure an IP address for the synchronous serial interface on Device A.

    [~DeviceA] interface serial 0/1/0:0
    [~DeviceA-Serial0/1/0:0] link-protocol ppp
    [*DeviceA-Serial0/1/0:0] ip address 10.1.1.1 255.255.255.0
    [*DeviceA-Serial0/1/0:0] shutdown
    [*DeviceA-Serial0/1/0:0] commit
    [~DeviceA-Serial0/1/0:0] quit
    

    # Configure an IP address for the synchronous serial interface on Device B.

    [~DeviceB] interface serial 0/2/0:0
    [~DeviceB-Serial0/2/0:0] link-protocol ppp
    [*DeviceB-Serial0/2/0:0] ip address 10.1.1.2 255.255.255.0
    [*DeviceB-Serial0/2/0:0] shutdown
    [*DeviceB-Serial0/2/0:0] commit
    [~DeviceB-Serial0/2/0:0] quit
    

  3. Restart all the interfaces to make the configuration take effect.

    # Restart the synchronous serial interface on Device A.

    [~DeviceA] interface serial 0/1/0:0
    [~DeviceA-Serial0/1/0:0] undo shutdown
    [*DeviceA-Serial0/1/0:0] commit
    [~DeviceA-Serial0/1/0:0] quit
    

    # Restart the synchronous serial interface on Device B.

    [~DeviceB] interface serial 0/2/0:0
    [~DeviceB-Serial0/2/0:0] undo shutdown
    [*DeviceB-Serial0/2/0:0] commit
    [~DeviceB-Serial0/2/0:0] quit
    

  4. Verify the configuration.

    # On Device A, ping the IP address of the synchronous serial interface on Device B. The command output shows that the ping is successful.

    [~DeviceA] ping 10.1.1.2
    PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=31 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 29/29/31 ms

Configuration Files
  • Device A configuration file

    #
    sysname DeviceA
    #
    controller E1 0/1/0
     using e1
     undo shutdown
    #
    interface Serial0/1/0:0
     link-protocol ppp
     ip address 10.1.1.1 255.255.255.0
     undo shutdown
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    controller E1 0/2/0
     using e1
     undo shutdown
    #
    interface Serial0/2/0:0
     link-protocol ppp
     ip address 10.1.1.2 255.255.255.0
     undo shutdown
    #
    return

Example for Configuring MP Groups

When two devices connect to each other through E1 interfaces, these E1 interfaces can be added to MP groups to increase the available bandwidth. This section provides an example on how to configure MP groups.

Applicable Products and Versions

This configuration example applies to NE40E/ME60 series products running V800R010C00 or later.

Networking Requirements

On the network shown in Figure 1-79, Device A and Device B connect to each other through two pairs of E1 interfaces.

A single link sometimes cannot support data transmission when services are busy. To quickly, efficiently, and securely increase the available transmission bandwidth for data transmission, MP groups can be used.

Figure 1-79  Adding E1 interfaces to MP groups
NOTE:

In this example, interface1, interface2, interface3, and interface4 represent E1 0/1/0, E1 0/1/1, E1 0/2/0, and E1 0/2/1respectively.



Configuration Roadmap
The configuration roadmap is as follows:
  1. Create MP-group interfaces.
  2. Create synchronous serial interfaces and add the interfaces to the MP-group interfaces.
  3. Restart all the interfaces to make the configuration take effect.
Data Preparation

To complete the configuration, you need the following data:

  • IP address of the MP-group interface on Device A

  • IP address of the MP-group interface on Device B

  • E1 interface numbers of Device A

  • E1 interface numbers of Device B

NOTE:

The interface to be added to an MP-group interface must have the same slot number and card number as the MP-group interface.

The timeslot channels of the serial interfaces on Device A must be the same as those on Device B.

Procedure

  1. Create MP-group interfaces.

    # Create an MP-group interface and configure an IP address for it on Device A.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceA
    [*HUAWEI] commit
    [~DeviceA] interface mp-group 0/1/1
    [*DeviceA-Mp-group0/1/1] ip address 10.1.1.1 255.255.255.0
    [*DeviceA-Mp-group0/1/1] shutdown
    [*DeviceA-Mp-group0/1/1] commit
    [~DeviceA-Mp-group0/1/1] quit

    # Create an MP-group interface and configure an IP address for it on Device B.

    <HUAWEI> system-view
    [~HUAWEI] sysname DeviceB
    [*HUAWEI] commit
    [~DeviceB] interface mp-group 0/2/1
    [*DeviceB-Mp-group0/2/1] ip address 10.1.1.2 255.255.255.0
    [*DeviceB-Mp-group0/2/1] shutdown
    [*DeviceB-Mp-group0/2/1] commit
    [~DeviceB-Mp-group0/2/1] quit

  2. Create synchronous serial interfaces and add the interfaces to the MP-group interfaces.

    # Configure E1 interfaces of Device A as synchronous serial interfaces and add them to the MP-group interface.

    [~DeviceA] controller e1 0/1/0
    [~DeviceA-E1 0/1/0] channel-set 1 timeslot-list 1-15
    [*DeviceA-E1 0/1/0] commit
    [~DeviceA-E1 0/1/0] quit
    [~DeviceA] controller e1 0/1/1
    [~DeviceA-E1 0/1/1] channel-set 1 timeslot-list 16-31
    [*DeviceA-E1 0/1/1] commit
    [~DeviceA-E1 0/1/1] quit
    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] link-protocol ppp
    [*DeviceA-Serial0/1/0:1] ppp mp mp-group 0/1/1
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    [~DeviceA] interface serial 0/1/1:1
    [~DeviceA-Serial0/1/1:1] link-protocol ppp
    [*DeviceA-Serial0/1/1:1] ppp mp mp-group 0/1/1
    [*DeviceA-Serial0/1/1:1] commit
    [~DeviceA-Serial0/1/1:1] quit

    # Configure E1 interfaces of Device B as synchronous serial interfaces and add them to the MP-group interface.

    [~DeviceB] controller e1 0/2/0
    [~DeviceB-E1 0/2/0] channel-set 1 timeslot-list 1-15
    [*DeviceB-E1 0/2/0] commit
    [~DeviceB-E1 0/2/0] quit
    [~DeviceB] controller e1 0/2/1
    [~DeviceB-E1 0/2/1] channel-set 1 timeslot-list 16-31
    [*DeviceB-E1 0/2/1] commit
    [~DeviceB-E1 0/2/1] quit
    [~DeviceB] interface serial 0/2/0:1
    [~DeviceB-Serial0/2/0:1] link-protocol ppp
    [*DeviceB-Serial0/2/0:1] ppp mp mp-group 0/2/1
    [*DeviceB-Serial0/2/0:1] commit
    [~DeviceB-Serial0/2/0:1] quit
    [~DeviceB] interface serial 0/2/1:1
    [~DeviceB-Serial0/2/1:1] link-protocol ppp
    [*DeviceB-Serial0/2/1:1] ppp mp mp-group 0/2/1
    [*DeviceB-Serial0/2/1:1] commit
    [~DeviceB-Serial0/2/1:1] quit

  3. Restart all the interfaces to make the configuration take effect.

    # Restart the synchronous serial and MP-group interfaces on Device A.

    [~DeviceA] interface serial 0/1/0:1
    [~DeviceA-Serial0/1/0:1] undo shutdown
    [*DeviceA-Serial0/1/0:1] commit
    [~DeviceA-Serial0/1/0:1] quit
    [~DeviceA] interface serial 0/1/1:1
    [~DeviceA-Serial0/1/1:1] undo shutdown
    [*DeviceA-Serial0/1/1:1] commit
    [~DeviceA-Serial0/1/1:1] quit
    [~DeviceA] interface mp-group 0/1/1
    [~DeviceA-Mp-group0/1/1] undo shutdown
    [*DeviceA-Mp-group0/1/1] commit
    [~DeviceA-Mp-group0/1/1] quit

    # Restart the synchronous serial and MP-group interfaces on Device B.

    [~DeviceB] interface serial 0/2/0:1
    [~DeviceB-Serial0/2/0:1] undo shutdown
    [*DeviceB-Serial0/2/0:1] commit
    [~DeviceB-Serial0/2/0:1] quit
    [~DeviceB] interface serial 0/2/1:1
    [~DeviceB-Serial0/2/1:1] undo shutdown
    [*DeviceB-Serial0/2/1:1] commit
    [~DeviceB-Serial0/2/1:1] quit
    [~DeviceB] interface mp-group 0/2/1
    [~DeviceB-Mp-group0/2/1] undo shutdown
    [*DeviceB-Mp-group0/2/1] commit
    [~DeviceB-Mp-group0/2/1] quit

  4. Verify the configuration.

    # On Device A, check information about the MP-group interface and statistics about the packets sent and received by the MP-group interface.

    [~DeviceA] display ppp mp interface mp-group 0/1/1
    Mp-group is Mp-group0/1/1
     ===========Sublinks status begin======
     Serial0/1/0:1 physical UP,protocol UP
     Serial0/1/1:1 physical UP,protocol UP
     ===========Sublinks status end========
     Bundle Multilink, 2 member, slot 1, Master link is Mp-group0/1/1
      0 lost fragments, 0 reordered, 0 unassigned, 0 interleaved,
     sequence 0/0 rcvd/sent
     The bundled son channels are:
          Serial0/1/0:1
          Serial0/1/1:1 

    # On Device B, check information about the MP-group interface and statistics about the packets sent and received by the MP-group interface.

    [~DeviceB] display ppp mp interface mp-group 0/2/1
    Mp-group is Mp-group0/2/1
     ===========Sublinks status begin======
     Serial0/2/0:1 physical UP,protocol UP
     Serial0/2/1:1 physical UP,protocol UP
     ===========Sublinks status end========
     Bundle Multilink, 2 member, slot 2, Master link is Mp-group0/2/1
      0 lost fragments, 0 reordered, 0 unassigned, 0 interleaved,
     sequence 0/0 rcvd/sent
     The bundled son channels are:
          Serial0/2/0:1
          Serial0/2/1:1 

    # On Device A, ping the IP address of MP-group 0/2/1 on Device B. The command output shows that the ping is successful.

    [~DeviceA] ping 10.1.1.2
    PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=31 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=29 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
      --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 29/29/31 ms

Configuration Files
  • Device A configuration file

    #
    sysname DeviceA
    #
    controller E1 0/1/0
     channel-set 1 timeslot-list 1-15
    #
    interface Serial0/1/0:1
     undo shutdown
     link-protocol ppp
     ppp mp Mp-group0/1/1
    #
    controller E1 0/1/1
     channel-set 1 timeslot-list 16-31
    #
    interface Serial0/1/1:1
     undo shutdown
     link-protocol ppp
     ppp mp Mp-group0/1/1  
    #
    interface Mp-group0/1/1
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
    #
    return
  • Device B configuration file

    #
    sysname DeviceB
    #
    controller E1 0/2/0
     channel-set 1 timeslot-list 1-15
    #
    interface Serial0/2/0:1
     undo shutdown
     link-protocol ppp
     ppp mp Mp-group0/2/1
    #
    controller E1 0/2/1
     channel-set 1 timeslot-list 16-31
    #
    interface Serial0/2/1:1
     undo shutdown
     link-protocol ppp
     ppp mp Mp-group0/2/1  
    #
    interface Mp-group0/2/1
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
    #
    return
Updated: 2019-05-16

Document ID: EDOC1000120969

Views: 26230

Downloads: 879

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next