Configuring Layer 3 DCI
Configuring Spine Nodes
This section describes only the interconnection configuration between spine nodes and DCI leaf nodes. Other configurations are the same as those in Configuring Spine Nodes.
Spine-01-01 |
Spine-01-02 |
Description |
---|---|---|
vlan 2001 |
vlan 2001 |
Create a service VLAN. |
# |
# |
- |
interface Vlanif2001 |
interface Vlanif2001 |
Create a service VLANIF interface. |
ip address 10.132.11.1 255.255.255.0 |
ip address 10.132.11.1 255.255.255.0 |
Configuring an IPv4 Address. |
ipv6 enable ipv6 address fc00:132:11::1/64 |
ipv6 enable ipv6 address fc00:132:11::1/64 |
Configuring an IPv6 Address. |
mac-address 0000-5e00-0101 |
mac-address 0000-5e00-0101 |
- |
# |
# |
- |
vlan 11 # interface Vlanif11 ip address 10.125.3.1 255.255.255.252 ipv6 enable ipv6 address fc00:125:3::1/64 mac-address 0000-5e00-0101 # |
vlan 11 # interface Vlanif11 ip address 10.125.3.1 255.255.255.252 ipv6 enable ipv6 address fc00:125:3::1/64 mac-address 0000-5e00-0101 # |
Configure a Layer 3 logical interface for interconnecting with the DCI leaf nodes. |
interface Eth-Trunk1 port trunk allow-pass vlan 11 # |
interface Eth-Trunk1 port trunk allow-pass vlan 11 # |
Use the Layer 2 interconnection interface for interconnecting with the DCI leaf nodes. |
ip route-static 10.132.12.0 24 10.125.3.2 |
ip route-static 10.132.12.0 24 10.125.3.2 |
Configure a static route destined for DC2 with the next hop being a remote DCI leaf node. |
ipv6 route-static fc00:132:12:: 64 fc00:125:3::2 |
ipv6 route-static fc00:132:12:: 64 fc00:125:3::2 |
Spine-02-01 |
Spine-02-02 |
Description |
---|---|---|
vlan 2002 |
vlan 2002 |
Create a service VLAN. |
# |
# |
- |
interface Vlanif2002 |
interface Vlanif2002 |
Create a service VLANIF interface. |
ip address 10.132.12.1 255.255.255.0 |
ip address 10.132.12.1 255.255.255.0 |
Configuring an IPv4 Address. |
ipv6 enable ipv6 address fc00:132:12::1/64 |
ipv6 enable ipv6 address fc00:132:12::1/64 |
Configuring an IPv6 Address. |
mac-address 0000-5e00-0101 |
mac-address 0000-5e00-0101 |
- |
# |
# |
- |
vlan 12 # interface Vlanif12 ip address 10.125.3.5 255.255.255.252 ipv6 enable ipv6 address fc00:125:3::5/64 mac-address 0000-5e00-0101 # |
vlan 12 # interface Vlanif12 ip address 10.125.3.5 255.255.255.252 ipv6 enable ipv6 address fc00:125:3::5/64 mac-address 0000-5e00-0101 # |
Configure a Layer 3 logical interface for interconnecting with the DCI leaf nodes. |
interface Eth-Trunk1 port trunk allow-pass vlan 12 # |
interface Eth-Trunk1 port trunk allow-pass vlan 12 # |
Use the Layer 2 interconnection interface for interconnecting with the DCI leaf nodes. |
ip route-static 10.132.11.0 24 10.125.3.6 |
ip route-static 10.132.11.0 24 10.125.3.6 |
Configure a static route destined for DC2 with the next hop being a remote DCI leaf node. |
ipv6 route-static fc00:132:11:: 64 fc00:125:3::6 |
ipv6 route-static fc00:132:11:: 64 fc00:125:3::6 |
Configuring DCI Leaf Nodes
This section describes only the Layer 3 interconnection configuration between DCI leaf nodes and spine nodes. Other configurations are the same as those in Configuring DCI Leaf Nodes.
DCI Leaf-01-01 |
DCI Leaf-01-02 |
Description |
---|---|---|
ip vpn-instance vrf1 ipv4-family route-distinguisher 11:6001 vpn-target 0:6001 export-extcommunity evpn vpn-target 0:6001 import-extcommunity evpn vxlan vni 6001 # |
ip vpn-instance vrf1 ipv4-family route-distinguisher 12:6001 vpn-target 0:6001 export-extcommunity evpn vpn-target 0:6001 import-extcommunity evpn vxlan vni 6001 # |
Configure a VPN instance to advertise routes destined for the local spine nodes. |
vlan 11 # interface Vlanif11 ip binding vpn-instance vrf1 ip address 10.125.3.2 255.255.255.252 ipv6 enable ipv6 address fc00:125:3::2/64 mac-address 0000-5e00-0102 # |
vlan 11 # interface Vlanif11 ip binding vpn-instance vrf1 ip address 10.125.3.2 255.255.255.252 ipv6 enable ipv6 address fc00:125:3::2/64 mac-address 0000-5e00-0102 # |
Configure a Layer 3 logical interface for interconnecting with the spine nodes. |
interface Eth-Trunk1 port trunk allow-pass vlan 11 # |
interface Eth-Trunk1 port trunk allow-pass vlan 11 # |
Use the Layer 2 interconnection interface for interconnecting with the spine nodes. |
ip route-static vpn-instance vrf1 10.132.11.0 24 10.125.3.1 |
ip route-static vpn-instance vrf1 10.132.11.0 24 10.125.3.1 |
Configure a static route to a local spine node. |
ipv6 route-static vpn-instance vrf1 fc00:132:11:: 64 fc00:125:3::1 |
ipv6 route-static vpn-instance vrf1 fc00:132:11:: 64 fc00:125:3::1 |
|
bgp 1001 instance overlay ipv4-family vpn-instance vrf1 import-route static maximum load-balancing 32 advertise l2vpn evpn # |
bgp 1001 instance overlay ipv4-family vpn-instance vrf1 import-route static maximum load-balancing 32 advertise l2vpn evpn # |
Import the static route to BGP EVPN. |
DCI Leaf-02-01 |
DCI Leaf-02-02 |
Description |
---|---|---|
ip vpn-instance vrf1 ipv4-family route-distinguisher 13:6001 vpn-target 0:6001 export-extcommunity evpn vpn-target 0:6001 import-extcommunity evpn vxlan vni 6001 # |
ip vpn-instance vrf1 ipv4-family route-distinguisher 14:6001 vpn-target 0:6001 export-extcommunity evpn vpn-target 0:6001 import-extcommunity evpn vxlan vni 6001 # |
Configure a VPN instance to advertise routes destined for the local spine nodes. |
vlan 12 # interface Vlanif12 ip binding vpn-instance vrf1 ip address 10.125.3.6 255.255.255.252 ipv6 enable ipv6 address fc00:125:3::6/64 mac-address 0000-5e00-0102 # |
vlan 12 # interface Vlanif12 ip binding vpn-instance vrf1 ip address 10.125.3.6 255.255.255.252 ipv6 enable ipv6 address fc00:125:3::6/64 mac-address 0000-5e00-0102 # |
Configure a Layer 3 logical interface for interconnecting with the spine nodes. |
interface Eth-Trunk1 port trunk allow-pass vlan 12 # |
interface Eth-Trunk1 port trunk allow-pass vlan 12 # |
Use the Layer 2 interconnection interface for interconnecting with the spine nodes. |
ip route-static vpn-instance vrf1 10.132.12.0 24 10.125.3.5 |
ip route-static vpn-instance vrf1 10.132.12.0 24 10.125.3.5 |
Configure a static route to a local spine node. |
ipv6 route-static vpn-instance vrf1 fc00:132:12:: 64 fc00:125:3::5 |
ipv6 route-static vpn-instance vrf1 fc00:132:12:: 64 fc00:125:3::5 |
|
bgp 1002 instance overlay ipv4-family vpn-instance vrf1 import-route static maximum load-balancing 32 advertise l2vpn evpn # |
bgp 1002 instance overlay ipv4-family vpn-instance vrf1 import-route static maximum load-balancing 32 advertise l2vpn evpn # |
Import the static route to BGP EVPN. |