No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

S7700 and S9700 V200R010C00

This document describes IP Unicast Routing configurations supported by the switch, including the principle and configuration procedures of IP Routing Overview, Static Route, RIP, RIPng, OSPF, OSPFv3, IS-IS(IPv4), IS-IS(IPv6), BGP, Routing Policy ,and PBR, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an OSPFv3 Virtual Link

Example for Configuring an OSPFv3 Virtual Link

Networking Requirements

In Figure 1, OSPFv3 is enabled on all Switches, and the AS is divided into three areas. SwitchB and SwitchC serve as ABRs to forward inter-area routes. Area 2 is not directly connected to the Area 0, the backbone area. Area 1 is the area between Area 0 and Area 2.

Configure a virtual link in Area 1 where SwitchB and SwitchC are located so that SwitchA and SwitchD can communicate with each other.

Figure 6-14  Networking diagram for configuring an OSPFv3 virtual link

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IPv6 addresses for interfaces.

  2. Enable basic OSPFv3 functions on each switch.

  3. Configure a virtual link between SwitchB and SwitchC to connect the non-backbone areas to the backbone area.

Procedure

  1. Add interfaces to VLANs.

    # Configure SwitchA. Ensure that the configurations of SwitchB, SwitchC, and SwitchD are the same as that of SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type trunk
    [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/0] quit
    

  2. Assign IPv6 addresses to the VLANIF interfaces.

    # Configure SwitchA. Ensure that the configurations of SwitchB, SwitchC, and SwitchD are the same as that of SwitchA.

    [SwitchA] ipv6
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ipv6 enable
    [SwitchA-Vlanif10] ipv6 address fc00:0:0:1001::2/64
    [SwitchA-Vlanif10] quit

  3. Configure basic OSPFv3 functions.

    # On SwitchA, enable OSPFv3 and set the router ID to 10.1.1.1.

    [SwitchA] ospfv3
    [SwitchA-ospfv3-1] router-id 10.1.1.1
    [SwitchA-ospfv3-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ospfv3 1 area 2
    [SwitchA-Vlanif10] quit

    # On SwitchB, enable OSPFv3 and set the router ID to 10.2.2.2.

    [SwitchB] ospfv3
    [SwitchB-ospfv3-1] router-id 10.2.2.2
    [SwitchB-ospfv3-1] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ospfv3 1 area 2
    [SwitchB-Vlanif10] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] ospfv3 1 area 1
    [SwitchB-Vlanif20] quit

    # On SwitchC, enable OSPFv3 and set the router ID to 10.3.3.3.

    [SwitchC] ospfv3
    [SwitchC-ospfv3-1] router-id 10.3.3.3
    [SwitchC-ospfv3-1] quit
    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] ospfv3 1 area 1
    [SwitchC-Vlanif20] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] ospfv3 1 area 0
    [SwitchC-Vlanif30] quit

    # On SwitchD, enable OSPFv3 and set the router ID to 10.4.4.4.

    [SwitchD] ospfv3
    [SwitchD-ospfv3-1] router-id 10.4.4.4
    [SwitchD-ospfv3-1] quit
    [SwitchD] interface vlanif 30
    [SwitchD-Vlanif30] ospfv3 1 area 0
    [SwitchD-Vlanif30] quit

    # Check the OSPFv3 routing table of SwitchC. The command output shows that the routing table of SwitchC does not contain the routes of Area 2. This is because Area 2 is not directly connected to Area 0.

    [SwitchC] display ospfv3 routing
    
    Codes : E2 - Type 2 External, E1 - Type 1 External, IA - Inter-Area,
            N - NSSA, U - Uninstalled, D - Denied by Import Policy
    
    OSPFv3 Process (1)
       Destination                                   Metric
         Next-hop
         FC00:0:0:1000::/64                                     1
               directly connected, Vlanif20
         FC00:0:0:1002::/64                                     1
               directly connected, Vlanif30               

  4. Configure a virtual link in Area 1 where SwitchB and SwitchC are located.

    # Configure SwitchB.

    [SwitchB] ospfv3
    [SwitchB-ospfv3-1] area 1
    [SwitchB-ospfv3-1-area-0.0.0.1] vlink-peer 10.3.3.3
    [SwitchB-ospfv3-1-area-0.0.0.1] return

    # Configure SwitchC.

    [SwitchC] ospfv3
    [SwitchC-ospfv3-1] area 1
    [SwitchC-ospfv3-1-area-0.0.0.1] vlink-peer 10.2.2.2
    [SwitchC-ospfv3-1-area-0.0.0.1] return

  5. Verify the configuration.

    # Check the OSPFv3 routing table of SwitchC.

    <SwitchC> display ospfv3 routing
    
    Codes : E2 - Type 2 External, E1 - Type 1 External, IA - Inter-Area,
            N - NSSA, U - Uninstalled, D - Denied by Import Policy
    
    OSPFv3 Process (1)
       Destination                                   Metric
         Next-hop
         FC00:0:0:1000::/64                                     1
               directly connected, Vlanif20
         FC00:0:0:1000::1/128                                   1
               via FE80::4D67:0:EB7D:2, Vlanif20
         FC00:0:0:1000::2/128                                   0
               directly connected, Vlanif20
      IA FC00:0:0:1001::/64                                     2
               via FE80::4D67:0:EB7D:2, Vlanif20
         FC00:0:0:1002::/64                                     1
               directly connected, Vlanif30

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 10
    #
    ospfv3 1
     router-id 10.1.1.1
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1001::2/64
     ospfv3 1 area 0.0.0.2
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 10 20
    #
    ospfv3 1
     router-id 10.2.2.2
     area 0.0.0.1
      vlink-peer 10.3.3.3
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1001::1/64
     ospfv3 1 area 0.0.0.2
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:1000::1/64
     ospfv3 1 area 0.0.0.1
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #  
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #                    
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 20 30
    #
    ospfv3 1
     router-id 10.3.3.3
     area 0.0.0.1
      vlink-peer 10.2.2.2
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:1000::2/64
     ospfv3 1 area 0.0.0.1
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:1002::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #  
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    ipv6
    #
    vlan batch 30
    #
    ospfv3 1
     router-id 10.4.4.4
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:1002::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000141900

Views: 178184

Downloads: 192

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next