No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

S7700 and S9700 V200R010C00

This document describes IP Unicast Routing configurations supported by the switch, including the principle and configuration procedures of IP Routing Overview, Static Route, RIP, RIPng, OSPF, OSPFv3, IS-IS(IPv4), IS-IS(IPv6), BGP, Routing Policy ,and PBR, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring One-Arm Static BFD for RIP

Example for Configuring One-Arm Static BFD for RIP

Networking Requirements

In Figure 1, four switches communicate using RIP on a small-sized network. Services are transmitted through the primary link SwitchA→SwitchB→SwitchD. Reliability must be improved for data transmitted from SwitchA to SwitchB so that services can be rapidly switched to another path when the primary link fails.

NOTE:

In this scenario, ensure that all connected interfaces have STP disabled. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 3-13  One-arm static BFD for RIP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP address for each interface to ensure network reachability.

  2. Enable RIP on each switch to implement network connections between processes.

  3. Configure one-arm static BFD on SwitchA. BFD can rapidly detect the link status and help RIP speed up route convergence to implement fast link switching.

Procedure

  1. Configure VLANs and add interfaces to the VLANs. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type trunk
    [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/0] quit
    [SwitchA] interface gigabitethernet 2/0/0
    [SwitchA-GigabitEthernet2/0/0] port link-type trunk
    [SwitchA-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet2/0/0] quit
    

  2. Configure an IP address to each VLANIF interface. The configurations of SwitchB, SwitchC, and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.2.2.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.3.3.1 24
    [SwitchA-Vlanif20] quit

  3. Configure basic RIP functions.

    # Configure SwitchA.

    [SwitchA] rip 1
    [SwitchA-rip-1] version 2
    [SwitchA-rip-1] network 10.0.0.0
    [SwitchA-rip-1] quit

    # Configure SwitchB.

    [SwitchB] rip 1
    [SwitchB-rip-1] version 2
    [SwitchB-rip-1] network 10.0.0.0
    [SwitchB-rip-1] network 172.16.0.0
    [SwitchB-rip-1] quit

    # Configure SwitchC.

    [SwitchC] rip 1
    [SwitchC-rip-1] version 2
    [SwitchC-rip-1] network 10.0.0.0
    [SwitchC-rip-1] quit

    # Configure SwitchD.

    [SwitchD] rip 1
    [SwitchD-rip-1] version 2
    [SwitchD-rip-1] network 172.16.0.0
    [SwitchD-rip-1] quit

    # After completing the preceding operations, run the display rip neighbor command. The command output shows that SwitchA, SwitchB, and SwitchC have established neighbor relationships with each other. In the following example, the display on SwitchA is used.

    [SwitchA] display rip 1 neighbor
    ---------------------------------------------------------------------           
     IP Address      Interface                   Type   Last-Heard-Time             
    ---------------------------------------------------------------------           
     10.2.2.2        Vlanif10                    RIP    0:0:10                      
     Number of RIP routes  : 2                                                      
     10.3.3.2        Vlanif20                    RIP    0:0:8                       
     Number of RIP routes  : 1 

    # Run the display ip routing-table command. The command output shows that the devices have imported routes from each other. In the following example, the display on SwitchA is used.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 8        Routes : 9                                     
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
           10.2.2.0/24  Direct  0    0           D   10.2.2.1        Vlanif10       
           10.2.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif10       
           10.3.3.0/24  Direct  0    0           D   10.3.3.1        Vlanif20       
           10.3.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif20       
           10.4.4.0/24  RIP     100  1           D   10.2.2.2        Vlanif10       
                        RIP     100  1           D   10.3.3.2        Vlanif20       
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
         172.16.1.0/24  RIP     100  1           D   10.2.2.2        Vlanif10       

    The preceding command output shows that the next-hop address and outbound interface of the route to destination 172.16.1.0/24 are 10.2.2.2 and VLANIF10, and traffic is transmitted over the active link SwitchA->SwitchB.

  4. Configure one-arm static BFD on SwitchA.

    # Configure one-arm BFD on SwitchA.

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bfd 1 bind peer-ip 10.2.2.2 interface vlanif 10 source-ip 10.1.1.1 one-arm-echo
    [SwitchA-bfd-session-1] discriminator local 1
    [SwitchA-bfd-session-1] min-echo-rx-interval 200
    [SwitchA-bfd-session-1] commit
    [SwitchA-bfd-session-1] quit

    The source IP address 10.1.1.1 can be configured as the IP address of another interface (such as loopback interface) on the device. This parameter must be configured. Otherwise, the BFD session cannot be set up.

    # Enable static BFD on VLANIF 10.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] rip bfd static
    [SwitchA-Vlanif10] quit

    # After the configurations are completed, run the display bfd session all command on SwitchA. The command output shows that a static BFD session has been set up.

    [SwitchA] display bfd session all
    --------------------------------------------------------------------------------
    Local Remote     PeerIpAddr      State     Type        InterfaceName            
    --------------------------------------------------------------------------------
    1     -          10.2.2.2        Up        S_IP_IF     Vlanif10                 
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0  

  5. Verify the configuration.

    # Run the shutdown command on GigabitEthernet1/0/0 of SwitchB to simulate a fault in the active link.

    NOTE:

    The link fault is simulated to verify the configuration. In actual situations, the operation is not required.

    [SwitchB] interface gigabitethernet 1/0/0
    [SwitchB-GigabitEthernet1/0/0] shutdown

    # Check the routing table of SwitchA.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 6        Routes : 6                                     
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
           10.3.3.0/24  Direct  0    0           D   10.3.3.1        Vlanif20       
           10.3.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif20       
           10.4.4.0/24  RIP     100  1           D   10.3.3.2        Vlanif20       
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
         172.16.1.0/24  RIP     100  2           D   10.3.3.2        Vlanif20       

    The preceding command output shows that the standby link SwitchA->SwitchC->SwitchB is used after the active link fails, and the next-hop address and outbound interface of the route to destination 172.16.1.0/24 are 10.3.3.2 and VLANIF20.

Configuration files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    bfd
    #
    interface Vlanif10
     ip address 10.2.2.1 255.255.255.0
     rip bfd static 
    #
    interface Vlanif20
     ip address 10.3.3.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bfd 1 bind peer-ip 10.2.2.2 interface Vlanif10 source-ip 10.1.1.1 one-arm-echo
     discriminator local 1
     min-echo-rx-interval 200
     commit
    #
    rip 1 
     version 2 
     network 10.0.0.0
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 30 40
    #
    interface Vlanif10
     ip address 10.2.2.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.4.4.1 255.255.255.0
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    rip 1 
     version 2 
     network 10.0.0.0
     network 172.16.0.0
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20 30
    #
    interface Vlanif20
     ip address 10.3.3.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.4.4.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    rip 1 
     version 2 
     network 10.0.0.0
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 40
    #
    interface Vlanif40
     ip address 172.16.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    rip 1 
     version 2 
     network 172.16.0.0
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000141900

Views: 178940

Downloads: 192

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next