No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

S7700 and S9700 V200R010C00

This document describes IP Unicast Routing configurations supported by the switch, including the principle and configuration procedures of IP Routing Overview, Static Route, RIP, RIPng, OSPF, OSPFv3, IS-IS(IPv4), IS-IS(IPv6), BGP, Routing Policy ,and PBR, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring OSPFv3 GR

Example for Configuring OSPFv3 GR

Networking Requirements

In Figure 1, SwitchA, SwitchB, and SwitchC belong to the same OSPFv3 area. They communicate with each other through the OSPFv3 protocol and are enabled with GR.

When OSPFv3 adjacencies are set up between SwitchA, SwitchC, and SwitchB, the three switches exchange routing information. If the OSPFv3 protocol restarts on SwitchA, SwitchA synchronizes data with neighboring switches through GR.

Figure 6-15  Networking diagram for configuring OSPFv3 GR

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IPv6 addresses for interfaces.

  2. Enable basic OSPFv3 functions on each switch.

  3. Enable the OSPFv3 GR helper in the OSPFv3 view of SwitchB.

  4. Enable the OSPFv3 GR in the OSPFv3 view of SwitchA.

Procedure

  1. Add interfaces to VLANs.

    # Configure SwitchA. Ensure that the configurations of SwitchB and SwitchC are the same as that of SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type trunk
    [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/0] quit
    

  2. Assign IPv6 addresses to the VLANIF interfaces.

    # Configure SwitchA. Ensure that the configurations of SwitchB and SwitchC are the same as that of SwitchA.

    [SwitchA] ipv6
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ipv6 enable
    [SwitchA-Vlanif10] ipv6 address fc00:0:0:1000::1/64
    [SwitchA-Vlanif10] quit

  3. Configure basic OSPFv3 functions.

    # On SwitchA, enable OSPFv3 and set the router ID to 10.1.1.1.

    [SwitchA] ospfv3 100
    [SwitchA-ospfv3-100] router-id 10.1.1.1
    [SwitchA-ospfv3-100] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ospfv3 100 area 0
    [SwitchA-Vlanif10] quit

    # On SwitchB, enable OSPFv3 and set the router ID to 10.2.2.2.

    [SwitchB] ospfv3 100
    [SwitchB-ospfv3-100] router-id 10.2.2.2
    [SwitchB-ospfv3-100] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ospfv3 100 area 0
    [SwitchB-Vlanif10] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] ospfv3 100 area 0
    [SwitchB-Vlanif20] quit

    # On SwitchC, enable OSPFv3 and set the router ID to 10.3.3.3.

    [SwitchC] ospfv3 100
    [SwitchC-ospfv3-100] router-id 10.3.3.3
    [SwitchC-ospfv3-100] quit
    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] ospfv3 100 area 0
    [SwitchC-Vlanif20] quit

  4. Enable OSPFv3 GR on SwitchA.

    [SwitchA] ospfv3 100
    [SwitchA-ospfv3-100] graceful-restart
    [SwitchA-ospfv3-100] return

  5. Enable OSPFv3 helper on SwitchB.

    [SwitchB] ospfv3 100
    [SwitchB-ospfv3-100] helper-role
    [SwitchB-ospfv3-100] return

  6. Verify the configuration.

    # Run the display ipv6 fib 1 command on SwitchA to view the FIB information.

    <SwitchA> display ipv6 fib 1
     IPv6 FIB Table:
     Total number of Routes : 5
    
    Destination:  ::1                                     PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FE80::                                  PrefixLength: 10
    Nexthop    :  ::                                      Flag        : BU
    Interface  :  NULL0                                   Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::1                        PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::                         PrefixLength: 64
    Nexthop    :  FC00:0:0:1000::1                        Flag        : U
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:2000::                         PrefixLength: 64
    Nexthop    :  FE80::200:1FF:FE00:200                  Flag        : DGU
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46

    # Restart OSPFv3 process 100 on SwitchA without using the GR mechanism.

    <SwitchA> reset ospfv3 100

    # Immediately run the display ipv6 fib 1 command on SwitchA to view the FIB information.

    <SwitchA> display ipv6 fib 1
     IPv6 FIB Table:
     Total number of Routes : 4
    
    Destination:  ::1                                     PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FE80::                                  PrefixLength: 10
    Nexthop    :  ::                                      Flag        : BU
    Interface  :  NULL0                                   Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::1                        PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::                         PrefixLength: 64
    Nexthop    :  FC00:0:0:1000::1                        Flag        : U
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46

    This information shows that the FIB information on SwitchA has been modified and the forwarding service is affected.

    # Restart OSPFv3 process 100 on SwitchA using the GR mechanism.

    <SwitchA> reset ospfv3 100 graceful-restart

    # Immediately run the display ipv6 fib 1 command on SwitchA to view the FIB information. Check whether GR is functioning normally. If so, the FIB information is not modified and the forwarding is not affected when you restart the OSPFv3 process using GR on SwitchA.

    <SwitchA> display ipv6 fib 1
     IPv6 FIB Table:
     Total number of Routes : 5
    
    Destination:  ::1                                     PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FE80::                                  PrefixLength: 10
    Nexthop    :  ::                                      Flag        : BU
    Interface  :  NULL0                                   Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::1                        PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::                         PrefixLength: 64
    Nexthop    :  FC00:0:0:1000::1                        Flag        : U
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:2000::                         PrefixLength: 64
    Nexthop    :  FE80::200:1FF:FE00:200                  Flag        : DGU
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46

    This information shows that the FIB information on SwitchA has not been modified and the forwarding is not affected.

Configuration Files

  • SwitchA configuration file

    # 
    sysname SwitchA
    # 
    ipv6
    #
    vlan batch 10
    #
    ospfv3 100 
     router-id 10.1.1.1 
     graceful-restart
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1000::1/64
     ospfv3 100 area 0.0.0.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    # 
    return 
  • SwitchB configuration file

    # 
    sysname SwitchB
    # 
    ipv6
    #
    vlan batch 10 20
    #
    ospfv3 100 
     router-id 10.2.2.2 
     helper-role 
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1000::2/64
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2000::1/64
     ospfv3 100 area 0.0.0.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #  
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    # 
    return 
  • SwitchC configuration file

    # 
    sysname SwitchC
    # 
    ipv6
    #
    vlan batch 20
    #
    ospfv3 100 
     router-id 10.3.3.3
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2000::2/64
     ospfv3 100 area 0.0.0.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000141900

Views: 192027

Downloads: 194

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next