No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R010C00

This document describes MPLS configurations supported by the switch, including the principle and configuration procedures of static LSPs, MPLS LDP, MPLS TE, MPLS QoS, MPLS OAM, Seamless MPLS, and MPLS common features, and provides configuration examples.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring RSVP GR

Example for Configuring RSVP GR

Networking Requirements

As shown in Figure 5-55, an enterprise has its own MPLS backbone network. LSRA, LSRB, and LSRC are devices on the backbone network. The three LSRs all have double MPUs. The IS-IS protocol is used to implement IP interworking. A TE tunnel from LSRA to LSRC is set up on the network.

The enterprise wants to ensure uninterrupted data forwarding during an active/standby switchover on LSRA, LSRB, or LSRC.

Figure 5-55  Networking of RSVP GR

Configuration Roadmap

RSVP GR can be configured on the network to ensure uninterrupted data forwarding during an active/standby switchover.

The configuration roadmap is as follows:

  1. Configure IS-IS to ensure that routes between backbone nodes are reachable.

  2. Enable MPLS TE and RSVP TE on the backbone nodes so that they can set up MPLS TE tunnels.

  3. Enable IS-IS TE and change the cost type to enable the nodes to advertise TE information using IS-IS.

  4. On the ingress node, create a tunnel interface and configure tunnel attributes on the tunnel interface. Enable MPLS TE CSPF to dynamically set up MPLS TE tunnels.

  5. Configure IS-IS GR and RSVP GR on each node to ensure uninterrupted data forwarding during an active/standby switchover.

Procedure

  1. Assign IP addresses to interfaces.

    # Configure LSRA. Assign IP addresses to interfaces of LSRB and LSRC according to Figure 5-55. The configurations on LSRB and LSRC are similar to the configuration on LSRA, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRA
    [LSRA] vlan batch 100
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    

  2. Configure IS-IS to advertise routes.

    # Configure LSRA.

    [LSRA] isis 1
    [LSRA-isis-1] network-entity 00.0005.0000.0000.0001.00
    [LSRA-isis-1] is-level level-2
    [LSRA-isis-1] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] isis enable 1
    [LSRA-Vlanif100] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] isis enable 1
    [LSRA-LoopBack1] quit

    # Configure LSRB.

    [LSRB] isis 1
    [LSRB-isis-1] network-entity 00.0005.0000.0000.0002.00
    [LSRB-isis-1] is-level level-2
    [LSRB-isis-1] quit
    [LSRB] interface vlanif 100
    [LSRB-Vlanif100] isis enable 1
    [LSRB-Vlanif100] quit
    [LSRB] interface vlanif 200
    [LSRB-Vlanif200] isis enable 1
    [LSRB-Vlanif200] quit
    [LSRB] interface loopback 1
    [LSRB-LoopBack1] isis enable 1
    [LSRB-LoopBack1] quit

    # Configure LSRC.

    [LSRC] isis 1
    [LSRC-isis-1] network-entity 00.0005.0000.0000.0003.00
    [LSRC-isis-1] is-level level-2
    [LSRC-isis-1] quit
    [LSRC] interface vlanif 200
    [LSRC-Vlanif200] isis enable 1
    [LSRC-Vlanif200] quit
    [LSRC] interface loopback 1
    [LSRC-LoopBack1] isis enable 1
    [LSRC-LoopBack1] quit

    Run the display ip routing-table command on the LSRs, and you can see that they learn the routes from each other. The command output on LSRA is provided as an example:

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 8        Routes : 8                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            1.1.1.9/32  Direct  0    0           D   127.0.0.1       LoopBack1      
            2.2.2.9/32  ISIS-L2 15   10          D   172.1.1.2       Vlanif100
            3.3.3.9/32  ISIS-L2 15   20          D   172.1.1.2       Vlanif100
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          172.1.1.0/24  Direct  0    0           D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
          172.2.1.0/24  ISIS-L2 15   20          D   172.1.1.2       Vlanif100
    

  3. Configure basic MPLS capabilities, enable MPLS TE and RSVP TE.

    Enable MPLS, MPLS TE, RSVP-TE globally on the LSRs and on the interfaces that the tunnel passes through.

    # Configure LSRA. The configurations on LSRB and LSRC are similar to the configuration on LSRA, and are not mentioned here.

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit

  4. Configure IS-IS TE and enable IS-IS GR.

    # Configure LSRA. The configurations on LSRB and LSRC are similar to the configuration on LSRA, and are not mentioned here.

    [LSRA] isis 1
    [LSRA-isis-1] cost-style wide
    [LSRA-isis-1] traffic-eng level-2
    [LSRA-isis-1] graceful-restart
    [LSRA-isis-1] quit

  5. Configure an MPLS TE tunnel interface and enable MPLS TE CSPF.

    On the ingress of the tunnel, create a tunnel interface and set the IP address, tunneling protocol, destination IP address, tunnel ID, and dynamic signaling protocol for the tunnel interface. Then, run the mpls te commit command to commit the configuration.

    # Configure LSRA.

    [LSRA] mpls
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit
    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopback 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 3.3.3.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit
    

    Run the display interface tunnel command on LSRA. You can see that the tunnel interface is Up.

    [LSRA] display interface tunnel
    Tunnel1 current state : UP
    Line protocol current state : UP
    Last line protocol up time : 2013-01-14 09:18:46
    Description:
    ...

  6. Configure RSVP GR.

    # Configure LSRA. The configurations on LSRB and LSRC are similar to the configuration on LSRA, and are not mentioned here.

    [LSRA] mpls
    [LSRA-mpls] mpls rsvp-te hello
    [LSRA-mpls] mpls rsvp-te hello full-gr
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls rsvp-te hello
    [LSRA-Vlanif100] quit
    

  7. Verify the configuration.

    After the configurations are complete, run the display mpls rsvp-te graceful-restart command on LSRA to view the local GR status, restart time, and recovery time.

    [LSRA] display mpls rsvp-te graceful-restart
    Display Mpls Rsvp te graceful restart information                               
     LSR ID: 1.1.1.9                                                                
     Graceful-Restart Capability:   GR-Self GR-Support                              
     Restart Time:  90060 Milli Second                                              
     Recovery Time: 0 Milli Second                                                  
     GR Status:  Gracefully Restart Not going on                                    
     Number of Restarting neighbors: 0                                              
     Number of LSPs recovered: 0                                                    
     Received Gr Path message count: 0                                              
     Send Gr Path message count: 0                                                  
     Received RecoveryPath message count: 0                                         
     Send RecoveryPath message count: 0  

    Run the display mpls rsvp-te graceful-restart peer command on LSRA to view the GR status of the neighboring node.

    [LSRA] display mpls rsvp-te graceful-restart peer
     Neighbor on Interface Vlanif100
     Neighbor Addr: 172.1.1.2              Last Attribute: Added Usually            
     SrcInstance: 0x7C832B3D               NbrSrcInstance: 0x6A48E0F5               
     Neighbor Capability:                                                           
                        Can Do Self GR                                              
                        Can Support GR                                              
     GR Status:          Normal                                                     
     Restart Time:  90015 Millisecond                                               
     Recovery Time: 0 Millisecond                                                   
     Stored GR message number: 0                                                    
     PSB Count: 0                          RSB Count: 1                             
     Total to be Recover PSB Count: 0     Recovered PSB Count: 0                    
     Total to be Recover RSB Count: 0     Recovered RSB Count: 0                    
     P2MP PSB Count: 0                     P2MP RSB Count: 0                        
     Total to be Recover P2MP PSB Count: 0     Recovered P2MP PSB Count: 0          
     Total to be Recover P2MP RSB Count: 0     Recovered P2MP RSB Count: 0   

Configuration File

  • LSRA configuration file

    #
    sysname LSRA
    #
    vlan batch 100
    #
    mpls lsr-id 1.1.1.9
    mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te hello
     mpls rsvp-te hello full-gr
     mpls te cspf
    #
    isis 1
     graceful-restart
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0001.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te hello
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te tunnel-id 100
     mpls te commit
    #
    return
  • LSRB configuration file

    #
    sysname LSRB
    #
    vlan batch 100 200
    #
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te hello
     mpls rsvp-te hello full-gr
    #
    isis 1
     graceful-restart
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0002.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te hello
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te hello
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
     isis enable 1
    #
    return
  • LSRC configuration file

    #
    sysname LSRC
    #
    vlan batch 200
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te hello
     mpls rsvp-te hello full-gr
    #
    isis 1
     graceful-restart
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0003.00
     traffic-eng level-2
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te hello
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
     isis enable 1
    #
    return
Translation
Download
Updated: 2019-04-18

Document ID: EDOC1000141902

Views: 69229

Downloads: 189

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next