No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R010C00

This document describes MPLS configurations supported by the switch, including the principle and configuration procedures of static LSPs, MPLS LDP, MPLS TE, MPLS QoS, MPLS OAM, Seamless MPLS, and MPLS common features, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Card Removal Protection (Manual TE FRR)

Example for Configuring Card Removal Protection (Manual TE FRR)

Networking Requirements

As shown in Figure 5-49, the path of the primary CR-LSP is LSRA -> LSRB -> LSRC -> LSRD. TE FRR is required to protect the link between LSRB and LSRC.

The requirement is as follows: When the interface card where GE2/0/0 resides is removed from LSRB, traffic is switched to the bypass tunnel. When the interface card is installed on LSRB again, the traffic is switched back to the primary tunnel.

NOTE:

In this scenario, to avoid loops, ensure that all connected interfaces have STP disabled and connected interfaces are removed from VLAN 1. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 5-49  Networking of card removal protection through manual TE FRR

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure manual TE FRR.

  2. Specify explicit paths for the primary and bypass tunnels. The explicit paths of the primary and bypass tunnels must pass through different interface cards on LSRB. Otherwise, card removal protection cannot be implemented.

Procedure

  1. Configure manual TE FRR.

    Configure the primary and bypass tunnels and bind the two tunnels by referring to Example for Configuring Manual TE FRR.

    When configuring the primary and bypass tunnels, specify explicit paths for the two tunnels and ensure that their explicit paths pass through different interface cards on LSRB.

  2. Verify the configuration.

    # Run the tracert lsp te tunnel command on the LSRA. You can see that traffic is transmitted over the primary tunnel.

    [LSRA] tracert lsp te tunnel 1
      LSP Trace Route FEC: TE TUNNEL IPV4 SESSION QUERY Tunnel1 , press CTRL_C to br
    eak.                                                                            
      TTL   Replier            Time    Type      Downstream                         
      0                                Ingress   172.1.1.2/[4115 ]                  
      1     172.1.1.2          5 ms    Transit   172.2.1.2/[4145 ]                  
      2     172.2.1.2          4 ms    Transit   172.3.1.2/[3 ]                     
      3     4.4.4.9            13 ms   Egress 

    # Remove the interface card where the primary tunnel outbound interface GE2/0/0 is located from LSRB, and then run the display interface tunnel command on LSRB. You can see that the tunnel interface of the primary tunnel is still Up.

    # Run the display mpls stale-interface and display mpls te tunnel stale-interface interface-index verbose commands on LSRB. You can see that the outbound interface of the primary tunnel is in Stale state.

    [LSRB] display mpls stale-interface
    Stale-Interface       Status    TE Attr   LSP Count  CRLSP Count Effective MTU  
    0x9d                Up        Dis       0          1           1500 
    
    [LSRB] display mpls te tunnel stale-interface 9d verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                          
        Tunnel Interface Name   :  -                                                
        TunnelIndex             :  2           LSP Index         :  2049            
        Session ID              :  100         LSP ID            :  25              
        LSR Role                :  Transit                                          
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  4.4.4.9                                          
        In-Interface            :  Vlanif100                                        
        Out-Interface           :  0x9d                                             
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        ER-Hop Table Index      :  -           AR-Hop Table Index:  2               
        C-Hop Table Index       :  -                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8964                                             
        Created Time            :  2013-09-16 22:15:23+00:00                        
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x63        Protected Flag    :  0x1             
        Bypass In Use           :  In Use                                           
        Bypass Tunnel Id        :  48                                               
        BypassTunnel            :  Tunnel Index[Tunnel2], InnerLabel[4144]          
        Bypass LSP ID           :  4           FrrNextHop        :  172.5.1.2       
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -           CT1 Unbound Bandwidth:  -            
        CT2 Unbound Bandwidth   :  -           CT3 Unbound Bandwidth:  -            
        CT4 Unbound Bandwidth   :  -           CT5 Unbound Bandwidth:  -            
        CT6 Unbound Bandwidth   :  -           CT7 Unbound Bandwidth:  -            
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               

    # Run the tracert lsp te tunnel command on LSRA, and you can see that traffic is transmitted through the bypass tunnel.

    [LSRA] tracert lsp te tunnel 1
      LSP Trace Route FEC: TE TUNNEL IPV4 SESSION QUERY Tunnel1 , press CTRL_C to br
    eak.                                                                            
      TTL   Replier            Time    Type      Downstream                         
      0                                Ingress   172.1.1.2/[4115 ]                  
      1     172.1.1.2          3 ms    Transit   172.4.1.2/[4145 1033 ]             
      2     172.4.1.2          9 ms    Transit   172.5.1.2/[3 ]                     
      3     172.5.1.2          3 ms    Transit   172.3.1.2/[3 ]                     
      4     4.4.4.9            4 ms    Egress 

    # After the removed interface card is installed on LSRB again, run the tracert lsp te tunnel command on LSRA. You can see that traffic is switched back to the primary tunnel.

    [LSRA] tracert lsp te tunnel 1
      LSP Trace Route FEC: TE TUNNEL IPV4 SESSION QUERY Tunnel1 , press CTRL_C to br
    eak.                                                                            
      TTL   Replier            Time    Type      Downstream                         
      0                                Ingress   172.1.1.2/[4116 ]                  
      1     172.1.1.2          3 ms    Transit   172.2.1.2/[4146 ]                  
      2     172.2.1.2          4 ms    Transit   172.3.1.2/[3 ]                     
      3     4.4.4.9            12 ms   Egress 

Configuration File

  • LSRA configuration file

    #
     sysname LSRA
    #
    vlan batch 100
    #
    mpls lsr-id 1.1.1.9
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path pri-path
     next hop 172.1.1.2
     next hop 172.2.1.2
     next hop 172.3.1.2
     next hop 4.4.4.9
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0001.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 4.4.4.9
     mpls te tunnel-id 100
     mpls te record-route label
     mpls te path explicit-path pri-path
     mpls te fast-reroute
     mpls te commit
    #
    return
  • LSRB configuration file

    #
     sysname LSRB
    #
    vlan batch 100 200 400
    #
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls te timer fast-reroute 120
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path by-path
     next hop 172.4.1.2
     next hop 172.5.1.2
     next hop 3.3.3.9
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0002.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
     isis enable 1
    #
    interface Tunnel2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te tunnel-id 300
     mpls te record-route
     mpls te path explicit-path by-path
     mpls te bypass-tunnel
     mpls te protected-interface Vlanif200
     mpls te commit
    #
    return
  • LSRC configuration file

    #
     sysname LSRC
    #
    vlan batch 200 300 500
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0003.00
     traffic-eng level-2
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
     isis enable 1
    #
    return
  • LSRD configuration file

    #
     sysname LSRD
    #
    vlan batch 300
    #
    mpls lsr-id 4.4.4.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0004.00
     traffic-eng level-2
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
     isis enable 1
    #
    return
  • LSRE configuration file

    #
     sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0005.00
     traffic-eng level-2
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
     isis enable 1
    #
    return
Translation
Download
Updated: 2019-04-18

Document ID: EDOC1000141902

Views: 73094

Downloads: 189

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next