No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R010C00

This document describes MPLS configurations supported by the switch, including the principle and configuration procedures of static LSPs, MPLS LDP, MPLS TE, MPLS QoS, MPLS OAM, Seamless MPLS, and MPLS common features, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Setting Up CR-LSPs Using CR-LSP Attribute Templates

Example for Setting Up CR-LSPs Using CR-LSP Attribute Templates

Networking Requirements

As shown in Figure 5-37, an MPLS TE tunnel is set up between LSRA and LSRC. The primary path of the tunnel is LSRA -> LSRB -> LSRC. When the primary CR-LSP fails, traffic must be switched to a backup CR-LSP.

LSRA needs to set up multiple MPLS TE tunnels to meet service requirements. The network administrator wants to simplify the MPLS TE tunnel configuration.

NOTE:

In this scenario, to avoid loops, ensure that all connected interfaces have STP disabled and connected interfaces are removed from VLAN 1. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 5-37  Networking of CR-LSP setup using CR-LSP attribute templates

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign IP addresses to interfaces and configure OSPF to ensure that public network routes between the nodes are reachable.

  2. Configure LSR IDs for the nodes, enable MPLS, MPLS TE, RSVP-TE, and CSPF on the LSRs globally and on their interfaces, and enable OSPF TE on the LSRs.

  3. Use CR-LSP attribute templates to simplify the configuration. Configure different attribute templates for the primary CR-LSP, hot-standby CR-LSP, and ordinary backup CR-LSP.

  4. On the ingress node of the primary tunnel, create a tunnel interface, configure the tunnel IP address, tunneling protocol, destination IP address, tunnel ID, and RSVP-TE signaling protocol for the tunnel interface, and then apply the corresponding CR-LSP attribute template to set up the primary CR-LSP.

  5. Configure hot-standby and ordinary backup CR-LSPs on the ingress node of the primary tunnel. In this way, traffic can be switched to the backup CR-LSP when the primary CR-LSP fails. Apply the CR-LSP corresponding attribute template to create the backup CR-LSP.

Procedure

  1. Assign IP addresses to interfaces and configure OSPF on the LSRs.

    # Configure LSRA. Assign IP addresses to interfaces of LSRB, LSRC, LSRE, and LSRF according to Figure 5-37. The configurations on these LSRs are similar to the configuration on LSRA, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRA
    [LSRA] vlan batch 100 400 600
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 400
    [LSRA-Vlanif400] ip address 172.4.1.1 255.255.255.0
    [LSRA-Vlanif400] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] ip address 172.6.1.1 255.255.255.0
    [LSRA-Vlanif600] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 2/0/0
    [LSRA-GigabitEthernet2/0/0] port link-type trunk
    [LSRA-GigabitEthernet2/0/0] port trunk allow-pass vlan 600
    [LSRA-GigabitEthernet2/0/0] quit
    [LSRA] interface gigabitethernet 3/0/0
    [LSRA-GigabitEthernet3/0/0] port link-type trunk
    [LSRA-GigabitEthernet3/0/0] port trunk allow-pass vlan 400
    [LSRA-GigabitEthernet3/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] network 172.4.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] network 172.6.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    After the configurations are complete, run the display ip routing-table command on the LSRs. You can see that the LSRs learn the routes of Loopback1 from each other. The command output on LSRA is provided as an example:

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 16       Routes : 18                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            1.1.1.9/32  Direct  0    0           D   127.0.0.1       LoopBack1      
            2.2.2.9/32  OSPF    10   1           D   172.1.1.2       Vlanif100
            3.3.3.9/32  OSPF    10   2           D   172.1.1.2       Vlanif100
                        OSPF    10   2           D   172.4.1.2       Vlanif400
                        OSPF    10   2           D   172.6.1.2       Vlanif600
            5.5.5.9/32  OSPF    10   1           D   172.4.1.2       Vlanif400
            6.6.6.9/32  OSPF    10   1           D   172.6.1.2       Vlanif600
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          172.1.1.0/24  Direct  0    0           D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
          172.2.1.0/24  OSPF    10   2           D   172.1.1.2       Vlanif100
          172.4.1.0/24  Direct  0    0           D   172.4.1.1       Vlanif400
          172.4.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif400
          172.5.1.0/24  OSPF    10   2           D   172.4.1.2       Vlanif400
          172.6.1.0/24  Direct  0    0           D   172.6.1.1       Vlanif600
          172.6.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif600
          172.7.1.0/24  OSPF    10   2           D   172.6.1.2       Vlanif600
    

  2. Configure basic MPLS capabilities and enable MPLS TE, RSVP-TE, and CSPF.

    # Configure LSRA. The configurations on LSRB, LSRC, LSRE, and LSRF are similar to the configuration on LSRA, and are not mentioned here. CSPF needs to be enabled only on the ingress node of the primary tunnel.

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 400
    [LSRA-Vlanif400] mpls
    [LSRA-Vlanif400] mpls te
    [LSRA-Vlanif400] mpls rsvp-te
    [LSRA-Vlanif400] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] mpls
    [LSRA-Vlanif600] mpls te
    [LSRA-Vlanif600] mpls rsvp-te
    [LSRA-Vlanif600] quit
    

  3. Configure OSPF TE.

    # Configure LSRA. The configurations on LSRB, LSRC, LSRE, and LSRF are similar to the configuration on LSRA, and are not mentioned here.

    [LSRA] ospf
    [LSRA-ospf-1] opaque-capability enable
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

  4. Configure CR-LSP attribute templates and specify explicit paths for the CR-LSPs.

    # Specify an explicit path for the primary CR-LSP.

    [LSRA] explicit-path pri-path
    [LSRA-explicit-path-pri-path] next hop 172.1.1.2
    [LSRA-explicit-path-pri-path] next hop 172.2.1.2
    [LSRA-explicit-path-pri-path] next hop 3.3.3.9
    [LSRA-explicit-path-pri-path] quit

    # Specify an explicit path for the hot-standby CR-LSP.

    [LSRA] explicit-path hotstandby-path
    [LSRA-explicit-path-hotstandby-path] next hop 172.4.1.2
    [LSRA-explicit-path-hotstandby-path] next hop 172.5.1.2
    [LSRA-explicit-path-hotstandby-path] next hop 3.3.3.9
    [LSRA-explicit-path-hotstandby-path] quit

    # Specify an explicit path for the ordinary backup CR-LSP.

    [LSRA] explicit-path ordinary-path
    [LSRA-explicit-path-ordinary-path] next hop 172.6.1.2
    [LSRA-explicit-path-ordinary-path] next hop 172.7.1.2
    [LSRA-explicit-path-ordinary-path] next hop 3.3.3.9
    [LSRA-explicit-path-ordinary-path] quit

    # Configure the CR-LSP attribute template used for setting up the primary CR-LSP.

    [LSRA] lsp-attribute lsp_attribute_pri
    [LSRA-lsp-attribute-lsp_attribute_pri] explicit-path pri-path
    [LSRA-lsp-attribute-lsp_attribute_pri] commit
    [LSRA-lsp-attribute-lsp_attribute_pri] quit

    # Configure the CR-LSP attribute template used for setting up the hot-standby CR-LSP.

    [LSRA] lsp-attribute lsp_attribute_hotstandby
    [LSRA-lsp-attribute-lsp_attribute_hotstandby] explicit-path hotstandby-path
    [LSRA-lsp-attribute-lsp_attribute_hotstandby] hop-limit 12
    [LSRA-lsp-attribute-lsp_attribute_hotstandby] commit
    [LSRA-lsp-attribute-lsp_attribute_hotstandby] quit

    # Configure the CR-LSP attribute template used for setting up the ordinary backup CR-LSP.

    [LSRA] lsp-attribute lsp_attribute_ordinary
    [LSRA-lsp-attribute-lsp_attribute_ordinary] explicit-path ordinary-path
    [LSRA-lsp-attribute-lsp_attribute_ordinary] hop-limit 15
    [LSRA-lsp-attribute-lsp_attribute_ordinary] commit
    [LSRA-lsp-attribute-lsp_attribute_ordinary] quit

  5. On the ingress node LSRA, create the MPLS TE tunnel on the primary CR-LSP.

    # Specify an MPLS TE tunnel interface for the primary CR-LSP and apply the primary CR-LSP attribute template to set up this CR-LSP.

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopBack 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 3.3.3.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te primary-lsp-constraint lsp-attribute lsp_attribute_pri
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

    Run the display interface tunnel 1 command on LSRA to check the tunnel status. The tunnel is in Up state.

    [LSRA] display interface tunnel 1
    Tunnel1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2013-01-22 16:57:00                                
    Description:
    ...

  6. Configure hot-standby and common backup CR-LSPs on the ingress node.

    # On LSRA, apply CR-LSP attribute templates to create hot-standby and common backup CR-LSPs.

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] mpls te hotstandby-lsp-constraint 1 lsp-attribute lsp_attribute_hotstandby
    [LSRA-Tunnel1] mpls te ordinary-lsp-constraint 1 lsp-attribute lsp_attribute_ordinary
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

    Run the display mpls te tunnel-interface command on LSRA to check tunnel information. You can see that the hot-standby CR-LSP has been set up successfully.

    [LSRA] display mpls te tunnel-interface
        ----------------------------------------------------------------            
                                   Tunnel1                                      
        ----------------------------------------------------------------            
        Tunnel State Desc   :  UP                                                   
        Active LSP          :  Primary LSP                                          
        Session ID          :  100                                                  
        Ingress LSR ID      :  1.1.1.9          Egress LSR ID:  3.3.3.9             
        Admin State         :  UP               Oper State   :  UP                  
        Primary LSP State      : UP                                                 
          Main LSP State       : READY               LSP ID  : 5                    
        Hot-Standby LSP State  : UP                                                 
          Main LSP State       : READY               LSP ID  : 32772                
                                                                           

  7. Verify the configuration.

    Run the display mpls te tunnel-interface lsp-constraint command on LSRA to view the configurations of the CR-LSP attribute templates.

    [LSRA] display mpls te tunnel-interface lsp-constraint
        Tunnel Name                     :  Tunnel1
        Primary-lsp-constraint Name     :  lsp_attribute_pri
        Hotstandby-lsp-constraint Number:  1
        Hotstandby-lsp-constraint Name  :  lsp_attribute_hotstandby
        Ordinary-lsp-constraint Number  :  1
        Ordinary-lsp-constraint Name    :  lsp_attribute_ordinary
    

    # Run the display mpls te tunnel verbose command on LSRA to view detailed tunnel information. You can see that the primary and hot-standby CR-LSPs have been set up using the attribute templates.

    [LSRA] display mpls te tunnel verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                          
        Tunnel Interface Name   :  Tunnel1                                          
        TunnelIndex             :  1           LSP Index         :  2048            
        Session ID              :  100         LSP ID            :  5               
        LSR Role                :  Ingress     LSP Type          :  Primary         
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif100                                        
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  1                                                
        ER-Hop Table Index      :  0           AR-Hop Table Index:  0               
        C-Hop Table Index       :  1                                                
        PrevTunnelIndexInSession:  2           NextTunnelIndexInSession:  -         
        PSB Handle              :  8194                                             
        Created Time            :  2013-09-16 14:53:15+00:00                        
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
                                                                                    
                                                                                    
        No                      :  2                                                
        Tunnel-Name             :  Tunnel1                                          
        Tunnel Interface Name   :  Tunnel1                                          
        TunnelIndex             :  2           LSP Index         :  2050            
        Session ID              :  100         LSP ID            :  32772           
        LSR Role                :  Ingress     LSP Type          :  Hot-Standby     
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif400                                        
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  1                                                
        ER-Hop Table Index      :  1           AR-Hop Table Index:  1               
        C-Hop Table Index       :  2                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  1         
        PSB Handle              :  8195                                             
        Created Time            :  2013-09-16 14:53:15+00:00                        
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
                                                                                    
    

    # Run the shutdown command on GE1/0/0 and GE3/0/0 of LSRA.

    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] shutdown
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 3/0/0
    [LSRA-GigabitEthernet3/0/0] shutdown
    [LSRA-GigabitEthernet3/0/0] quit

    # Run the display mpls te tunnel verbose command on LSRA. You can see that an ordinary CR-LSP has been set up using the attribute template.

    [LSRA] display mpls te tunnel verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                          
        Tunnel Interface Name   :  Tunnel1                                          
        TunnelIndex             :  2           LSP Index         :  2048            
        Session ID              :  100         LSP ID            :  32774           
        LSR Role                :  Ingress     LSP Type          :  Ordinary        
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif600                                        
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  1                                                
        ER-Hop Table Index      :  2           AR-Hop Table Index:  1               
        C-Hop Table Index       :  2                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8196                                             
        Created Time            :  2013-09-16 15:00:08+00:00                        
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
                                                                                    
    

Configuration File

  • LSRA configuration file

    #
    sysname LSRA
    #
    vlan batch 100 400 600
    #
    mpls lsr-id 1.1.1.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te                                                                   
     mpls te cspf 
    #
    explicit-path hotstandby-path
     next hop 172.4.1.2
     next hop 172.5.1.2
     next hop 3.3.3.9 
    #
    explicit-path ordinary-path
     next hop 172.6.1.2
     next hop 172.7.1.2
     next hop 3.3.3.9 
    #
    explicit-path pri-path
     next hop 172.1.1.2
     next hop 172.2.1.2
     next hop 3.3.3.9 
    #
    lsp-attribute lsp_attribute_hotstandby
     explicit-path hotstandby-path
     hop-limit 12
     commit
    #
    lsp-attribute lsp_attribute_ordinary
     explicit-path ordinary-path
     hop-limit 15
     commit
    #
    lsp-attribute lsp_attribute_pri
     explicit-path pri-path
     commit
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #    
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif600
     ip address 172.6.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #    
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te tunnel-id 100
     mpls te primary-lsp-constraint lsp-attribute lsp_attribute_pri
     mpls te hotstandby-lsp-constraint 1 lsp-attribute lsp_attribute_hotstandby
     mpls te ordinary-lsp-constraint 1 lsp-attribute lsp_attribute_ordinary
     mpls te record-route 
     mpls te commit
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.4.1.0 0.0.0.255
      network 172.6.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRB configuration file

    #
    sysname LSRB
    #
    vlan batch 100 200
    # 
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    # 
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.2.1.0 0.0.0.255                                                   
      mpls-te enable
    #
    return
  • LSRC configuration file

    #
    sysname LSRC
    #
    vlan batch 200 500 700
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0                                                       
      network 172.2.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRE configuration file

    #
    sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0                                                       
      network 172.4.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRF configuration file

    #
    sysname LSRF
    #
    vlan batch 600 700
    #
    mpls lsr-id 6.6.6.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif600
     ip address 172.6.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 6.6.6.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 6.6.6.9 0.0.0.0                                                       
      network 172.6.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
Translation
Download
Updated: 2019-04-18

Document ID: EDOC1000141902

Views: 70277

Downloads: 189

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next