No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

S7700 and S9700 V200R010C00

This document describes IP multicast basics and how to configure IP multicast features, including IGMP/MLD, PIM (IPv4&IPv6), MSDP, multicast VPN, Layer 3 multicast CAC, Layer 2 multicast CAC, IGMP/MLD snooping, and multicast VLAN, IPv4&IPv6 multicast route management, static multicast MAC address, multicast network.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring PIM GR

Example for Configuring PIM GR

Networking Requirements

In a multicast application, if an active/standby switchover occurs on the device, the new active main processing unit (MPU) deletes multicast forwarding entries on the line processing units (LPUs) and relearns the PIM routing table and multicast forwarding entries. During this process, multicast traffic forwarding is interrupted.

The PIM graceful restart (GR) function on an IPTV network can protect the core devices and edge devices. When an active/standby switchover occurs, the PIM GR function ensures that the multicast data is forwarded normally. Therefore, the fault tolerance capability of the devices on the IPTV network is improved.

Basic PIM-SM configuration has been completed on the network shown in Figure 4-24, and user hosts on the network can receive multicast data. Enable PIM GR on SwitchC. When SwitchC forwards multicast data to the receiver, the active MPU backs up the PIM routing table and Join/Prune messages to be sent to upstream devices to the standby MPU. When the active/standby switchover occurs on SwitchC, LPUs maintain existing forwarding entries to ensure nonstop forwarding of multicast data. The receiver can receive multicast data from the source during the active/standby switchover.

Figure 4-24  Network diagram for configuring PIM GR

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface on the switch and a unicast routing protocol.

  2. Enable the unicast GR function on each switch and set the unicast GR period.

  3. Enable the multicast function, enable PIM-SM on each interface on the switch, and enable IGMP on interfaces that connect the switch and hosts.

  4. Configure the same static rendezvous point (RP) on each switch.

  5. Enable the PIM GR function on SwitchC and set the GR period.

Procedure

  1. Configure an IP address for each interface on the switch and a unicast routing protocol.

    # Configure the IP address and mask on each interface on the switch shown in Figure 4-24, and configure Open Shortest Path First (OSPF) on each switch to ensure that SwitchA, SwitchB, and SwitchC can communicate at the network layer. The configuration of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not provided here.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type trunk
    [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/0] quit
    [SwitchA] interface gigabitethernet2/0/0
    [SwitchA-GigabitEthernet2/0/0] port link-type trunk
    [SwitchA-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet2/0/0] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.2.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.110.1.1 24
    [SwitchA-Vlanif20] quit
    [SwitchA] interface loopback 0
    [SwitchA-LoopBack0] ip address 10.1.1.1 32
    [SwitchA-LoopBack0] quit
    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.0
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
    .

  2. Enable the unicast GR function on each switch and set the GR period.

    # Enable the unicast GR function on each switch and set the unicast GR period to 200 seconds. The configuration of SwitchA and SwitchB are similar to the configuration of SwitchC, and are not provided.

    [SwitchC] ospf 1
    [SwitchC-ospf-1] opaque-capability enable
    [SwitchC-ospf-1] graceful-restart
    [SwitchC-ospf-1] graceful-restart period 200
    [SwitchC-ospf-1] quit

  3. Enable the multicast function, enable PIM-SM on each interface on the switch, and enable IGMP on interfaces that connect the switch and hosts.

    # Configure SwitchA.

    [SwitchA] multicast routing-enable
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] pim sm
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] pim sm
    [SwitchA-Vlanif20] quit
    [SwitchA] interface loopback 0
    [SwitchA-LoopBack0] pim sm
    [SwitchA-LoopBack0] quit

    # Configure SwitchB.

    [SwitchB] multicast routing-enable
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] pim sm
    [SwitchB-Vlanif10] quit
    [SwitchB] interface vlanif 40
    [SwitchB-Vlanif40] pim sm
    [SwitchB-Vlanif40] quit

    # Configure SwitchC.

    [SwitchC] multicast routing-enable
    [SwitchC] interface vlanif 60
    [SwitchC-Vlanif60] pim sm
    [SwitchC-Vlanif60] igmp enable
    [SwitchC-Vlanif60] quit
    [SwitchC] interface vlanif 40
    [SwitchC-Vlanif40] pim sm
    [SwitchC-Vlanif40] quit

  4. Configure the static RP.

    NOTE:

    The local loopback interface is always in Up state and has high stability. Therefore, you are advised to configure a static RP address for a loopback interface.

    # Configure the static RP on each switch. The configuration of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned.

    [SwitchA] pim
    [SwitchA-pim] static-rp 10.1.1.1
    [SwitchA-pim] quit

  5. Enable PIM GR and set the PIM GR period.

    # Enable PIM GR on SwitchC and set the PIM GR period to 300s.

    [SwitchC] pim
    [SwitchC-pim] graceful-restart
    [SwitchC-pim] graceful-restart period 300
    [SwitchC-pim] quit

  6. Verify the configuration.

    # Multicast source 10.110.1.100 sends data to multicast group 225.1.1.1. Host A sends an IGMP Report message to join the multicast group and receives multicast data from the multicast source. Before SwitchC performs an active/standby switchover, run the display pim routing-table command on SwitchB and SwitchC to view the routing table. The following information is displayed.

    [SwitchB] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 10.1.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 01:52:38
         Upstream interface: Vlanif10
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                Protocol: igmp, UpTime: 01:52:38, Expires: 00:02:53
    
     (10.110.1.100, 225.1.1.1)
         RP: 10.1.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 01:52:38
         Upstream interface: Vlanif10
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 01:52:38, Expires: 00:03:03  
    [SwitchC] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 10.1.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 01:51:24
         Upstream interface: Vlanif40
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: igmp, UpTime: 01:51:24, Expires: -
    
     (10.110.1.100, 225.1.1.1)
         RP: 10.1.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 01:51:24
         Upstream interface: Vlanif40
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 01:51:24, Expires: -
    

    # Trigger an active/standby switchover on SwitchC.

    [SwitchC] slave switchover

    The system displays a message, indicating that an active/standby switchover will be performed. Enter Y to continue.

    # After SwitchC performs the active/standby switchover, during the PIM GR, run the display pim routing-table command on SwitchB and SwitchC to view the routing table. The following information is displayed.

    [SwitchB] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 10.1.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 02:52:38
         Upstream interface: Vlanif10
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 02:52:38, Expires: 00:03:00
    
     (10.110.1.100, 225.1.1.1)
         RP: 10.1.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 02:52:38
         Upstream interface: Vlanif10
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 02:52:38, Expires: 00:03:12  
    [SwitchC] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 10.1.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 02:51:24
         Upstream interface: Vlanif40
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: igmp, UpTime: 02:51:24, Expires: -
    
     (10.110.1.100, 225.1.1.1)
         RP: 10.1.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 02:51:24
         Upstream interface: Vlanif40
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 02:51:24, Expires: -
    

    In a normal multicast network, the downstream switch periodically sends Join/Prune packets to upstream devices to refresh the timeout period of upstream PIM routing entries so that the multicast data is forwarded normally.

    If the GR function is not configured on SwitchC, the new active MPU deletes the multicast forwarding entries of LPUs, receives the IGMP Report packets sent by hosts, and creates the PIM routing entries. During this process, multicast traffic forwarding is interrupted.

    The preceding information indicates that after SwitchC performs an active/standby switchover, the downstream interface on SwitchB remains unchanged. After SwitchC performs the active/standby switchover, it sends the backup Join messages to the upstream devices. In this way, the multicast forwarding entries are maintained during GR to ensure that multicast data forwarding is not interrupted.

    During the restoration of multicast routing entries on SwitchC, users can still receive multicast data normally and services are not affected.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     opaque-capability enable 
     graceful-restart period 200
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     static-rp 10.1.1.1 
    #
    return  
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 40
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     opaque-capability enable 
     graceful-restart period 200 
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 10.1.1.1 
    #
    return  
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 40 60
    #
    multicast routing-enable
    #
    interface Vlanif40
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface Vlanif60
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     opaque-capability enable 
     graceful-restart period 200 
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 10.1.1.1 
     graceful-restart 
     graceful-restart period 300 
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000141903

Views: 154656

Downloads: 111

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next