No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

S7700 and S9700 V200R010C00

This document describes IP multicast basics and how to configure IP multicast features, including IGMP/MLD, PIM (IPv4&IPv6), MSDP, multicast VPN, Layer 3 multicast CAC, Layer 2 multicast CAC, IGMP/MLD snooping, and multicast VLAN, IPv4&IPv6 multicast route management, static multicast MAC address, multicast network.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the MLD Snooping Querier

Example for Configuring the MLD Snooping Querier

Networking Requirements

In Figure 12-8, Source1 and Source2 on a Layer 2 network send multicast data to FF16::1 and FF16::2. HostA and HostC need to receive data of multicast group FF16::1, whereas HostB and Host D need to receive data of multicast group FF16::2.

Figure 12-8  Network diagram for configuring MLD snooping querier

Configuration Roadmap

Enable MLD snooping on each switch in the network and configure MLD snooping querier to meet the service requirement. Enable each switch to discard unknown multicast packets to prevent the device from broadcasting multicast packets in a VLAN when there is no corresponding Layer 2 forwarding entry.

  1. According to Figure 12-8, create a VLAN on the switches and add interfaces to the VLAN.
  2. Enable MLD snooping globally and in the VLAN on all the switches.
  3. Configure SwitchA closest to the multicast source as the MLD snooping querier.
  4. Enable all the switches to discard unknown multicast packets.

Procedure

  1. Create a VLAN and add interfaces to the VLAN. The configurations of SwitchB, SwitchC and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 2/0/2
    [SwitchA-GigabitEthernet2/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet2/0/2] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet2/0/2] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet2/0/2] quit
    [SwitchA] interface gigabitethernet 3/0/3
    [SwitchA-GigabitEthernet3/0/3] port link-type hybrid
    [SwitchA-GigabitEthernet3/0/3] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet3/0/3] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet3/0/3] quit

  2. Enable MLD snooping.

    # Configure SwitchA. The configurations of SwitchB, SwitchC and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    [SwitchA] mld-snooping enable
    [SwitchA] vlan 10
    [SwitchA-vlan10] mld-snooping enable
    [SwitchA-vlan10] quit

  3. Configure MLD snooping querier.

    # Configure SwitchA as the querier.

    [SwitchA] vlan 10
    [SwitchA-vlan10] mld-snooping querier enable
    [SwitchA-vlan10] quit

  4. Configure the switches to discard unknown multicast packets.

    # Configure SwitchA. The configurations of SwitchB, SwitchC and SwitchD are similar to the configuration of SwitchA, and are not mentioned here.

    [SwitchA] vlan 10
    [SwitchA-vlan10] multicast drop-unknown
    [SwitchA-vlan10] quit
    

  5. Verify the configuration.

    # After the MLD snooping querier starts to work, all devices except the querier can receive MLD General Query messages. Use the following command to check MLD packet statistics, such as statistics about received MLD packets on SwitchB.

    [SwitchB] display mld-snooping statistics vlan 10
     MLD Snooping Packets Counter                                                   
       Statistics for VLAN 10                                                       
         Recv V1 Report  316                                                        
         Recv V2 Report  0                                                          
         Recv V1 Query  305                                                        
         Recv V2 Query   0                                                          
         Recv Done       2                                                          
         Recv Pim Hello  85                                                         
         Send Query(S=0) 1                                                          
         Send Query(S!=0)0                                                          
         Send General Query               0                                         
         Send Group-Specific Query        0                                         
         Send Group-Source-Specific Query 0                                         

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    mld-snooping enable
    #
    vlan 10
     multicast drop-unknown
     mld-snooping enable
     mld-snooping querier enable
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet2/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet3/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    mld-snooping enable
    #
    vlan 10
     multicast drop-unknown
     mld-snooping enable
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet2/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet3/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet4/0/4
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    mld-snooping enable
    #
    vlan 10
     multicast drop-unknown
     mld-snooping enable
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet2/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet3/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 10
    #
    mld-snooping enable
    #
    vlan 10
     multicast drop-unknown
     mld-snooping enable
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet2/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000141903

Views: 146710

Downloads: 111

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next