No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

S7700 and S9700 V200R010C00

This document describes IP multicast basics and how to configure IP multicast features, including IGMP/MLD, PIM (IPv4&IPv6), MSDP, multicast VPN, Layer 3 multicast CAC, Layer 2 multicast CAC, IGMP/MLD snooping, and multicast VLAN, IPv4&IPv6 multicast route management, static multicast MAC address, multicast network.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv6 PIM GR

Example for Configuring IPv6 PIM GR

Networking Requirements

Multicast services are deployed on the network shown in Figure 5-4. An active/standby switchover needs to be performed on SwitchC. To ensure uninterrupted VoD services for downstream users, the LPUs of SwitchC must be able to forward multicast data during the active/standby switchover.

Figure 5-4  Network diagram for configuring PIM GR

Switch VLANIF Interface/Loopback Interface IPv6 Address
SwitchA VLANIF10 FC00:0:0:2001:2::1/64
  VLANIF20 FC00:0:0:2001:1::2/64
  Loopback0 FC00:0:0:2002:1::1/64
SwitchB VLANIF10 FC00:0:0:2001:2::2/64
  VLANIF40 FC00:0:0:2001:5::1/64
SwitchC VLANIF40 FC00:0:0:2001:5::2/64
  VLANIF60 FC00:0:0:2001:6::1/64

Configuration Roadmap

In a multicast application, if an active/standby switchover occurs on a switch, the new master main processing unit (MPU) deletes multicast forwarding entries from the line processing units (LPUs) and relearns IPv6 PIM routes and multicast forwarding entries. During this process, multicast traffic is interrupted. When IPv6 PIM GR is enabled on SwitchC, its master MPU backs up multicast information to the slave MPU when SwitchC forwards multicast data to receivers. The information that is backed up includes the IPv6 PIM routes and Join/Prune messages to be sent upstream. When an active/standby switchover occurs on SwitchC, the LPUs maintain the existing forwarding entries to ensure uninterrupted forwarding of multicast data. The receivers can still receive multicast data from the source during the active/standby switchover.

The configuration roadmap is as follows:

  1. Configure an IPv6 address for each interface on the switch and an IPv6 unicast routing protocol.

  2. Enable the unicast graceful restart (GR) function on each switch and set the unicast GR period. PIM GR depends on the unicast GR function.

  3. Enable the IPv6 multicast function, enable IPv6 PIM-SM on each interface on the switch, and enable MLD on interfaces that connect the switch and hosts.

  4. Configure the same static rendezvous point (RP) address on each switch.

  5. Enable the IPv6 PIM GR function on switchC and set the GR period.

Procedure

  1. Configure an IPv6 address for each interface on the switch and an IPv6 unicast routing protocol.

    # Configure IPv6 addresses and masks for VLANIF interfaces on the switches and run Open Shortest Path First version 3 (OSPFv3) between the switches to ensure that they can communicate at the network layer. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not provided here.

    [SwitchA] ipv6
    [SwitchA] ospfv3
    [SwitchA-ospfv3-1] router-id 1.1.1.1
    [SwitchA-ospfv3-1] quit
    [SwitchA] vlan batch 10 20
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ipv6 enable
    [SwitchA-Vlanif10] ipv6 address fc00:0:0:2001:2::1 64
    [SwitchA-Vlanif10] ospfv3 1 area 0
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ipv6 enable
    [SwitchA-Vlanif20] ipv6 address fc00:0:0:2001:1::2 64
    [SwitchA-Vlanif20] ospfv3 1 area 0
    [SwitchA-Vlanif20] quit
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/0] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/0] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/0] quit
    [SwitchA] interface gigabitethernet 2/0/0
    [SwitchA-GigabitEthernet2/0/0] port link-type trunk
    [SwitchA-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet2/0/0] quit
    

  2. Enable the unicast GR function on each switch and set the GR period.

    # Enable the unicast GR function on each switch and set the unicast GR period to 200 seconds. The configuration of SwitchA and SwitchB are similar to the configuration of SwitchC, and are not provided.

    [SwitchC] ospfv3
    [SwitchC-ospfv3-1] graceful-restart
    [SwitchC-ospfv3-1] graceful-restart period 200
    [SwitchC-ospfv3-1] quit

  3. Enable the multicast function, enable PIM-SM on each interface on the switch, and enable MLD on interfaces that connect the switch and hosts.

    # Enable the IPv6 multicast function on each switch, enable IPv6 PIM-SM on interfaces on each switch, and enable MLD on interfaces that connect SwitchC and hosts. The configuration of SwitchA and SwitchB are similar to the configuration of SwitchC, and are not provided here.

    [SwitchC] multicast ipv6 routing-enable
    [SwitchC] interface vlanif 60
    [SwitchC-Vlanif60] pim ipv6 sm
    [SwitchC-Vlanif60] mld enable
    [SwitchC-Vlanif60] quit
    [SwitchC] interface vlanif 40
    [SwitchC-Vlanif40] pim ipv6 sm
    [SwitchC-Vlanif40] quit

  4. Configure the static RP.

    # Create a Loopback interface on SwitchA and enable IPv6 PIM-SM on the interface.

    [SwitchA] interface loopback 0
    [SwitchA-LoopBack0] ipv6 enable
    [SwitchA-LoopBack0] ipv6 address fc00:0:0:2002:1::1 64
    [SwitchA-LoopBack0] pim ipv6 sm
    [SwitchA-LoopBack0] ospfv3 1 area 0
    [SwitchA-LoopBack0] quit

    # Configure a static RP on all the switches. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not provided here.

    [SwitchA] pim-ipv6
    [SwitchA-pim6] static-rp fc00:0:0:2002:1::1
    [SwitchA-pim6] quit

  5. Enable IPv6 PIM GR and set the IPv6 PIM GR period.

    # Enable IPv6 PIM GR on SwitchC and set the IPv6 PIM GR period to 300s.

    [SwitchC] pim-ipv6
    [SwitchC-pim6] graceful-restart
    [SwitchC-pim6] graceful-restart period 300
    [SwitchC-pim6] quit

  6. Verify the configuration.

    # Configure the multicast source (FC00:0:0:2001:1::1) to send data to the multicast group (FF2E::1) and configure HostA to send an MLD Report message to join the multicast group. HostA can receive data from the multicast source. Before an active/standby switchover on SwitchC, run the display pim ipv6 routing-table command on SwitchB and SwitchC to view their multicast routing tables. The command output is as follows:

    <SwitchB> display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: FC00:0:0:2002:1::1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:00:53
         Upstream interface: Vlanif10
             Upstream neighbor: FE80::E0:F2C:3C02:1
             RPF prime neighbor: FE80::E0:F2C:3C02:1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:00:53, Expires: 00:02:37
    
     (FC00:0:0:2001:1::1, FF2E::1)
         RP: FC00:0:0:2002:1::1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:21:24
         Upstream interface: Vlanif10
             Upstream neighbor: FE80::E0:F2C:3C02:1
             RPF prime neighbor: FE80::E0:F2C:3C02:1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:00:53, Expires: 00:03:07
    <SwitchC> display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: FC00:0:0:2002:1::1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:01:16
         Upstream interface: Vlanif40
             Upstream neighbor: FE80::5463:0:9245:2
             RPF prime neighbor: FE80::5463:0:9245:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: mld, UpTime: 00:01:16, Expires: -
    
     (FC00:0:0:2001:1::1, FF2E::1)
         RP: FC00:0:0:2002:1::1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:01:16
         Upstream interface: Vlanif40
             Upstream neighbor: FE80::5463:0:9245:2
             RPF prime neighbor: FE80::5463:0:9245:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:01:16, Expires: - 

    # Perform an active/standby switchover on SwitchC.

    [SwitchC] slave switchover

    # During the PIM GR process, run the display pim ipv6 routing-table command on SwitchB and SwitchC to view the routing tables. The following information is displayed.

    <SwitchB> display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: FC00:0:0:2002:1::1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:20
         Upstream interface: Vlanif10
             Upstream neighbor: FE80::E0:F2C:3C02:1
             RPF prime neighbor: FE80::E0:F2C:3C02:1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:02:20, Expires: 00:03:10
    
     (FC00:0:0:2001:1::1, FF2E::1)
         RP: FC00:0:0:2002:1::1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:02:20
         Upstream interface: Vlanif10
             Upstream neighbor: FE80::E0:F2C:3C02:1
             RPF prime neighbor: FE80::E0:F2C:3C02:1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:02:20, Expires: 00:03:17
    
    <SwitchC> display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: FC00:0:0:2002:1::1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:44
         Upstream interface: Vlanif40
             Upstream neighbor: FE80::5463:0:9245:2
             RPF prime neighbor: FE80::5463:0:9245:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: mld, UpTime: 00:02:44, Expires: -
    
     (FC00:0:0:2001:1::1, FF2E::1)
         RP: FC00:0:0:2002:1::1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:02:44
         Upstream interface: Vlanif40
             Upstream neighbor: FE80::5463:0:9245:2
             RPF prime neighbor: FE80::5463:0:9245:2
         Downstream interface(s) information:                    
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:02:44, Expires: - 

    In a normal multicast network, the downstream switch periodically sends Join/Prune packets to upstream devices to refresh the timeout period of upstream IPv6 PIM routing entries so that the multicast data is forwarded normally.

    If the GR function is not configured on SwitchC, the new active MPU deletes the IPv6 multicast forwarding entries of LPUs, receives the MLD Report packets sent by hosts, and creates the PIM routing entries. During this process, multicast traffic forwarding is interrupted.

    The preceding information indicates that after SwitchC performs an active/standby switchover, the downstream interface on SwitchB remains unchanged. After SwitchC performs the active/standby switchover, it sends the backup Join messages to the upstream devices. In this way, the multicast forwarding entries are maintained during GR to ensure that multicast data forwarding is not interrupted.

    During the restoration of multicast routing entries on SwitchC, users can still receive multicast data normally and services are not affected.

Configuration Files

  • SwitchA configuration file

    #
     sysname SwitchA
    #
     vlan batch 10 20
    #
     ipv6
    #
     multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 1.1.1.1
     graceful-restart period 200
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001:2::1/64
     ospfv3 1 area 0.0.0.0
     pim ipv6 sm
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2001:1::2/64
     ospfv3 1 area 0.0.0.0
     pim ipv6 sm
    #
    interface GigabitEthernet1/0/0
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address FC00:0:0:2002:1::1/64
     ospfv3 1 area 0.0.0.0
     pim ipv6 sm 
    #
    pim-ipv6
     static-rp FC00:0:0:2002:1::1
    #
    return
  • SwitchB configuration file
    #
     sysname SwitchB
    #
     vlan batch 10 40
    #
     ipv6
    #
     multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 2.2.2.2
     graceful-restart period 200
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001:2::2/64
     ospfv3 1 area 0.0.0.0
     pim ipv6 sm
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2001:5::1/64
     ospfv3 1 area 0.0.0.0
     pim ipv6 sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    pim-ipv6
     static-rp FC00:0:0:2002:1::1
    #
    return
  • SwitchC configuration file

    #
     sysname SwitchC
    #
     vlan batch 40 60
    #
     ipv6
    #
     multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 3.3.3.3
     graceful-restart period 200
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2001:5::2/64
     ospfv3 1 area 0.0.0.0
     pim ipv6 sm
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:2001:6::1/64
     ospfv3 1 area 0.0.0.0
     pim ipv6 sm
     mld enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface GigabitEthernet2/0/0
     port link-type hybrid
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    pim-ipv6
     static-rp FC00:0:0:2002:1::1
     graceful-restart
     graceful-restart period 300
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000141903

Views: 144421

Downloads: 111

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next