No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

S7700 and S9700 V200R010C00

This document describes IP multicast basics and how to configure IP multicast features, including IGMP/MLD, PIM (IPv4&IPv6), MSDP, multicast VPN, Layer 3 multicast CAC, Layer 2 multicast CAC, IGMP/MLD snooping, and multicast VLAN, IPv4&IPv6 multicast route management, static multicast MAC address, multicast network.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Layer 3 Multicast CAC

Example for Configuring Layer 3 Multicast CAC

Networking Requirements

As shown in Figure 8-2, SwitchA is the last-hop device that connects user network segments to the Protocol Independent Multicast (PIM) network. The PIM network runs PIM Sparse Mode (PIM-SM). The following Layer 3 multicast CAC settings need to be configured on SwitchA to meet service requirements:

  • Configure a global CAC limit to control the number of all multicast groups on SwitchA, ensuring high-quality programs for most of users.
  • Create two channels: standard-definition television (SDTV) and high-definition television (HDTV). Configure different global CAC limits for the channels based on the subscription fees of the channels.
  • Configure different CAC limits for the two channels on the user-side interfaces connected to user network segments, based on interests of users for the programs.
Figure 8-2  Network diagram for Layer 3 multicast CAC configuration

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable PIM-SM and Internet Group Management Protocol (IGMP) on user-side interfaces, and enable PIM-SM on network-side interfaces. This configuration example provides only the configuration on user-side interfaces. For the configuration on network-side interfaces, see Configuring IPv4 PIM-SM.
  2. Set the global CAC limit to 100 to control the multicast data traffic forwarded by SwitchA within the bandwidth capacity of user-side links. In this way, most users can watch high-quality programs.
  3. Create channels SDTV and HDTV. Configure group address range 225.0.0.1 to 225.0.0.255 for channel SDTV and group address range 226.0.0.1 to 226.0.0.255 for channel HDTV. Considering subscription fees of the two channels, set the CAC limit for channel SDTV to 40 and the CAC limit for channel HDTV to 60.
  4. To meet different program requirements on the user network segments, set CAC limits on the user-side interfaces as follows:
    • On VLANIF 10, set the CAC limit for channel SDTV to 30 and the CAC limit for channel HDTV to 20.
    • On VLANIF 20, set the CAC limit for channel SDTV to 10 and the CAC limit for channel HDTV to 40.

Procedure

  1. Create VLANs on SwitchA and add user-side physical interfaces to the VLANs.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type trunk
    [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/0] quit
    [SwitchA] interface gigabitethernet 2/0/0
    [SwitchA-GigabitEthernet2/0/0] port link-type trunk
    [SwitchA-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet2/0/0] quit
    

  2. Create VLANIF interfaces and configure Open Shortest Path First (OSPF) on SwitchA.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 192.168.2.1 24
    [SwitchA-Vlanif20] quit
    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
    

  3. On SwitchA, enable multicast routing, and enable PIM-SM and IGMP on the VLANIF interfaces connected to user network segments.

    [SwitchA] multicast routing-enable
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] pim sm
    [SwitchA-Vlanif10] igmp enable
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] pim sm
    [SwitchA-Vlanif20] igmp enable
    [SwitchA-Vlanif20] quit
    

  4. Configure a global CAC limit to control the total number of multicast groups on SwitchA.

    [SwitchA] multicast-channel
    [SwitchA-multicast-channel] multicast limit 100
    

  5. Create channels SDTV and HDTV and configure group address ranges and CAC limits for the two channels.

    [SwitchA-multicast-channel] channel SDTV type asm
    [SwitchA-multicast-channel-SDTV] group 225.0.0.0 mask 255.255.255.0
    [SwitchA-multicast-channel-SDTV] multicast limit 40
    [SwitchA-multicast-channel-SDTV] quit
    [SwitchA-multicast-channel] channel HDTV type asm
    [SwitchA-multicast-channel-HDTV] group 226.0.0.0 mask 255.255.255.0
    [SwitchA-multicast-channel-HDTV] multicast limit 60
    [SwitchA-multicast-channel-HDTV] quit
    [SwitchA-multicast-channel] quit
    

  6. Configure CAC limits for the two channels on VLANIF interfaces connected to user network segments.

    # On VLANIF10, set the CAC limit for channel SDTV to 30 and the CAC limit for channel HDTV to 20.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] multicast limit channel SDTV out max-entry 30
    [SwitchA-Vlanif10] multicast limit channel HDTV out max-entry 20
    [SwitchA-Vlanif10] quit
    

    # On VLANIF 20, set the CAC limit for channel SDTV to 10 and the CAC limit for channel HDTV to 40.

    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] multicast limit channel SDTV out max-entry 10
    [SwitchA-Vlanif20] multicast limit channel HDTV out max-entry 40
    [SwitchA-Vlanif20] quit
    [SwitchA] quit

  7. Verify the configuration.

    # Run the display multicast limit global command on SwitchA to view the global multicast CAC configuration and statistics.

    <SwitchA> display multicast limit global
    Multicast limitation information of instance: public net
      Global entries      : 100
      Global threshold    : -
      Global Used-Entries : 2
    

    # Run the display multicast limit channel channel-name global command on SwitchA to view the multicast CAC configuration and statistics for a specified channel. For example, the multicast CAC configuration and statistics for channel SDTV are as follows:

    <SwitchA> display multicast limit channel SDTV global
    Multicast limitation information of instance: public net
      -----------------------------------------------------------------------
      Channel Program         Mode  Entries  Threshold  Used-Entries
      -----------------------------------------------------------------------
      SDTV                    ASM   40       -          30
      -----------------------------------------------------------------------
    

    # Run the display multicast limit channel channel-name out-interface command on SwitchA to view the multicast CAC configuration and statistics for a specified channel on an outbound interface.

    <SwitchA> display multicast limit channel SDTV out-interface all
    Multicast limitation information of instance: public net
     Channel Program: SDTV
     -------------------------------------------------------------------------------
     Interface          Entries Bandwidth(kbit/s) Used-Entries Used-Bandwidth(kbit/s)
     -------------------------------------------------------------------------------
     Vlanif20           10      -                  10           -
     Vlanif10           30      -                  20           -
     -------------------------------------------------------------------------------
    
    <SwitchA> display multicast limit channel HDTV out-interface all
    Multicast limitation information of instance: public net
     Channel Program: HDTV
     -------------------------------------------------------------------------------
     Interface          Entries Bandwidth(kbit/s) Used-Entries Used-Bandwidth(kbit/s)
     -------------------------------------------------------------------------------
     Vlanif20           40      -                  20           -
     Vlanif10           20      -                  15           -
     -------------------------------------------------------------------------------
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    multicast routing-enable
    #
    multicast-channel
     multicast limit 100
     channel HDTV type asm
      multicast limit 60
      group 226.0.0.0 mask 255.255.255.0
     channel SDTV type asm
      multicast limit 40
      group 225.0.0.0 mask 255.255.255.0
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
     pim sm
     igmp enable
     multicast limit channel HDTV out max-entry 20
     multicast limit channel SDTV out max-entry 30
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
     pim sm
     igmp enable
     multicast limit channel HDTV out max-entry 40
     multicast limit channel SDTV out max-entry 10
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
    
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000141903

Views: 153121

Downloads: 111

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next