No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

S7700 and S9700 V200R010C00

This document describes IP multicast basics and how to configure IP multicast features, including IGMP/MLD, PIM (IPv4&IPv6), MSDP, multicast VPN, Layer 3 multicast CAC, Layer 2 multicast CAC, IGMP/MLD snooping, and multicast VLAN, IPv4&IPv6 multicast route management, static multicast MAC address, multicast network.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VSI-based Layer 2 Multicast CAC

Example for Configuring VSI-based Layer 2 Multicast CAC

Networking Requirements

As shown in Figure 15-6, VSI orange and VSI blue are configured on the VPLS network for two enterprises. Each VSI has a multicast source deployed in a site to provide video-on-demand services for users in the VSI. Each multicast group consumes 18 Mbit/s of link bandwidth. Users in VSI blue are more interested in programs of channel XXTV provided by Source2 (with a group address range of 225.0.0.1 to 225.0.0.255 and 30 programs). To provide high-quality programs for most users and reserve sufficient bandwidth for programs that users are interested in, VSI-based Layer 2 multicast CAC needs to be configured on the VPLS network.

Figure 15-6  Network diagram for VSI-based Layer 2 multicast CAC configuration

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IGMP snooping on the VPLS network. Layer 2 multicast CAC can function only after IGMP snooping is enabled.
  2. On PE3, set the global CAC limit for multicast groups to 100 to ensure sufficient bandwidth on attachment circuit (AC) side links.
  3. On PE3, set the CAC limit for multicast groups in VSI orange to 50 to ensure sufficient bandwidth on the AC-side link connected to GE4/0/0.
  4. Create a channel on PE3 and configure a group address range for the channel. On PE3, set the CAC limit for multicast groups in XXTV to 30 on GE3/0/0, to ensure sufficient bandwidth for programs that users in VSI blue are interested in.

Procedure

  1. Configure IP address for PE interfaces, and add physical interfaces to specified VLANs.

    # Configure PE1. The configurations of PE2 and PE2 are similar to the configuration of PE1, and the configurations are not provided here.

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan batch 10
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] port link-type trunk
    [PE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] ip address 10.1.1.2 24
    [PE1-Vlanif10] quit
    [PE1] interface loopback1
    [PE1-LoopBack1] ip address 1.1.1.1 32
    [PE1-LoopBack1] quit

  2. Configure Open Shortest Path First (OSPF) to advertise the network segments connected to VLANIF interfaces and the host routes of the label switched router (LSR) IDs.

    # Configure PE1. The configurations of PE2 and PE2 are similar to the configuration of PE1, and the configurations are not provided here.

    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

  3. Configure basic Multiprotocol Label Switching (MPLS) functions and Label Distribution Protocol (LDP).

    # Configure PE1.

    [PE1] mpls lsr-id 1.1.1.1
    [PE1] mpls 
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] mpls
    [PE1-Vlanif10] mpls ldp
    [PE1-Vlanif10] quit
    [PE1] mpls ldp remote-peer 3.3.3.3
    [PE1-mpls-ldp-remote-3.3.3.3] remote-ip 3.3.3.3
    [PE1-mpls-ldp-remote-3.3.3.3] quit

    # Configure PE2.

    [PE2] mpls lsr-id 2.2.2.2
    [PE2] mpls 
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface vlanif 20
    [PE2-Vlanif20] mpls
    [PE2-Vlanif20] mpls ldp
    [PE2-Vlanif20] quit
    [PE2] mpls ldp remote-peer 3.3.3.3
    [PE2-mpls-ldp-remote-3.3.3.3] remote-ip 3.3.3.3
    [PE2-mpls-ldp-remote-3.3.3.3] quit

    # Configure PE3.

    [PE3] mpls lsr-id 3.3.3.3
    [PE3] mpls 
    [PE3-mpls] quit
    [PE3] mpls ldp
    [PE3-mpls-ldp] quit
    [PE3] interface vlanif 10
    [PE3-Vlanif10] mpls
    [PE3-Vlanif10] mpls ldp
    [PE3-Vlanif10] quit
    [PE3] interface vlanif 20
    [PE3-Vlanif20] mpls
    [PE3-Vlanif20] mpls ldp
    [PE3-Vlanif20] quit
    [PE3] mpls ldp remote-peer 1.1.1.1
    [PE3-mpls-ldp-remote-1.1.1.1] remote-ip 1.1.1.1
    [PE3-mpls-ldp-remote-1.1.1.1] quit
    [PE3] mpls ldp remote-peer 2.2.2.2
    [PE3-mpls-ldp-remote-2.2.2.2] remote-ip 2.2.2.2
    [PE3-mpls-ldp-remote-2.2.2.2] quit

  4. Enable MPLS L2VPN and configure VSIs.

    # Configure PE1.

    [PE1] mpls l2vpn
    [PE1-l2vpn] quit
    [PE1] vsi orange static
    [PE1-vsi-orange] pwsignal ldp
    [PE1-vsi-orange-ldp] vsi-id 111
    [PE1-vsi-orange-ldp] peer 3.3.3.3
    [PE1-vsi-orange-ldp] quit
    [PE1-vsi-orange] quit

    # Configure PE2.

    [PE2] mpls l2vpn
    [PE2-l2vpn] quit
    [PE2] vsi blue static
    [PE2-vsi-blue] pwsignal ldp
    [PE2-vsi-blue-ldp] vsi-id 222
    [PE2-vsi-blue-ldp] peer 3.3.3.3
    [PE2-vsi-blue-ldp] quit
    [PE2-vsi-blue] quit

    # Configure PE3.

    [PE3] mpls l2vpn
    [PE3-l2vpn] quit
    [PE3] vsi orange static
    [PE3-vsi-orange] pwsignal ldp
    [PE3-vsi-orange-ldp] vsi-id 111
    [PE3-vsi-orange-ldp] peer 1.1.1.1
    [PE3-vsi-orange-ldp] quit
    [PE3-vsi-orange] quit
    [PE3] vsi blue static
    [PE3-vsi-blue] pwsignal ldp
    [PE3-vsi-blue-ldp] vsi-id 222
    [PE3-vsi-blue-ldp] peer 2.2.2.2
    [PE3-vsi-blue-ldp] quit
    [PE3-vsi-blue] quit

  5. Bind the VSIs to interfaces on PE1, PE2, and PE3.

    # Configure PE1.

    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] undo portswitch
    [PE1-GigabitEthernet2/0/0] l2 binding vsi orange
    [PE1-GigabitEthernet2/0/0] quit

    # Configure PE2.

    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] undo portswitch
    [PE2-GigabitEthernet2/0/0] l2 binding vsi blue
    [PE2-GigabitEthernet2/0/0] quit

    # Configure PE3.

    [PE3] interface gigabitethernet 3/0/0
    [PE3-GigabitEthernet3/0/0] undo portswitch
    [PE3-GigabitEthernet3/0/0] l2 binding vsi blue
    [PE3-GigabitEthernet3/0/0] quit
    [PE3] interface gigabitethernet 4/0/0
    [PE3-GigabitEthernet4/0/0] undo portswitch
    [PE3-GigabitEthernet4/0/0] l2 binding vsi orange
    [PE3-GigabitEthernet4/0/0] quit

  6. Enable IGMP snooping on PE1, PE2, and PE3.

    # Configure PE1.

    [PE1] igmp-snooping enable
    [PE1] igmp-snooping over-vpls enable
    [PE1] vsi orange
    [PE1-vsi-orange] igmp-snooping enable
    [PE1-vsi-orange] quit

    # Configure PE2.

    [PE2] igmp-snooping enable
    [PE2] igmp-snooping over-vpls enable
    [PE2] vsi blue
    [PE2-vsi-blue] igmp-snooping enable
    [PE2-vsi-blue] quit

    # Configure PE3.

    [PE3] igmp-snooping enable
    [PE3] igmp-snooping over-vpls enable
    [PE3] vsi orange
    [PE3-vsi-orange] igmp-snooping enable
    [PE3-vsi-orange] quit
    [PE3] vsi blue
    [PE3-vsi-blue] igmp-snooping enable
    [PE3-vsi-blue] quit

  7. Configure global Layer 2 multicast CAC on PE3 to limit the maximum number of multicast groups to 100.

    [PE3] l2-multicast limit max-entry 100
    

  8. Configure Layer 2 multicast CAC in VSI orange on PE3 to limit the maximum number of multicast groups in this VSI to 50.

    [PE3] vsi orange
    [PE3-vsi-orange] l2-multicast limit max-entry 50
    [PE3-vsi-orange] quit

  9. Create channel XXTV on PE3 and set the group address range for the channel to 225.0.0.1-225.0.0.255.

    [PE3] l2-multicast-channel
    [PE3-l2-channel-glb] channel XXTV type asm
    [PE3-l2-channel-glb-XXTV] group 225.0.0.0 24
    [PE3-l2-channel-glb-XXTV] quit
    [PE3-l2-channel-glb] quit

  10. Set the maximum number of multicast groups in channel XXTV to 30 on GE3/0/0 of PE3.

    [PE3] interface gigabitethernet 3/0/0
    [PE3-GigabitEthernet3/0/0] l2-multicast limit channel XXTV max-entry 30
    [PE3-GigabitEthernet3/0/0] quit
    

  11. Verify the configuration.

    # Run the display l2-multicast limit configuration command to check the Layer 2 multicast CAC configuration.

    [PE3] display l2-multicast limit configuration
    L2-multicast limit information, The unit of bandwidth is Kbits/sec              
    ------------------------------------------------------------------------------  
                                         Channel   ConfigEntries  ConfigBandwidth   
                                         Channel   CurrentEntries CurrentBandwidth  
    ------------------------------------------------------------------------------  
    Global limit information:                                                       
    ------------------------------------------------------------------------------  
                                                   100            ----------        
                                                   80             ----------        
    interface GigabitEthernet3/0/0 channel limit information:              
    ------------------------------------------------------------------------------  
                                          XXTV     30             ----------        
                                                   25             ----------        
    VSI orange limit information:                                                     
    ------------------------------------------------------------------------------  
                                                   50             ----------        
                                                   40             ----------        
    

Configuration Files

  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 10
    #
    igmp-snooping enable
    igmp-snooping over-vpls enable
    #
    mpls lsr-id 1.1.1.1
    mpls
    #
    mpls l2vpn
    #
    vsi orange static
     pwsignal ldp
      vsi-id 111
      peer 3.3.3.3
     igmp-snooping enable
    #
    mpls ldp
    #
    mpls ldp remote-peer 3.3.3.3
     remote-ip 3.3.3.3
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     l2 binding vsi orange
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 20
    #
    igmp-snooping enable
    igmp-snooping over-vpls enable
    #
    mpls lsr-id 2.2.2.2
    mpls
    #
    mpls l2vpn
    #
    vsi blue static
     pwsignal ldp
      vsi-id 222
      peer 3.3.3.3
     igmp-snooping enable
    #
    mpls ldp
    #
    mpls ldp remote-peer 3.3.3.3
     remote-ip 3.3.3.3
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     l2 binding vsi blue
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.2.0 0.0.0.255
    #
    return
  • PE3 configuration file

    #
    sysname PE3
    #
    vlan batch 10 20
    #
    igmp-snooping enable
    igmp-snooping over-vpls enable
    l2-multicast limit max-entry 100
    #
    mpls lsr-id 3.3.3.3
    mpls
    #
    mpls l2vpn
    #
    vsi orange static
     pwsignal ldp
      vsi-id 111
      peer 1.1.1.1
     igmp-snooping enable
     l2-multicast limit max-entry 50
    #
    vsi blue static
     pwsignal ldp
      vsi-id 222
      peer 2.2.2.2
     igmp-snooping enable
    #
    mpls ldp
    #
    mpls ldp remote-peer 1.1.1.1
     remote-ip 1.1.1.1
    #
    mpls ldp remote-peer 2.2.2.2
     remote-ip 2.2.2.2
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet3/0/0
     undo portswitch
     l2 binding vsi blue
     l2-multicast limit channel XXTV max-entry 30 
    #
    interface GigabitEthernet4/0/0
     undo portswitch
     l2 binding vsi orange
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    l2-multicast-channel
     channel XXTV type asm
      group 225.0.0.0 255.255.255.0
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000141903

Views: 145809

Downloads: 111

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next