No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

S7700 and S9700 V200R010C00

This document describes IP multicast basics and how to configure IP multicast features, including IGMP/MLD, PIM (IPv4&IPv6), MSDP, multicast VPN, Layer 3 multicast CAC, Layer 2 multicast CAC, IGMP/MLD snooping, and multicast VLAN, IPv4&IPv6 multicast route management, static multicast MAC address, multicast network.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN-based Layer 2 Multicast CAC

Example for Configuring VLAN-based Layer 2 Multicast CAC

Networking Requirements

As shown in Figure 15-5, Source provides two channels for users in VLAN 10, VLAN 20, and VLAN 30: channel XXTV (with a group address range of 225.0.0.1 to 225.0.0.255 and 30 programs) and channel YYTV (with a group address range 226.0.0.1 to 226.0.0.255 and 25 programs). Each program consumes about 18 Mbit/s bandwidth on a user-side link of SwitchB. Users in VLAN 10 are more interested in programs of XXTV; users in VLAN 20 are more interested in programs of YYTV; users in VLAN 30 seldom watch programs online. To provide high-quality programs for most users and reserve sufficient bandwidth for programs that users are interested in, VLAN-based Layer 2 multicast CAC needs to be configured on SwitchB.

Figure 15-5  Network diagram for Layer 2 multicast CAC configuration

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IGMP snooping on SwitchB. Layer 2 multicast CAC can function only after IGMP snooping is enabled.
  2. Create channels and configure group address ranges for the channels.
  3. Set the global CAC limit to 100 to ensure sufficient bandwidth for multicast data on user-side links.
  4. Set the CAC limit in VLAN 10 to 50 to ensure sufficient link bandwidth for multicast data on GE1/0/1. Set the CAC limit for channel XXTV to 30 and the limit for channel YYTV to 20, ensuring sufficient bandwidth to transmit multicast data of channel XXTV.
  5. On GE1/0/2, set the CAC limit for VLAN 20 to 35 and the CAC limit for VLAN30 to 15, ensuring sufficient link bandwidth for multicast data on this interface. Then set the CAC limits for the two channels in VLAN 20 on GE1/0/2: 10 for XXTV and 25 for YYTV, ensuring sufficient bandwidth to transmit multicast data of channel YYTV.

Procedure

  1. Create VLANs on SwitchB and add interfaces to the VLANs.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 10 20 30
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 20 30
    [SwitchB-GigabitEthernet1/0/2] quit

  2. Enable IGMP snooping on SwitchB.

    [SwitchB] igmp-snooping enable
    [SwitchB] igmp-snooping enable vlan 10 20 30
    

  3. On SwitchB, set the group address range for global channel XXTV to 225.0.0.1-225.0.0.255, and the group address range for global channel YYTV to 226.0.0.1-226.0.0.255.

    [SwitchB] l2-multicast-channel
    [SwitchB-l2-channel-glb] channel XXTV type asm
    [SwitchB-l2-channel-glb-XXTV] group 225.0.0.0 24
    [SwitchB-l2-channel-glb-XXTV] quit
    [SwitchB-l2-channel-glb] channel YYTV type asm
    [SwitchB-l2-channel-glb-YYTV] group 226.0.0.0 24
    [SwitchB-l2-channel-glb-YYTV] quit
    [SwitchB-l2-channel-glb] quit

  4. Configure global Layer 2 multicast CAC on SwitchB to limit the number of multicast groups for all users to 100.

    [SwitchB] l2-multicast limit max-entry 100
    

  5. Configure Layer 2 multicast CAC for VLAN 10 on SwitchB to limit the number of multicast groups in VLAN 10 to 50, including 30 multicast groups in channel XXTV and 20 multicast groups in YYTV.

    [SwitchB] l2-multicast limit max-entry 50 vlan 10
    [SwitchB] l2-multicast limit channel XXTV max-entry 30 vlan 10
    [SwitchB] l2-multicast limit channel YYTV max-entry 20 vlan 10

  6. Configure Layer 2 multicast CAC for VLAN 20 and VLAN 30 on GE1/0/2 of SwitchB to limit the number of multicast groups as follows: a maximum of 35 multicast groups in VLAN 20, 15 multicast groups in VLAN 30, 10 multicast groups of XXTV in VLAN 20, and 25 multicast groups of YYTV in VLAN 20.

    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] l2-multicast limit max-entry 35 vlan 20
    [SwitchB-GigabitEthernet1/0/2] l2-multicast limit max-entry 15 vlan 30
    [SwitchB-GigabitEthernet1/0/2] l2-multicast limit channel XXTV max-entry 10 vlan 20
    [SwitchB-GigabitEthernet1/0/2] l2-multicast limit channel YYTV max-entry 25 vlan 20
    [SwitchB-GigabitEthernet1/0/2] quit
    

  7. Verify the configuration.

    # Run the display l2-multicast limit configuration command to check the Layer 2 multicast CAC configuration.

    [SwitchB] display l2-multicast limit configuration
    L2-multicast limit information, The unit of bandwidth is Kbits/sec              
    ------------------------------------------------------------------------------  
                                         Channel   ConfigEntries  ConfigBandwidth   
                                         Channel   CurrentEntries CurrentBandwidth  
    ------------------------------------------------------------------------------  
    Global limit information:                                                       
    ------------------------------------------------------------------------------  
                                                   100            ----------        
                                                   80             ----------        
    VLAN 10 limit information:                                                     
    ------------------------------------------------------------------------------  
                                                   50             ----------        
                                                   40             ----------        
    VLAN 10 channel limit information:                                             
    ------------------------------------------------------------------------------  
                                          XXTV     30             ----------        
                                                   20             ----------        
    VLAN 10 channel limit information:                                             
    ------------------------------------------------------------------------------  
                                          YYTV     20             ----------        
                                                   20             ----------        
    interface GigabitEthernet1/0/2 VLAN 20 limit information:                      
    ------------------------------------------------------------------------------  
                                                   35             ----------        
                                                   25             ----------        
    interface GigabitEthernet1/0/2 VLAN 20 channel limit information:              
    ------------------------------------------------------------------------------  
                                          XXTV     10             ----------        
                                                   10             ----------        
    interface GigabitEthernet1/0/2 VLAN 20 channel limit information:              
    ------------------------------------------------------------------------------  
                                          YYTV     25             ----------        
                                                   15             ----------        
    interface GigabitEthernet1/0/2 VLAN 30 limit information:                      
    ------------------------------------------------------------------------------  
                                                   15             ----------        
                                                   15             ---------- 

Configuration Files

  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 20 30
    #
    igmp-snooping enable
    l2-multicast limit max-entry 100
    l2-multicast limit max-entry 50 vlan 10
    l2-multicast limit channel XXTV max-entry 30 vlan 10
    l2-multicast limit channel YYTV max-entry 20 vlan 10
    #
    vlan 10
     igmp-snooping enable
    vlan 20
     igmp-snooping enable
    vlan 30
     igmp-snooping enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 30
     l2-multicast limit max-entry 15 vlan 30
     l2-multicast limit max-entry 35 vlan 20
     l2-multicast limit channel XXTV max-entry 10 vlan 20
     l2-multicast limit channel YYTV max-entry 25 vlan 20
    #
    l2-multicast-channel
     channel XXTV type asm
      group 225.0.0.0 255.255.255.0
     channel YYTV type asm
      group 226.0.0.0 255.255.255.0
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000141903

Views: 145670

Downloads: 111

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next