No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - VPN

S9300, S9300E, and S9300X V200R010C00

This document describes the VPN configuration procedures and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring CE Dual-Homing

Example for Configuring CE Dual-Homing

Networking Requirements

It is a trend to transmit all telecommunication services on an IP network. Key services such as 3G/NGN, IPTV streaming media, and VPN services require high reliability on networks. In addition to improving the reliability of the network devices, you can improve the link reliability by configuring fast route convergence, fault detection, fast reroute, and route backup.

On the access layer, the CE dual-homing networking is a common method to improve the network reliability. A dual-homed CE connects to two PEs that belong to the same VPN. In this networking, the CE connects to the backbone network through two links. The two links work in load balancing mode or active/standby mode.

As shown in Figure 2-62, CE1 is located in site1 of vpn1, and CE2 is located in site2 of vpn1. CE1 connects to PE1 and PE2, and CE2 connects to PE3 and PE4.

If the data traffic volume from CE1 to CE2 is large but traffic volume from CE2 to CE1 is small, the data traffic from CE1 to CE2 can be transmitted in load balancing mode. The data traffic from CE2 to CE1 is transmitted through PE4, and PE3 only works as a backup.

NOTE:

In this scenario, to avoid loops, ensure that all connected interfaces have STP disabled and connected interfaces are removed from VLAN 1. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 2-62  Networking diagram for configuring CE dual-homing

Switch

Interface

VLANIF Interface

IP Address

PE1

Loopback1

-

1.1.1.1/32

PE1

GE1/0/0

VLANIF101

10.1.1.2/30

PE1

GE2/0/0

VLANIF10

100.1.1.1/30

PE2

Loopback1

-

2.2.2.2/32

PE2

GE1/0/0

VLANIF102

10.2.1.2/30

PE2

GE2/0/0

VLANIF20

100.2.1.1/30

P1

Loopback1

-

5.5.5.5/32

P1

GE1/0/0

VLANIF10

100.1.1.2/30

P1

GE2/0/0

VLANIF30

100.3.1.1/30

P2

Loopback1

-

6.6.6.6/32

P2

GE1/0/0

VLANIF20

100.2.1.2/30

P2

GE2/0/0

VLANIF40

100.4.1.1/30

PE3

Loopback1

-

3.3.3.3/32

PE3

GE1/0/0

VLANIF30

100.3.1.2/30

PE3

GE2/0/0

VLANIF103

10.3.1.1/30

PE4

Loopback1

-

4.4.4.4/32

PE4

GE1/0/0

VLANIF40

100.4.1.2/30

PE4

GE2/0/0

VLANIF104

10.4.1.1/30

CE1

GE1/0/0

VLANIF101

10.1.1.1/30

CE1

GE2/0/0

VLANIF102

10.2.1.1/30

CE1

GE3/0/0

VLANIF1001

1.5.1.1/24

CE2

GE1/0/0

VLANIF103

10.3.1.2/30

CE2

GE2/0/0

VLANIF104

10.4.1.2/30

CE2

GE3/0/0

VLANIF1002

1.6.1.1/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic BGP/MPLS IP VPN functions.

  2. In the BGP view of CE1, configure load balancing for traffic sent to CE2.

  3. Increase the MED value of the BGP-VPN route on PE3 to ensure that the next hop of the route selected by CE2 to the customer network connected to CE1 is PE4.

Procedure

  1. Configure an IGP on the MPLS backbone network so that PEs and Ps can communicate with each other.

    # Configure PE1.

    # Assign IP addresses to interfaces. The IP addresses of the loopback interfaces must use a 32-bit mask.

    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.1 32
    [PE1-LoopBack1] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] ip address 100.1.1.1 30
    [PE1-Vlanif10] quit
    

    # Configure the ISIS protocol to advertise routes of the interfaces.

    [PE1] isis 1
    [PE1-isis-1] network-entity 10.0000.0000.0001.00
    [PE1-isis-1] quit
    [PE1] interface loopback 1
    [PE1-LoopBack1] isis enable 1
    [PE1-LoopBack1] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] isis enable 1
    [PE1-Vlanif10] quit
    

    The configuration on PE2, PE3, PE4, P1, and P2 is similar to the configuration on PE1 and is not mentioned here.

    After the configuration is complete, run the display ip routing-table command. The command output shows that PE1 and PE3 can learn the routes of Loopback1 interface of each other; PE2 and PE4 can learn routes of Loopback1 interface of each other.

    The information displayed on PE1 is used as an example.

    [PE1] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
             Destinations : 8        Routes : 8
    
      Destination/Mask  Proto    Pre  Cost       Flags  NextHop         Interface
    
            1.1.1.1/32  Direct   0    0              D  127.0.0.1       LoopBack1
            3.3.3.3/32  ISIS-L1  15   20             D  100.1.1.2       Vlanif10
            5.5.5.5/32  ISIS-L1  15   10             D  100.1.1.2       Vlanif10
          100.1.1.0/30  Direct   0    0              D  100.1.1.1       Vlanif10
          100.1.1.1/32  Direct   0    0              D  127.0.0.1       Vlanif10
          100.3.1.0/30  ISIS-L1  15   20             D  100.1.1.2       Vlanif10
          127.0.0.0/8   Direct   0    0              D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct   0    0              D  127.0.0.1       InLoopBack0
    

  2. Configure basic MPLS capabilities and MPLS LDP on the MPLS backbone network to establish LDP LSPs.

    # Configure PE1.

    # Enable MPLS and LDP in the system view, set the LSR ID to the IP address of the loopback interface, and trigger the LSP.

    [PE1] mpls lsr-id 1.1.1.1
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    

    # Enable MPLS and LDP on the interface connected to the backbone network.

    [PE1] interface vlanif 10
    [PE1-Vlanif10] mpls
    [PE1-Vlanif10] mpls ldp
    [PE1-Vlanif10] quit
    

    # The configuration on PE2, PE3, PE4, P1, and P2 is similar to the configuration on PE1 and is not mentioned here.

    After the configuration is complete, LDP sessions can be established between PE1 and P, and between PE3 and P. Run the display mpls ldp session command, and you can see that the status of the sessions is Operational. Run the display mpls ldp lsp command. Information about the established LDP LSPs is displayed.

    The information displayed on PE1 is used as an example.

    [PE1] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv 
    ------------------------------------------------------------------------------ 
    5.5.5.5:0          Operational DU   Passive  0000:07:02  1688/1688 
    ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    
    [PE1] display mpls ldp lsp
    
     LDP LSP Information
     -------------------------------------------------------------------------------
     Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel   UpstreamPeer   NextHop         OutInterface
     -------------------------------------------------------------------------------
     1.1.1.1/32         3/NULL        5.5.5.5        127.0.0.1       InLoop0
    *1.1.1.1/32         Liberal/1024                 DS/5.5.5.5
     3.3.3.3/32         NULL/1025     -              100.1.1.2       Vlanif10
     3.3.3.3/32         1025/1025     5.5.5.5        100.1.1.2       Vlanif10
     5.5.5.5/32         NULL/3        -              100.1.1.2       Vlanif10
     5.5.5.5/32         1024/3        5.5.5.5        100.1.1.2       Vlanif10
     -----------------------------------------------------------------------------
     TOTAL: 5 Normal LSP(s) Found.
     TOTAL: 1 Liberal LSP(s) Found.
     TOTAL: 0 Frr LSP(s) Found.
     A '*' before an LSP means the LSP is not established                           
     A '*' before a Label means the USCB or DSCB is stale                           
     A '*' before a UpstreamPeer means the session is stale                         
     A '*' before a DS means the session is stale                                   
     A '*' before a NextHop means the LSP is FRR LSP                                

  3. Configure VPN instances on PEs and bind the interfaces connected to CEs to the VPN instances.

    # Configure PE1.

    # Create a VPN instance and set the RD and VPN target of the VPN instance. The VPN target set on the local PE must match the VPN target of the MP-BGP peer PE so that the sites of the same VPN can communicate with each other.

    [PE1] ip vpn-instance vpn1
    [PE1-vpn-instance-vpn1] ipv4-family
    [PE1-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:1
    [PE1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [PE1-vpn-instance-vpn1-af-ipv4] quit
    [PE1-vpn-instance-vpn1] quit
    

    # Bind the interface connected to CE1 to the corresponding VPN instance and set the IP address of the interface.

    [PE1] interface vlanif 101
    [PE1-Vlanif101] ip binding vpn-instance vpn1
    [PE1-Vlanif101] ip address 10.1.1.2 30
    [PE1-Vlanif101] quit
    

    # Configure PE2.

    # Create a VPN instance and set the RD and VPN target of the VPN instance. The VPN target set on the local PE must match the VPN target of the MP-BGP peer PE so that the sites of the same VPN can communicate with each other.

    [PE2] ip vpn-instance vpn1
    [PE2-vpn-instance-vpn1] ipv4-family
    [PE2-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:2
    [PE2-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [PE2-vpn-instance-vpn1-af-ipv4] quit
    [PE2-vpn-instance-vpn1] quit
    

    # Bind the interface connected to CE1 to the corresponding VPN instance and set the IP address of the interface.

    [PE2] interface vlanif 102
    [PE2-Vlanif102] ip binding vpn-instance vpn1
    [PE2-Vlanif102] ip address 10.2.1.2 30
    [PE2-Vlanif102] quit
    

    # Configure PE3.

    # Create a VPN instance and set the RD and VPN target of the VPN instance. The VPN target set on the local PE must match the VPN target of the MP-BGP peer PE so that the sites of the same VPN can communicate with each other.

    [PE3] ip vpn-instance vpn1
    [PE3-vpn-instance-vpn1] ipv4-family
    [PE3-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:3
    [PE3-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [PE3-vpn-instance-vpn1-af-ipv4] quit
    [PE3-vpn-instance-vpn1] quit
    

    # Bind the interface connected to CE2 to the corresponding VPN instance and set the IP address of the interface.

    [PE3] interface vlanif 103
    [PE3-Vlanif103] ip binding vpn-instance vpn1
    [PE3-Vlanif103] ip address 10.3.1.1 30
    [PE3-Vlanif103] quit
    

    # Configure PE4.

    # Create a VPN instance and set the RD and VPN target of the VPN instance. The VPN target set on the local PE must match the VPN target of the MP-BGP peer PE so that the sites of the same VPN can communicate with each other.

    [PE4] ip vpn-instance vpn1
    [PE4-vpn-instance-vpn1] ipv4-family
    [PE4-vpn-instance-vpn1-af-ipv4] route-distinguisher 100:4
    [PE4-vpn-instance-vpn1-af-ipv4] vpn-target 1:1 both
    [PE4-vpn-instance-vpn1-af-ipv4] quit
    [PE4-vpn-instance-vpn1] quit
    

    # Bind the interface connected to CE2 to the corresponding VPN instance and set the IP address of the interface.

    [PE4] interface vlanif 104
    [PE4-Vlanif104] ip binding vpn-instance vpn1
    [PE4-Vlanif104] ip address 10.4.1.1 30
    [PE4-Vlanif104] quit
    

    # Assign IP addresses to the interfaces on the CEs according to Figure 2-62. The configuration procedure is not provided here.

    After the configuration is complete, run the display ip vpn-instance verbose command on the PEs to check the configuration of VPN instances.

    The information displayed on PE1 is used as an example.

    [PE1] display ip vpn-instance verbose
     Total VPN-Instances configured : 1
     Total IPv4 VPN-Instances configured : 1
     Total IPv6 VPN-Instances configured : 0
    
     VPN-Instance Name and ID : vpn1, 1
      Interfaces : Vlanif101
     Address family ipv4
      Create date : 2012/07/25 00:58:17 UTC+08:00
      Up time : 0 days, 17 hours, 38 minutes and 53 seconds
      Route Distinguisher : 100:1
      Export VPN Targets :  1:1
      Import VPN Targets :  1:1
      Label Policy : label per route
      Log Interval : 5
    

  4. Establish MP-IBGP peer relationships between PEs.

    # Configure PE1.

    # Specify PE3 as the IGBP peer and use the IP address of the loopback interface to establish an IBGP connection with the peer.

    [PE1] bgp 100
    [PE1-bgp] peer 3.3.3.3 as-number 100
    [PE1-bgp] peer 3.3.3.3 connect-interface loopback 1
    

    # Enter the VPNv4 address family view and enable the local PE to exchange VPN routing information with the IGBP peer.

    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 3.3.3.3 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit

    # Configure PE3.

    # Specify PE1 as the IGBP peer and use the IP address of the loopback interface to establish an IBGP connection with the peer.

    [PE3] bgp 100
    [PE3-bgp] peer 1.1.1.1 as-number 100
    [PE3-bgp] peer 1.1.1.1 connect-interface loopback 1

    # Enter the VPNv4 address family view and enable the local PE to exchange VPN routing information with the IGBP peer.

    [PE3-bgp] ipv4-family vpnv4
    [PE3-bgp-af-vpnv4] peer 1.1.1.1 enable
    [PE3-bgp-af-vpnv4] quit
    [PE3-bgp] quit

    # Configure PE2.

    # Specify PE4 as the IGBP peer and use the IP address of the loopback interface to establish an IBGP connection with the peer.

    [PE2] bgp 100
    [PE2-bgp] peer 4.4.4.4 as-number 100
    [PE2-bgp] peer 4.4.4.4 connect-interface loopback 1
    

    # Enter the VPNv4 address family view and enable the local PE to exchange VPN routing information with the IGBP peer.

    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 4.4.4.4 enable
    [PE2-bgp-af-vpnv4] quit
    [PE2-bgp] quit

    # Configure PE4.

    # Specify PE2 as the IGBP peer and use the IP address of the loopback interface to establish an IBGP connection with the peer.

    [PE4] bgp 100
    [PE4-bgp] peer 2.2.2.2 as-number 100
    [PE4-bgp] peer 2.2.2.2 connect-interface loopback 1

    # Enter the VPNv4 address family view and enable the local PE to exchange VPN routing information with the IGBP peer.

    [PE4-bgp] ipv4-family vpnv4
    [PE4-bgp-af-vpnv4] peer 2.2.2.2 enable
    [PE4-bgp-af-vpnv4] quit
    [PE4-bgp] quit

    After the configuration is complete, run the display bgp vpnv4 all peer command on the PEs. The command output shows that BGP peer relationships have been established between the PEs and are in Established state.

    The information displayed on PE1 is used as an example.

    [PE1] display bgp vpnv4 all peer
                                                                                    
     BGP local router ID : 1.1.1.1
     Local AS number : 100
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      3.3.3.3         4   100       70       81     0 01:00:23 Established       3
    

  5. Configure EBGP between the PEs and CEs to import the VPN routes.

    # Configure CE1.

    # Enable BGP, specify PE1 and PE2 as EBGP peers, and import direct routes.

    [CE1] bgp 65410
    [CE1-bgp] peer 10.1.1.2 as-number 100
    [CE1-bgp] peer 10.2.1.2 as-number 100
    [CE1-bgp] import-route direct
    [CE1-bgp] quit
    

    # Configure PE1.

    # Enable BGP, specify CE1 as the EBGP peer, and import direct routes.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpn1
    [PE1-bgp-vpn1] peer 10.1.1.1 as-number 65410
    [PE1-bgp-vpn1] import-route direct
    [PE1-bgp-vpn1] quit
    [PE1-bgp] quit

    # Configure PE2.

    # Enable BGP, specify CE1 as the EBGP peer, and import direct routes.

    [PE2] bgp 100
    [PE2-bgp] ipv4-family vpn-instance vpn1
    [PE2-bgp-vpn1] peer 10.2.1.1 as-number 65410
    [PE2-bgp-vpn1] import-route direct
    [PE2-bgp-vpn1] quit
    [PE2-bgp] quit

    # Configure CE2.

    # Enable BGP, specify PE3 and PE4 as EBGP peers, and import direct routes.

    [CE2] bgp 65420
    [CE2-bgp] peer 10.3.1.1 as-number 100
    [CE2-bgp] peer 10.4.1.1 as-number 100
    [CE2-bgp] import-route direct
    [CE2-bgp] quit
    

    # Configure PE3.

    # Enable BGP, specify CE2 as the EBGP peer, and import direct routes.

    [PE3] bgp 100
    [PE3-bgp] ipv4-family vpn-instance vpn1
    [PE3-bgp-vpn1] peer 10.3.1.2 as-number 65420
    [PE3-bgp-vpn1] import-route direct
    [PE3-bgp-vpn1] quit
    [PE3-bgp] quit

    # Configure PE4.

    # Enable BGP, specify CE2 as the EBGP peer, and import direct routes.

    [PE4] bgp 100
    [PE4-bgp] ipv4-family vpn-instance vpn1
    [PE4-bgp-vpn1] peer 10.4.1.2 as-number 65420
    [PE4-bgp-vpn1] import-route direct
    [PE4-bgp-vpn1] quit
    [PE4-bgp] quit

    After the configuration is complete, run the display bgp vpnv4 vpn-instance vpn-instancename peer command on the PEs. The command output shows that BGP peer relationships have been established between the PEs and CEs and are in Established state. Each PE can ping its connected CE.

    The information displayed on PE1 is used as an example.

    [PE1] display bgp vpnv4 vpn-instance vpn1 peer
    
     BGP local router ID : 1.1.1.1
     Local AS number : 100
    
     VPN-Instance vpn1, Router ID 1.1.1.1:   
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      10.1.1.1        4 65410      408      435     0 06:16:09 Established       5
    
    [PE1] ping -vpn-instance vpn1 10.1.1.1
      PING 10.1.1.1 : 56  data bytes, press CTRL_C to break
          Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=255 time=80 ms
          Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=255 time=20 ms
          Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=255 time=30 ms
          Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=255 time=50 ms
          Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=255 time=30 ms
    
      --- 10.1.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 20/42/80 ms

  6. On CE1, configure load balancing for the traffic sent from CE1 to CE2.

    [CE1] bgp 65410
    [CE1-bgp] ipv4-family unicast
    [CE1-bgp-af-ipv4] maximum load-balancing 2
    [CE1-bgp-af-ipv4] quit
    [CE1-bgp] quit

  7. Configure a routing policy on PE3 to increase the MED value of the BGP routes advertised to CE2. Then the traffic sent from CE2 to CE1 is forwarded by PE4, and PE3 is a backup of PE4.

    [PE3] route-policy policy1 permit node 10
    [PE3-route-policy] apply cost 120
    [PE3-route-policy] quit
    [PE3] bgp 100
    [PE3-bgp] ipv4-family vpn-instance vpn1
    [PE3-bgp-vpn1] peer 10.3.1.2 route-policy policy1 export
    [PE3-bgp-vpn1] quit
    [PE3-bgp] quit

    Check the BGP routing table of CE2. In the routing table, the route to 1.5.1.0/30 advertised by PE3 has a MED value of 120, larger than the MED value of the route advertised by PE4 (the default MED value is 0). Therefore, CE2 selects the route advertised by PE4.

    [CE2] display bgp routing-table
     Total Number of Routes: 11
     BGP Local router ID is 10.2.1.1
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
     *>   1.5.1.0/24         10.4.1.1                              0      100 65410?
     *                       10.3.1.1        120                   0      100 65410?
     *>   1.6.1.0/24         0.0.0.0         0                     0      ?
     *>   10.1.1.0/30        10.3.1.1        120                   0      100?
     *                       10.4.1.1                              0      100 65410?
     *>   10.2.1.0/30        10.4.1.1                              0      100?
     *                       10.3.1.1        120                   0      100 65410?
     *>   10.3.1.0/30        0.0.0.0         0                     0      ?
     *                       10.3.1.1        120                   0      100?
     *>   10.4.1.0/30        0.0.0.0         0                     0      ?
     *                       10.4.1.1        0                     0      100?
    

  8. Verify the configurations.

    If the configuration is successful:

    The display ip routing-table command on CE1 displays the routes to the customer network connected to CE2. The routes work in load balancing mode.

    [CE1] display ip routing-table
    
    Route Flags: R - relay, D - download to fib
    
    ------------------------------------------------------------------------------
    
    Routing Tables: Public
             Destinations : 11       Routes : 12
    
    Destination/Mask    Proto  Pre  Cost        Flags NextHop         Interface
    
            1.5.1.0/24  Direct 0    0             D  1.5.1.1         Vlanif1001
            1.5.1.1/32  Direct 0    0             D  127.0.0.1       Vlanif1001
            1.6.1.0/24  EBGP   255  0             D  10.1.1.2        Vlanif101
                        EBGP   255  0             D  10.2.1.2        Vlanif102
           10.1.1.0/30  Direct 0    0             D  10.1.1.1        Vlanif101
           10.1.1.1/32  Direct 0    0             D  127.0.0.1       Vlanif101
           10.2.1.0/30  Direct 0    0             D  10.2.1.1        Vlanif102
           10.2.1.1/32  Direct 0    0             D  127.0.0.1       Vlanif102
           10.3.1.0/30  EBGP   255  0             D  10.1.1.2        Vlanif101
           10.4.1.0/30  EBGP   255  0             D  10.2.1.2        Vlanif102
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    

    The display ip routing-table command on CE2 displays the routes to the customer network connected to CE1. The next hop of the route is 10.4.1.1, IP address of the interface that connects PE4 to CE2.

    [CE2] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 11       Routes : 11
    
    Destination/Mask    Proto  Pre  Cost        Flags NextHop         Interface
    
            1.5.1.0/24  EBGP   255  0             D  10.4.1.1        Vlanif104
            1.6.1.0/24  Direct 0    0             D  1.6.1.1         Vlanif1002
            1.6.1.1/32  Direct 0    0             D  127.0.0.1       Vlanif1002
           10.1.1.0/30  EBGP   255  120           D  10.3.1.1        Vlanif103
           10.2.1.0/30  EBGP   255  0             D  10.4.1.1        Vlanif104
           10.3.1.0/30  Direct 0    0             D  10.3.1.2        Vlanif103
           10.3.1.2/32  Direct 0    0             D  127.0.0.1       Vlanif103
           10.4.1.0/30  Direct 0    0             D  10.4.1.2        Vlanif104
           10.4.1.2/32  Direct 0    0             D  127.0.0.1       Vlanif104
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
     vlan batch 101 102 1001
    #
    interface Vlanif101
     ip address 10.1.1.1 255.255.255.252
    #
    interface Vlanif102
     ip address 10.2.1.1 255.255.255.252
    #
    interface Vlanif1001
     ip address 1.5.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 1001
    #
    bgp 65410
     peer 10.1.1.2 as-number 100
     peer 10.2.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      maximum load-balancing 2
      peer 10.1.1.2 enable
      peer 10.2.1.2 enable
    #
    return
  • PE1 configuration file

    #
    sysname PE1
    #
     vlan batch 10 101
    #
    ip vpn-instance vpn1
     ipv4-family
     route-distinguisher 100:1
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 1.1.1.1
     mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 100.1.1.1 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif101
     ip binding vpn-instance vpn1
     ip address 10.1.1.2 255.255.255.252
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.3 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.1.1.1 as-number 65410
      import-route direct
    #
    return
  • PE2 configuration file

    #
     sysname PE2
    #
     vlan batch 20 102
    #
    ip vpn-instance vpn1
     ipv4-family
     route-distinguisher 100:2
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 2.2.2.2
     mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 100.2.1.1 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif102
     ip binding vpn-instance vpn1
     ip address 10.2.1.2 255.255.255.252
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 4.4.4.4 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 4.4.4.4 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.2.1.1 as-number 65410
      import-route direct
    #
    return
  • P1 configuration file

    #
     sysname P1
    #
     vlan batch 10 30
    #
     mpls lsr-id 5.5.5.5
     mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0005.00
    #
    interface Vlanif10
     ip address 100.1.1.2 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 100.3.1.1 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface LoopBack1
     ip address 5.5.5.5 255.255.255.255
     isis enable 1
    #
    return
  • P2 configuration file

    #
     sysname P2
    #
     vlan batch 20 40
    #
     mpls lsr-id 6.6.6.6
     mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0006.00
    #
    interface Vlanif20
     ip address 100.2.1.2 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 100.4.1.1 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack1
     ip address 6.6.6.6 255.255.255.255
     isis enable 1
    #
    return
  • PE3 configuration file

    sysname PE3
    #
     vlan batch 30 103
    #
    ip vpn-instance vpn1
     ipv4-family
     route-distinguisher 100:3
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 3.3.3.3
     mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif30
     ip address 100.3.1.2 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif103
     ip binding vpn-instance vpn1
     ip address 10.3.1.1 255.255.255.252
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.3.1.2 as-number 65420
      peer 10.3.1.2 route-policy policy1 export
      import-route direct
    #
    route-policy policy1 permit node 10
     apply cost 120
    #
    return
  • PE4 configuration file

    #
    sysname PE4
    #
     vlan batch 40 104
    #
    ip vpn-instance vpn1
     ipv4-family
     route-distinguisher 100:4
     vpn-target 1:1 export-extcommunity
     vpn-target 1:1 import-extcommunity
    #
     mpls lsr-id 4.4.4.4
     mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif40
     ip address 100.4.1.2 255.255.255.252
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif 104
     ip binding vpn-instance vpn1
     ip address 10.4.1.1 255.255.255.252
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
     isis enable 1
    #
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.2 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.2 enable
     #
     ipv4-family vpn-instance vpn1
      peer 10.4.1.2 as-number 65420
      import-route direct
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 103 104 1002
    #
    interface Vlanif103
     ip address 10.3.1.2 255.255.255.252
    #
    interface Vlanif104
     ip address 10.4.1.2 255.255.255.252
    #
    interface Vlanif1002
     ip address 1.6.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 1002
    #
    bgp 65420
     peer 10.3.1.1 as-number 100
     peer 10.4.1.1 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.3.1.1 enable
      peer 10.4.1.1 enable
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000142068

Views: 119037

Downloads: 212

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next