No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring link aggregation, VLANs, Voice VLAN, VLAN mapping, QinQ, GVRP, MAC table, STP/RSTP/MSTP, SEP, and so on.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Single RRPP Ring with a Single Instance

Example for Configuring a Single RRPP Ring with a Single Instance

Networking Requirements

As shown in Figure 18-32, SwitchA, SwitchB, and SwitchC constitute a ring network. The network is required to prevent loops when the ring is complete and implement fast convergence to rapidly restore communication between nodes on the ring when the ring fails. You can enable RRPP on SwitchA, SwitchB, and SwitchC to meet this requirement.

Figure 18-32  Networking diagram of a single RRPP ring

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure interfaces to be added to the RRPP domain on the devices so that data can pass through the interfaces. Disable protocols that conflict with RRPP, such as STP.

  2. Create an RRPP domain and its control VLAN.

  3. Map data that needs to pass through the VLANs on the RRPP ring to Instance 1, including data VLANs 100 to 300 and control VLANs 20 and 21 (VLAN 21 is the sub-control VLAN generated by the device).

  4. In the RRPP domain, configure a protected VLAN, create an RRPP ring and configure SwitchA, SwitchB, and SwitchC as nodes on Ring 1 in Domain 1. Configure SwitchA as the master node on Ring 1, and configure SwitchB and SwitchC as transit nodes on Ring 1.

  5. Enable the RRPP ring and RRPP protocol on devices to make RRPP take effect.

Procedure

  1. Create an RRPP domain and its control VLAN.

    # Configure SwitchA. The configurations on SwitchB and SwitchC are similar to that on SwitchA and not mentioned here. For details, see the configuration files.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] rrpp domain 1
    [SwitchA-rrpp-domain-region1] control-vlan 20
    [SwitchA-rrpp-domain-region1] quit

  2. Map Instance 1 to control VLANs 20 and 21 and data VLANs 100 to 300.

    # Configure SwitchA. The configurations on SwitchB and SwitchC are the same as that of SwitchA and not mentioned here. For details, see the configuration files.

    [SwitchA] vlan batch 100 to 300
    [SwitchA] stp region-configuration
    [SwitchA-mst-region] instance 1 vlan 20 21 100 to 300
    [SwitchA-mst-region] active region-configuration
    [SwitchA-mst-region] quit

  3. Configure the interfaces to be added to the RRPP ring as trunk interfaces, allow data VLANs 100 to 300 to pass through the interfaces, and disable STP on the interfaces.

    # Configure SwitchA. The configurations on SwitchB and SwitchC are the same as that ofSwitchA and not mentioned here. For details, see the configuration files.

    [SwitchA] interface gigabitethernet 2/0/1
    [SwitchA-GigabitEthernet2/0/1] port link-type trunk
    [SwitchA-GigabitEthernet2/0/1] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 to 300  
    [SwitchA-GigabitEthernet2/0/1] stp disable
    [SwitchA-GigabitEthernet2/0/1] quit
    [SwitchA] interface gigabitethernet 2/0/2
    [SwitchA-GigabitEthernet2/0/2] port link-type trunk
    [SwitchA-GigabitEthernet2/0/2] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet2/0/2] port trunk allow-pass vlan 100 to 300 
    [SwitchA-GigabitEthernet2/0/2] stp disable
    [SwitchA-GigabitEthernet2/0/2] quit

  4. Specify a protected VLAN, and create and enable an RRPP ring.

    # Configure SwitchA.

    [SwitchA] rrpp domain 1
    [SwitchA-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchA-rrpp-domain-region1] ring 1 node-mode master primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
    [SwitchA-rrpp-domain-region1] ring 1 enable
    [SwitchA-rrpp-domain-region1] quit

    # Configure SwitchB.

    [SwitchB] rrpp domain 1
    [SwitchB-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchB-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
    [SwitchB-rrpp-domain-region1] ring 1 enable
    [SwitchB-rrpp-domain-region1] quit

    # Configure SwitchC.

    [SwitchC] rrpp domain 1
    [SwitchC-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchC-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
    [SwitchC-rrpp-domain-region1] ring 1 enable
    [SwitchC-rrpp-domain-region1] quit

  5. Enable RRPP.

    # Configure SwitchA. The configurations on SwitchB and SwitchC are the same as that of SwitchA and not mentioned here. For details, see the configuration files.

    [SwitchA] rrpp enable

  6. Verify the configuration.

    After the preceding configurations are complete and the network becomes stable, run the following commands to verify the configuration. The display on Switch A is used as an example.

    # Run the display rrpp brief command on SwitchA. The command output is as follows:

    [SwitchA] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , E - Edge , A - Assistant-Edge
    
    RRPP Protocol Status:  Enable
    RRPP Working Mode: HW
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 1
    
    Domain Index  : 1
    Control VLAN  : major 20    sub 21
    Protected VLAN : Reference Instance 1
    Hello Timer   : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring   Ring    Node     Primary/Common           Secondary/Edge          Is
     ID     Level   Mode     Port                     Port                    Enabled
     ----------------------------------------------------------------------------
     1      0       M        GigabitEthernet2/0/1     GigabitEthernet2/0/2    Yes

    The command output shows that RRPP is enabled on SwitchA, the major control VLAN of domain 1 is VLAN 20 and the sub-control VLAN is VLAN 21, and SwitchA is the master node on Ring 1. The primary interface is GigabitEthernet2/0/1 and the secondary interface is GigabitEthernet2/0/2.

    # Run the display rrpp verbose domain command on SwitchA. The command output is as follows:

    [SwitchA] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 20    sub 21
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet2/0/1         Port status: UP
    Secondary port : GigabitEthernet2/0/2         Port status: BLOCKED

    The command output shows that the RRPP ring is complete.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 20 to 21 100 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode master primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    return
    
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 20 to 21 100 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 20 to 21 100 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    return

Relevant Information

Video

Configure RRPP

Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000142081

Views: 255939

Downloads: 408

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next