No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - Ethernet Switching

This document describes the configuration of Ethernet services, including configuring link aggregation, VLANs, Voice VLAN, VLAN mapping, QinQ, GVRP, MAC table, STP/RSTP/MSTP, SEP, and so on.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Link Aggregation in LACP Mode

Example for Configuring Link Aggregation in LACP Mode

Networking Requirements

In Figure 3-26, SwitchA and SwitchB connect to devices in VLAN 10 and VLAN 20 through Ethernet links, and heavy traffic is transmitted between SwitchA and SwitchB. The customer hopes that SwitchA and SwitchB can provide increased link bandwidth to enable inter-VLAN communication. Link aggregation in LACP mode can be configured on SwitchA and SwitchB to improve the bandwidth and reliability. The requirements are as follows:

  • Two active links provide load balancing.

  • One link functions as the backup link. When a fault occurs on an active link, the backup link replaces the faulty link to maintain reliable data transmission.

  • Devices in the same VLAN can communicate.

Figure 3-26  Networking diagram for configuring link aggregation in LACP mode

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk and configure the Eth-Trunk to work in LACP mode to implement link aggregation.

  2. Add member interfaces to the Eth-Trunk.

  3. Set the LACP system priority and determine which device is the Actor. The Partner device selects active interfaces based on the interface priorities of the Actor.

  4. Set the upper threshold for the number of active interfaces to improve reliability.

  5. Set LACP interface priorities and determine active interfaces so that interfaces with higher priorities are selected as active interfaces.

  6. Create VLANs and add interfaces to the VLANs.

Procedure

  1. Create Eth-Trunk 1 on SwitchA and configure Eth-Trunk 1 to work in LACP mode. The configuration for SwitchB is the same as that for SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] mode lacp
    [SwitchA-Eth-Trunk1] quit

  2. Add member interfaces to Eth-Trunk 1 on SwitchA. The configuration for SwitchB is the same as that for SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] eth-trunk 1
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] eth-trunk 1
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] eth-trunk 1
    [SwitchA-GigabitEthernet1/0/3] quit
    

  3. Set the system priority on SwitchA to 100 so that SwitchA becomes the Actor.

    [SwitchA] lacp priority 100
    

  4. On SwitchA, set the upper threshold for the number of active interfaces to 2.

    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] max active-linknumber 2
    [SwitchA-Eth-Trunk1] quit

  5. Set the LACP interface priority and determine active links on SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] lacp priority 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] lacp priority 100
    [SwitchA-GigabitEthernet1/0/2] quit
    

  6. Create VLANs and add interfaces to the VLANs.

    # Create VLAN 10 and VLAN 20 and add interfaces to VLAN 10 and VLAN 20. The configuration for SwitchB is the same as that for SwitchA.

    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type trunk
    [SwitchA-GigabitEthernet1/0/4] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/4] quit
    [SwitchA] interface gigabitethernet 1/0/5
    [SwitchA-GigabitEthernet1/0/5] port link-type trunk
    [SwitchA-GigabitEthernet1/0/5] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet1/0/5] quit
    

    # Configure Eth-Trunk 1 to allow packets from VLAN 10 and VLAN 20 to pass through. The configuration for SwitchB is the same as that for SwitchA.

    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] port link-type trunk
    [SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
    [SwitchA-Eth-Trunk1] quit

  7. Verify the configuration.

    # Check information about the Eth-Trunk of the switches and check whether negotiation is successful on the link.

    [SwitchA] display eth-trunk 1
    Eth-Trunk1's state information is:
    Local:                                                                          
    LAG ID: 1                       WorkingMode: LACP                             
    Preempt Delay: Disabled         Hash arithmetic: According to SIP-XOR-DIP       
    System Priority: 100            System ID: 00e0-fca8-0417
    Least Active-linknumber: 1      Max Active-linknumber: 2                        
    Operate status: up              Number Of Up Port In Trunk: 2
    --------------------------------------------------------------------------------
    ActorPortName                    Status     PortType PortPri   PortNo PortKey   PortState  Weight
    GigabitEthernet1/0/1             Selected  1GE       100      6145    2865      11111100     1
    GigabitEthernet1/0/2             Selected  1GE       100      6146    2865      11111100     1
    GigabitEthernet1/0/3             Unselect  1GE       32768    6147    2865      11100000     1
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName                     SysPri    SystemID    PortPri PortNo PortKey   PortState
    GigabitEthernet1/0/1              32768  00e0-fca6-7f85  32768     6145   2609      11111100
    GigabitEthernet1/0/2              32768  00e0-fca6-7f85  32768     6146   2609      11111100
    GigabitEthernet1/0/3              32768  00e0-fca6-7f85  32768     6147   2609      11110000
    
    [SwitchB] display eth-trunk 1
    Eth-Trunk1's state information is:
    Local:
    LAG ID: 1                      WorkingMode: LACP
    Preempt Delay: Disabled        Hash arithmetic: According to SIP-XOR-DIP
    System Priority: 32768         System ID: 00e0-fca6-7f85
    Least Active-linknumber: 1     Max Active-linknumber: 8
    Operate status: up             Number Of Up Port In Trunk: 2
    --------------------------------------------------------------------------------
    ActorPortName                   Status     PortType    PortPri   PortNo  PortKey   PortState  Weight
    GigabitEthernet1/0/1            Selected  1GE        32768      6145    2609      11111100     1
    GigabitEthernet1/0/2            Selected  1GE        32768      6146    2609      11111100     1
    GigabitEthernet1/0/3            Unselect  1GE        32768      6147    2609      11100000     1
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName                     SysPri    SystemID     PortPri  PortNo  PortKey   PortState
    GigabitEthernet1/0/1              100    00e0-fca8-0417  100      6145     2865      11111100
    GigabitEthernet1/0/2              100    00e0-fca8-0417  100      6146     2865      11111100
    GigabitEthernet1/0/3              100    00e0-fca8-0417  32768    6147     2865      11110000
    

    The preceding information shows that the LACP system priority value of SwitchA is 100, which means it has a higher LACP system priority than SwitchB. Member interfaces GigabitEthernet1/0/1 and GigabitEthernet1/0/2 are the active interfaces and are in Selected state. Interface GigabitEthernet1/0/3 is in Unselect state. Two links are active and work in load balancing mode, and one link is the backup link.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    lacp priority 100
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     mode lacp
     max active-linknumber 2
    #
    interface GigabitEthernet1/0/1
     eth-trunk 1
     lacp priority 100
    #
    interface GigabitEthernet1/0/2
     eth-trunk 1
     lacp priority 100
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface GigabitEthernet1/0/4
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/5
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     mode lacp
    #
    interface GigabitEthernet1/0/1
     eth-trunk 1
    #
    interface GigabitEthernet1/0/2
     eth-trunk 1
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface GigabitEthernet1/0/4
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/5
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000142081

Views: 256257

Downloads: 408

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next