No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - QoS

This document describes the configurations of QoS functions, including MQC, priority mapping, traffic policing, traffic shaping, interface-based rate limiting, congestion avoidance, congestion management, packet filtering, redirection, traffic statistics, ACL-based simplified traffic policy, and HQoS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Congestion Avoidance and Congestion Management

Example for Configuring Congestion Avoidance and Congestion Management

Networking Requirements

The Switch is connected to the router through GE2/0/1; the 802.1p priorities of voice, video, and data services on the Internet are 6, 5, and 2 respectively, and these services can reach users through the router and Switch, as shown in Figure 5-12. The rate of inbound interface GE2/0/1 on the Switch is greater than the rates of outbound interfaces GE1/0/1 and GE1/0/2; therefore, congestion may occur on these two outbound interfaces.

To reduce the impact of network congestion and ensure bandwidth for high-priority and delay-sensitive services, set parameters based on Table 5-3 and Table 5-4.

Table 5-3  Congestion avoidance parameters

Service Type

Color

Lower Threshold (%)

Upper Threshold (%)

Drop Percent

Voice

Green

80

100

10

Video

Yellow

60

80

20

Data

Red

40

60

40

Table 5-4  Congestion management parameters

Service Type

CoS

Voice

EF

Video

AF3

Data

AF1

Figure 5-12  Networking diagram for configuring congestion avoidance and congestion management

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure the VLAN for each interface so that devices can communicate with each other.

  2. Create and configure a DiffServ domain on the Switch, map packets of 802.1p priorities to PHBs and colors of packets, and bind the DiffServ domain to an inbound interface on the Switch.

  3. Create a WRED drop profile on the Switch and apply the WRED drop profile on an outbound interface.

  4. Set scheduling parameters of queues of different CoS on outbound interfaces of the Switch.

Procedure

  1. Configure the VLAN for each interface so that the devices can communicate with each other.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 2 5 6
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 5 6
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 5 6
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 2 5 6
    [Switch-GigabitEthernet2/0/1] quit
    

  2. Configure priority mapping based on simple traffic classification.

    # Create DiffServ domain ds1, map packets of 802.1p priorities being 6, 5, and 2 to PHBs EF, AF3, and AF1, and color packets as green, yellow, and red.

    [Switch] diffserv domain ds1
    [Switch-dsdomain-ds1] 8021p-inbound 6 phb ef green
    [Switch-dsdomain-ds1] 8021p-inbound 5 phb af3 yellow
    [Switch-dsdomain-ds1] 8021p-inbound 2 phb af1 red
    [Switch-dsdomain-ds1] quit
    

    # Bind incoming interface GE2/0/1 on the Switch to DiffServ domain ds1.

    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] trust upstream ds1
    [Switch-GigabitEthernet2/0/1] trust 8021p inner
    [Switch-GigabitEthernet2/0/1] quit

  3. Configure congestion avoidance.

    # Create drop profile wred1 on the Switch and set parameters of packets of three colors.

    [Switch] drop-profile wred1
    [Switch-drop-wred1] color green low-limit 80 high-limit 100 discard-percentage 10
    [Switch-drop-wred1] color yellow low-limit 60 high-limit 80 discard-percentage 20
    [Switch-drop-wred1] color red low-limit 40 high-limit 60 discard-percentage 40
    [Switch-drop-wred1] quit
    

    # Apply drop profile wred1 on outbound interfaces GE1/0/1 and GE1/0/2 of the Switch.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] qos wred wred1
    [Switch-GigabitEthernet1/0/1] qos queue 5 wred wred1
    [Switch-GigabitEthernet1/0/1] qos queue 3 wred wred1
    [Switch-GigabitEthernet1/0/1] qos queue 1 wred wred1
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] qos wred wred1
    [Switch-GigabitEthernet1/0/2] qos queue 5 wred wred1
    [Switch-GigabitEthernet1/0/2] qos queue 3 wred wred1
    [Switch-GigabitEthernet1/0/2] qos queue 1 wred wred1
    [Switch-GigabitEthernet1/0/2] quit

  4. Configure congestion management.

    # Set scheduling parameters of queues of different CoS on outgoing interfaces GE1/0/1 and GE1/0/2 of the Switch.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] qos pq 5
    [Switch-GigabitEthernet1/0/1] qos drr 0 to 4
    [Switch-GigabitEthernet1/0/1] qos queue 3 drr weight 100
    [Switch-GigabitEthernet1/0/1] qos queue 1 drr weight 50
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] qos pq 5
    [Switch-GigabitEthernet1/0/2] qos drr 0 to 4
    [Switch-GigabitEthernet1/0/2] qos queue 3 drr weight 100
    [Switch-GigabitEthernet1/0/2] qos queue 1 drr weight 50
    [Switch-GigabitEthernet1/0/2] quit
    

  5. Verify the configuration.

    # Check the configuration of DiffServ domain ds1.

    [Switch] display diffserv domain name ds1
    diffserv domain name:ds1
     8021p-inbound 0 phb be green
     8021p-inbound 1 phb af1 green
     8021p-inbound 2 phb af1 red
     8021p-inbound 3 phb af3 green
     8021p-inbound 4 phb af4 green
     8021p-inbound 5 phb af3 yellow
     8021p-inbound 6 phb ef green
     8021p-inbound 7 phb cs7 green
     8021p-outbound be green map 0
    ......

    # Check the configuration of drop profile wred1.

    [Switch] display drop-profile name wred1
    Drop-profile[1]: wred1
    Queue depth    : default
    Color     Low-limit   High-limit  Discard-percentage
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Green     80          100         10
    Yellow    60          80          20
    Red       40          60          40
    Non-tcp   100         100         100
    -----------------------------------------------------------------
    

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 2 5 to 6
    #
    diffserv domain ds1
     8021p-inbound 2 phb af1 red
     8021p-inbound 5 phb af3 yellow
     8021p-inbound 6 phb ef green
    #
    drop-profile wred1
     color green low-limit 80 high-limit 100 discard-percentage 10
     color yellow low-limit 60 high-limit 80 discard-percentage 20
     color red low-limit 40 high-limit 60 discard-percentage 40
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     qos wred wred1
     qos pq 5 to 7 drr 0 to 4
     qos queue 1 drr weight 50
     qos queue 3 drr weight 100
     qos queue 1 wred wred1
     qos queue 3 wred wred1
     qos queue 5 wred wred1
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     qos wred wred1
     qos pq 5 to 7 drr 0 to 4
     qos queue 1 drr weight 50
     qos queue 3 drr weight 100
     qos queue 1 wred wred1
     qos queue 3 wred wred1
     qos queue 5 wred wred1
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     trust upstream ds1
     trust 8021p inner
    #
    return
    
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000142089

Views: 45122

Downloads: 87

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next