No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - QoS

This document describes the configurations of QoS functions, including MQC, priority mapping, traffic policing, traffic shaping, interface-based rate limiting, congestion avoidance, congestion management, packet filtering, redirection, traffic statistics, ACL-based simplified traffic policy, and HQoS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Interface-based Rate Limiting

Example for Configuring Interface-based Rate Limiting

Networking Requirements

In Figure 4-15, the Switch connects to the router through GE2/0/1; enterprise departments 1 and 2 connect to the Switch through GE1/0/1 and GE1/0/2 and access the Internet through the Switch and router.

There is only data service traffic on the network, so differentiated services are not required. The bandwidth of each department needs to be limited. Department 1 must be allocated guaranteed bandwidth of 8 Mbit/s and maximum bandwidth of 10 Mbit/s. Department 2 must be allocated guaranteed bandwidth of 5 Mbit/s and maximum bandwidth of 8 Mbit/s.

Figure 4-15  Networking of interface-based rate limiting

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLANs and configure interfaces to enable the enterprise to connect to the network through the Switch.

  2. Create different CAR profiles and configure the CIRs and PIRs in the profiles. Apply the CAR profiles to GE1/0/1 and GE1/0/2 on the Switch in the inbound direction to limit the rates of packets from different departments.

Procedure

  1. Create VLANs and configure interfaces on the Switch.

    # Create VLAN 100 and VLAN 200.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 200
    

    # Configure GE1/0/1, GE1/0/2, and GE2/0/1 as trunk interfaces, and add GE1/0/1 to VLAN 100, GE1/0/2 to VLAN 200, and GE2/0/1 to VLAN 100 and VLAN 200.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 200
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 200
    [Switch-GigabitEthernet2/0/1] quit

  2. Configure CAR profiles.

    # Create CAR profiles car1 and car2 on the Switch to limit the rates of traffic from departments 1 and 2.

    [Switch] qos car car1 cir 8192 pir 10240
    [Switch] qos car car2 cir 5120 pir 8192
    

  3. Apply the CAR profiles.

    # Apply the CAR profiles to GE1/0/1 and GE1/0/2 on the Switch in the inbound direction respectively to limit the rate of traffic from enterprise departments 1 and 2.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] qos car inbound car1
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] qos car inbound car2
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] quit

  4. Verify the configuration.

    # View the CAR profile configuration.

    <Switch> display qos car all
      ----------------------------------------------------------------              
       CAR Name     : car1                                                           
       CAR Index    : 0                                                             
        car cir 8192 (Kbps) pir 10240 (Kbps) cbs 1024000 (byte) pbs 1280000 (byte)  
      ----------------------------------------------------------------              
       CAR Name     : car2                                                          
       CAR Index    : 1                                                             
        car cir 5120 (Kbps) pir 8192 (Kbps) cbs 640000 (byte) pbs 1024000 (byte)    

    # Send traffic at rates of 6000 kbit/s, 9000 kbit/s, and 11000 kbit/s to GE1/0/1 and GE1/0/2, and run the display qos car statistics command to view traffic statistics. When packets are sent at a rate of 6000 kbit/s, GE1/0/1 and GE1/0/2 forward all packets. When packets are sent at a rate of 9000 kbit/s, GE1/0/1 forwards all packets and GE1/0/2 discards some packets on are discarded. When packets are sent at a rate of 11000 kbit/s, both GE1/0/1 and GE1/0/2 discard some packets.

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 100 200
    #
    qos car car1 cir 8192 pir 10240 cbs 1024000 pbs 1280000
    qos car car2 cir 5120 pir 8192 cbs 640000 pbs 1024000
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
     qos car inbound car1
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
     qos car inbound car2
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
    

Relevant Information

Video

Configure Interface-based Rate Limiting

Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000142089

Views: 42469

Downloads: 87

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next