No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - Reliability

This document describes the configuration of BFD, DLDP, VRRP, SmartLink, CFM, EFM, Y.1731 and MAC swap loopback to ensure reliability on the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Combining Monitor Link and Smart Link on a Network

Example for Combining Monitor Link and Smart Link on a Network

Networking Requirements

As shown in Figure 6-19, SwitchC is connected to user networks and is dual-homed to SwitchA and SwitchB, which are connected to the backbone network.

A monitoring mechanism is required to prevent service interruption caused by uplink failures. If an uplink fails, the downlinks can rapidly detect the failure and trigger link switching immediately to minimize the service interruption time.

Figure 6-19  Combination of Smart Link and Monitor Link

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a Smart Link group on SwitchA and SwitchC and add corresponding interfaces to the Smart Link groups.
  2. Enable SwitchA and SwitchC to send Flush packets.
  3. Enable SwitchA and SwitchB to receive Flush packets.
  4. Configure a Monitor Link group on SwitchA and configure the Smart Link group as an uplink. In this way, the Smart Link group improves the uplink reliability in the Monitor Link group.
  5. Configure a Monitor Link group on SwitchB to enable the Smart Link group on SwitchC to rapidly detect uplink failures. This configuration widens the application scope of Smart Link.

Procedure

  1. Configure the control VLAN on SwitchA, SwitchB and SwitchC. Add the interfaces of the Smart Link or Monitor Link groups to this VLAN.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here. For details, see the configuration files.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 2/0/1
    [SwitchA-GigabitEthernet2/0/1] port link-type trunk
    [SwitchA-GigabitEthernet2/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet2/0/1] quit
    [SwitchA] interface gigabitethernet 2/0/2
    [SwitchA-GigabitEthernet2/0/2] port link-type trunk
    [SwitchA-GigabitEthernet2/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet2/0/2] quit
    

  2. Create Smart Link groups.

    # Configure SwitchA.

    [SwitchA] smart-link group 1
    [SwitchA-smlk-group1] quit

    # Configure SwitchC.

    [SwitchC] smart-link group 2
    [SwitchC-smlk-group2] quit

  3. Add interfaces to the Smart Link groups and specify the master and slave interfaces.

    # Configure SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] stp disable
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] stp disable
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] smart-link group 1
    [SwitchA-smlk-group1] port gigabitethernet 1/0/1 master
    [SwitchA-smlk-group1] port gigabitethernet 1/0/2 slave
    

    # Configure SwitchC.

    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] stp disable
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface gigabitethernet 1/0/2
    [SwitchC-GigabitEthernet1/0/2] stp disable
    [SwitchC-GigabitEthernet1/0/2] quit
    [SwitchC] smart-link group 2
    [SwitchC-smlk-group2] port gigabitethernet 1/0/1 master
    [SwitchC-smlk-group2] port gigabitethernet 1/0/2 slave
    

  4. Enable revertive switching and set the WTR time.

    # Configure SwitchA.

    [SwitchA-smlk-group1] restore enable
    [SwitchA-smlk-group1] timer wtr 30
    

    # Configure SwitchC.

    [SwitchC-smlk-group2] restore enable
    [SwitchC-smlk-group2] timer wtr 30
    

  5. Enable SwitchA and SwitchC to send Flush packets, and enable SwitchA and SwitchB to receive Flush packets.

    # Configure SwitchA to send and receive Flush packets containing an SHA-encrypted password.

    [SwitchA-smlk-group1] flush send control-vlan 10 password sha 123
    [SwitchA-smlk-group1] quit
    [SwitchA] interface gigabitethernet 2/0/1
    [SwitchA-GigabitEthernet2/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchA-GigabitEthernet2/0/1] stp disable
    [SwitchA-GigabitEthernet2/0/1] quit
    [SwitchA] interface gigabitethernet 2/0/2
    [SwitchA-GigabitEthernet2/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchA-GigabitEthernet2/0/2] stp disable
    [SwitchA-GigabitEthernet2/0/2] quit
    

    # Configure SwitchB to receive Flush packets containing an SHA-encrypted password.

    [SwitchB] interface gigabitethernet 2/0/1
    [SwitchB-GigabitEthernet2/0/1] smart-link flush receive control-vlan 10 password sha 123
    [SwitchB-GigabitEthernet2/0/1] stp disable
    [SwitchB-GigabitEthernet2/0/1] quit
    [SwitchB] interface gigabitethernet 2/0/2
    [SwitchB-GigabitEthernet2/0/2] smart-link flush receive control-vlan 10 password sha 123
    [SwitchB-GigabitEthernet2/0/2] stp disable
    [SwitchB-GigabitEthernet2/0/2] quit
    

    # Configure SwitchC to receive Flush packets containing an SHA-encrypted password.

    [SwitchC-smlk-group2] flush send control-vlan 10 password sha 123
    [SwitchC-smlk-group2] quit

  6. Enable the Smart Link group.

    # Configure SwitchA.

    [SwitchA] smart-link group 1
    [SwitchA-smlk-group1] smart-link enable
    [SwitchA-smlk-group1] quit

    # Configure SwitchC.

    [SwitchC] smart-link group 2
    [SwitchC-smlk-group2] smart-link enable
    [SwitchC-smlk-group2] quit

  7. Create a Monitor Link group and add uplink and downlink interfaces to the Monitor Link group.

    # Configure SwitchA.

    [SwitchA] monitor-link group 1
    [SwitchA-mtlk-group1] smart-link group 1 uplink
    [SwitchA-mtlk-group1] port gigabitethernet 2/0/1 downlink 1
    

    # Configure SwitchB.

    [SwitchB] monitor-link group 2
    [SwitchB-mtlk-group2] port gigabitethernet 1/0/1 uplink
    [SwitchB-mtlk-group2] port gigabitethernet 2/0/1 downlink 1
    

  8. Set the WTR time of the Monitor Link group.

    # Configure SwitchA.

    [SwitchA-mtlk-group1] timer recover-time 10
    [SwitchA-mtlk-group1] quit

    # Configure SwitchB.

    [SwitchB-mtlk-group2] timer recover-time 10
    [SwitchB-mtlk-group2] quit

  9. Verify the configuration.

    [SwitchA] display smart-link group 1
    Smart Link group 1 information :
      Smart Link group was enabled
      Wtr-time is: 30 sec.
      There is no Load-Balance
      There is no protected-vlan reference-instance 
      DeviceID: 0018-2000-0083  Control-vlan ID: 10
      Member                  Role    State     Flush Count  Last-Flush-Time
      ----------------------------------------------------------------------
    
      GigabitEthernet1/0/1    Master  Active    1            0000/00/00 00:00:00 UTC+05:00
      GigabitEthernet1/0/2    Slave   Inactive  0            0000/00/00 00:00:00 UTC+05:00
    
    [SwitchA] display monitor-link group 1
    Monitor Link group 1 information : 
      Recover-timer is 10 sec.                                                       
        Member              Role     State Last-up-time                       Last-down-time 
     Smart-link1            UpLk     UP    0000/00/00 00:00:00 UTC+05:00      0000/00/00 00:00:00 UTC+05:00
     GigabitEthernet2/0/1   DwLk[1]  UP    0000/00/00 00:00:00 UTC+05:00      0000/00/00 00:00:00 UTC+05:00
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#rwIhOw`~g7,xyl>~|:v9Cyw2CH,7l2\dbzA[cH3YA9BdA;1qqSs%WJHM3|hO%^%#
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#fR)IGHHT:>]iNbG:Nq#)<^1p#`np!T#/\V&%)iHB_ibX!99]e#E{/L2Sxw!I%^%#
    #
    smart-link group 1
     restore enable
     smart-link enable 
     port GigabitEthernet1/0/1 master
     port GigabitEthernet1/0/2 slave 
     timer wtr 30
     flush send control-vlan 10 password sha %^%#XbPxG#g5C6$/*d2^GRU>3ODTJF_C(Bht`^*}tT05u]7SIZ5y%9bQ!x~3:v;O%^%#
    #
    monitor-link group 1
     smart-link group 1 uplink
     port GigabitEthernet2/0/1 downlink 1
     timer recover-time 10
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#IOf[Q`=F=QK"O4-j9A}Y-N7<,F~cn%/NR:G-,L5*[SMN,FlIYAZd88*ObE;T%^%#
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
     smart-link flush receive control-vlan 10 password sha %^%#vMK'GvJozEo1Fi:%~jkO<ge&0HgYZVh@ch709e49'r8&M{k6X.NzX)<K_R<P%^%#
    #
    monitor-link group 2
     port GigabitEthernet1/0/1 uplink
     port GigabitEthernet2/0/1 downlink 1
     timer recover-time 10
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     stp disable
    #
    smart-link group 2
     restore enable
     smart-link enable 
     port GigabitEthernet1/0/1 master
     port GigabitEthernet1/0/2 slave 
     timer wtr 30
     flush send control-vlan 10 password sha %^%#:ssvXl%=T&UGOl$eoPWJaQ'>)@+TbEELAQM=7sh~J1>;>,H<HIEjK$@kW1B1%^%#
    #
    return
Translation
Download
Updated: 2019-08-21

Document ID: EDOC1000142090

Views: 95525

Downloads: 111

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next