No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - Reliability

This document describes the configuration of BFD, DLDP, VRRP, SmartLink, CFM, EFM, Y.1731 and MAC swap loopback to ensure reliability on the device.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the BFD Echo Function

Example for Configuring the BFD Echo Function

Networking Requirements

As shown in Figure 2-26, SwitchA connects to SwitchB through a direct link. SwitchA supports BFD, whereas SwitchB does not support BFD. Faults on the link between SwitchA and SwitchB need to be fast detected.

Figure 2-26  Networking diagram for configuring the BFD Echo function

Configuration Roadmap

The configuration roadmap is as follows:

  • Configure the BFD Echo function on SwitchA to detect faults on the link between SwitchA and SwitchB.

Procedure

  1. On SwitchA and SwitchB, create VLANs, and configure GE1/0/1 interfaces as hybrid interfaces and add the interfaces to VLANs.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 13
    [SwitchA-vlan13] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 13
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 13 
    [SwitchA-GigabitEthernet1/0/1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 13
    [SwitchB-vlan13] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 13
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 13 
    [SwitchB-GigabitEthernet1/0/1] quit

  2. Set IP addresses of VLANIF interfaces so that SwitchA can communicate with SwitchB at Layer 3.

    # Configure SwitchA.

    [SwitchA] interface vlanif13
    [SwitchA-Vlanif13] ip address 10.1.1.5 24
    [SwitchA-Vlanif13] quit

    # Configure SwitchB.

    [SwitchB] interface vlanif13
    [SwitchB-Vlanif13] ip address 10.1.1.6 24
    [SwitchB-Vlanif13] quit

  3. Configure a BFD session supporting the BFD Echo function.

    # Configure SwitchA.

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bfd atob bind peer-ip 10.1.1.6 interface vlanif13 source-ip 10.1.1.5 one-arm-echo
    [SwitchA-bfd-session-atob] discriminator local 1
    [SwitchA-bfd-session-atob] min-echo-rx-interval 100
    [SwitchA-bfd-session-atob] commit
    [SwitchA-bfd-session-atob] quit

  4. Verify the configuration.

    # When the network runs stably, run the display bfd session all verbose command on SwitchA. You can see that a single-hop BFD session is set up and its status is Up.

    [SwitchA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 256       (One Hop) State : Up        Name : atob
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : -
      Session Detect Mode    : Asynchronous One-arm-echo Mode
      BFD Bind Type          : Interface(Vlanif13)
      Bind Session Type      : Static
      Bind Peer IP Address   : 10.1.1.6
      NextHop Ip Address     : 10.1.1.6
      Bind Interface         : Vlanif13
      Bind Source IP Address : 10.1.1.5
      FSM Board Id           : 0                TOS-EXP                : 7
      Echo Rx Interval (ms)  : 100
      Actual Tx Interval (ms): 100              Actual Rx Interval (ms): 100
      Local Detect Multi     : 3                Detect Interval (ms)   : 300
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 255
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                
      Active Multi           : 3                DSCP                   : - 
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      Session Echo Tx TmrID  : -
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
      Session Description    : -
    --------------------------------------------------------------------------------
    
         Total UP/DOWN Session Number : 1/0   

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 13
    #
    bfd
    #
    interface Vlanif13
     ip address 10.1.1.5 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 13 
     port hybrid untagged vlan 13
    #
    bfd atob bind peer-ip 10.1.1.6 interface Vlanif13 source-ip 10.1.1.5 one-arm-echo
     discriminator local 1
     min-echo-rx-interval 100
     commit
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 13
    #
    interface Vlanif13
     ip address 10.1.1.6 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 13 
     port hybrid untagged vlan 13
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1000142090

Views: 82351

Downloads: 104

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next