No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - WLAN-AC

This document describes native AC (hereinafter referred to as WLAN AC) configuration procedures and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Accounting for the Specified Network

Example for Configuring Accounting for the Specified Network

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, WDS profile, and Mesh profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is automatically delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 12-19, an 802.1x wireless user on the campus network can access resources on Network 1 (192.168.100.0/24) and Network 2 (10.102.64.0/24) through the AC. Network 1 stores domestic resources and Network 2 stores overseas resources.

The DAA function can be configured on the AC to perform accounting on the traffic destined for Network 1 and Network 2 separately. When users access Network 1, they are charged at a low charge rate; when users access Network 2, they are charged at a high charge rate.

Figure 12-19  Networking diagram of configuring accounting for the specified network

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure network interworking of the AC, SwitchA, AP, and other network devices.
  2. Configure the AC to assign IP addresses to the AP and STA.
  3. Configure RADIUS authentication parameters.
  4. Configure an 802.1x access profile to manage 802.1x access control parameters.
  5. Configure an authentication profile, apply the 802.1x access profile, and configure a forcible authentication domain.
  6. Configure the AP to go online.
  7. Configure WLAN service parameters, set the security policy to WPA2-802.1x-AES, and bind the security profile and authentication profile to the VAP profile to access-control STAs.
  8. Configure DAA to perform destination-based accounting.
    1. Configure the traffic identification rules for the two network segments so that the device can classify traffic going to different destination addresses.
    2. Configure different tariff levels for traffic destined for different network segments. The tariff level of traffic destined for Network 1 is 1 and the tariff level of traffic destined for Network 2 is 2.
    3. Configure accounting policies for tariff levels:
      • For tariff level 1, traffic statistics collection is enabled but accounting is not performed.
      • For tariff level 2, traffic statistics collection is enabled and accounting is performed.
Table 12-11  Data planning

Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

Source interface on the AC

VLANIF 100: 10.23.100.1/24

SwitchA VLAN

VLAN 100

DHCP server

  • IP address that the AC assigns to the AP: 10.23.100.2-10.23.100.254/24
  • IP addresses that AC assigns to STAs: 10.23.101.2-10.23.101.254/24

Gateway for the AP

VLANIF 100: 10.23.100.1/24

Gateway for STAs

VLANIF 101: 10.23.101.1/24

RADIUS authentication parameters

  • Name of a RADIUS server template: radius_huawei
  • IP address: 10.7.66.66
  • Authentication port number: 1812
  • Accounting port number: 1813
  • Shared key: huawei@123
  • Authentication scheme: radius_huawei
  • Accounting scheme: radius_huawei
  • AAA domain: huawei.com

User name and password of STAs

  • User name: test@huawei.com
  • Password: 123456

802.1x access profile

  • Name: wlan-dot1x
  • Authentication mode: EAP

Authentication profile

  • Name: wlan-authentication
  • Referenced profile: 802.1x access profile wlan-dot1x
  • Forcible authentication domain: huawei.com
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-vap and regulatory domain profile domain1
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2-802.1x-AES
VAP profile
  • Name: wlan-vap
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-ssid, security profile wlan-security, and authentication profile wlan-authentication

QoS profile

  • Name: huawei

DAA accounting

  • The tariff level of traffic destined for 192.168.100.0/24 is 1.
  • The tariff level of traffic destined for 10.102.64.0/24 is 2.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

  • Ensure that the RADIUS server IP address, port number, and shared key are correct and consistent with the RADIUS server. When the AC functions as an EAP relay, ensure that the RADIUS server supports the EAP protocol. Otherwise, the RADIUS server cannot process 802.1x authentication requests.

  • Ensure that reachable routes exist between the AC and RADIUS server, and between the user and two network segments.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure SwitchA and the AC so that the AP and AC can transmit CAPWAP packets.

    # Add GE0/0/1 that connects SwitchA to the AP to management VLAN 100 and add GE0/0/2 that connects SwitchA to the AC to the same VLAN.

    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    

    # Add GE1/0/1 that connects the AC to SwitchA to VLAN 100.

    [HUAWEI] sysname AC
    [AC] vlan batch 100
    [AC] interface gigabitethernet 1/0/1
    [AC-GigabitEthernet1/0/1] port link-type trunk
    [AC-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet1/0/1] quit
    

  3. Configure routes based on the networking. Ensure that routes are reachable between the AC and RADIUS server, and between the user and Network1 and Network2. The configuration procedure is not provided here.
  4. Configure the AC as a DHCP server to assign IP addresses to APs and STAs.

    # Configure the DHCP server to assign IP addresses to APs from the IP address pool on VLANIF 100, and assign IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] vlan batch 101
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit

  5. Configure RADIUS authentication parameters.

    # Configure a RADIUS server template radius_huawei. The IP address and port number of the RADIUS authentication server are 10.7.66.66 and 1812; the IP address and port number of the RADIUS accounting server are 10.7.66.66 and 1813. The shared key is huawei@123.

    [Switch] radius-server template radius_huawei
    [Switch-radius-radius_huawei] radius-server authentication 10.7.66.66 1812
    [Switch-radius-radius_huawei] radius-server accounting 10.7.66.66 1813
    [Switch-radius-radius_huawei] radius-server shared-key cipher huawei@123
    [Switch-radius-radius_huawei] quit

    # Configure the authentication scheme radius_huawei and set the authentication method to RADIUS authentication.

    [AC] aaa
    [AC-aaa] authentication-scheme radius_huawei
    [AC-aaa-authen-radius_huawei] authentication-mode radius
    [AC-aaa-authen-radius_huawei] quit

    # Configure the accounting scheme radius_huawei and set the accounting method to RADIUS accounting.

    [AC-aaa] accounting-scheme radius_huawei
    [AC-aaa-accounting-radius_huawei] accounting-mode radius
    [AC-aaa-accounting-radius_huawei] quit
    

    # Configure the AAA domain huawei.com, and apply the authentication scheme radius_huawei, accounting scheme radius_huawei, and RADIUS server template radius_huawei to the domain.

    [AC-aaa] domain huawei.com
    [AC-aaa-domain-huawei.com] authentication-scheme radius_huawei
    [AC-aaa-domain-huawei.com] accounting-scheme radius_huawei
    [AC-aaa-domain-huawei.com] radius-server radius_huawei
    [AC-aaa-domain-huawei.com] quit
    [AC-aaa] quit
    

    # Configure the global default domain huawei.com. During access authentication, enter a user name in the format of user@huawei.com to perform AAA authentication in the domain huawei.com. If the user name does not contain a domain name or contains an invalid domain name, the user is authenticated in the default domain.

    [AC] domain huawei.com

    # Test whether a STA can be authenticated using RADIUS authentication. A user name test@huawei.com and password 123456 have been configured on the RADIUS server.

    [AC] test-aaa test@huawei.com 123456 radius-template radius_huawei
    Info: Account test succeed.
    

  6. Configure an 802.1x access profile to manage 802.1x access control parameters.

    # Create the 802.1x access profile wlan-dot1x.

    [AC] dot1x-access-profile name wlan-dot1x
    

    # Set the authentication mode to EAP relay.

    [AC-dot1x-access-profile-wlan-dot1x] dot1x authentication-method eap
    [AC-dot1x-access-profile-wlan-dot1x] quit
    

  7. Configure an authentication profile named wlan-authentication, apply the 802.1x access profile, and configure a forcible authentication domain.

    [AC] authentication-profile name wlan-authentication
    [AC-authen-profile-wlan-authentication] dot1x-access-profile wlan-dot1x
    [AC-authen-profile-wlan-authentication] access-domain huawei.com dot1x force
    [AC-authen-profile-wlan-authentication] quit

  8. Configure the AP to go online.

    # Create an AP group and add the AP to the AP group.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP6010DN-AGN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]y
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online normally.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    --------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    --------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP6010DN-AGN    nor   0   10S
    --------------------------------------------------------------------------------
    Total: 1
    

  9. Configure WLAN service parameters.

    # Create the security profile wlan-security and set the security policy in the profile.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 dot1x aes
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create the SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create the VAP profile wlan-vap, set the data forwarding mode and service VLAN, and apply the security profile, SSID profile, and authentication profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-vap
    [AC-wlan-vap-prof-wlan-vap] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AC-wlan-vap-prof-wlan-vap] authentication-profile wlan-authentication
    [AC-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AC-wlan-vap-prof-wlan-vap] quit
    

    # Bind the VAP profile wlan-vap to the AP group and apply the profile to radio 0 and radio 1 of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  10. Set channels and power for the AP radios.

    NOTE:

    The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable the automatic channel and power calibration functions.

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.
    [AC-wlan-view] rrm-profile name default
    [AC-wlan-rrm-prof-default] calibrate auto-channel-select disable
    [AC-wlan-rrm-prof-default] calibrate auto-txpower-select disable
    [AC-wlan-rrm-prof-default] quit
    # Set a channel and power for radio 0 of the AP.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Set a channel and power for radio 1 of the AP.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  11. Configure DAA.

    # Configure ACL 3000 and ACL 3001, which are used as traffic identification rules.

    [AC-wlan-view] quit
    [Switch] acl 3000
    [Switch-acl-adv-3000] rule 1 permit ip destination 192.168.100.0 0.0.0.255
    [Switch-acl-adv-3000] quit
    [Switch] acl 3001
    [Switch-acl-adv-3001] rule 1 permit ip destination 10.102.64.0 0.0.0.255
    [Switch-acl-adv-3001] quit
    

    # Configure the tariff levels. The tariff level of traffic destined for 192.168.100.0/24 is 1 and the tariff level of traffic destined for 10.102.64.00/24 is 2.

    [Switch] traffic-group huawei
    [Switch-traffic-group-huawei] acl 3000 tariff-level 1
    [Switch-traffic-group-huawei] acl 3001 tariff-level 2
    [Switch-traffic-group-huawei] quit
    

    # Apply the traffic group to the device globally.

    NOTE:

    If you modify the source address or destination address in a traffic identification rule or the tariff level in a traffic group, you must run the traffic-group group-name enable command to make the modification effective.

    [AC] traffic-group huawei enable

    # Configure traffic-based accounting.

    [Switch] qos-profile name huawei
    [Switch-qos-huawei] statistic enable
    [Switch-qos-huawei] quit
    [Switch] aaa
    [Switch-aaa] domain huawei.com
    [Switch-aaa-domain-huawei.com] tariff-level 1 qos-profile huawei accounting-on
    [Switch-aaa-domain-huawei.com] tariff-level 2 qos-profile huawei accounting-on 
    [Switch-aaa-domain-huawei.com] quit
    [Switch-aaa] quit
    [Switch] wlan
    

  12. Commit the configuration.

    [AC-wlan-view] commit all
    Warning: Committing configuration may cause service interruption, continue?[Y/N]:y

  13. Verify the configuration.

    # Run the display traffic-group name group-name command to check information about the traffic group huawei.

    [AC-wlan-view] display traffic-group name huawei
      ----------------------------------------------------------------------------
      Acl-id                Tariff-level
      ----------------------------------------------------------------------------
      3000                      1
      3001                      2
      ----------------------------------------------------------------------------
      Total: 2
    

    # Run the display traffic-group state command. The use status of the traffic group is success.

    [AC-wlan-view] display traffic-group state
      ----------------------------------------------------------------------------
      Slot-id                        State                        
      ----------------------------------------------------------------------------
      1                              success                 
      ----------------------------------------------------------------------------
      Total: 1 

Configuration Files

SwitchA configuration file

#
sysname SwitchA
#
vlan batch 100
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk pvid vlan 100
 port trunk allow-pass vlan 100
 port-isolate enable group 1
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 100

AC configuration file

#
sysname AC
#
vlan batch 100 to 101
#
authentication-profile name wlan-authentication
 dot1x-access-profile wlan-dot1x
 access-domain huawei.com dot1x force
#
domain huawei.com
#
dhcp enable
#
radius-server template radius_huawei
 radius-server shared-key cipher %^%#M$Up)3_vN.!k^6W/]Z6@isD3H={HJJ"B#dVXm-*/%^%#
 radius-server authentication 10.7.66.66 1812 weight 80
 radius-server accounting 10.7.66.66 1813 weight 80
#
acl number 3000
 rule 1 permit ip destination 192.168.100.0 0.0.0.255
acl number 3001
 rule 1 permit ip destination 10.102.64.0 0.0.0.255
#
qos-profile name huawei
 statistic enable
#
aaa
 authentication-scheme radius_huawei
  authentication-mode radius
 accounting-scheme radius_huawei
  accounting-mode radius
 domain huawei.com
  authentication-scheme radius_huawei
  accounting-scheme radius_huawei
  radius-server radius_huawei
  tariff-level 1 qos-profile huawei accounting-on
  tariff-level 2 qos-profile huawei accounting-on
#
interface Vlanif100
 ip address 10.23.100.1 255.255.255.0
 dhcp select interface
#
interface Vlanif101
 ip address 10.23.101.1 255.255.255.0
 dhcp select interface
#
interface GigabitEthernet1/0/1
 port link-type trunk
 port trunk allow-pass vlan 100
traffic-group huawei
 acl 3000 tariff-level 1
 acl 3001 tariff-level 2
traffic-group huawei enable
#
capwap source interface vlanif100
#
wlan
 security-profile name wlan-security
  security wpa2 dot1x aes
 ssid-profile name wlan-ssid
  ssid wlan-net
 vap-profile name wlan-vap
  forward-mode tunnel
  service-vlan vlan-id 101
  ssid-profile wlan-ssid
  security-profile wlan-security
  authentication-profile wlan-authentication
 regulatory-domain-profile name domain1
 rrm-profile name default
  calibrate auto-channel-select disable
  calibrate auto-txpower-select disable
 ap-group name ap-group1
  regulatory-domain-profile domain1
  radio 0
   vap-profile wlan-vap wlan 1
  radio 1
   vap-profile wlan-vap wlan 1
 ap-id 0 ap-mac 60de-4476-e360
  ap-name area_1
  ap-group ap-group1
  radio 0
   channel 20mhz 6
   eirp 127
  radio 1
   channel 20mhz 149
   eirp 127
#
dot1x-access-profile name wlan-dot1x
#
return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1000142094

Views: 121392

Downloads: 119

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next