No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - WLAN-AC

This document describes native AC (hereinafter referred to as WLAN AC) configuration procedures and provides configuration examples.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an IoT AP

Example for Configuring an IoT AP

Networking Requirements

A supermarket requires a wireless network for employees and customers to access the Internet anywhere, anytime. In addition, the supermarket wants to leverage existing wireless network resources to expand IoT applications for locating and managing persons and objects in the supermarket. In Figure 20-5, an IoT AP has an RFID card inserted to receive radio signals from RFID tags carried by the persons and objects. The AP and the host computer can communicate.

Figure 20-5  Networking diagram for configuring an IoT AP

Configuration Roadmap

  1. Configure interworking among the AP, SwitchA, AC, and host computer.

  2. Configure the AC as a DHCP server to assign an IP address to the AP.

  3. Configure the AP to go online.

  4. Configure communication parameters between the AP and the RFID card.

  5. Configure communication parameters between the AP and the host computer.

  6. On the host computer, add the IP address of the AP and configure the same shared key as that on the AP.

Table 20-3  Data planning

Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

AC's source interface

VLANIF 100

DHCP server The AC functions as a DHCP server to assign IP addresses to the APs and STAs.
IP address pool for the AP 10.23.100.2 to 10.23.100.254/24
IP address pool for STAs

10.23.101.2 to 10.23.101.254/24

AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-vap and regulatory domain profile domain1
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-ssid and security profile wlan-security
Serial profile
  • Name: wlan-serial
  • Baud rate: 19200 bit/s
  • Parity bit: odd
  • Stop bit: 2 bits
  • Frame format: frame-start-stop
  • Frame length: 270 bytes
  • Frame start flag: bb
  • Frame stop flag: cc
IoT profile
  • Name: wlan-iot
  • IP address of the host computer: 10.23.100.254
  • Port number of the host computer: 3000
  • Shared key: aabb0011@11

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure SwitchA and the AC to enable the AP and AC to exchange CAPWAP packets.

    # Configure access switch SwitchA. Add GE0/0/1 to GE0/0/2 on SwitchA to VLAN 100 (management VLAN).

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet  0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    

    # Configure the AC. Add GE1/0/1 to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 1/0/1
    [AC-GigabitEthernet1/0/1] port link-type trunk
    [AC-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet1/0/1] quit
    

  2. Configure interworking between the AC and the host computer.

    # Add GE1/0/2 that connects the AC to the host computer to VLANs 100 and 101.

    [AC] interface gigabitethernet 1/0/2
    [AC-GigabitEthernet1/0/2] port link-type trunk
    [AC-GigabitEthernet1/0/2] port trunk pvid vlan 100
    [AC-GigabitEthernet1/0/2] port trunk allow-pass vlan 100 101
    [AC-GigabitEthernet1/0/2] quit
    

  3. Configure the AC as a DHCP server to allocate IP addresses to STAs and the AP.

    # Configure the AC as the DHCP server to allocate an IP address to the AP from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    

  4. Configure the AP to go online.

    # Create an AP group to which the APs with the same configuration can be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to the AP group ap-group1. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is located by its name. For example, if the AP with MAC address 60de-4476-e360 is deployed in area 1, name the AP area_1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP4050DN-E is used and has two radios: radio 0 and radio 1.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit

    # After the AP is powered on, run the display ap all command to check the AP status. If the State field displays nor, the AP has gone online.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP4050DN-E      nor   0   25S
    -------------------------------------------------------------------------------------
    Total: 1

  5. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-vap
    [AC-wlan-vap-prof-wlan-vap] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AC-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AC-wlan-vap-prof-wlan-vap] quit
    

    # Bind VAP profile wlan-vap to the AP group and apply the profile to radio 0 and radio 1 of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  6. Set channels and power for the AP radios.
  7. Configure communication parameters between the AP and the RFID card, and configure communication parameters between the AP and the host computer.

    # Create serial profile wlan-serial and configure serial communication parameters and framing parameters.

    [AC-wlan-view] serial-profile name wlan-serial
    [AC-wlan-serial-prof-wlan-serial] speed 19200
    [AC-wlan-serial-prof-wlan-serial] parity odd
    [AC-wlan-serial-prof-wlan-serial] stopbits 2
    [AC-wlan-serial-prof-wlan-serial] frame-format frame-start-stop
    [AC-wlan-serial-prof-wlan-serial] frame-length 270
    [AC-wlan-serial-prof-wlan-serial] frame-start bb
    [AC-wlan-serial-prof-wlan-serial] frame-stop cc
    [AC-wlan-serial-prof-wlan-serial] quit
    

    # Create IoT profile wlan-iot, configure the IP address and port number of the host computer, and configure security communication parameters.

    [AC-wlan-view] iot-profile name wlan-iot
    [AC-wlan-iot-prof-wlan-iot] management-server server-ip 10.23.100.254 server-port 3000
    [AC-wlan-iot-prof-wlan-iot] config-agent permit ip-address 10.23.102.253 255.255.255.0
    [AC-wlan-iot-prof-wlan-iot] share-key aabb0011@11
    [AC-wlan-iot-prof-wlan-iot] quit
    

    # Bind wlan-serial and wlan-iot to the IoT card interface.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] card 1
    [AC-wlan-group-card-ap-group1/1] serial-profile wlan-serial
    [AC-wlan-group-card-ap-group1/1] iot-profile wlan-iot config-agent udp-port 10000 
    [AC-wlan-group-card-ap-group1/1] quit
    [AC-wlan-ap-group-ap-group1] quit
    

  8. On the host computer, add the IP address of the AP and configure the same shared key as that on the AP.
  9. Commit the configuration.

    [AC-wlan-view] commit all
    Warning: Committing configuration may cause service interruption, continue?[Y/N]:y

  10. Verify the configuration.

    The configuration is automatically delivered to the AP after it is completed. Run the display vap ssid wlan-net command. If Status in the command output displays ON, the VAP has been successfully created on the AP radios.

    [AC-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID    BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    1      60DE-4476-E360 ON      WPA2-PSK      1     wlan-net
    0     area_1  1    1      60DE-4476-E370 ON      WPA2-PSK      0     wlan-net
    ------------------------------------------------------------------------------------
    Total: 2

    # Display configuration information about the serial profile.

    [AC-wlan-view] display serial-profile name wlan-serial
    --------------------------------------------------------------------------------
    Speed(Unit:bps)             : 19200                                             
    Parity                      : odd                                               
    Stop bits                   : 2                                                 
    Frame format                : frame-start-stop                                  
    Frame length(Unit:Byte)     : 270                                               
    Frame start                 : 0xbb                                              
    Frame stop                  : 0xcc                                              
    --------------------------------------------------------------------------------
    

    # Display configuration information about the IoT profile.

    [AC-wlan-view] display iot-profile name wlan-iot 
    --------------------------------------------------------------------------------
    Agent permit IP address       : 10.23.102.253                                   
    Agent permit net-mask         : 255.255.255.0                                   
    Management server IP address  : 10.23.100.254                                   
    Management server port        : 3000                                            
    Share key                     : ******                                          
    --------------------------------------------------------------------------------
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#_b"h2cpaO$9bZ-;`-_;CN5)k,_\UP3[!AJE6Vtg3%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     regulatory-domain-profile name domain1
     serial-profile name wlan-serial
      speed 19200
      parity odd
      stopbits 2
      frame-length 270
      frame-start bb
      frame-stop cc
     iot-profile name wlan-IoT
      management-server server-ip 10.23.100.254 server-port 3000
       confi-agent permit ip-address 10.23.102.253 255.255.255.0
       share-key share-key %^%#iPQQ*<;e|<w;Ab3w`iu;,hnSW<sfx.bvBVOODN^(%^%#
     ap-group name ap-group1
      card 1
       serial-profile wlan-serial 
       iot-profile wlan-IoT config-agent udp-port 10000 
      regulatory-domain-profile domain1
      radio 0
       vap-profile wlan-vap wlan 1
      radio 1
       vap-profile wlan-vap wlan 1
     ap-id 0 type-id 61 ap-mac 60de-4476-e360 ap-sn 210235419610CB002287
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
      radio 1
       channel 20mhz 149
       eirp 127
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1000142094

Views: 120222

Downloads: 119

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next