No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - WLAN-AC

This document describes native AC (hereinafter referred to as WLAN AC) configuration procedures and provides configuration examples.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Non-Fast Roaming Between APs in Different Service VLANs

Example for Configuring Non-Fast Roaming Between APs in Different Service VLANs

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, WDS profile, and Mesh profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is automatically delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 9-8, two APs are deployed in a campus network to provide WLAN services for employees of two departments, and are managed and controlled by an AC. The AC dynamically assigns IP addresses to the APs and STAs. The employees of the two departments belong to different VLANs, that is, AP1 belongs to VLAN101 and AP2 belongs to VLAN102. User data is forwarded through tunnels.

The department requires that services should not be interrupted when a STA moves from AP1 to AP2.

Figure 9-8  Networking diagram for configuring non-fast roaming between APs in different service VLANs

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure parameters used for communication between the AC and APs to transmit CAPWAP packets.
  2. Configure the AC to function as a DHCP server to assign IP addresses to the STAs and APs.
  3. Configure basic WLAN services to enable the STAs to connect to the WLAN.
Table 9-7  Data planning

Item

Data

DHCP server

The AC functions as a DHCP server to assign IP addresses to the STAs and APs.

IP address pool for the APs 10.23.100.2-10.23.100.254/24
IP address pool for the STAs

10.23.101.2-10.23.101.254/24

10.23.102.2-10.23.102.254/24

AC's source interface address VLANIF100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profile: VAP profile wlan-vap1 and regulatory domain profile domain1
  • Name: ap-group2
  • Referenced profile: VAP profile wlan-vap2 and regulatory domain profile domain1
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap1
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security
  • Name: wlan-vap2
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 102
  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure the AC and Switch_A so that the APs and AC can transmit CAPWAP packets.

    # Configure Switch_A: add interfaces GE0/0/1, GE0/0/2, and GE0/0/3 to management VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_A
    [Switch_A] vlan batch 100
    [Switch_A] interface gigabitethernet 0/0/1
    [Switch_A-GigabitEthernet0/0/1] port link-type trunk
    [Switch_A-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch_A-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [Switch_A-GigabitEthernet0/0/1] port-isolate enable
    [Switch_A-GigabitEthernet0/0/1] quit
    [Switch_A] interface gigabitethernet 0/0/2
    [Switch_A-GigabitEthernet0/0/2] port link-type trunk
    [Switch_A-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch_A-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch_A-GigabitEthernet0/0/2] port-isolate enable
    [Switch_A-GigabitEthernet0/0/2] quit
    [Switch_A] interface gigabitethernet 0/0/3
    [Switch_A-GigabitEthernet0/0/3] port link-type trunk
    [Switch_A-GigabitEthernet0/0/3] port trunk allow-pass vlan 100
    [Switch_A-GigabitEthernet0/0/3] quit
    

    # Add GE1/0/1 that connects the AC to Switch_A to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname AC
    [AC] vlan batch 100
    [AC] interface gigabitethernet 1/0/1
    [AC-GigabitEthernet1/0/1] port link-type trunk
    [AC-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet1/0/1] quit
    

  3. Connect the AC to the upper-level network device.

    # Add the AC uplink interface GE1/0/3 to VLAN101 and VLAN102.

    [AC] vlan batch 101 102
    [AC] interface gigabitethernet 1/0/3
    [AC-GigabitEthernet1/0/3] port link-type trunk
    [AC-GigabitEthernet1/0/3] port trunk allow-pass vlan 101 102
    [AC-GigabitEthernet1/0/3] quit
    

  4. Configure the AC to function as a DHCP server to assign IP addresses to the STAs and APs.

    # Configure the DHCP server based on the interface address pool. VLANIF100 provides IP addresses for AP1 and AP2, VLANIF101 provides IP addresses for STAs connected to AP1, and VLANIF102 provides IP addresses for STAs connected to AP2.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    [AC] interface vlanif 102
    [AC-Vlanif102] ip address 10.23.102.1 24
    [AC-Vlanif102] dhcp select interface
    [AC-Vlanif102] quit
    

  5. Configure the AP to go online.

    # Create an AP group and add the AP to the AP group.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] ap-group name ap-group2
    [AC-wlan-ap-group-ap-group2] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] ap-group name ap-group2
    [AC-wlan-ap-group-ap-group2] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group2] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 100
    # Import APs offline on the AC and add AP1 to AP group ap-group1 and AP2 to AP group ap-group2. Assume that the APs' MAC addresses are 60de-4476-e360 and 60de-4474-9640. Configure names for the APs based on the APs' deployment locations, so that you can know where the APs are deployed from their names. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP6010DN-AGN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac 60de-4474-9640
    [AC-wlan-ap-1] ap-name area_2
    [AC-wlan-ap-1] ap-group ap-group2
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-1] quit
    

    # After the APs are powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the APs have gone online.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [2]
    --------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    --------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP6010DN-AGN    nor   0   5M:2S
    1    60de-4474-9640 area_2 ap-group2 10.23.100.253 AP6010DN-AGN    nor   0   5M:4S
    --------------------------------------------------------------------------------
    Total: 2
    

  6. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profiles wlan-vap1 and wlan-vap2, set the data forwarding mode and service VLANs, and apply the security profile wlan-security and SSID profile wlan-ssid to the VAP profiles.

    [AC-wlan-view] vap-profile name wlan-vap1
    [AC-wlan-vap-prof-wlan-vap1] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-vap1] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-vap1] security-profile wlan-security
    [AC-wlan-vap-prof-wlan-vap1] ssid-profile wlan-ssid
    [AC-wlan-vap-prof-wlan-vap1] quit
    [AC-wlan-view] vap-profile name wlan-vap2
    [AC-wlan-vap-prof-wlan-vap2] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-vap2] service-vlan vlan-id 102
    [AC-wlan-vap-prof-wlan-vap2] security-profile wlan-security
    [AC-wlan-vap-prof-wlan-vap2] ssid-profile wlan-ssid
    [AC-wlan-vap-prof-wlan-vap2] quit
    

    # Bind VAP profile wlan-vap1 to AP group ap-group1, and VAP profile wlan-vap2 to AP group ap-group2, and apply the VAP profiles to radio 0 and radio 1 of the APs.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap1 wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap1 wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] ap-group name ap-group2
    [AC-wlan-ap-group-ap-group2] vap-profile wlan-vap2 wlan 1 radio 0
    [AC-wlan-ap-group-ap-group2] vap-profile wlan-vap2 wlan 1 radio 1
    [AC-wlan-ap-group-ap-group2] quit
    

  7. Set channels and power for the AP radios.

    NOTE:

    The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable the automatic channel and power calibration functions.

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.
    [AC-wlan-view] rrm-profile name default
    [AC-wlan-rrm-prof-default] calibrate auto-channel-select disable
    [AC-wlan-rrm-prof-default] calibrate auto-txpower-select disable
    [AC-wlan-rrm-prof-default] quit
    # Set a channel and power for radio 0 of the AP.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Set a channel and power for radio 1 of the AP.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  8. Commit the configuration.

    [AC-wlan-view] commit all
    Warning: Committing configuration may cause service interruption, continue?[Y/N]:y

  9. Verify the configuration.

    After the service configuration is complete, run the display vap ssid wlan-net command. If Status in the command output is displayed as ON, the VAPs have been successfully created on AP radios.
    [AC-wlan-view] display vap ssid wlan-net
    Info: This operation may take a few seconds, please wait.
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID     BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    1       60DE-4476-E360 ON      WPA2-PSK      0     wlan-net
    0     area_1  1    1       60DE-4476-E370 ON      WPA2-PSK      0     wlan-net
    1     area_2  0    1       60DE-4474-9640 ON      WPA2-PSK      0     wlan-net
    1     area_2  1    1       60DE-4474-9650 ON      WPA2-PSK      0     wlan-net
    -------------------------------------------------------------------------------
    Total: 4
    In the coverage area of AP1, connect the STA to the wireless network with SSID wlan-net and enter the password a1234567. After the STA successfully associates with the network, run the display station ssid wlan-net command on the AC. The command output shows that the STA with MAC address e019-1dc7-1e08 has associated with AP1.
    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ---------------------------------------------------------------------------------
    STA MAC         AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    ---------------------------------------------------------------------------------
    e019-1dc7-1e08  0     area_1   1/1      5G    11n   38/64      -68   101   10.23.101.254
    ---------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1
    When the STA moves from the coverage of AP1 to AP2, run the display station ssid wlan-net command on the AC to check the STA access information. The STA is associated with AP2.
    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID                                                     
    Rx/Tx: link receive rate/link transmit rate(Mbps)                             
    ----------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address     
    ----------------------------------------------------------------------------------------
    e019-1dc7-1e08   1     area_2   1/1      5G    11n   46/59      -58   101   10.23.101.254
    ----------------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1
    Run the display station roam-track sta-mac e019-1dc7-1e08 command on the AC to check the STA roaming track.
    [AC-wlan-view] display station roam-track sta-mac e019-1dc7-1e08
    Access SSID:huawei
    Rx/Tx:link receive rate/link transmit rate(Mbps)
    ------------------------------------------------------------------------------
    L2/L3           AC IP                  AP name              Radio ID
    BSSID           TIME                   In/Out RSSI          Out Rx/Tx
    ------------------------------------------------------------------------------
    --              10.23.100.1            area_1               0
    60de-4476-e360  2015/02/07 17:48:30    -51/-48              46/13
    L2              10.23.100.1            area_2               0
    60de-4474-9640  2015/02/07 17:54:50    -58/-                -/-
    ------------------------------------------------------------------------------
    Number: 1

Configuration Files

  • SwitchA configuration file

    #
    sysname Switch_A
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1 
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1 
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • AC configuration file

    #
    sysname AC
    #
    vlan batch 100 to 102
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 101 to 102
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap1
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     vap-profile name wlan-vap2
      forward-mode tunnel
      service-vlan vlan-id 102
      ssid-profile wlan-ssid
      security-profile wlan-security
     regulatory-domain-profile name domain1
     rrm-profile name default
      calibrate auto-channel-select disable
      calibrate auto-txpower-select disable
     ap-group name ap-group1
      regulatory-domain-profile domain1
      radio 0
       vap-profile wlan-vap1 wlan 1
      radio 1
       vap-profile wlan-vap1 wlan 1
     ap-group name ap-group2
      regulatory-domain-profile domain1
      radio 0
       vap-profile wlan-vap2 wlan 1
      radio 1
       vap-profile wlan-vap2 wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
      radio 1
       channel 20mhz 149
       eirp 127
     ap-id 1 type-id 19 ap-mac 60de-4474-9640 ap-sn 210235554710CB000078
      ap-name area_2
      ap-group ap-group2
     #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1000142094

Views: 120835

Downloads: 119

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next