No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R010C00 Configuration Guide - WLAN-AC

This document describes native AC (hereinafter referred to as WLAN AC) configuration procedures and provides configuration examples.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring User CAC

Example for Configuring User CAC

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile, WIDS profile, WDS profile, and Mesh profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is automatically delivered to and takes effect on the APs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 7-15, a wireless network is deployed in the conference hall. The AC connects to the upper-layer network.

To improve Internet experience of wireless users and prevent fierce competition for wireless channels among too many access users, the customer requires that the number of access users be controlled on each AP.

Figure 7-15  Networking diagram for configuring user CAC

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure the AP, AC, switch, and upper-layer devices to communicate at Layer 2.
  2. Configure the AC as a DHCP server to assign IP addresses to the APs and STAs.
  3. Configure the APs to go online.
    1. Create an AP group and add APs that require the same configuration to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the APs.
    3. Configure the AP authentication mode and import the APs offline to allow the APs to go online.
  4. Configure WLAN service parameters for STAs to access the WLAN.
  5. Configure user CAC and adjust CAC parameters to control the number of access users on each AP.
Table 7-10  Data required for completing the configuration

Item

Data

DHCP server The AC functions as a DHCP server to assign IP addresses to the APs and STAs.
IP address pool for the APs 10.23.100.2-10.23.100.254/24
IP address pool for the STAs 10.23.101.2-10.23.101.254/24
IP address of the AC's source interface VLANIF 100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-vap, regulatory domain profile domain1, and 2G radio profile radio2g
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-ssid and security profile wlan-security
2G radio profile
  • Name: radio2g
  • Referenced profile: RRM profile user-cac
RRM profile
  • Name: user-cac
  • User CAC based on the number of users
    • CAC threshold for new STAs: 32
    • CAC threshold for roaming STAs: 32
  • RSSI threshold for rejecting access from weak-signal STAs: 25 dB

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Set the NAC mode to unified on the AC so that users can connect to the network properly.

    <HUAWEI> system-view
    [HUAWEI] authentication unified-mode
    
    NOTE:

    If the NAC mode is changed from traditional to unified, the unified mode takes effect after you save the configuration and restart the device.

  2. Configure SwitchA and the AC so that the AP and AC can transmit CAPWAP packets.

    # Add GE0/0/1 that connects SwitchA to the AP to management VLAN 100 and add GE0/0/2 that connects SwitchA to the AC to the same VLAN.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    

    # Add GE1/0/1 that connects the AC to SwitchA to VLAN 100.

    [HUAWEI] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 1/0/1
    [AC-GigabitEthernet1/0/1] port link-type trunk
    [AC-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet1/0/1] quit
    

  3. Configure the AC to communicate with the upstream device.

    NOTE:

    Configure AC uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AC uplink interface GE1/0/2 to service VLAN 101.

    [AC] interface gigabitethernet 1/0/2
    [AC-GigabitEthernet1/0/2] port link-type trunk
    [AC-GigabitEthernet1/0/2] port trunk allow-pass vlan 101
    [AC-GigabitEthernet1/0/2] quit
    

  4. Configure the AC as a DHCP server to allocate IP addresses to STAs and the AP.

    # Configure the AC as the DHCP server to allocate an IP address to the AP from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    

  5. Configure the AP to go online.

    # Create an AP group and add the AP to the AP group.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name domain1
    [AC-wlan-regulate-domain-domain1] country-code cn
    [AC-wlan-regulate-domain-domain1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP6010DN-AGN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online normally.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP6010DN-AGN    nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1

  6. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-security
    [AC-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-ssid
    [AC-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-vap
    [AC-wlan-vap-prof-wlan-vap] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AC-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AC-wlan-vap-prof-wlan-vap] quit
    

    # Bind VAP profile wlan-vap to the AP group and apply the profile to radio 0 and radio 1 of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  7. Set channels and power for the AP radios.

    NOTE:

    The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable the automatic channel and power calibration functions.

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.
    [AC-wlan-view] rrm-profile name default
    [AC-wlan-rrm-prof-default] calibrate auto-channel-select disable
    [AC-wlan-rrm-prof-default] calibrate auto-txpower-select disable
    [AC-wlan-rrm-prof-default] quit
    # Set a channel and power for radio 0 of the AP.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Set a channel and power for radio 1 of the AP.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  8. Configure user CAC.

    # In the RRM profile user-cac, enable user CAC based on the number of users and set the CAC thresholds for new STAs and roaming STAs to 32; enable the function of rejecting access from weak-signal STAs and set the RSSI threshold to 25 dB; enable the APs to automatically hide SSIDs when the user count reaches the CAC threshold.

    [AC-wlan-view] rrm-profile name user-cac
    [AC-wlan-rrm-prof-user-cac] uac client-number enable 
    [AC-wlan-rrm-prof-user-cac] uac client-number threshold access 32 roam 32
    [AC-wlan-rrm-prof-user-cac] uac client-snr enable 
    [AC-wlan-rrm-prof-user-cac] uac client-snr threshold 25 
    [AC-wlan-rrm-prof-user-cac] uac reach-access-threshold hide-ssid
    [AC-wlan-rrm-prof-user-cac] quit

    # Create the 2G radio profile radio2g and bind the RRM profile user-cac to the 2G radio profile.

    [AC-wlan-view] radio-2g-profile name radio2g 
    [AC-wlan-radio-2g-prof-radio2g] rrm-profile user-cac
    [AC-wlan-radio-2g-prof-radio2g] quit

    # Bind the 2G radio profile radio2g to the AP group ap-group1.

    [AC-wlan-view] ap-group name ap-group1 
    [AC-wlan-ap-group-ap-group1] radio-2g-profile radio2g
    [AC-wlan-ap-group-ap-group1] quit

  9. Commit the configuration.

    [AC-wlan-view] commit all
    Warning: Committing configuration may cause service interruption, continue?[Y/N]:y

  10. Verify the configuration.

    • Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station ssid wlan-net command on the AC. The command output shows that the STAs are connected to the WLAN wlan-net.

      [AC-wlan-view] display station ssid wlan-net
      Rf/WLAN: Radio ID/WLAN ID                                                     
      Rx/Tx: link receive rate/link transmit rate(Mbps)                             
      ----------------------------------------------------------------------------------------
      STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address  
      ----------------------------------------------------------------------------------------
      e019-1dc7-1e08   0     area_1   0/1      2.4G  11n   65/38      -29   101   10.23.101.254
      ----------------------------------------------------------------------------------------
      Total: 1 2.4G: 1 5G: 0
    • Run the display rrm-profile name user-cac command on the AC to check the user CAC configuration.

      [AC-wlan-view] display rrm-profile name user-cac
      ------------------------------------------------------------
      Auto channel select                                    : enable
      Auto transmit power select                             : enable
      PER threshold for trigger channel/power select(%)      : 60
      Airtime fairness schedule                              : disable
      Dynamic adjust EDCA parameter                          : enable
      UAC check client's SNR                                 : enable
      UAC client's SNR threshold(dB)                         : 25
      UAC check client number                                : enable
      UAC client number access threshold                     : 32
      UAC client number roam threshold                       : 32
      UAC check channel utilization                          : disable
      UAC channel utilization access threshold               : 80
      UAC channel utilization roam threshold                 : 80
      UAC hide SSID                                          : enable
      Band steer deny threshold                              : 2
      Band balance start threshold                           : 15
      Band balance gap threshold(%)                           : 25
      Client's band expire based on continuous probe counts  : 35
      Station load balance                                   : disable
      Station load balance start threshold                   : 10
      Station load balance gap threshold(%)                  : 20
      Station load balance deny threshold                    : 6
      Smart-roam                                             : disable
      Smart-roam check SNR                                   : enable
      Smart-roam standing SNR threshold(dB)                  : 20
      Smart-roam SNR quick-kickoff-threshold(dB)             : 15
      Smart-roam check rate                                  : disable
      AMC policy                                             : auto-balance
      Smart-roam rate threshold(%)                           : 20
      Smart-roam rate quick-kickoff-threshold(%)             : 20
      Smart-roam high level SNR margin(dB)                   : 15
      Smart-roam low level SNR margin(dB)                    : 6
      Smart-roam SNR check interval(s)                       : 3
      Smart-roam unable roam client expire time(m)           : 120
      ------------------------------------------------------------  
    • When the number of users connected to an AP reaches 32 in the conference hall, new users and roaming users cannot find the SSID wlan-net on their terminals.

Configuration Files

  • SwitchA configuration file
    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     regulatory-domain-profile name domain1
     rrm-profile name user-cac
      uac client-snr enable
      uac client-snr threshold 25
      uac client-number enable
      uac client-number threshold access 32 roam 32
      uac reach-access-threshold hide-ssid
     radio-2g-profile name radio2g
      rrm-profile user-cac
     ap-group name ap-group1
      regulatory-domain-profile domain1
      radio 0
       radio-2g-profile radio2g 
       vap-profile wlan-vap wlan 1
      radio 1
       vap-profile wlan-vap wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
      radio 1
       channel 20mhz 149
       eirp 127
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1000142094

Views: 120681

Downloads: 119

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next