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Alarm Handling

CloudEngine 8800, 7800, 6800, and 5800 V200R002C50

This document provides the explanations, causes, and recommended actions of alarms on the product.
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TRILL_1.3.6.1.4.1.2011.5.25.331.1.3.4 trillAuthenticationTypeFailure

TRILL_1.3.6.1.4.1.2011.5.25.331.1.3.4 trillAuthenticationTypeFailure

Description

The authentication type of received PDU is different from local configuration. (trillSysInstance=[trillSysInstance], trillCircIndex=[trillCircIndex], trillCircIfIndex=[trillCircIfIndex], trillPduFragment=[trillPduFragment], ifIndex=[ifIndex], IfName=[IfName])

The device received a PDU carrying an authentication mode that was different from the local one.

Attributes

Attribute

Description

Alarm or Event

Event

Trap Severity

Error

Mnemonic Code

TRILL_AUTHENTICATION_TYPE_FAILURE

Trap OID

1.3.6.1.4.1.2011.5.25.331.1.3.4

Alarm ID

This is an event trap and does not involve alarm ID.

Alarm Type

This is an event trap and does not involve alarm type.

Raise or Clear

This is an event trap and does not involve alarm generation or clearance. 

Match trap

This is an event trap and does not involve the match trap.

Parameters

Parameter Description

trillSysInstance

TRILL process ID

trillCircIndex

TRILL interface index

trillCircIfIndex

Interface index obtained from the interface management module

trillPduFragment

64-byte PDU fragment

ifIndex

Interface index defined by the interface management module

IfName

Interface name

VB

VB OID

VB Name

VB Index

1.3.6.1.4.1.2011.5.25.331.1.1.3.1.1

hwTrillSysInstance

ifIndex

1.3.6.1.4.1.2011.5.25.331.1.1.3.1.2

hwTrillCircIfIndex

ifIndex

1.3.6.1.4.1.2011.5.25.331.1.1.3.1.3

hwTrillPduFragment

ifIndex

1.3.6.1.2.1.31.1.1.1.1

ifName

ifIndex

Impact on the System

1. If a Hello packet fails to be authenticated, no TRILL neighbor relationship can be established.

2. If an LSP or SNP fails to be authenticated, LSDBs cannot be synchronized, but a TRILL neighbor relationship can still be established.

Possible Causes

Cause 1: TRILL authentication was configured for the local interface or process. The authentication mode configured on the remote device was different from that configured on the local device.

Cause 2: TRILL authentication was configured for the local interface or process, but not for the remote interface or process.

Procedure

  1. Check the TRILL process ID from the trillSysInstance field in the trap information.
  2. Identify the PDU type based on the second byte of the trillPduFragment field.

    • 14: Hello packet. Go to Step 3.
    • 1B: LSP. Go to Step 5.
    • 11: SNP. Go to Step 6.

  3. Run the display trill peer command on the source switch to check the interface that sent the PDU and run the display this command in the interface view to check whether the configured authentication mode is the same as that configured on the destination switch.

    • If the two authentication modes are the same, go to Step 8.

    • If the two authentication modes are different, go to Step 4.

  4. Run the trill authentication-mode command in the interface view of the source switch to change the authentication mode to the one configured on the destination switch, ensure that the passwords configured on both sides are the same, and then check whether the trap is cleared.

    • If the trap is cleared, go to Step 8.

    • If the trap persists, go to Step 7.

  5. Run the display current-configuration configuration trill command on the source switch to check whether an authentication mode is configured in the TRILL process and whether the authentication mode is the same as that configured on the destination switch. Ensure that the passwords configured on both sides are the same.

    • If an authentication mode is configured in the TRILL process and the two authentication modes are the same, go to Step 8.

    • If no authentication mode is configured in the TRILL process or the two authentication modes are different, go to Step 7.

  6. Run the area-authentication-mode command in the TRILL view of the source switch to change the authentication mode to the one configured on the destination switch and then check whether the trap is cleared.

    • If the trap is cleared, go to Step 8.

    • If the trap persists, go to Step 7.

  7. Collect alarm information and configuration information, and then contact technical support personnel.
  8. End.
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Updated: 2019-03-20

Document ID: EDOC1000166558

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