No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

CloudEngine 12800 and 12800E V200R002C50

This document describes the configurations of IP Unicast Routing, including IP Routing, Static Route, RIP, RIPng, OSPF, OSPFv3, IPv4 IS-IS, IPv6 IS-IS, BGP, Routing Policy, and PBR.

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic OSPFv3 Functions

Example for Configuring Basic OSPFv3 Functions

Networking Requirements

As shown in Figure 6-12, all switchs run OSPFv3. The entire autonomous system is divided into three areas. Switch B and Switch C serve as ABRs to forward the inter-area routes.

After the configuration, each router should learn the routes from the AS to all network segments.

Figure 6-12 Networking diagram of configuring OSPFv3 areas

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable basic OSPFv3 functions on each switch.

  2. Check the routing list and LSDB.

Procedure

  1. Assign an IPv6 address to each interface. The detailed configuration is not mentioned here.
  2. Configure basic OSPFv3 functions.

    # Configure Switch A.

    [~SwitchA] ospfv3
    [*SwitchA-ospfv3-1] router-id 10.10.10.1
    [*SwitchA-ospfv3-1] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ospfv3 1 area 1
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] ospfv3 1 area 1
    [*SwitchA-Vlanif40] quit
    [*SwitchA] commit

    # Configure Switch B.

    [~SwitchB] ospfv3
    [*SwitchB-ospfv3-1] router-id 10.10.10.2
    [*SwitchB-ospfv3-1] quit
    [*SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] ospfv3 1 area 0
    [*SwitchB-Vlanif10] quit
    [*SwitchB] interface vlanif 20
    [*SwitchB-Vlanif20] ospfv3 1 area 1
    [*SwitchB-Vlanif20] quit
    [*SwitchB] commit

    # Configure Switch C.

    [~SwitchC] ospfv3
    [*SwitchC-ospfv3-1] router-id 10.10.10.3
    [*SwitchC-ospfv3-1] quit
    [*SwitchC] interface vlanif 10
    [*SwitchC-Vlanif10] ospfv3 1 area 0
    [*SwitchC-Vlanif10] quit
    [*SwitchC] interface vlanif 30
    [*SwitchC-Vlanif30] ospfv3 1 area 2
    [*SwitchC-Vlanif30] quit
    [*SwitchC] commit

    # Configure Switch D.

    [~SwitchD] ospfv3
    [*SwitchD-ospfv3-1] router-id 10.10.10.4
    [*SwitchD-ospfv3-1] quit
    [*SwitchD] interface vlanif 30
    [*SwitchD-Vlanif30] ospfv3 1 area 2
    [*SwitchD-Vlanif30] quit
    [*SwitchD] commit

  3. Verify the configuration.

    #View the neighbors of Switch B, and you can see that the status of the neighbor relationship between Switch B and other devices is Full.

    [~SwitchB] display ospfv3 peer
    
    
    OSPFv3 Process (1)
    Total number of peer(s): 2       
     Peer(s) in full state: 2       
    OSPFv3 Area (0.0.0.0)
    Neighbor ID      Pri State            Dead Time  Interface          Instance ID
    10.10.10.3         1 Full/DR          00:00:32   Vlanif10              0
    OSPFv3 Area (0.0.0.1)
    Neighbor ID      Pri State            Dead Time  Interface          Instance ID
    10.10.10.1         1 Full/Backup      00:00:34   Vlanif20              0

    # Display the OSPFv3 neighbors of SwitchC.

    [~SwitchC] display ospfv3 peer
    
    
    OSPFv3 Process (1)
    Total number of peer(s): 2       
     Peer(s) in full state: 2       
    OSPFv3 Area (0.0.0.0)
    Neighbor ID      Pri State            Dead Time  Interface          Instance ID
    10.10.10.2         1 Full/Backup      00:00:37   Vlanif10              0
    OSPFv3 Area (0.0.0.2)
    Neighbor ID      Pri State            Dead Time  Interface          Instance ID
    10.10.10.4         1 Full/DR          00:00:33   Vlanif30              0

    # Display the OSPFv3 routing table of SwitchD.

    [~SwitchD] display ospfv3 routing
                                                                                    
    Codes : E2 - Type 2 External, E1 - Type 1 External, IA - Inter-Area,             
            N - NSSA
    Flags : A - Added to URT6                                                       
                                                                                    
    OSPFv3 Process (1)                                                              
         Destination                                                         Metric 
           Next-hop                                                                 
    IA   FC00:0:0:1000::/64                                                     2 
           via FE80::225:9EFF:FE01:211, Vlanif30, Flags : A                       
    IA   FC00:0:0:1001::/64                                                     3 
           via FE80::225:9EFF:FE01:211, Vlanif30, Flags : A                       
         FC00:0:0:1002::/64                                                     1 
           directly connected, Vlanif30, Flags : A                                
    IA   FC00:0:0:2000::/64                                                     4 
           via FE80::225:9EFF:FE01:211, Vlanif30, Flags : A                       

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 20 40
    #
    ospfv3 1
     router-id 10.10.10.1
     area 0.0.0.1
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:1001::2/64
     ospfv3 1 area 0.0.0.1
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2000::1/64
     ospfv3 1 area 0.0.0.1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    ospfv3 1
     router-id 10.10.10.2
     area 0.0.0.0
     area 0.0.0.1
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1000::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:1001::1/64
     ospfv3 1 area 0.0.0.1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 10 30
    #
    ospfv3 1
     router-id 10.10.10.3
     area 0.0.0.0
     area 0.0.0.2
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1000::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:1002::1/64
     ospfv3 1 area 0.0.0.2
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 30
    #
    ospfv3 1
     router-id 10.10.10.4
     area 0.0.0.2
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:1002::2/64
     ospfv3 1 area 0.0.0.2
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
Translation
Download
Updated: 2019-03-21

Document ID: EDOC1000166601

Views: 275938

Downloads: 161

Average rating:
This Document Applies to these Products

Related Version

Related Documents

Share
Previous Next