No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 12800 and 12800E V200R002C50

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multi-Hop BFD for IPv6

Example for Configuring Multi-Hop BFD for IPv6

Networking Requirements

In Figure 2-29, SwitchA is indirectly connected to SwitchC and Layer 2 transmission devices, SwitchD and SwitchE, are deployed between them. Static routes are configured so that SwitchA can communicate with SwitchC. Faults on the link between SwitchA and SwitchC need to be quickly detected.

Figure 2-29 Networking diagram for configuring multi-hop BFD for IPv6

Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on SwitchA and SwitchC to detect the multi-hop route.

Procedure

  1. On SwitchA, SwitchB and SwitchC, create VLANs and add interfaces to VLANs.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 10
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

  2. Configure IPv6 addresses for VLANIF interfaces so that SwitchA and SwitchB, and SwitchB and SwitchC can communicate at Layer 3.

    # Configure SwitchA. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:2001::1 64
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

  3. Configure a reachable IPv6 static route between SwitchA and SwitchC.

    # Configure SwitchA. The configuration of SwitchC is similar to the configuration of SwitchA.

    [~SwitchA] ipv6 route-static :: 64 fc00:0:0:2001::2
    [*SwitchA] commit

  4. Configure multi-hop BFD.

    # Create a BFD session between SwitchA and SwitchC.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit
    [*SwitchA] bfd atoc bind peer-ipv6 fc00:0:0:2002::1
    [*SwitchA-bfd-session-atoc] discriminator local 10
    [*SwitchA-bfd-session-atoc] discriminator remote 20
    [*SwitchA-bfd-session-atoc] commit
    [~SwitchA-bfd-session-atoc] quit

    # Create a BFD session between SwitchC and SwitchA.

    [~SwitchC] bfd
    [*SwitchC-bfd] quit
    [*SwitchC] bfd ctoa bind peer-ipv6 fc00:0:0:2001::1
    [*SwitchC-bfd-session-ctoa] discriminator local 20
    [*SwitchC-bfd-session-ctoa] discriminator remote 10
    [*SwitchC-bfd-session-ctoa] commit
    [~SwitchC-bfd-session-ctoa] quit

  5. Verify the configuration.

    # Run the display bfd session verbose command on SwitchA and SwitchC. The output on SwitchA is used as an example and shows that a BFD session is set up and is in Up state.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atoc                  (Multiple Hops) State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : FC00:0:0:2002::1                                     
      Bind Interface         : -                                                    
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 4784             TTL                    : 254        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

    # Run the shutdown command on the 10GE1/0/1 interface of SwitchA to simulate a link fault.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] shutdown
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    # Run the display bfd session all verbose command on SwitchA and SwitchB. The output on SwitchA is used as an example and shows that a multi-hop BFD session is set up and is in Down state.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atoc                  (Multiple Hops) State : Down
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : FC00:0:0:2002::1                                     
      Bind Interface         : -                                                    
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 6761             Actual Rx Interval (ms): 6761       
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 4784             TTL                    : 254        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    bfd
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    bfd atoc bind peer-ipv6 FC00:0:0:2002::1
     discriminator local 10
     discriminator remote 20
    #
    ipv6 route-static :: 64 FC00:0:0:2001::2
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001::2 64
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2002::2 64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/1
     port link-type trunk
     port trunk pvid vlan 20
     port trunk allow-pass vlan 20
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    bfd
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2002::1 64
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 20
     port trunk allow-pass vlan 20
    #
    bfd ctoa bind peer-ipv6 FC00:0:0:2001::1
     discriminator local 20
     discriminator remote 10
    #
    ipv6 route-static :: 64 FC00:0:0:2002::2
    #
    return
Translation
Download
Updated: 2019-03-21

Document ID: EDOC1000166606

Views: 127343

Downloads: 90

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next